Added installation of http 2.7.10 package to get xml2rfc.tcl

to work. This will install http/http.tcl and http/pkgIndex.tcl
	to the tcl8.5/http/ directory.
This commit is contained in:
kivinen 2013-04-08 14:19:38 +00:00
parent 789273f4e1
commit c387ac5764
3 changed files with 21 additions and 20 deletions

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.13 2012/08/21 21:31:47 marino Exp $
@comment $NetBSD: PLIST,v 1.14 2013/04/08 14:19:38 kivinen Exp $
bin/tclsh
bin/tclsh${BASEVER}
include/tcl.h
@ -110,6 +110,8 @@ lib/tcl${BASEVER}/encoding/shiftjis.enc
lib/tcl${BASEVER}/encoding/symbol.enc
lib/tcl${BASEVER}/encoding/tis-620.enc
lib/tcl${BASEVER}/history.tcl
lib/tcl${BASEVER}/http/http.tcl
lib/tcl${BASEVER}/http/pkgIndex.tcl
lib/tcl${BASEVER}/http1.0/http.tcl
lib/tcl${BASEVER}/http1.0/pkgIndex.tcl
lib/tcl${BASEVER}/init.tcl

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.54 2012/12/29 13:49:12 bsiegert Exp $
$NetBSD: distinfo,v 1.55 2013/04/08 14:19:38 kivinen Exp $
SHA1 (tcl8.5.13-src.tar.gz) = 65b677dc699426233b926edfa9e304d456da7cad
RMD160 (tcl8.5.13-src.tar.gz) = 20cfb8adebd77a6d037f67a9af7e88d80032b3c2
@ -8,7 +8,7 @@ SHA1 (patch-generic_tclPort.h) = cd44f24c79048a70e2c4929aa1499ee336602ba5
SHA1 (patch-generic_tclPosixStr.c) = 8c252a4f3d8898fb48544d15123d6a8ddc3172f0
SHA1 (patch-tests_load.test) = 438695ab76e01646e49aadc01c44344a5495eabb
SHA1 (patch-tests_pkgMkIndex.test) = 70d1042c1f4743052c5fa191fa7c4732a08e28a2
SHA1 (patch-unix_Makefile.in) = d8828e3818a141a006b4fbdaeea43b350d62f014
SHA1 (patch-unix_Makefile.in) = c87f98382790ff40aa54aabb99361f6c469dc050
SHA1 (patch-unix_configure) = 2e1e6d2020e68b91b94c0b05cb1d349126989adc
SHA1 (patch-unix_tclConfig.sh.in) = 5a32d8e97240d14f3a03e205637fe3bf8307d868
SHA1 (patch-unix_tclUnixCompat.c) = 7ffa40a1a56345f5b86cd896e8e3b0d5748d8c5e

View file

@ -1,8 +1,6 @@
$NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
--- unix/Makefile.in.orig 2012-11-09 15:14:39.000000000 +0000
+++ unix/Makefile.in
@@ -8,6 +8,7 @@ VERSION = @TCL_VERSION@
--- unix/Makefile.in.orig 2012-11-09 17:14:39.000000000 +0200
+++ unix/Makefile.in 2013-04-08 17:05:01.000000000 +0300
@@ -8,6 +8,7 @@
MAJOR_VERSION = @TCL_MAJOR_VERSION@
MINOR_VERSION = @TCL_MINOR_VERSION@
PATCH_LEVEL = @TCL_PATCH_LEVEL@
@ -10,7 +8,7 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
#--------------------------------------------------------------------------
# Things you can change to personalize the Makefile for your own site (you can
@@ -54,6 +55,8 @@ SCRIPT_INSTALL_DIR = $(INSTALL_ROOT)$(TC
@@ -54,6 +55,8 @@
# Directory in which to install the include file tcl.h:
INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
@ -19,7 +17,7 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
# Path to the private tcl header dir:
PRIVATE_INCLUDE_DIR = @PRIVATE_INCLUDE_DIR@
@@ -100,7 +103,7 @@ CFLAGS_OPTIMIZE = @CFLAGS_OPTIMIZE@
@@ -100,7 +103,7 @@
#CFLAGS = $(CFLAGS_DEBUG)
#CFLAGS = $(CFLAGS_OPTIMIZE)
#CFLAGS = $(CFLAGS_DEBUG) $(CFLAGS_OPTIMIZE)
@ -28,7 +26,7 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
# Flags to pass to the linker
LDFLAGS_DEBUG = @LDFLAGS_DEBUG@
@@ -194,6 +197,7 @@ BUILD_DLTEST = @BUILD_DLTEST@
@@ -194,6 +197,7 @@
#BUILD_DLTEST =
TCL_LIB_FILE = @TCL_LIB_FILE@
@ -36,7 +34,7 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
#TCL_LIB_FILE = libtcl.a
# Generic lib name used in rules that apply to tcl and tk
@@ -542,7 +546,7 @@ SRCS = $(GENERIC_SRCS) $(TOMMATH_SRCS) $
@@ -542,7 +546,7 @@
all: binaries libraries doc
@ -45,7 +43,7 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
libraries:
@@ -558,6 +562,11 @@ ${STUB_LIB_FILE}: ${STUB_LIB_OBJS}
@@ -558,6 +562,11 @@
rm -f $@
@MAKE_STUB_LIB@
@ -57,7 +55,7 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
# Make target which outputs the list of the .o contained in the Tcl lib useful
# to build a single big shared library containing Tcl and other extensions.
# Used for the Tcl Plugin. -- dl
@@ -719,9 +728,16 @@ install-binaries: binaries
@@ -719,9 +728,16 @@
done;
@echo "Installing $(LIB_FILE) to $(DLL_INSTALL_DIR)/"
@@INSTALL_LIB@
@ -75,7 +73,7 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
@echo "Installing tclConfig.sh to $(CONFIG_INSTALL_DIR)/"
@$(INSTALL_DATA) tclConfig.sh "$(CONFIG_INSTALL_DIR)"/tclConfig.sh
@if test "$(STUB_LIB_FILE)" != "" ; then \
@@ -731,7 +747,8 @@ install-binaries: binaries
@@ -731,7 +747,8 @@
@EXTRA_INSTALL_BINARIES@
install-libraries: libraries $(INSTALL_TZDATA) install-msgs
@ -85,7 +83,7 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
do \
if [ ! -d "$$i" ] ; then \
echo "Making directory $$i"; \
@@ -739,7 +756,7 @@ install-libraries: libraries $(INSTALL_T
@@ -739,7 +756,7 @@
else true; \
fi; \
done;
@ -94,7 +92,7 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
do \
if [ ! -d "$(SCRIPT_INSTALL_DIR)"/$$i ] ; then \
echo "Making directory $(SCRIPT_INSTALL_DIR)/$$i"; \
@@ -748,12 +765,17 @@ install-libraries: libraries $(INSTALL_T
@@ -748,12 +765,17 @@
fi; \
done;
@echo "Installing header files to $(INCLUDE_INSTALL_DIR)/";
@ -117,12 +115,13 @@ $NetBSD: patch-unix_Makefile.in,v 1.3 2012/11/24 21:38:49 adam Exp $
done;
@echo "Installing library files to $(SCRIPT_INSTALL_DIR)/";
@for i in $(TOP_DIR)/library/*.tcl $(TOP_DIR)/library/tclIndex \
@@ -766,22 +788,24 @@ install-libraries: libraries $(INSTALL_T
do \
@@ -767,21 +789,26 @@
$(INSTALL_DATA) $$i "$(SCRIPT_INSTALL_DIR)"/http1.0; \
done;
- @echo "Installing package http 2.7.10 as a Tcl Module";
@echo "Installing package http 2.7.10 as a Tcl Module";
- @$(INSTALL_DATA) $(TOP_DIR)/library/http/http.tcl "$(SCRIPT_INSTALL_DIR)"/../tcl8/8.4/http-2.7.10.tm;
+ @$(INSTALL_DATA) $(TOP_DIR)/library/http/http.tcl "$(SCRIPT_INSTALL_DIR)"/http/http.tcl;
+ @$(INSTALL_DATA) $(TOP_DIR)/library/http/pkgIndex.tcl "$(SCRIPT_INSTALL_DIR)"/http/pkgIndex.tcl;
@echo "Installing package opt0.4 files to $(SCRIPT_INSTALL_DIR)/opt0.4/";
@for i in $(TOP_DIR)/library/opt/*.tcl ; \
do \