Initial import of p5-Coro version 5.22 in the NetBSD Packages

Collection.

The Perl 5 module collection Coro manages continuations in general,
most often in the form of cooperative threads.The specific flavor
of thread offered by this module also guarantees you that it will
not switch between threads unless necessary, at easily-identified
points in your program, so locking and parallel access are rarely
an issue, making thread programming much safer and easier than using
other thread models.
This commit is contained in:
seb 2010-04-19 22:11:50 +00:00
parent 8051009d3e
commit c3b1331b35
4 changed files with 68 additions and 0 deletions

7
devel/p5-Coro/DESCR Normal file
View file

@ -0,0 +1,7 @@
The Perl 5 module collection Coro manages continuations in general,
most often in the form of cooperative threads.The specific flavor
of thread offered by this module also guarantees you that it will
not switch between threads unless necessary, at easily-identified
points in your program, so locking and parallel access are rarely
an issue, making thread programming much safer and easier than using
other thread models.

37
devel/p5-Coro/Makefile Normal file
View file

@ -0,0 +1,37 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/04/19 22:11:50 seb Exp $
#
DISTNAME= Coro-5.22
PKGNAME= p5-${DISTNAME}
CATEGORIES= parallel
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Coro/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://search.cpan.org/dist/Coro/
COMMENT= Perl 5 module providing cooperative threads
LICENSE= ${PERL5_LICENSE}
PKG_DESTDIR_SUPPORT= user-destdir
USE_LANGUAGES= c
PERL5_PACKLIST= auto/Coro/.packlist
DEPENDS+= p5-AnyEvent-AIO>=1:../../devel/p5-AnyEvent-AIO
DEPENDS+= p5-AnyEvent-BDB>=1:../../databases/p5-AnyEvent-BDB
DEPENDS+= p5-BDB-[0-9]*:../../databases/p5-BDB
DEPENDS+= p5-IO-AIO>=3.1:../../devel/p5-IO-AIO
DEPENDS+= p5-AnyEvent>=5:../../devel/p5-AnyEvent
DEPENDS+= p5-Guard>=0.5:../../devel/p5-Guard
DEPENDS+= p5-common-sense-[0-9]*:../../devel/p5-common-sense
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "NetBSD"
# Only tested on NetBSD/i386 5.0.2
MAKE_ENV+= CORO_INTERFACE=p # pthread implementation
.endif
.include "../../devel/p5-Event/buildlink3.mk"
.include "../../devel/p5-EV/buildlink3.mk"
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

6
devel/p5-Coro/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/04/19 22:11:50 seb Exp $
SHA1 (Coro-5.22.tar.gz) = 341aeb99a0b45a1860bdf4c15c2d3fc75da5dbae
RMD160 (Coro-5.22.tar.gz) = 5e09dd57011f5fba5373295ef981ac99baff54fb
Size (Coro-5.22.tar.gz) = 154510 bytes
SHA1 (patch-aa) = d7d87d47b94013d5d60797f6023671850446d75d

View file

@ -0,0 +1,18 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/04/19 22:11:50 seb Exp $
Prevent interactive configuration.
--- Coro/Makefile.PL.orig 2009-08-22 22:36:23.000000000 +0000
+++ Coro/Makefile.PL
@@ -23,9 +23,9 @@ maintainer :)
EOF
-if (prompt ("Skip further questions and use defaults (y/n)?", "y") =~ /[yY]/) {
+#if (prompt ("Skip further questions and use defaults (y/n)?", "y") =~ /[yY]/) {
$ENV{PERL_MM_USE_DEFAULT} = 1;
-}
+#}
$DEFINE .= " -DHAVE_MMAP" if $Config{d_mmap} eq "define" && $Config{d_munmap} eq "define";