Atomic operations via gcc are not supported on many archs. Allow them only
on amd64, powerpc, i386 and alpha.
This commit is contained in:
parent
1e190480e9
commit
c3d2378d8c
2 changed files with 16 additions and 4 deletions
|
@ -1,11 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.22 2011/09/12 16:24:32 taca Exp $
|
||||
$NetBSD: distinfo,v 1.23 2011/10/06 05:34:00 jklos Exp $
|
||||
|
||||
SHA1 (php-5.3.8/php-5.3.8.tar.bz2) = 8f29029e092f262876bfdd2ce56f6867e2b74b85
|
||||
RMD160 (php-5.3.8/php-5.3.8.tar.bz2) = f18a18e2dfd7ea7885760eec2a05b3c4a15ad9db
|
||||
Size (php-5.3.8/php-5.3.8.tar.bz2) = 11190060 bytes
|
||||
SHA1 (php-5.3.8/suhosin-patch-5.3.7-0.9.10.patch.gz) = 3c38e873584b8f9e325a813cc9b197a342595099
|
||||
RMD160 (php-5.3.8/suhosin-patch-5.3.7-0.9.10.patch.gz) = 19f789bf49a5fed2cd88b199fd8ac5d1ffa9bdc8
|
||||
Size (php-5.3.8/suhosin-patch-5.3.7-0.9.10.patch.gz) = 41175 bytes
|
||||
SHA1 (patch-aa) = b0dc6cd0b2103d5858280202506b33322a98496e
|
||||
SHA1 (patch-ab) = d08bb50cf074a6065ef0d1d67a713b7573cb2f5b
|
||||
SHA1 (patch-ac) = 1720f154232241c19d0c6e08a824e33252f1b690
|
||||
|
@ -17,5 +14,6 @@ SHA1 (patch-ah) = b20c29c64b3099f77855a5ec28960dc1c4f65c83
|
|||
SHA1 (patch-ai) = d4766893a2c47a4e4a744248dda265b0a9a66a1f
|
||||
SHA1 (patch-aj) = d611d13fcc28c5d2b9e9586832ce4b8ae5707b48
|
||||
SHA1 (patch-al) = fbbee5502e0cd1c47c6e7c15e0d54746414ec32e
|
||||
SHA1 (patch-as) = 5faa039f0ab7663e82787973e937aea685ba2dac
|
||||
SHA1 (patch-php__mssql.c) = b46c688ff2d8da33ca2f9beb0eb9182b6edf7e23
|
||||
SHA1 (patch-php__mssql.h) = fa9e349127121cf478691c108ac611563e445c40
|
||||
|
|
14
lang/php53/patches/patch-as
Normal file
14
lang/php53/patches/patch-as
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-as,v 1.1 2011/10/06 05:34:00 jklos Exp $
|
||||
|
||||
--- ext/standard/php_crypt_r.c.orig 2011-10-06 05:25:16.000000000 +0000
|
||||
+++ ext/standard/php_crypt_r.c
|
||||
@@ -94,7 +94,8 @@ void _crypt_extended_init_r(void)
|
||||
if (!initialized) {
|
||||
#ifdef PHP_WIN32
|
||||
InterlockedIncrement(&initialized);
|
||||
-#elif (defined(__GNUC__) && !defined(__hpux) && (__GNUC__ > 4 || \
|
||||
+#elif (defined(__GNUC__) && (defined(__amd64__) || defined(__alpha__) || \
|
||||
+ defined(__i386__) || defined(__powerpc__)) && (__GNUC__ > 4 || \
|
||||
(__GNUC__ == 4 && (__GNUC_MINOR__ > 1 || (__GNUC_MINOR__ == 1 && __GNUC_PATCHLEVEL__ > 1)))))
|
||||
__sync_fetch_and_add(&initialized, 1);
|
||||
#elif defined(HAVE_ATOMIC_H) /* Solaris 10 defines atomic API within */
|
Loading…
Reference in a new issue