libintl.a is now a part of NetBSD, so build the gettext module by default.
This bumps the version number to 4.0.4.1nb1. Also, build the php CGI binary by statically linking against the helper library libphp4.la so we aren't forced to install a shared library used solely by one program.
This commit is contained in:
parent
c4527c3354
commit
c3e8df992f
5 changed files with 28 additions and 14 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.6 2001/01/22 05:49:14 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2001/01/25 17:18:07 jlam Exp $
|
||||
|
||||
.include "../../www/php4/Makefile.common"
|
||||
|
||||
|
@ -18,10 +18,7 @@ pre-install:
|
|||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/libexec/cgi-bin
|
||||
${LIBTOOL} ${INSTALL_DATA} ${WRKSRC}/libphp4.la ${PREFIX}/lib
|
||||
${LIBTOOL} ${INSTALL_PROGRAM} ${WRKSRC}/php ${PREFIX}/libexec/cgi-bin
|
||||
${RM} -f ${PREFIX}/bin/php
|
||||
${LN} -sf ../libexec/cgi-bin/php ${PREFIX}/bin/php
|
||||
${LN} -sf ../../bin/php ${PREFIX}/libexec/cgi-bin/php
|
||||
${TOUCH} ${PREFIX}/${PHP_EXTENSION_DIR}/.directory
|
||||
${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc
|
||||
${INSTALL_DATA} ${WRKSRC}/php.ini-optimized ${PREFIX}/etc
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile.common,v 1.5 2001/01/15 16:38:06 jlam Exp $
|
||||
# $NetBSD: Makefile.common,v 1.6 2001/01/25 17:18:07 jlam Exp $
|
||||
|
||||
DISTNAME= php-${PHP_DIST_VERS}
|
||||
PHP_DIST_VERS= 4.0.4pl1
|
||||
PHP_VERS= 4.0.4.1
|
||||
PHP_VERS= 4.0.4.1nb1
|
||||
CATEGORIES+= www php4
|
||||
|
||||
# Note the http address is written this way by purpose, so that bsd.pkg.mk DTRT
|
||||
|
@ -33,9 +33,17 @@ GNU_CONFIGURE= # defined
|
|||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
|
||||
CONFIGURE_ENV+= LIBS="${LIBS}"
|
||||
|
||||
USE_LIBINTL= # defined
|
||||
.if exists(/usr/include/libintl.h)
|
||||
GETTEXTDIR= /usr
|
||||
.else
|
||||
GETTEXTDIR= ${LOCALBASE}
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --without-gd
|
||||
CONFIGURE_ARGS+= --without-mysql
|
||||
CONFIGURE_ARGS+= --with-gdbm=${LOCALBASE}
|
||||
CONFIGURE_ARGS+= --with-gettext=${GETTEXTDIR}
|
||||
CONFIGURE_ARGS+= --with-yp --with-zlib
|
||||
CONFIGURE_ARGS+= --with-config-file-path=${PREFIX}/etc
|
||||
CONFIGURE_ARGS+= --with-system-regex
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: patch-sum,v 1.6 2001/01/15 16:32:28 jlam Exp $
|
||||
$NetBSD: patch-sum,v 1.7 2001/01/25 17:18:07 jlam Exp $
|
||||
|
||||
MD5 (patch-aa) = 511e161c09ffe0d7935026e72d9ab4a7
|
||||
MD5 (patch-ab) = 890bb3a2222ae5295d5f4ea01d2cfd5d
|
||||
MD5 (patch-ac) = b33a7b6413fb5c850ebbb4c21f04b4d4
|
||||
MD5 (patch-ad) = bef4f5e16a927892db85ba59aa860163
|
||||
MD5 (patch-ae) = 496c420d0067a985139375ee634cbbd4
|
||||
MD5 (patch-af) = cb061c65724b0f99f4bf588ea6c42c8a
|
||||
|
|
13
www/php4/patches/patch-af
Normal file
13
www/php4/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1 2001/01/25 17:18:08 jlam Exp $
|
||||
|
||||
--- Makefile.in.orig Sun Jun 11 14:51:17 2000
|
||||
+++ Makefile.in
|
||||
@@ -19,7 +19,7 @@
|
||||
PROGRAM_NAME = php
|
||||
PROGRAM_SOURCES = stub.c
|
||||
PROGRAM_LDADD = libphp4.la
|
||||
-PROGRAM_LDFLAGS = -export-dynamic
|
||||
+PROGRAM_LDFLAGS = -static -export-dynamic
|
||||
PROGRAM_DEPENDENCIES = $(PROGRAM_LDADD)
|
||||
|
||||
targets = $(LTLIBRARY_NAME) $(PHP_PROGRAM)
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2001/01/22 05:49:14 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2001/01/25 17:18:08 jlam Exp $
|
||||
bin/pear
|
||||
bin/php
|
||||
bin/php-config
|
||||
|
@ -147,11 +147,6 @@ include/php/regex/regex.h
|
|||
include/php/regex/regex2.h
|
||||
include/php/regex/regex_extra.h
|
||||
include/php/regex/utils.h
|
||||
lib/libphp4.a
|
||||
lib/libphp4.la
|
||||
lib/libphp4.so
|
||||
lib/libphp4.so.0
|
||||
lib/libphp4.so.0.0
|
||||
lib/php/Benchmark/Iterate.php
|
||||
lib/php/Benchmark/Timer.php
|
||||
lib/php/Crypt/HCEMD5.php
|
||||
|
|
Loading…
Reference in a new issue