Fix errno.

This commit is contained in:
joerg 2006-01-05 19:27:50 +00:00
parent b736e73e6a
commit c3ed17d3df
3 changed files with 35 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.1.1.1 2005/12/28 22:29:17 is Exp $
$NetBSD: distinfo,v 1.2 2006/01/05 19:27:50 joerg Exp $
SHA1 (mflteco.tar.gz) = d32206d961fa7068afa5a36cf9e688a018622c11
RMD160 (mflteco.tar.gz) = 993ea515f87c17bafc763e3d7dcd55130cf7e83e
@ -6,3 +6,5 @@ Size (mflteco.tar.gz) = 80566 bytes
SHA1 (patch-aa) = 3ee2c99f1a14c8f155faf866d29d070face206ab
SHA1 (patch-ab) = bdeaa25511e11a8e39516eb2aa4c2dbea9f1cf9e
SHA1 (patch-ac) = 052cf6f4ec6d03948543248f7bb9a872b00fb9f8
SHA1 (patch-ad) = cc4a7ce57a28623427163a7607952149c015d8a7
SHA1 (patch-ae) = 94cc73f43245b997d8504564f3efe0b74e5e9fc0

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ad,v 1.1 2006/01/05 19:27:50 joerg Exp $
--- te_defs.h.orig 2006-01-04 20:59:21.000000000 +0000
+++ te_defs.h
@@ -387,7 +387,6 @@ extern struct outfiledata po_file, so_fi
extern int char_count; /* char count for tab typer */
extern char lastc; /* last char read */
extern int ttyerr; /* error return from ioctl */
-extern int errno; /* system error code */
#ifdef POSIX_TECO
extern struct termios ttybuf; /* local copy of tty control data */
#else

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ae,v 1.1 2006/01/05 19:27:50 joerg Exp $
--- te_chario.c.orig 2006-01-04 21:01:15.000000000 +0000
+++ te_chario.c
@@ -101,7 +101,6 @@ char ldbuf[TTNAMEMAX];
setup_tty(arg)
int arg;
{
- extern int errno;
int ioerr;
struct sgttyb tmpbuf;
@@ -186,7 +185,6 @@ setup_tty(arg)
setup_tty(arg)
int arg;
{
- extern int errno;
int ioerr;
struct termios tmpbuf;