Changes 1.1.10 (toolkit):

* More string format fixes in silcd and client libary
* configure: changed AC_PROG_LIBTOOL order to fix disabling shared libs
* configure: check threads support in OpenBSD
* Fixed string format vulnerability in client entry handling
* Reported and patch provided by William Cummings
* silcd: Fixed IDENTIFY command reply handling for channels

Changes 1.1.18 (server):
* silcd: Added heartbeat support
* Added support for sending SILC_PACKET_HEARTBEAT packets to connection,
  to make sure they keep alive and to detect if they have died
* Set SO_KEEPALIVE for all accept()ed sockets
* silcd: Fixed SIGUSR1 signal handling
* Fixed the SIGUSR1 signal handling which can be used to dump the server
  internals to /tmp.
* Changed also End of Stream handling to handle NULL idata pointer instead
  of ignoring the EOS in case it is NULL.
* Changed also the DETACH timeout handling to use the packet stream
  directly instead of looking up client in the callback
* More string format fixes in silcd and client libary
This commit is contained in:
adam 2010-08-30 11:17:16 +00:00
parent c3f527e04f
commit c448e288e3
12 changed files with 1616 additions and 1214 deletions

View file

@ -1,23 +1,30 @@
# $NetBSD: Makefile,v 1.62 2010/02/19 21:01:36 joerg Exp $
#
# $NetBSD: Makefile,v 1.63 2010/08/30 11:17:16 adam Exp $
DISTNAME= silc-server-1.1.6
PKGREVISION= 1
CATEGORIES= chat security
MASTER_SITES= http://www.silcnet.org/download/server/sources/ \
ftp://ftp.silcnet.org/silc/server/sources/
EXTRACT_SUFX= .tar.bz2
DISTNAME= silc-server-1.1.18
CATEGORIES= chat security
MASTER_SITES= http://www.silcnet.org/download/server/sources/ \
ftp://ftp.silcnet.org/silc/server/sources/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= salo@NetBSD.org
HOMEPAGE= http://www.silcnet.org/
COMMENT= Server for the Secure Internet Live Conferencing (SILC) protocol
MAINTAINER= salo@NetBSD.org
HOMEPAGE= http://www.silcnet.org/
COMMENT= Server for the Secure Internet Live Conferencing (SILC) protocol
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
OVERRIDE_DIRDEPTH= 3
SHLIBTOOL_OVERRIDE= # empty
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-optimizations
CONFIGURE_ARGS+= --with-logsdir=${VARBASE}/log/silcd
CONFIGURE_ARGS+= --with-silc-includes=${BUILDLINK_PREFIX.silc-toolkit}/include/silc
CONFIGURE_ARGS+= --with-silc-libs=${BUILDLINK_PREFIX.silc-toolkit}/libs
CONFIGURE_ARGS+= --with-silcd-config-file=${PKG_SYSCONFDIR}/silcd.conf
CONFIGURE_ARGS+= --with-silcd-pid-file=${VARBASE}/run/silcd.pid
CONFIGURE_ARGS+= --without-gmp
CONFIGURE_ARGS+= --without-iconv
#.if ${MACHINE_ARCH} != "i386"
#CONFIGURE_ARGS+= --disable-asm
#.endif
.include "../../mk/bsd.prefs.mk"
@ -31,7 +38,7 @@ PKG_GROUPS_VARS+= SILCD_GROUP
PKG_SYSCONFSUBDIR?= ${PKGBASE}
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
MAKE_ENV+= examplesdir=${EGDIR:Q}
MAKE_ENV+= examplesdir=${EGDIR}
CONF_FILES_MODE= 0600
CONF_FILES+= ${EGDIR}/silcd.conf.default \
@ -50,25 +57,8 @@ RCD_SCRIPT_SRC.silcd= ${FILESDIR}/silcd.generic
.endif
BUILD_DEFS+= VARBASE
OWN_DIRS_PERMS+= ${VARBASE}/log/silcd ${SILCD_USER} ${SILCD_GROUP} 0700
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/${PKGBASE}
CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/${PKGBASE}
CONFIGURE_ARGS+= --with-etcdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+= --with-silcd-config-file=${PKG_SYSCONFDIR}/silcd.conf
CONFIGURE_ARGS+= --with-simdir=${PREFIX}/lib/${PKGBASE}/modules
CONFIGURE_ARGS+= --with-logsdir=${VARBASE}/log/silcd
CONFIGURE_ARGS+= --with-silcd-pid-file=${VARBASE}/run/silcd.pid
CONFIGURE_ARGS+= --without-iconv
CONFIGURE_ARGS+= --without-libtoolfix
# Doesn't work -- shared libraries are not installed
#CONFIGURE_ARGS+= --enable-shared
.if ${MACHINE_ARCH} != "i386"
CONFIGURE_ARGS+= --disable-asm
.endif
.include "options.mk"
SUBST_CLASSES+= paths
@ -84,4 +74,5 @@ INSTALLATION_DIRS+= ${EGDIR}
post-install:
${INSTALL_DATA} ${WRKSRC}/motd.txt ${DESTDIR}${EGDIR}/motd.txt.default
.include "../../devel/silc-toolkit/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,9 +1,10 @@
@comment $NetBSD: PLIST,v 1.20 2009/06/14 17:37:49 joerg Exp $
@comment $NetBSD: PLIST,v 1.21 2010/08/30 11:17:16 adam Exp $
man/man5/silcd.conf.5
man/man8/silcd.8
sbin/silcd
share/doc/silc-server/COPYING
share/doc/silc-server/CREDITS
share/doc/silc-server/ChangeLog
share/doc/silc-server/FAQ
share/doc/silc-server/INSTALL
share/doc/silc-server/README

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.35 2010/02/14 20:18:06 joerg Exp $
$NetBSD: distinfo,v 1.36 2010/08/30 11:17:16 adam Exp $
SHA1 (silc-server-1.1.6.tar.bz2) = 2f06d07e49a4313ad1458c5e1c79684418e242d3
RMD160 (silc-server-1.1.6.tar.bz2) = f309ba57222ed4278e904a2eaab5230893b58095
Size (silc-server-1.1.6.tar.bz2) = 924011 bytes
SHA1 (patch-aa) = b65ad3161d637fbc79a8ebb6516aebb7d396a7b3
SHA1 (patch-ab) = 55b3f00076c5b8a443465753ae07b9e812236f18
SHA1 (silc-server-1.1.18.tar.bz2) = eece759734da72b6ae16f83e4f8cabd8886dab05
RMD160 (silc-server-1.1.18.tar.bz2) = c68ea0875c9723a2f2322d2f1933e07e60abe53f
Size (silc-server-1.1.18.tar.bz2) = 908188 bytes
SHA1 (patch-aa) = 434f064e5d95e4590cebc2be651dcc0b5433d06e
SHA1 (patch-ab) = 94fad845b0efd346643acbea600833246bdbda46
SHA1 (patch-ac) = 53f13f15466f6d62a59068810896d763b60e8d70

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.11 2010/02/14 20:18:06 joerg Exp $
$NetBSD: patch-aa,v 1.12 2010/08/30 11:17:16 adam Exp $
--- apps/silcd/Makefile.in.orig 2005-05-10 18:59:04.000000000 +0200
+++ apps/silcd/Makefile.in 2005-06-19 02:36:04.000000000 +0200
@@ -581,13 +581,10 @@
--- apps/silcd/Makefile.in.orig 2009-09-26 20:34:14.000000000 +0000
+++ apps/silcd/Makefile.in
@@ -580,13 +580,10 @@ uninstall-am: uninstall-sbinPROGRAMS
install-dirs-server:
-mkdir -p $(docdir)
@ -16,7 +16,7 @@ $NetBSD: patch-aa,v 1.11 2010/02/14 20:18:06 joerg Exp $
-@if test -f $(top_srcdir)/doc/silcd.8 ; then \
$(INSTALL_DATA) $(top_srcdir)/doc/silcd.8 $(mandir)/man8; \
fi
@@ -605,8 +602,10 @@
@@ -604,8 +601,10 @@ etc-install-server:
fi
examples-install:
@ -29,7 +29,7 @@ $NetBSD: patch-aa,v 1.11 2010/02/14 20:18:06 joerg Exp $
generate-server-key:
-@if test '!' -f $(etcdir)/silcd.pub ; then \
@@ -616,9 +615,7 @@
@@ -615,9 +614,7 @@ generate-server-key:
install-data-hook: \
install-dirs-server \
doc-install-server \

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.8 2002/12/06 19:52:38 salo Exp $
$NetBSD: patch-ab,v 1.9 2010/08/30 11:17:16 adam Exp $
--- doc/example_silcd.conf.in.orig Sat Nov 30 15:09:21 2002
+++ doc/example_silcd.conf.in Fri Dec 6 19:04:31 2002
@@ -166,14 +166,14 @@
--- doc/example_silcd.conf.in.orig 2008-10-25 13:59:17.000000000 +0000
+++ doc/example_silcd.conf.in
@@ -186,7 +186,7 @@ ServerInfo {
#
# Server name (FQDN)
#
@ -11,15 +11,16 @@ $NetBSD: patch-ab,v 1.8 2002/12/06 19:52:38 salo Exp $
#
# Primary listener. Specify the IP address and the port to bind
# the server.
@@ -194,7 +194,7 @@ ServerInfo {
# if the server is behind NAT.
#
Primary {
- ip = "10.2.1.6";
+ ip = "127.0.0.1";
# public_ip = "11.1.1.1";
port = 706;
};
@@ -181,8 +181,7 @@
@@ -203,8 +203,7 @@ ServerInfo {
# Secondary listener(s). If you need to bind your server into
# several interfaces use the Secondary to specify the listener(s).
#
@ -29,7 +30,7 @@ $NetBSD: patch-ab,v 1.8 2002/12/06 19:52:38 salo Exp $
#
# ServerType field specifies the purpose of this server
@@ -193,7 +192,7 @@
@@ -215,7 +214,7 @@ ServerInfo {
#
# Geographic location
#
@ -38,7 +39,7 @@ $NetBSD: patch-ab,v 1.8 2002/12/06 19:52:38 salo Exp $
#
# Full admin name
@@ -209,8 +208,8 @@
@@ -231,8 +230,8 @@ ServerInfo {
# Run SILC server as specific user and group. The server must be
# initially run as root.
#
@ -49,7 +50,7 @@ $NetBSD: patch-ab,v 1.8 2002/12/06 19:52:38 salo Exp $
#
# Public and private keys
@@ -223,7 +222,7 @@
@@ -245,7 +244,7 @@ ServerInfo {
#
# Specifies the text file displayed on client connection
#
@ -58,7 +59,7 @@ $NetBSD: patch-ab,v 1.8 2002/12/06 19:52:38 salo Exp $
#
# Pid file
@@ -255,7 +254,7 @@
@@ -278,7 +277,7 @@ Logging {
# reduces memory usage. By default it is false and log files are
# written with FlushDelay timeout.
#
@ -67,7 +68,7 @@ $NetBSD: patch-ab,v 1.8 2002/12/06 19:52:38 salo Exp $
# FlushDelay tells log files update delay (seconds) in case you
# have chosen buffering output. This setting has effect only if
@@ -435,9 +434,9 @@
@@ -458,9 +457,9 @@ Client {
# required.
#
Admin {
@ -80,7 +81,7 @@ $NetBSD: patch-ab,v 1.8 2002/12/06 19:52:38 salo Exp $
Passphrase = "verysecret";
# PublicKey = "/path/to/the/public.pub";
};
@@ -496,17 +495,17 @@
@@ -520,17 +519,17 @@ ServerConnection {
# backup router is in our cell then set the "BackupLocal" option to true.
# If the backup router is in other cell then set it to false.
#

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ac,v 1.14 2010/08/30 11:17:16 adam Exp $
--- configure.orig 2010-08-30 10:05:32.000000000 +0000
+++ configure
@@ -19018,9 +19018,6 @@ if test -n "$with_silc_includes" || test
has_threads=true
fi
f=`$EGREP __SILC_HAVE_SIM $ac_silc_includes/silc.h`
- if test -n "$f"; then
- LIBS="$LIBS -ldl"
- fi
else
# pkg-config check

View file

@ -1,44 +1,38 @@
# $NetBSD: Makefile,v 1.15 2010/01/16 17:57:37 wiz Exp $
#
# $NetBSD: Makefile,v 1.16 2010/08/30 11:17:16 adam Exp $
DISTNAME= silc-toolkit-0.9.13
PKGREVISION= 1
CATEGORIES= devel chat security
MASTER_SITES= http://www.silcnet.org/download/toolkit/sources/ \
ftp://ftp.silcnet.org/silc/toolkit/sources/
EXTRACT_SUFX= .tar.bz2
DISTNAME= silc-toolkit-1.1.10
CATEGORIES= devel chat security
MASTER_SITES= http://www.silcnet.org/download/toolkit/sources/ \
ftp://ftp.silcnet.org/silc/toolkit/sources/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= salo@NetBSD.org
HOMEPAGE= http://www.silcnet.org/
COMMENT= Secure Internet Live Conferencing (SILC) protocol Toolkit
MAINTAINER= salo@NetBSD.org
HOMEPAGE= http://www.silcnet.org/
COMMENT= Secure Internet Live Conferencing (SILC) protocol Toolkit
PKG_DESTDIR_SUPPORT= user-destdir
MAKE_JOBS_SAFE= no
CONFLICTS+= silc-client<1.0.1nb1
GNU_CONFIGURE= YES
USE_LIBTOOL= YES
OVERRIDE_DIRDEPTH= 3 # */*/*/libtool
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-optimizations
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/silc
CONFIGURE_ARGS+= --with-simdir=${PREFIX}/lib/silc/modules
CONFIGURE_ARGS+= --without-gmp
CONFIGURE_ARGS+= --without-iconv
#.if ${MACHINE_ARCH} != "i386"
#CONFIGURE_ARGS+= --disable-asm
#.endif
PKGCONFIG_OVERRIDE+= lib/silc.pc.in
PKGCONFIG_OVERRIDE+= lib/silcclient.pc.in
PKGCONFIG_OVERRIDE+= lib/silcserver.pc.in
.include "../../mk/bsd.prefs.mk"
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/silc
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/silc
CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/silc-toolkit
CONFIGURE_ARGS+= --with-simdir=${PREFIX}/lib/silc/modules
CONFIGURE_ARGS+= --without-iconv
CONFIGURE_ARGS+= --without-irssi
CONFIGURE_ARGS+= --without-silcd
CONFIGURE_ARGS+= --without-libtoolfix
# lib/silcclient/client_attrs.c causes an ICE with xlc on Darwin.
NOT_FOR_COMPILER+= xlc
.if ${MACHINE_ARCH} != "i386"
CONFIGURE_ARGS+= --disable-asm
.endif
NOT_FOR_COMPILER= xlc
.include "options.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.8 2009/03/20 19:24:29 joerg Exp $
# $NetBSD: buildlink3.mk,v 1.9 2010/08/30 11:17:16 adam Exp $
#
BUILDLINK_TREE+= silc-toolkit
@ -6,8 +6,8 @@ BUILDLINK_TREE+= silc-toolkit
.if !defined(SILC_TOOLKIT_BUILDLINK3_MK)
SILC_TOOLKIT_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.silc-toolkit+= silc-toolkit>=0.9.12
BUILDLINK_ABI_DEPENDS.silc-toolkit+= silc-toolkit>=0.9.12nb1
BUILDLINK_API_DEPENDS.silc-toolkit+= silc-toolkit>=1.1.10
BUILDLINK_ABI_DEPENDS.silc-toolkit+= silc-toolkit>=1.1.10
BUILDLINK_PKGSRCDIR.silc-toolkit?= ../../devel/silc-toolkit
.include "../../devel/libgetopt/buildlink3.mk"

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.5 2009/10/07 18:23:19 joerg Exp $
$NetBSD: distinfo,v 1.6 2010/08/30 11:17:16 adam Exp $
SHA1 (silc-toolkit-0.9.13.tar.bz2) = 957513aaf7785b7626eddf203520acc63192b6ea
RMD160 (silc-toolkit-0.9.13.tar.bz2) = dad8e919cedec78c852aa0625496bb30621b798d
Size (silc-toolkit-0.9.13.tar.bz2) = 2879639 bytes
SHA1 (patch-aa) = 18a35ea14c980fbcaf582139479a53d7996a28e0
SHA1 (patch-ab) = 60f292a9994c5d94748c51553146bcf992c7584a
SHA1 (silc-toolkit-1.1.10.tar.bz2) = 0bd4b1b410424733687fd2ad33c1b09cbbf8673f
RMD160 (silc-toolkit-1.1.10.tar.bz2) = 9a505420569e8595eaee684c2e4bde7e4570654d
Size (silc-toolkit-1.1.10.tar.bz2) = 1830280 bytes

View file

@ -1,31 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/06/06 12:23:23 salo Exp $
--- Makefile.in.orig 2004-02-29 16:10:00.000000000 +0100
+++ Makefile.in 2004-06-05 19:05:03.000000000 +0200
@@ -827,13 +827,13 @@
fi
sim-install:
+ -$(BSD_INSTALL_DATA_DIR) $(modulesdir)
-$(INSTALL_DATA) $(srcdir)/lib/silcsim/*.so $(modulesdir)/
toolkit-install:
- -mkdir -p $(docdir)/toolkit/
- -$(INSTALL_DATA) $(srcdir)/doc/toolkit/* $(docdir)/toolkit
- -$(INSTALL_DATA) $(srcdir)/lib/doc/*.gif $(docdir)/toolkit
- -cp -R $(srcdir)/tutorial $(prefix)
+ -$(BSD_INSTALL_DATA_DIR) $(docdir)/manual/
+ -$(INSTALL_DATA) $(srcdir)/doc/toolkit/* $(docdir)/manual
+ -$(INSTALL_DATA) $(srcdir)/lib/doc/*.gif $(docdir)/manual
examples-install:
-mkdir -p $(docdir)/examples/
@@ -846,7 +846,7 @@
fi
@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs-client sim-install doc-install-client etc-install-client
-@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_TRUE@install-data-hook: install-dirs-client install-dirs-server sim-install doc-install-client doc-install-server toolkit-install examples-install etc-install-client etc-install-server
+@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_TRUE@install-data-hook: sim-install toolkit-install
@SILC_DIST_CLIENT_FALSE@@SILC_DIST_TOOLKIT_FALSE@install-data-hook: install-dirs-server sim-install doc-install-server examples-install etc-install-server generate-server-key
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.

View file

@ -1,20 +0,0 @@
$NetBSD: patch-ab,v 1.3 2009/10/07 18:23:19 joerg Exp $
--- lib/Makefile.in.orig 2009-10-07 20:09:56.000000000 +0200
+++ lib/Makefile.in
@@ -645,11 +645,11 @@ remove:
@SILC_DIST_TOOLKIT_TRUE@install-exec-hook:
@SILC_DIST_TOOLKIT_TRUE@ -mkdir -p $(DESTDIR)$(libdir)
-@SILC_DIST_TOOLKIT_TRUE@ -$(LIBTOOL) $(INSTALL) libsilc.la $(DESTDIR)$(libdir)/
-@SILC_DIST_TOOLKIT_TRUE@ -$(LIBTOOL) $(INSTALL) libsilcclient.la $(DESTDIR)$(libdir)/
+@SILC_DIST_TOOLKIT_TRUE@ -$(LIBTOOL) --mode=install $(INSTALL) libsilc.la $(DESTDIR)$(libdir)/
+@SILC_DIST_TOOLKIT_TRUE@ -$(LIBTOOL) --mode=install $(INSTALL) libsilcclient.la $(DESTDIR)$(libdir)/
@SILC_DIST_TOOLKIT_FALSE@install-exec-hook:
-@SILC_DIST_TOOLKIT_FALSE@ -mkdir -p $(libdir)
-@SILC_DIST_TOOLKIT_FALSE@ -$(LIBTOOL) $(INSTALL) libsilc.la $(DESTDIR)$(libdir)/
+@SILC_DIST_TOOLKIT_FALSE@ -mkdir -p ${DESTDIR}$(libdir)
+@SILC_DIST_TOOLKIT_FALSE@ -$(LIBTOOL) --mode=install $(INSTALL) libsilc.la $(DESTDIR)$(libdir)/
@SILC_DIST_TOOLKIT_FALSE@ -rm -rf $(DESTDIR)$(libdir)/libsilc.a
@SILC_DIST_CLIENT_TRUE@@SILC_DIST_TOOLKIT_FALSE@ -$(LIBTOOL) $(INSTALL) libsilcclient.la $(DESTDIR)$(libdir)/
@SILC_DIST_CLIENT_TRUE@@SILC_DIST_TOOLKIT_FALSE@ -rm -rf $(DESTDIR)$(libdir)/libsilcclient.a