Initial import of dwm-3.9 from pkgsrc-wip.

dwm is a dynamic window manager for X. It manages windows in tiling
and floating modes. Either mode can be applied dynamically, optimizing
the environment for the application in use and the task performed. It
is the little brother of wmii.

dwm contains a small status bar which displays all available tags, the
mode, the title of the focused window, and the text read from standard
input. The selected tags are highlighted with a different color, the
tags of the focused window are highlighted with a small point.
This commit is contained in:
xtraeme 2007-04-13 09:08:07 +00:00
parent 59daad6172
commit c451d2cd27
5 changed files with 72 additions and 0 deletions

9
wm/dwm/DESCR Normal file
View file

@ -0,0 +1,9 @@
dwm is a dynamic window manager for X. It manages windows in tiling
and floating modes. Either mode can be applied dynamically, optimizing
the environment for the application in use and the task performed. It
is the little brother of wmii.
dwm contains a small status bar which displays all available tags, the
mode, the title of the focused window, and the text read from standard
input. The selected tags are highlighted with a different color, the
tags of the focused window are highlighted with a small point.

18
wm/dwm/Makefile Normal file
View file

@ -0,0 +1,18 @@
# $NetBSD: Makefile,v 1.1.1.1 2007/04/13 09:08:07 xtraeme Exp $
DISTNAME= dwm-3.9
CATEGORIES= wm
MASTER_SITES= http://suckless.org/download/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://dwm.suckless.org/
COMMENT= Dynamic window manager
NO_CONFIGURE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dwm ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/dwm.1 ${PREFIX}/${PKGMANDIR}/man1
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
wm/dwm/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2007/04/13 09:08:07 xtraeme Exp $
bin/dwm
man/man1/dwm.1

6
wm/dwm/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2007/04/13 09:08:07 xtraeme Exp $
SHA1 (dwm-3.9.tar.gz) = e070acaac4221f229a7eeac198e78e9cf7438be1
RMD160 (dwm-3.9.tar.gz) = 43f380b84e4250d1bb638096f0f792dc14ad4abf
Size (dwm-3.9.tar.gz) = 17998 bytes
SHA1 (patch-aa) = 79a3a1843ce347f3f0152065c7e391cd71bc4795

36
wm/dwm/patches/patch-aa Normal file
View file

@ -0,0 +1,36 @@
$NetBSD: patch-aa,v 1.1.1.1 2007/04/13 09:08:07 xtraeme Exp $
--- config.mk.orig 2007-04-02 11:11:37.000000000 +0200
+++ config.mk 2007-04-13 04:30:19.000000000 +0200
@@ -4,19 +4,18 @@
# Customize below to fit your system
# paths
-PREFIX = /usr/local
-MANPREFIX = ${PREFIX}/share/man
+MANPREFIX = ${PREFIX}/${PKGMANDDIR}
-X11INC = /usr/X11R6/include
-X11LIB = /usr/X11R6/lib
+X11INC = ${X11BASE}/include
+X11LIB = ${X11BASE}/lib
# includes and libs
INCS = -I. -I/usr/include -I${X11INC}
-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
+LIBS = -lc -lX11
# flags
-CFLAGS = -Os ${INCS} -DVERSION=\"${VERSION}\"
-LDFLAGS = ${LIBS}
+CFLAGS += -DVERSION=\"${VERSION}\"
+LDFLAGS += ${LIBS}
#CFLAGS = -g -Wall -O2 ${INCS} -DVERSION=\"${VERSION}\"
#LDFLAGS = -g ${LIBS}
@@ -26,4 +25,4 @@
#CFLAGS += -xtarget=ultra
# compiler and linker
-CC = cc
+#CC = cc