Fix build of abiword-plugins with gnutls-3.5.

From upstream via David H. Gutteridge in PR 51501.

Bump PKGREVISION.
This commit is contained in:
wiz 2016-09-27 12:00:50 +00:00
parent ec67624b70
commit c45c4f0d55
4 changed files with 33 additions and 5 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.69 2016/09/19 17:18:19 jperkin Exp $
# $NetBSD: Makefile,v 1.70 2016/09/27 12:00:51 wiz Exp $
.include "../../editors/abiword/Makefile.common"
DISTNAME= abiword-${ABIVERSION}
PKGNAME= abiword-plugins-${ABIVERSION}
PKGREVISION= 8
PKGREVISION= 9
CATEGORIES= editors
MASTER_SITES= http://www.abiword.com/downloads/abiword/${PKGVERSION_NOREV}/source/
@ -37,7 +37,7 @@ CONFIGURE_ARGS+= --with-evolution-data-server=no
# Disabled plugins: gda rsvg mathview
# rsvg is not needed with gtk, we don't have libgnomedb
# and mathview doesn't work (in future versions mathveiw uses
# lasem instead of gtkmathview, it might work)
# lasem instead of gtkmathview, it might work)
CONFIGURE_ARGS+= --enable-plugins="\
aiksaurus \
applix \

View file

@ -1,3 +1,4 @@
# $NetBSD: Makefile.common,v 1.45 2015/12/29 04:04:28 dholland Exp $
# $NetBSD: Makefile.common,v 1.46 2016/09/27 12:00:50 wiz Exp $
# used by editors/abiword-plugins/Makefile
ABIVERSION=3.0.1

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.70 2016/04/18 15:29:50 jperkin Exp $
$NetBSD: distinfo,v 1.71 2016/09/27 12:00:50 wiz Exp $
SHA1 (abiword-3.0.1.tar.gz) = 7badf9663564a144e16764a456cadda18df70991
RMD160 (abiword-3.0.1.tar.gz) = 05d92a7304e4e419776970d7b35065ceb59f7681
@ -7,6 +7,7 @@ Size (abiword-3.0.1.tar.gz) = 11144990 bytes
SHA1 (patch-configure.ac) = 239c0635c2c616c7e0a986a5fd92428393af38b7
SHA1 (patch-plugin-configure.m4) = a8b8db3bdbd69339e32eefec1de7b1b59467db40
SHA1 (patch-plugins_aiksaurus_Makefile.am) = 1529d5098b7fb798c428fe02cc50879374cb3e9d
SHA1 (patch-plugins_collab_backends_service_xp_tls__tunnel.cpp) = f8eed4520951653822c6de8da371c8cb42dcbc89
SHA1 (patch-plugins_command_Makefile.am) = e003a6bf9a6e0566abc85f09868fdf1aa93234d7
SHA1 (patch-plugins_gimp_xp_AbiGimp.cpp) = 15692cf15fd4099e7ad4ad854b6b57b103717269
SHA1 (patch-plugins_goffice_Makefile.am) = 1959eea3b4e19f085aeb56870f682ce44561d445

View file

@ -0,0 +1,26 @@
$NetBSD: patch-plugins_collab_backends_service_xp_tls__tunnel.cpp,v 1.1 2016/09/27 12:00:51 wiz Exp $
Fix build with gnutls-3.5.
http://www.abisource.com/viewvc/abiword/branches/ABI-3-0-0-STABLE/plugins/collab/backends/service/xp/tls_tunnel.cpp?r1=35270&r2=35269&pathrev=35270
--- plugins/collab/backends/service/xp/tls_tunnel.cpp.orig 2014-11-04 01:12:14.000000000 +0000
+++ plugins/collab/backends/service/xp/tls_tunnel.cpp
@@ -306,9 +306,6 @@ void Proxy::tunnel_(transport_ptr_t tran
disconnect_(transport_ptr, session_ptr, local_socket_ptr, remote_socket_ptr);
}
-static const int PRIORITIES[] = { GNUTLS_KX_ANON_DH, GNUTLS_KX_RSA, GNUTLS_KX_DHE_DSS, GNUTLS_KX_DHE_RSA, 0 };
-static const int CIPHERS[] = { GNUTLS_CIPHER_AES_256_CBC, GNUTLS_CIPHER_AES_128_CBC, GNUTLS_CIPHER_3DES_CBC, GNUTLS_CIPHER_ARCFOUR_128, 0 };
-
// FIXME: this clientproxy can only handle 1 SSL connection at the same time
ClientProxy::ClientProxy(const std::string& connect_address, unsigned short connect_port,
const std::string& ca_file, bool check_hostname)
@@ -400,8 +397,6 @@ session_ptr_t ClientProxy::setup_tls_ses
// setup session
return_val_if_neg(gnutls_init(session_ptr.get(), GNUTLS_CLIENT), session_ptr_t());
return_val_if_neg(gnutls_set_default_priority(*session_ptr), session_ptr_t());
- return_val_if_neg(gnutls_kx_set_priority(*session_ptr,PRIORITIES), session_ptr_t());
- return_val_if_neg(gnutls_cipher_set_priority(*session_ptr,CIPHERS), session_ptr_t());
return_val_if_neg(gnutls_credentials_set(*session_ptr, GNUTLS_CRD_CERTIFICATE, x509cred), session_ptr_t());
// setup transport