Add xkbset 0.3:

xkbset is a program rather like xset in that it allows you to set
various features of the X window interface.  It allows one to configure
most of the options connected with the XKB extensions.  They are described
in Section 10 of XKBlib.ps.


XXX

With this program, X can be made to work on a Toshiba Portege 3000
wwwiiittthhhooouuuuttt key repeating. Just put this into your
.xinitrc / .xsession:

	xkbset exp bo
	xkbset bo

Thanks to erik.berglund@deployit.biz for this hint!
This commit is contained in:
hubertf 2002-09-23 15:39:46 +00:00
parent d302493840
commit c46615f8b7
5 changed files with 60 additions and 0 deletions

17
x11/xkbset/DESCR Normal file
View file

@ -0,0 +1,17 @@
xkbset is a program rather like xset in that it allows you to set
various features of the X window interface. It allows one to configure
most of the options connected with the XKB extensions. They are described
in Section 10 of XKBlib.ps.
This includes customizing the following:
MouseKeys: using the numeric pad keys to move the mouse;
StickyKeys: where modifiers like control and shift will lock until the
next key press (good for one finger typing);
SlowKeys: The keys will not work unless they are pressed for a certain
amount of time;
BounceKeys: If a key is pressed more than once rapidly, only one key
press will be registered.
I also include a gui program mskacc-gui which is a GUI program to play
with the mousekeys acceleration parameters. It is written in Perl/Tk,
so Perl/Tk will need to be installed on your machine.

15
x11/xkbset/Makefile Normal file
View file

@ -0,0 +1,15 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/09/23 15:39:46 hubertf Exp $
#
DISTNAME= xkbset-0.3
CATEGORIES= x11
MASTER_SITES= http://www.math.missouri.edu/~stephen/software/xkbset/
MAINTAINER= hubertf@netbsd.org
HOMEPAGE= http://www.math.missouri.edu/~stephen/software/#xkbset
COMMENT= Manages XKB features of the X window system
USE_X11BASE= yes
REPLACE_PERL= mskacc-gui
.include "../../mk/bsd.pkg.mk"

4
x11/xkbset/PLIST Normal file
View file

@ -0,0 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/09/23 15:39:46 hubertf Exp $
bin/xkbset
bin/mskacc-gui
man/man1/xkbset.1

5
x11/xkbset/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2002/09/23 15:39:46 hubertf Exp $
SHA1 (xkbset-0.3.tar.gz) = 23133cc74b09182c1ce8efc2dc2ff1a78feb34b6
Size (xkbset-0.3.tar.gz) = 13279 bytes
SHA1 (patch-aa) = a419e9bc0b713feb57fd08742260ddec788718f3

View file

@ -0,0 +1,19 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/09/23 15:39:46 hubertf Exp $
--- Makefile.orig Sun May 13 06:09:39 2001
+++ Makefile
@@ -1,10 +1,10 @@
# The following are for XFree86 on FreeBSD
-INC_PATH=-I/usr/X11R6/include
-LIB_PATH=-L/usr/X11R6/lib
+INC_PATH=-I${X11BASE}/include
+LIB_PATH= -Wl,-R${X11BASE}/lib -L${X11BASE}/lib
LIBS=-lX11
CC=cc ${INC_PATH} ${LIB_PATH} -Wall
-INSTALL_BIN=/usr/X11R6/bin
-INSTALL_MAN1=/usr/X11R6/man/man1
+INSTALL_BIN=${X11BASE}/bin
+INSTALL_MAN1=${X11BASE}/man/man1
all: xkbset xkbset.1