cmake: Fix build under macOS with Xcode 9.4
Xcode 9.4 triggers linker warnings that the C++ feature detection code considers fatal. Simply ignore these warning by adding an entry to the existing filter table.
This commit is contained in:
parent
26d3cabe19
commit
c475d9398a
2 changed files with 20 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.121 2018/06/01 07:16:03 adam Exp $
|
||||
$NetBSD: distinfo,v 1.122 2018/06/11 17:33:51 tron Exp $
|
||||
|
||||
SHA1 (cmake-3.11.3.tar.gz) = 73261a5b7f71abf7277c1d2a418ca3c4cf170c89
|
||||
RMD160 (cmake-3.11.3.tar.gz) = 90e5ae01c3a68b31095967b5d1c8e245065bb294
|
||||
|
@ -13,6 +13,7 @@ SHA1 (patch-Modules_FindX11.cmake) = 124a2d51155cb4455e8b829dc74598cbd50a4e1c
|
|||
SHA1 (patch-Modules_Platform_UnixPaths.cmake) = 38720e11b7b62cb702e80da19e044f070298f2db
|
||||
SHA1 (patch-Source_CMakeLists.txt) = 533667d43048b8bc2be17a766b5dc32f3101866e
|
||||
SHA1 (patch-Source_Checks_cm__cxx17__check.cpp) = 37772f3e7edc2413cb2e294462312aff18e5c989
|
||||
SHA1 (patch-Source_Checks_cm_cxx_features.cmake) = 83eb2bedb84972637d02d12f72fec0ccf74563eb
|
||||
SHA1 (patch-Source_CursesDialog_ccmake.cxx) = d7baafe6612b6ac9b0542ed10ffcf90cd8d1df87
|
||||
SHA1 (patch-Utilities_KWIML_CMakeLists.txt) = e4bdf9fc58757e87bf7e3e3e195839eededbc796
|
||||
SHA1 (patch-bootstrap) = 9d99cfe9f9ae826250f94bc297f5a22b8de09e84
|
||||
|
|
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-Source_Checks_cm_cxx_features.cmake,v 1.1 2018/06/11 17:33:51 tron Exp $
|
||||
|
||||
Ignore warnings like ...
|
||||
|
||||
ld: warning: text-based stub file /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SharedFileList.framework/Versions/A/SharedFileList.tbd and library file /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SharedFileList.framework/Versions/A/SharedFileList are out of sync. Falling back to library file for linking.
|
||||
|
||||
... caused by recent version of Xcode which break C++11 detection under macOS.
|
||||
|
||||
--- Source/Checks/cm_cxx_features.cmake.orig 2018-05-31 13:39:10.000000000 +0100
|
||||
+++ Source/Checks/cm_cxx_features.cmake 2018-06-11 18:24:30.000000000 +0100
|
||||
@@ -21,6 +21,7 @@
|
||||
string(REGEX REPLACE "[^\n]*warning:[^\n]*-Winvalid-command-line-argument[^\n]*" "" check_output "${check_output}")
|
||||
# Filter out warnings caused by local configuration.
|
||||
string(REGEX REPLACE "[^\n]*warning:[^\n]*directory not found for option[^\n]*" "" check_output "${check_output}")
|
||||
+ string(REGEX REPLACE "[^\n]*warning:[^\n]*text-based stub file [^\n]* and library file [^\n]* are out of sync[^\n]*" "" check_output "${check_output}")
|
||||
string(REGEX REPLACE "[^\n]*warning:[^\n]*object file compiled with -mlong-branch which is no longer needed[^\n]*" "" check_output "${check_output}")
|
||||
# If using the feature causes warnings, treat it as broken/unavailable.
|
||||
if(check_output MATCHES "[Ww]arning")
|
Loading…
Reference in a new issue