Release Notes for DNSCheck Lib v1.4.0
===================================== * Minimum required Perl version is now 5.10.1. * A couple of new tests: - That a minimal referral can fit in a 512-octet packet. - The responses come from the same IP address the question was sent to. - That NSEC or NSEC3 is used in signed zones. - That NSEC3 parameters are sane. - That RRSIG durations are sane. * CZNIC contributed a Czech translation. * Reserved IP ranges updated according to new RFCs. * All tests that made SMTP connections have been removed. * The CLI script has a --level flag to specify the lowest log level you want printed. * A new, better algorithm to check nameserver AS distribution. * Plus of course bug and stability fixes. Release Notes for DNSCheck Lib v1.3.0 ===================================== Notable changes: * The configuration file layout has changed completely! Instead of the old, complicated variant, default configuration, default policy and language files are now installed in the proper place in the Perl module tree. The user should never need to care exactly where that is. Local changes to the configuration now lives in /etc/dnscheck/config.yaml and /etc/dnscheck/policy.yaml You have to manually move and rename your old site_config.yaml and site_policy.yaml, if you have them!
This commit is contained in:
parent
6a27fae5c0
commit
c48c359c84
4 changed files with 43 additions and 37 deletions
|
@ -1,11 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.4 2013/05/31 12:41:32 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2013/06/15 21:18:49 pettai Exp $
|
||||
#
|
||||
|
||||
DISTNAME= dotse-dnscheck-1.2.6-0-g86a5c69
|
||||
PKGNAME= dnscheck-1.2.6
|
||||
PKGREVISION= 2
|
||||
DISTNAME= dotse-dnscheck-1.4.1-0-ga93f48c
|
||||
PKGNAME= dnscheck-1.4.1
|
||||
CATEGORIES= net perl5
|
||||
MASTER_SITES= -https://github.com/dotse/dnscheck/tarball/1.2.6
|
||||
MASTER_SITES= -https://github.com/dotse/dnscheck/tarball/1.4.1
|
||||
|
||||
MAINTAINER= pettai@NetBSD.org
|
||||
HOMEPAGE= https://github.com/dotse/dnscheck/
|
||||
|
@ -24,6 +23,9 @@ DEPENDS+= p5-IO-Socket-INET6>=2.51:../../net/p5-IO-Socket-INET6
|
|||
DEPENDS+= p5-Mail-RFC822-Address-[0-9]*:../../mail/p5-Mail-RFC822-Address
|
||||
DEPENDS+= p5-DBI-[0-9]*:../../databases/p5-DBI
|
||||
DEPENDS+= p5-DBD-mysql-[0-9]*:../../databases/p5-DBD-mysql
|
||||
DEPENDS+= p5-Config-Any-[0-9]*:../../devel/p5-Config-Any
|
||||
DEPENDS+= p5-File-ShareDir-[0-9]*:../../devel/p5-File-ShareDir
|
||||
DEPENDS+= p5-File-ShareDir-Install-[0-9]*:../../devel/p5-File-ShareDir-Install
|
||||
DEPENDS+= p5-File-Slurp-[0-9]*:../../devel/p5-File-Slurp
|
||||
DEPENDS+= p5-JSON-XS-[0-9]*:../../converters/p5-JSON-XS
|
||||
DEPENDS+= p5-MIME-Lite-[0-9]*:../../mail/p5-MIME-Lite
|
||||
|
@ -31,16 +33,17 @@ DEPENDS+= p5-Text-Template-[0-9]*:../../textproc/p5-Text-Template
|
|||
|
||||
REPLACE_PERL+= lib/DNSCheck.pm lib/DNSCheck/*.pm
|
||||
REPLACE_PERL+= lib/DNSCheck/Lookup/*.pm lib/DNSCheck/Test/*.pm
|
||||
REPLACE_PERL+= apps/dnscheck-packetcheck
|
||||
|
||||
PERL5_PACKLIST= auto/DNSCheck/.packlist
|
||||
BUILDLINK_API_DEPENDS.perl+= perl>=5.6.1
|
||||
|
||||
WRKSRC= ${WRKDIR}/dotse-dnscheck-b73204b/engine
|
||||
WRKSRC= ${WRKDIR}/dotse-dnscheck-f058797/engine
|
||||
SYSCONFDIR= `${BASENAME} ${PKG_SYSCONFDIR}`
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
|
||||
CONF_FILES= ${EGDIR}/config.yaml ${PKG_SYSCONFDIR}/${PKGBASE}/config.yaml
|
||||
CONF_FILES+= ${EGDIR}/policy.yaml ${PKG_SYSCONFDIR}/${PKGBASE}/policy.yaml
|
||||
#CONF_FILES= ${EGDIR}/config.yaml ${PKG_SYSCONFDIR}/${PKGBASE}/config.yaml
|
||||
#CONF_FILES+= ${EGDIR}/policy.yaml ${PKG_SYSCONFDIR}/${PKGBASE}/policy.yaml
|
||||
|
||||
BUILD_DEFS+= IPV6_READY
|
||||
|
||||
|
@ -55,9 +58,9 @@ OWN_DIRS= ${SYSCONFDIR}/${PKGBASE}
|
|||
post-patch:
|
||||
${RM} ${WRKSRC}/lib/DNSCheck/Config.pm.orig
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/config.yaml ${DESTDIR}${EGDIR}/
|
||||
${INSTALL_DATA} ${WRKSRC}/policy.yaml ${DESTDIR}${EGDIR}/
|
||||
#post-install:
|
||||
# ${INSTALL_DATA} ${WRKSRC}/config.yaml ${DESTDIR}${EGDIR}/
|
||||
# ${INSTALL_DATA} ${WRKSRC}/policy.yaml ${DESTDIR}${EGDIR}/
|
||||
|
||||
.include "../../lang/perl5/module.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2012/05/08 22:39:39 pettai Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2013/06/15 21:18:49 pettai Exp $
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck/Config.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck/Locale.pm
|
||||
|
@ -16,20 +16,24 @@ ${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck/Test/Delegation.pm
|
|||
${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck/Test/Host.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck/Test/Mail.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck/Test/Nameserver.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck/Test/SMTP.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck/Test/SOA.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/DNSCheck/Test/Zone.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/MockBootstrap.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/MockResolver.pm
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/auto/share/dist/DNSCheck/config.yaml
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/auto/share/dist/DNSCheck/en.yaml
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/auto/share/dist/DNSCheck/nl.yaml
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/auto/share/dist/DNSCheck/policy.yaml
|
||||
${PERL5_SUB_INSTALLVENDORLIB}/auto/share/dist/DNSCheck/sv.yaml
|
||||
${PERL5_SUB_INSTALLVENDORARCH}/auto/DNSCheck/.packlist
|
||||
${PERL5_SUB_INSTALLVENDORBIN}/dnscheck
|
||||
${PERL5_SUB_INSTALLVENDORBIN}/dnscheck-12hourmailer
|
||||
${PERL5_SUB_INSTALLVENDORBIN}/dnscheck-dispatcher
|
||||
${PERL5_SUB_INSTALLVENDORBIN}/dnscheck-dnssecmailer
|
||||
${PERL5_SUB_INSTALLVENDORBIN}/dnscheck-hostsyntax
|
||||
${PERL5_SUB_INSTALLVENDORBIN}/dnscheck-preflight
|
||||
${PERL5_SUB_INSTALLVENDORBIN}/dnscheck-zonediff
|
||||
${PERL5_SUB_INSTALLVENDORMAN1DIR}/dnscheck-12hourmailer.1
|
||||
${PERL5_SUB_INSTALLVENDORMAN1DIR}/dnscheck-dispatcher.1
|
||||
${PERL5_SUB_INSTALLVENDORMAN1DIR}/dnscheck-dnssecmailer.1
|
||||
${PERL5_SUB_INSTALLVENDORMAN1DIR}/dnscheck-hostsyntax.1
|
||||
${PERL5_SUB_INSTALLVENDORMAN1DIR}/dnscheck-preflight.1
|
||||
${PERL5_SUB_INSTALLVENDORMAN1DIR}/dnscheck-zonediff.1
|
||||
|
@ -51,11 +55,6 @@ ${PERL5_SUB_INSTALLVENDORMAN3DIR}/DNSCheck::Test::Delegation.3
|
|||
${PERL5_SUB_INSTALLVENDORMAN3DIR}/DNSCheck::Test::Host.3
|
||||
${PERL5_SUB_INSTALLVENDORMAN3DIR}/DNSCheck::Test::Mail.3
|
||||
${PERL5_SUB_INSTALLVENDORMAN3DIR}/DNSCheck::Test::Nameserver.3
|
||||
${PERL5_SUB_INSTALLVENDORMAN3DIR}/DNSCheck::Test::SMTP.3
|
||||
${PERL5_SUB_INSTALLVENDORMAN3DIR}/DNSCheck::Test::SOA.3
|
||||
${PERL5_SUB_INSTALLVENDORMAN3DIR}/DNSCheck::Test::Zone.3
|
||||
share/dnscheck/locale/en.yaml
|
||||
share/dnscheck/locale/nl.yaml
|
||||
share/dnscheck/locale/sv.yaml
|
||||
share/examples/dnscheck/config.yaml
|
||||
share/examples/dnscheck/policy.yaml
|
||||
@pkgdir share/examples/dnscheck
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2012/05/08 22:39:39 pettai Exp $
|
||||
$NetBSD: distinfo,v 1.2 2013/06/15 21:18:49 pettai Exp $
|
||||
|
||||
SHA1 (dotse-dnscheck-1.2.6-0-g86a5c69.tar.gz) = da2b5e8cf84eb4416dc32a4006c901b18040b137
|
||||
RMD160 (dotse-dnscheck-1.2.6-0-g86a5c69.tar.gz) = d19ba7cd9a6311f82c03421b3928a666b09fb0b8
|
||||
Size (dotse-dnscheck-1.2.6-0-g86a5c69.tar.gz) = 1262272 bytes
|
||||
SHA1 (patch-aa) = 86cf15f480ccb95b136e4712ff0910c01459a549
|
||||
SHA1 (patch-ab) = c07651c7015c8d71e77c3ee25e852c3132e73da3
|
||||
SHA1 (dotse-dnscheck-1.4.1-0-ga93f48c.tar.gz) = cd365d17ae472661117abb0263dedec36147e35c
|
||||
RMD160 (dotse-dnscheck-1.4.1-0-ga93f48c.tar.gz) = 55908f573896e185bfeb1810f0228fd547eb196a
|
||||
Size (dotse-dnscheck-1.4.1-0-ga93f48c.tar.gz) = 1330139 bytes
|
||||
SHA1 (patch-ab) = 4a5ef356166e3bd84b7f51575ac18147b7da45e1
|
||||
|
|
|
@ -1,15 +1,20 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2012/05/08 22:39:39 pettai Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2013/06/15 21:18:49 pettai Exp $
|
||||
|
||||
Look for the configuration files in SYSCONFDIR instead of share
|
||||
Look for the configuration files in SYSCONFDIR instead of /etc
|
||||
|
||||
--- ./lib/DNSCheck/Config.pm.orig 2009-04-04 13:49:09.000000000 +0200
|
||||
+++ ./lib/DNSCheck/Config.pm 2009-04-04 13:49:43.000000000 +0200
|
||||
@@ -52,7 +52,7 @@
|
||||
--- lib/DNSCheck/Config.pm.orig 2013-04-11 15:53:42.000000000 +0000
|
||||
+++ lib/DNSCheck/Config.pm
|
||||
@@ -58,11 +58,11 @@ sub new {
|
||||
croak 'Configuration file ' . $arg{'configfile'} . ' not readable';
|
||||
}
|
||||
|
||||
my %arg = @_;
|
||||
- my $config = _get_with_path( $arg{'configfile'}, _catfile( $arg{'configdir'}, 'config.yaml' ), '/etc/dnscheck/config.yaml', );
|
||||
+ my $config = _get_with_path( $arg{'configfile'}, _catfile( $arg{'configdir'}, 'config.yaml' ), '@SYSCONFDIR@/dnscheck/config.yaml', );
|
||||
|
||||
- $self->{configdir} = catfile($Config{'siteprefix'}, 'share/dnscheck');
|
||||
+ $self->{configdir} = catfile($Config{'siteprefix'}, '@SYSCONFDIR@/dnscheck');
|
||||
$self->{configdir} = $arg{'configdir'} if defined($arg{'configdir'});
|
||||
my $default_policy = _get_with_path( _catfile( dist_dir( 'DNSCheck' ), 'policy.yaml' ) );
|
||||
|
||||
$self->{sitedir} = $self->{configdir};
|
||||
- my $policy = _get_with_path( $arg{'policyfile'}, _catfile( $arg{'policydir'}, 'policy.yaml' ), '/etc/dnscheck/policy.yaml', );
|
||||
+ my $policy = _get_with_path( $arg{'policyfile'}, _catfile( $arg{'policydir'}, 'policy.yaml' ), '@SYSCONFDIR@/dnscheck/policy.yaml', );
|
||||
|
||||
my $locale;
|
||||
if ( $arg{'localefile'} ) {
|
||||
|
|
Loading…
Reference in a new issue