Make this package build on arm. The same principle should apply to

other CPU families, but I haven't tested those.
This commit is contained in:
cjep 2002-09-25 06:35:48 +00:00
parent 9bca19a995
commit c49fd74723
3 changed files with 26 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/06/26 13:37:01 uebayasi Exp $
# $NetBSD: Makefile,v 1.2 2002/09/25 06:35:48 cjep Exp $
#
DISTNAME= star-1.4.1
@ -12,4 +12,8 @@ COMMENT= the fastest tar like archiver for UNIX
USE_GMAKE= # defined
MAKE_FLAGS+= INS_BASE=${LOCALBASE}
pre-build:
@cd ${WRKSRC}/RULES && for i in arm; do \
${LN} -s i386-netbsd-cc.rul $$i-netbsd-cc.rul; done
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.2 2002/07/02 12:40:13 wiz Exp $
$NetBSD: distinfo,v 1.3 2002/09/25 06:35:48 cjep Exp $
SHA1 (star-1.4.1.tar.gz) = 8f8b0ee1c7c83040de9607db0ae63da221957f69
Size (star-1.4.1.tar.gz) = 496283 bytes
SHA1 (patch-aa) = 4fe4af396adf23eb7ac071b02a7bf726ab1e4318

View file

@ -0,0 +1,19 @@
$NetBSD: patch-aa,v 1.1 2002/09/25 06:35:49 cjep Exp $
--- RULES/mk-gmake.id.orig Sun Dec 6 12:51:19 1998
+++ RULES/mk-gmake.id Tue Sep 24 21:07:24 2002
@@ -44,8 +44,14 @@
XK_ARCH:= $(shell uname -m | tr '[A-Z]' '[a-z]' | tr ', /\\()"' ',//////' | tr ',/' ',-')
XM_ARCH:= $(shell $(_ARCHCMD) | tr '[A-Z]' '[a-z]' | tr ', /\\()"' ',//////' | tr ',/' ',-')
+__OS:= $(shell uname -s)
+
P_ARCH= $(XP_ARCH)
+ifeq ($(__OS),NetBSD)
+K_ARCH= $(XP_ARCH)
+else
K_ARCH= $(XK_ARCH)
+endif
M_ARCH= $(XM_ARCH)
_XP_ARCH= $(XP_ARCH:unknown=$(K_ARCH))