Update ruby-libxml to 2.4.0.
= Release History == 2.4.0 / 2012-12-14 Charlie Savage * Support libxml 2.9.0 (Daniel Veillard) * Extensive new interfaces for xml schema functionality including suppor for schemal elements, types, facets and attributes (Anton Sozontov) * Fix Encoding#from_s bug and update docs (Nikita Afanasenko) * Node#content= encoding (Nikita Afanasenko)
This commit is contained in:
parent
480867d31f
commit
c4afcc51c0
4 changed files with 19 additions and 26 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.15 2012/09/27 13:09:11 taca Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2012/12/17 14:34:49 taca Exp $
|
||||
|
||||
DISTNAME= libxml-ruby-2.3.3
|
||||
DISTNAME= libxml-ruby-2.4.0
|
||||
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME:C/ruby-//}
|
||||
CATEGORIES= textproc
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.9 2012/03/20 13:45:32 taca Exp $
|
||||
@comment $NetBSD: PLIST,v 1.10 2012/12/17 14:34:50 taca Exp $
|
||||
${GEM_HOME}/cache/${GEM_NAME}.gem
|
||||
${GEM_LIBDIR}/HISTORY
|
||||
${GEM_LIBDIR}/LICENSE
|
||||
|
@ -59,6 +59,14 @@ ${GEM_LIBDIR}/ext/libxml/ruby_xml_sax_parser.c
|
|||
${GEM_LIBDIR}/ext/libxml/ruby_xml_sax_parser.h
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema.c
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema.h
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema_attribute.c
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema_attribute.h
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema_element.c
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema_element.h
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema_facet.c
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema_facet.h
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema_type.c
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_schema_type.h
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_version.h
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_xinclude.c
|
||||
${GEM_LIBDIR}/ext/libxml/ruby_xml_xinclude.h
|
||||
|
@ -90,6 +98,10 @@ ${GEM_LIBDIR}/lib/libxml/properties.rb
|
|||
${GEM_LIBDIR}/lib/libxml/reader.rb
|
||||
${GEM_LIBDIR}/lib/libxml/sax_callbacks.rb
|
||||
${GEM_LIBDIR}/lib/libxml/sax_parser.rb
|
||||
${GEM_LIBDIR}/lib/libxml/schema.rb
|
||||
${GEM_LIBDIR}/lib/libxml/schema/attribute.rb
|
||||
${GEM_LIBDIR}/lib/libxml/schema/element.rb
|
||||
${GEM_LIBDIR}/lib/libxml/schema/type.rb
|
||||
${GEM_LIBDIR}/lib/libxml/tree.rb
|
||||
${GEM_LIBDIR}/lib/libxml/xpath_object.rb
|
||||
${GEM_LIBDIR}/lib/libxml_ruby.${RUBY_DLEXT}
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.11 2012/09/27 13:09:11 taca Exp $
|
||||
$NetBSD: distinfo,v 1.12 2012/12/17 14:34:50 taca Exp $
|
||||
|
||||
SHA1 (libxml-ruby-2.3.3.gem) = 0959b85a9fbd75296f960aab5041d4b1c357560b
|
||||
RMD160 (libxml-ruby-2.3.3.gem) = b5a93eb306927e87d2b05be6066a91b8488f7415
|
||||
Size (libxml-ruby-2.3.3.gem) = 250368 bytes
|
||||
SHA1 (patch-ext_libxml_ruby__xml__node.c) = 4d95701695786f0b1dae0a47e9cbe20ab88e6f0c
|
||||
SHA1 (libxml-ruby-2.4.0.gem) = 117a31827d164242c9eb0f72275ecdb27a4856e8
|
||||
RMD160 (libxml-ruby-2.4.0.gem) = e732dd157233cc8df734855079b69803f03341bc
|
||||
Size (libxml-ruby-2.4.0.gem) = 260608 bytes
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-ext_libxml_ruby__xml__node.c,v 1.1 2012/09/27 13:09:11 taca Exp $
|
||||
|
||||
Adopt to libxml 2.9.0.
|
||||
|
||||
--- ext/libxml/ruby_xml_node.c.orig 2012-09-27 09:39:32.000000000 +0000
|
||||
+++ ext/libxml/ruby_xml_node.c
|
||||
@@ -619,9 +619,9 @@ static VALUE rxml_node_to_s(int argc, VA
|
||||
xmlOutputBufferFlush(output);
|
||||
|
||||
if (output->conv)
|
||||
- result = rxml_new_cstr((const char*) output->conv->content, xencoding);
|
||||
+ result = rxml_new_cstr((const char*) xmlBufContent(output->conv), xencoding);
|
||||
else
|
||||
- result = rxml_new_cstr((const char*) output->buffer->content, xencoding);
|
||||
+ result = rxml_new_cstr((const char*) xmlBufContent(output->buffer), xencoding);
|
||||
|
||||
xmlOutputBufferClose(output);
|
||||
|
Loading…
Reference in a new issue