Import libreoffice4-bin-4.0.2 as misc/libreoffice4-bin.
LibreOffice is the free power-packed Open Source personal productivity suite for Windows, Macintosh and Linux, that gives you six feature-rich applications for all your document production and data processing needs: Writer, Calc, Impress, Draw, Math and Base. This packages tracks libreoffice-4.x branch.
This commit is contained in:
parent
5eea06d147
commit
c4b41de400
9 changed files with 179 additions and 0 deletions
6
misc/libreoffice4-bin/DESCR
Normal file
6
misc/libreoffice4-bin/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
LibreOffice is the free power-packed Open Source personal productivity
|
||||
suite for Windows, Macintosh and Linux, that gives you six feature-rich
|
||||
applications for all your document production and data processing
|
||||
needs: Writer, Calc, Impress, Draw, Math and Base.
|
||||
|
||||
This packages tracks libreoffice-4.x branch.
|
91
misc/libreoffice4-bin/Makefile
Normal file
91
misc/libreoffice4-bin/Makefile
Normal file
|
@ -0,0 +1,91 @@
|
|||
# $NetBSD: Makefile,v 1.1 2013/04/13 11:12:32 ryoon Exp $
|
||||
|
||||
DISTNAME= libreoffice4-bin # overridden below
|
||||
PKGNAME= libreoffice4-bin-${OO_RELEASE}
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://download.documentfoundation.org/libreoffice/stable/${OO_RELEASE}/rpm/x86/
|
||||
|
||||
MAINTAINER= ryoon@NetBSD.org
|
||||
HOMEPAGE= http://www.libreoffice.org/
|
||||
COMMENT= Integrated office productivity suite (binary pkg)
|
||||
LICENSE= gnu-lgpl-v3
|
||||
|
||||
CONFLICTS+= staroffice-[0-9]*
|
||||
CONFLICTS+= openoffice-[0-9]*
|
||||
CONFLICTS+= openoffice-bin-[0-9]*
|
||||
CONFLICTS+= openoffice2-bin-[0-9]*
|
||||
CONFLICTS+= openoffice2-[0-9]*
|
||||
CONFLICTS+= openoffice3-[0-9]*
|
||||
CONFLICTS+= openoffice3-bin-[0-9]*
|
||||
CONFLICTS+= openoffice-linux-[0-9]*
|
||||
CONFLICTS+= libreoffice3-bin-[0-9]*
|
||||
|
||||
OO_VER= 4
|
||||
OO_BASEVER= 4.0
|
||||
OO_RELEASE= 4.0.2
|
||||
PLIST_SUBST+= VER=${OO_VER:Q} BASEVER=${OO_BASEVER:Q}
|
||||
MESSAGE_SUBST+= VER=${OO_VER:Q}
|
||||
FILES_SUBST+= VER=${OO_VER:Q}
|
||||
|
||||
TEMP?= ${WRKSRC}
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
BUILD_DIRS= # empty
|
||||
|
||||
PLIST_SRC= ${PKGDIR}/PLIST.proglinks
|
||||
PLIST_SRC+= ${WRKDIR}/PLIST
|
||||
PLIST_SRC+= ${PKGDIR}/PLIST.dirs
|
||||
|
||||
EMUL_PLATFORMS= linux-i386 linux-x86_64
|
||||
#EMUL_PLATFORMS+= solaris-i386 solaris-sparc
|
||||
EMUL_MODULES.linux= freetype2 x11 locale png fontconfig cups gtk2 krb5
|
||||
EMUL_REQD= suse>=11.3
|
||||
|
||||
EMUL_PKG_FMT= rpm
|
||||
RPMFILES= ${WRKSRC}/RPMS/*.rpm
|
||||
RPM2PKG_PREFIX= ${DESTDIR}${PREFIX}
|
||||
RPM2PKG_SUBPREFIX= # empty
|
||||
RPM2PKG_STAGE= do-install
|
||||
RUN_LDCONFIG= no
|
||||
|
||||
USE_TOOLS+= patch
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${EMUL_PLATFORM} == "linux-i386"
|
||||
DISTNAME= LibreOffice_${OO_RELEASE}_Linux_x86_rpm
|
||||
WRKSRC= ${WRKDIR}/LibreOffice_${OO_RELEASE}.2_Linux_x86_rpm
|
||||
MASTER_SITES= http://download.documentfoundation.org/libreoffice/stable/${OO_RELEASE}/rpm/x86/
|
||||
.elif ${EMUL_PLATFORM} == "linux-x86_64"
|
||||
DISTNAME= LibreOffice_${OO_RELEASE}_Linux_x86-64_rpm
|
||||
WRKSRC= ${WRKDIR}/LibreOffice_${OO_RELEASE}.2_Linux_x86-64_rpm
|
||||
MASTER_SITES= http://download.documentfoundation.org/libreoffice/stable/${OO_RELEASE}/rpm/x86_64/
|
||||
.elif ${EMUL_PLATFORM} == "solaris-i386"
|
||||
DISTNAME= OOo_${OO_RELEASE}_Solaris_x86_install_en-US
|
||||
WRKSRC= ${WRKDIR}/OOO320_m18_native_packed-1_en-US.9502/packages
|
||||
.elif ${EMUL_PLATFORM} == "solaris-sparc"
|
||||
DISTNAME= OOo_${OO_RELEASE}_Solaris_Sparc_install_en-US
|
||||
WRKSRC= ${WRKDIR}/OOO320_m18_native_packed-1_en-US.9502/packages
|
||||
.endif
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
INSTALLATION_DIRS= bin
|
||||
|
||||
do-install:
|
||||
# ${PATCH} -d ${DESTDIR}${PREFIX}/opt/libreoffice${OO_BASEVER}/program < ${FILESDIR}/soffice-patch
|
||||
# ${RM} -f ${DESTDIR}${PREFIX}/opt/libreoffice${OO_BASEVER}/program/soffice.orig
|
||||
${PATCH} -d ${DESTDIR}${PREFIX}/opt/libreoffice${OO_BASEVER}/program < ${FILESDIR}/spadmin-patch
|
||||
${RM} -f ${DESTDIR}${PREFIX}/opt/libreoffice${OO_BASEVER}/program/spadmin.orig
|
||||
uniq ${RPM2PKG_PLIST} | \
|
||||
${SED} -e 's,^@exec mkdir -m 755 -p %D/,@pkgdir,' > ${WRKDIR}/PLIST
|
||||
${RM} -f ${DESTDIR}${PREFIX}/bin/soffice
|
||||
${SED} -e "s|@@PREFIX@@|${PREFIX}|g" -e "s|@@OO_VER@@|${OO_VER}|g" \
|
||||
-e "s|@@JAVA_HOME@@|${PKG_JAVA_HOME}|g" \
|
||||
-e "s|@@OO_BASEVER@@|${OO_BASEVER}|g" \
|
||||
< ${FILESDIR}/soffice > ${DESTDIR}${PREFIX}/bin/soffice
|
||||
${CHMOD} +x ${DESTDIR}${PREFIX}/bin/soffice
|
||||
.for i in scalc sdraw simpress smath spadmin swriter
|
||||
${LN} -sf ../opt/libreoffice${OO_BASEVER}/program/${i} ${DESTDIR}${PREFIX}/bin/${i}
|
||||
.endfor
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
misc/libreoffice4-bin/PLIST.dirs
Normal file
3
misc/libreoffice4-bin/PLIST.dirs
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST.dirs,v 1.1 2013/04/13 11:12:33 ryoon Exp $
|
||||
@pkgdir opt/libreoffice
|
||||
@pkgdir opt
|
8
misc/libreoffice4-bin/PLIST.proglinks
Normal file
8
misc/libreoffice4-bin/PLIST.proglinks
Normal file
|
@ -0,0 +1,8 @@
|
|||
@comment $NetBSD: PLIST.proglinks,v 1.1 2013/04/13 11:12:33 ryoon Exp $
|
||||
bin/scalc
|
||||
bin/sdraw
|
||||
bin/simpress
|
||||
bin/smath
|
||||
bin/soffice
|
||||
bin/spadmin
|
||||
bin/swriter
|
8
misc/libreoffice4-bin/distinfo
Normal file
8
misc/libreoffice4-bin/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1 2013/04/13 11:12:33 ryoon Exp $
|
||||
|
||||
SHA1 (LibreOffice_4.0.2_Linux_x86-64_rpm.tar.gz) = 23c17f21480d64357b3d1bacecec934a2a572cd6
|
||||
RMD160 (LibreOffice_4.0.2_Linux_x86-64_rpm.tar.gz) = 7aa8890c37a852db1123d5aa5c0d0001924dca27
|
||||
Size (LibreOffice_4.0.2_Linux_x86-64_rpm.tar.gz) = 190259207 bytes
|
||||
SHA1 (LibreOffice_4.0.2_Linux_x86_rpm.tar.gz) = 0d55b7aff1b3287c3a5027363709edfd89a9e92a
|
||||
RMD160 (LibreOffice_4.0.2_Linux_x86_rpm.tar.gz) = 9323c45b98f158d9d135360fcf630feceaaff583
|
||||
Size (LibreOffice_4.0.2_Linux_x86_rpm.tar.gz) = 184244626 bytes
|
17
misc/libreoffice4-bin/files/soffice
Normal file
17
misc/libreoffice4-bin/files/soffice
Normal file
|
@ -0,0 +1,17 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $NetBSD: soffice,v 1.1 2013/04/13 11:12:33 ryoon Exp $
|
||||
#
|
||||
SOINST=@@PREFIX@@/opt/libreoffice@@OO_BASEVER@@
|
||||
|
||||
# make sure we can find `whoami` on solaris
|
||||
PATH=${PATH}:/usr/ucb
|
||||
|
||||
# add the chosen java directory to $PATH to allow OOo to
|
||||
# automatically find it
|
||||
PATH=${PATH}:@@JAVA_HOME@@
|
||||
|
||||
# default data seg size is too small for java
|
||||
ulimit -d `ulimit -H -d`
|
||||
|
||||
exec ${SOINST}/program/soffice "$@"
|
17
misc/libreoffice4-bin/files/soffice-patch
Normal file
17
misc/libreoffice4-bin/files/soffice-patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
#
|
||||
# $NetBSD: soffice-patch,v 1.1 2013/04/13 11:12:33 ryoon Exp $
|
||||
#
|
||||
|
||||
--- soffice.orig 2009-01-18 23:49:18.000000000 +0100
|
||||
+++ soffice 2009-01-19 00:10:22.000000000 +0100
|
||||
@@ -73,6 +73,10 @@
|
||||
esac
|
||||
done
|
||||
|
||||
+# Set LD_LIBRARY_PATH so that javaldx finds libuno_sal.so.3:
|
||||
+LD_LIBRARY_PATH=$sd_prog/../basis-link/program:$sd_prog/../basis-link/../ure/lib${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
|
||||
+export LD_LIBRARY_PATH
|
||||
+
|
||||
# extend the ld_library_path for java: javaldx checks the sofficerc for us
|
||||
if [ -x "$sd_prog/../basis-link/ure-link/bin/javaldx" ] ; then
|
||||
my_path=`"$sd_prog/../basis-link/ure-link/bin/javaldx" $BOOTSTRAPVARS \
|
17
misc/libreoffice4-bin/files/spadmin-patch
Normal file
17
misc/libreoffice4-bin/files/spadmin-patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
#
|
||||
# $NetBSD: spadmin-patch,v 1.1 2013/04/13 11:12:33 ryoon Exp $
|
||||
#
|
||||
|
||||
--- spadmin.orig 2009-10-08 12:21:04.000000000 +0200
|
||||
+++ spadmin 2009-10-08 12:22:22.000000000 +0200
|
||||
@@ -56,6 +56,10 @@
|
||||
esac
|
||||
done
|
||||
|
||||
+# Set LD_LIBRARY_PATH so that javaldx finds libuno_sal.so.3:
|
||||
+LD_LIBRARY_PATH=$sd_prog/../basis-link/program:$sd_prog/../basis-link/../ure/lib${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
|
||||
+export LD_LIBRARY_PATH
|
||||
+
|
||||
# extend the ld_library_path for java: javaldx checks the sofficerc for us
|
||||
if [ -x "$sd_prog/../basis-link/ure-link/bin/javaldx" ] ; then
|
||||
my_path=`"$sd_prog/../basis-link/ure-link/bin/javaldx" $BOOTSTRAPVARS \
|
12
misc/libreoffice4-bin/options.mk
Normal file
12
misc/libreoffice4-bin/options.mk
Normal file
|
@ -0,0 +1,12 @@
|
|||
# $NetBSD: options.mk,v 1.1 2013/04/13 11:12:33 ryoon Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.libreoffice-bin
|
||||
PKG_SUPPORTED_OPTIONS= java
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mjava)
|
||||
PKG_JVMS_ACCEPTED= jdk15 sun-jdk6
|
||||
USE_JAVA= run
|
||||
.include "../../mk/java-vm.mk"
|
||||
.endif
|
Loading…
Reference in a new issue