games: add 3dpong

3D Pong is a one- or two-player, three dimensional sports game, based on
the first arcade game ever made, "Pong" from Atari. Each player controls
their "paddle" with the mouse, and tries to score by bouncing a ball into
the other player's goal (just behind the paddle).

3D Pong is a vector-based graphics X-Window game for Unix.
This commit is contained in:
nia 2021-12-30 00:26:20 +00:00
parent 6a291a2a1e
commit c4fd6d9f24
8 changed files with 85 additions and 1 deletions

6
games/3dpong/DESCR Normal file
View File

@ -0,0 +1,6 @@
3D Pong is a one- or two-player, three dimensional sports game, based on
the first arcade game ever made, "Pong" from Atari. Each player controls
their "paddle" with the mouse, and tries to score by bouncing a ball into
the other player's goal (just behind the paddle).
3D Pong is a vector-based graphics X-Window game for Unix.

21
games/3dpong/Makefile Normal file
View File

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1 2021/12/30 00:26:20 nia Exp $
DISTNAME= 3dpong-0.5
CATEGORIES= games
MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/3dpong/src/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.newbreedsoftware.com/3dpong/index2.php3
COMMENT= One or two player 3D sports game based on Pong from Atari
LICENSE= gnu-gpl-v2
USE_TOOLS+= gmake
MAKE_FLAGS+= CC=${CC:Q}
MAKE_FLAGS+= CFLAGS=${CFLAGS:Q}
MAKE_FLAGS+= XLIB="${LDFLAGS} -lX11"
MAKE_FLAGS+= PREFIX=${DESTDIR}${PREFIX}
MAKE_FLAGS+= MANPREFIX=${DESTDIR}${PREFIX}/${PKGMANDIR}
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

5
games/3dpong/PLIST Normal file
View File

@ -0,0 +1,5 @@
@comment $NetBSD: PLIST,v 1.1 2021/12/30 00:26:20 nia Exp $
bin/3dpong
bin/3dpong-handball.sh
bin/3dpong-vs-computer.sh
man/man6/3dpong.6

8
games/3dpong/distinfo Normal file
View File

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1 2021/12/30 00:26:20 nia Exp $
BLAKE2s (3dpong-0.5.tar.gz) = 007beba9c00c479de25e77bcbe5cb3c21fc95f6b04e0a2f4cacaf1d1959d442e
SHA512 (3dpong-0.5.tar.gz) = 83d771e149e94f0fadbb8c19ed2ba1d4ce518d97ad910185a5eee1c1c3501200403329db8aff1408953e712355785ea77eb63bcf2a7e01fd38868853cdaadcbc
Size (3dpong-0.5.tar.gz) = 37004 bytes
SHA1 (patch-src_3dpong.c) = 9222af77d2f465f9f26b2bf546abc1790b6b3336
SHA1 (patch-src_randnum.c) = f52b08c16d7990715cd050939e9679bfef0c120c
SHA1 (patch-src_text.c) = f2d4d8d8eaa50eb0dd1febc1f210a190254da78d

View File

@ -0,0 +1,14 @@
$NetBSD: patch-src_3dpong.c,v 1.1 2021/12/30 00:26:21 nia Exp $
unistd.h needed for usleep().
--- src/3dpong.c.orig 2004-04-29 06:49:13.000000000 +0000
+++ src/3dpong.c
@@ -15,6 +15,7 @@
#include <sys/types.h>
#include <sys/time.h>
#include <math.h>
+#include <unistd.h>
#include "window.h"
#include "connect.h"
#include "hints.h"

View File

@ -0,0 +1,14 @@
$NetBSD: patch-src_randnum.c,v 1.1 2021/12/30 00:26:21 nia Exp $
stdlib.h needed for rand()
--- src/randnum.c.orig 1997-12-10 01:56:00.000000000 +0000
+++ src/randnum.c
@@ -9,6 +9,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include <sys/time.h>
#include "randnum.h"

View File

@ -0,0 +1,15 @@
$NetBSD: patch-src_text.c,v 1.1 2021/12/30 00:26:21 nia Exp $
string.h needed for strlen().
--- src/text.c.orig 1997-12-10 23:27:49.000000000 +0000
+++ src/text.c
@@ -6,6 +6,8 @@
*/
#include <X11/Xlib.h>
+#include <stdlib.h>
+#include <string.h>
#include "text.h"
int FontHeight(XFontStruct *font_struct)

View File

@ -1,10 +1,11 @@
# $NetBSD: Makefile,v 1.509 2021/12/29 23:56:01 nia Exp $
# $NetBSD: Makefile,v 1.510 2021/12/30 00:26:20 nia Exp $
#
COMMENT= Games
SUBDIR+= 0verkill
SUBDIR+= 2048-cli
SUBDIR+= 3dpong
SUBDIR+= 4stAttack
SUBDIR+= 7kaa
SUBDIR+= 7kaa-music