lang/php81: update to 8.1.22

03 Aug 2023, PHP 8.1.22

- Build:
  . Fixed bug GH-11522 (PHP version check fails with '-' separator).
    (SVGAnimate)

- CLI:
  . Fix interrupted CLI output causing the process to exit. (nielsdos)

- Core:
  . Fixed oss-fuzz #60011 (Mis-compilation of by-reference nullsafe operator).
    (ilutov)
  . Fixed use-of-uninitialized-value with ??= on assert. (ilutov)
  . Fixed build for FreeBSD before the 11.0 releases. (David Carlier)

- Curl:
  . Fix crash when an invalid callback function is passed to
    CURLMOPT_PUSHFUNCTION. (nielsdos)

- Date:
  . Fixed bug GH-11368 (Date modify returns invalid datetime). (Derick)

- DOM:
  . Fixed bug GH-11625 (DOMElement::replaceWith() doesn't replace node with
    DOMDocumentFragment but just deletes node or causes wrapping <></>
    depending on libxml2 version). (nielsdos)

- Fileinfo:
  . Fixed bug GH-11298 (finfo returns wrong mime type for xz files). (Anatol)

- FTP:
  . Fix context option check for "overwrite". (JonasQuinten)
  . Fixed bug GH-10562 (Memory leak and invalid state with consecutive
    ftp_nb_fget). (nielsdos)

- GD:
  . Fix most of the external libgd test failures. (Michael Orlitzky)

- Hash:
  . Fix use-of-uninitialized-value in hash_pbkdf2(), fix missing $options
    parameter in signature. (ilutov)

- Intl:
  . Fix memory leak in MessageFormatter::format() on failure. (Girgias)

- Libxml:
  . Fixed bug GHSA-3qrf-m4j2-pcrr (Security issue with external entity loading
    in XML without enabling it). (CVE-2023-3823) (nielsdos, ilutov)

- MBString:
  . Fix GH-11300 (license issue: restricted unicode license headers).
    (nielsdos)

- Opcache:
  . Fixed bug GH-10914 (OPCache with Enum and Callback functions results in
    segmentation fault). (nielsdos)
  . Prevent potential deadlock if accelerated globals cannot be allocated.
    (nielsdos)

- PCNTL:
  . Fixed bug GH-11498 (SIGCHLD is not always returned from proc_open).
    (nielsdos)

- PCRE:
  . Mangle PCRE regex cache key with JIT option. (mvorisek)

- PDO:
  . Fix GH-11587 (After php8.1, when PDO::ATTR_EMULATE_PREPARES is true
    and PDO::ATTR_STRINGIFY_FETCHES is true, decimal zeros are no longer
    filled). (SakiTakamachi)

- PDO SQLite:
  . Fix GH-11492 (Make test failure: ext/pdo_sqlite/tests/bug_42589.phpt).
    (KapitanOczywisty, CViniciusSDias)

- Phar:
  . Add missing check on EVP_VerifyUpdate() in phar util. (nielsdos)
  . Fixed bug GHSA-jqcx-ccgc-xwhv (Buffer mismanagement in phar_dir_read()).
    (CVE-2023-3824) (nielsdos)

- PHPDBG:
  . Fixed bug GH-9669 (phpdbg -h options doesn't list the -z option). (adsr)

- Session:
  . Removed broken url support for transferring session ID. (ilutov)

- Standard:
  . Fix serialization of RC1 objects appearing in object graph twice. (ilutov)

- SQLite3:
  . Fix replaced error handling in SQLite3Stmt::__construct. (nielsdos)
This commit is contained in:
taca 2023-08-05 08:43:16 +00:00
parent fca657d4f4
commit c513f30e0e
4 changed files with 13 additions and 89 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: phpversion.mk,v 1.403 2023/07/07 12:51:19 taca Exp $
# $NetBSD: phpversion.mk,v 1.404 2023/08/05 08:43:16 taca Exp $
#
# This file selects a PHP version, based on the user's preferences and
# the installed packages. It does not add a dependency on the PHP
@ -90,7 +90,7 @@ PHPVERSION_MK= defined
PHP56_VERSION= 5.6.40
PHP74_VERSION= 7.4.33
PHP80_VERSION= 8.0.29
PHP81_VERSION= 8.1.21
PHP81_VERSION= 8.1.22
PHP82_VERSION= 8.2.8
# Define API version or initial release of major version.

View file

@ -1,10 +1,9 @@
$NetBSD: distinfo,v 1.25 2023/07/07 12:51:19 taca Exp $
$NetBSD: distinfo,v 1.26 2023/08/05 08:43:16 taca Exp $
BLAKE2s (php-8.1.21.tar.xz) = 602ab8065692c49bc5b94935cf36f3397b61b52ffd6ef4bef941563618722697
SHA512 (php-8.1.21.tar.xz) = aeb62947e12646a530b6f61efe9350e4a3632d421ee0bec6a1d26dc2fd680c782e12cbad06496f2d4ffcddf5182aa3438c19a59b0d593fc43789271241ec0383
Size (php-8.1.21.tar.xz) = 11862320 bytes
SHA1 (patch-build_libtool.m4) = e58a2bcebe9e9d7dc7255354fd9fe57878e3f8a6
SHA1 (patch-configure) = e91e22267a9b7ebcc16a586ba6f325c772adb13c
BLAKE2s (php-8.1.22.tar.xz) = bedc63f43971576a55baaffa7faaafd720c4cee88913201f90d45fb93fa21a25
SHA512 (php-8.1.22.tar.xz) = d5848f4174f47499207451ae7a8d7c254c1f06a9b500c907f9bff3c790e4a6a417d49cabb23b6e5f370d4f515c1ca9920ef2b3584be8979413dd4085549d9a8a
Size (php-8.1.22.tar.xz) = 11809048 bytes
SHA1 (patch-configure) = bf9d652aa5b5509b08ce7cdb6168936ca7b80584
SHA1 (patch-disable-filter-url) = 0a2c19c18f089448a8d842e99738b292ab9e5640
SHA1 (patch-ext_enchant_enchant.c) = 7924acc5fdadea89b3a385cf744ef982795bf89d
SHA1 (patch-ext_phar_Makefile.frag) = 53ea5c58b0bc27d236118d5750a74b1cba43e5dd

View file

@ -1,75 +0,0 @@
$NetBSD: patch-build_libtool.m4,v 1.1 2021/11/27 07:24:43 taca Exp $
Stop warnings on newer autoconf.
--- build/libtool.m4.orig 2021-03-02 16:37:06.000000000 +0000
+++ build/libtool.m4
@@ -676,8 +676,11 @@ s390*-*linux*|sparc*-*linux*)
CFLAGS="$CFLAGS -belf"
AC_CACHE_CHECK([whether the C compiler needs -belf], lt_cv_cc_needs_belf,
[AC_LANG_SAVE
- AC_LANG_C
- AC_TRY_LINK([],[],[lt_cv_cc_needs_belf=yes],[lt_cv_cc_needs_belf=no])
+ AC_LANG([C])
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([],[])],
+ [lt_cv_cc_needs_belf=yes],
+ [lt_cv_cc_needs_belf=no])
AC_LANG_RESTORE])
if test x"$lt_cv_cc_needs_belf" != x"yes"; then
# this is probably gcc 2.8.0, egcs 1.0 or newer; no need for -belf
@@ -1197,7 +1200,7 @@ if test "$_LT_AC_TAGVAR(lt_cv_prog_compi
ln conftest.a conftest.b 2>/dev/null && hard_links=no
AC_MSG_RESULT([$hard_links])
if test "$hard_links" = no; then
- AC_MSG_WARN([\`$CC' does not support \`-c -o', so \`make -j' may be unsafe])
+ AC_MSG_WARN([`$CC' does not support `-c -o', so `make -j' may be unsafe])
need_locks=warn
fi
else
@@ -1924,15 +1927,15 @@ AC_ARG_WITH([tags],
if test -f "$ltmain" && test -n "$tagnames"; then
if test ! -f "${ofile}"; then
- AC_MSG_WARN([output file \`$ofile' does not exist])
+ AC_MSG_WARN([output file `$ofile' does not exist])
fi
if test -z "$LTCC"; then
eval "`$SHELL ${ofile} --config | grep '^LTCC='`"
if test -z "$LTCC"; then
- AC_MSG_WARN([output file \`$ofile' does not look like a libtool script])
+ AC_MSG_WARN([output file `$ofile' does not look like a libtool script])
else
- AC_MSG_WARN([using \`LTCC=$LTCC', extracted from \`$ofile'])
+ AC_MSG_WARN([using `LTCC=$LTCC', extracted from `$ofile'])
fi
fi
if test -z "$LTCFLAGS"; then
@@ -1955,7 +1958,7 @@ if test -f "$ltmain" && test -n "$tagnam
if grep "^# ### BEGIN LIBTOOL TAG CONFIG: $tagname$" < "${ofile}" > /dev/null
then
- AC_MSG_ERROR([tag name \"$tagname\" already exists])
+ AC_MSG_ERROR([tag name "$tagname" already exists])
fi
# Update the list of available tags.
@@ -2728,7 +2731,7 @@ AC_DEFUN([AC_LIBTOOL_LANG_C_CONFIG], [_L
AC_DEFUN([_LT_AC_LANG_C_CONFIG],
[lt_save_CC="$CC"
AC_LANG_SAVE
-AC_LANG_C
+AC_LANG([C])
# Source file extension for C test sources.
ac_ext=c
@@ -2809,7 +2812,7 @@ CC="$lt_save_CC"
AC_DEFUN([AC_LIBTOOL_LANG_CXX_CONFIG], [_LT_AC_LANG_CXX_CONFIG(CXX)])
AC_DEFUN([_LT_AC_LANG_CXX_CONFIG],
[AC_LANG_SAVE
-AC_LANG_CPLUSPLUS
+AC_LANG([C++])
AC_REQUIRE([AC_PROG_CXX])
AC_REQUIRE([_LT_AC_PROG_CXXCPP])

View file

@ -1,13 +1,13 @@
$NetBSD: patch-configure,v 1.1 2021/11/27 07:24:43 taca Exp $
$NetBSD: patch-configure,v 1.2 2023/08/05 08:43:16 taca Exp $
* Do not include "PKG_CONFIG*" in CONFIGURE_OPTIONS.
* Don't automatically add libgcc on SunOS. Reported upstream as #75941.
* Don't autodetect maintainer-zts.
* The meta_ccld removal reported upstream as #75940.
--- configure.orig 2021-10-27 00:20:44.000000000 +0000
--- configure.orig 2023-08-01 16:16:09.000000000 +0000
+++ configure
@@ -4319,6 +4319,10 @@ EOF
@@ -4324,6 +4324,10 @@ EOF
else
break
fi
@ -15,10 +15,10 @@ $NetBSD: patch-configure,v 1.1 2021/11/27 07:24:43 taca Exp $
+ \'PKG_CONFIG\=*) CURRENT_ARG="'PKG_CONFIG=@TOOLS_PATH.pkg-config@'";;
+ \'PKG_CONFIG_LIBDIR\=*) CURRENT_ARG="'PKG_CONFIG_LIBDIR=@PHP_PKGCONFIG_PATH@'";;
+ esac
$as_echo "$CURRENT_ARG \\" >>config.nice
printf "%s\n" "$CURRENT_ARG \\" >>config.nice
CONFIGURE_OPTIONS="$CONFIGURE_OPTIONS $CURRENT_ARG"
done
@@ -7540,30 +7544,6 @@ EOF
@@ -7548,30 +7552,6 @@ EOF
;;
esac
@ -49,7 +49,7 @@ $NetBSD: patch-configure,v 1.1 2021/11/27 07:24:43 taca Exp $
PHP_VAR_SUBST="$PHP_VAR_SUBST APXS"
else
@@ -79589,7 +79569,7 @@ printf "%s\n" "#define HAVE_TIDYBUFFIO_H
@@ -80278,7 +80258,7 @@ printf "%s\n" "#define HAVE_TIDYBUFFIO_H
fi
TIDY_LIBDIR=$TIDY_DIR/$PHP_LIBDIR