Added libc++
This commit is contained in:
parent
f8bea53916
commit
c5476f224f
4 changed files with 146 additions and 4 deletions
|
@ -1,9 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.25 2014/01/25 12:26:14 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.26 2014/02/27 17:35:35 adam Exp $
|
||||
|
||||
DISTNAME= clang-3.4
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://llvm.org/releases/${PKGVERSION_NOREV}/
|
||||
DISTFILES= llvm-${PKGVERSION_NOREV}.src.tar.gz \
|
||||
libcxx-${PKGVERSION_NOREV}.src.tar.gz \
|
||||
clang-${PKGVERSION_NOREV}.src.tar.gz
|
||||
|
||||
MAINTAINER= adam.hoka@gmail.com
|
||||
|
@ -56,7 +58,7 @@ TEST_ILLUMOS_3849!=\
|
|||
#
|
||||
#CFLAGS.SunOS+= -mimpure-text
|
||||
|
||||
SUBST_CLASSES+= fix-paths
|
||||
SUBST_CLASSES+= fix-paths
|
||||
SUBST_STAGE.fix-paths= pre-configure
|
||||
SUBST_MESSAGE.fix-paths= Fixing absolute gcc paths for SunOS.
|
||||
SUBST_FILES.fix-paths= tools/clang/lib/Driver/Tools.cpp
|
||||
|
@ -82,6 +84,7 @@ SUBST_SED.fix-paths+= -e 's,^.*cxa_finalize.*$$, ; //cxa_finalize.o,g'
|
|||
.endif
|
||||
|
||||
post-extract:
|
||||
mv ${WRKDIR}/libcxx-${PKGVERSION_NOREV} ${WRKSRC}/projects/libcxx
|
||||
mv ${WRKDIR}/clang-${PKGVERSION_NOREV} ${WRKSRC}/tools/clang
|
||||
.if ${OPSYS} == "SunOS"
|
||||
${ECHO} "int sun_ld_needs_a_symbol=0;" >> ${WRKSRC}/lib/Target/NVPTX/InstPrinter/NVPTXInstPrinter.cpp
|
||||
|
|
104
lang/clang/PLIST
104
lang/clang/PLIST
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.11 2014/02/19 20:16:07 minskim Exp $
|
||||
@comment $NetBSD: PLIST,v 1.12 2014/02/27 17:35:35 adam Exp $
|
||||
bin/bugpoint
|
||||
bin/c-index-test
|
||||
bin/clang
|
||||
|
@ -32,6 +32,108 @@ bin/llvm-symbolizer
|
|||
bin/llvm-tblgen
|
||||
bin/macho-dump
|
||||
bin/opt
|
||||
include/c++/v1/CMakeLists.txt
|
||||
include/c++/v1/__bit_reference
|
||||
include/c++/v1/__config
|
||||
include/c++/v1/__debug
|
||||
include/c++/v1/__functional_03
|
||||
include/c++/v1/__functional_base
|
||||
include/c++/v1/__functional_base_03
|
||||
include/c++/v1/__hash_table
|
||||
include/c++/v1/__locale
|
||||
include/c++/v1/__mutex_base
|
||||
include/c++/v1/__split_buffer
|
||||
include/c++/v1/__sso_allocator
|
||||
include/c++/v1/__std_stream
|
||||
include/c++/v1/__tree
|
||||
include/c++/v1/__tuple
|
||||
include/c++/v1/__tuple_03
|
||||
include/c++/v1/__undef_min_max
|
||||
include/c++/v1/algorithm
|
||||
include/c++/v1/array
|
||||
include/c++/v1/atomic
|
||||
include/c++/v1/bitset
|
||||
include/c++/v1/cassert
|
||||
include/c++/v1/ccomplex
|
||||
include/c++/v1/cctype
|
||||
include/c++/v1/cerrno
|
||||
include/c++/v1/cfenv
|
||||
include/c++/v1/cfloat
|
||||
include/c++/v1/chrono
|
||||
include/c++/v1/cinttypes
|
||||
include/c++/v1/ciso646
|
||||
include/c++/v1/climits
|
||||
include/c++/v1/clocale
|
||||
include/c++/v1/cmath
|
||||
include/c++/v1/codecvt
|
||||
include/c++/v1/complex
|
||||
include/c++/v1/complex.h
|
||||
include/c++/v1/condition_variable
|
||||
include/c++/v1/csetjmp
|
||||
include/c++/v1/csignal
|
||||
include/c++/v1/cstdarg
|
||||
include/c++/v1/cstdbool
|
||||
include/c++/v1/cstddef
|
||||
include/c++/v1/cstdint
|
||||
include/c++/v1/cstdio
|
||||
include/c++/v1/cstdlib
|
||||
include/c++/v1/cstring
|
||||
include/c++/v1/ctgmath
|
||||
include/c++/v1/ctime
|
||||
include/c++/v1/cwchar
|
||||
include/c++/v1/cwctype
|
||||
include/c++/v1/deque
|
||||
include/c++/v1/exception
|
||||
include/c++/v1/experimental/dynarray
|
||||
include/c++/v1/experimental/optional
|
||||
include/c++/v1/ext/__hash
|
||||
include/c++/v1/ext/hash_map
|
||||
include/c++/v1/ext/hash_set
|
||||
include/c++/v1/forward_list
|
||||
include/c++/v1/fstream
|
||||
include/c++/v1/functional
|
||||
include/c++/v1/future
|
||||
include/c++/v1/initializer_list
|
||||
include/c++/v1/iomanip
|
||||
include/c++/v1/ios
|
||||
include/c++/v1/iosfwd
|
||||
include/c++/v1/iostream
|
||||
include/c++/v1/istream
|
||||
include/c++/v1/iterator
|
||||
include/c++/v1/limits
|
||||
include/c++/v1/list
|
||||
include/c++/v1/locale
|
||||
include/c++/v1/map
|
||||
include/c++/v1/memory
|
||||
include/c++/v1/mutex
|
||||
include/c++/v1/new
|
||||
include/c++/v1/numeric
|
||||
include/c++/v1/ostream
|
||||
include/c++/v1/queue
|
||||
include/c++/v1/random
|
||||
include/c++/v1/ratio
|
||||
include/c++/v1/regex
|
||||
include/c++/v1/scoped_allocator
|
||||
include/c++/v1/set
|
||||
include/c++/v1/shared_mutex
|
||||
include/c++/v1/sstream
|
||||
include/c++/v1/stack
|
||||
include/c++/v1/stdexcept
|
||||
include/c++/v1/streambuf
|
||||
include/c++/v1/string
|
||||
include/c++/v1/strstream
|
||||
include/c++/v1/system_error
|
||||
include/c++/v1/tgmath.h
|
||||
include/c++/v1/thread
|
||||
include/c++/v1/tuple
|
||||
include/c++/v1/type_traits
|
||||
include/c++/v1/typeindex
|
||||
include/c++/v1/typeinfo
|
||||
include/c++/v1/unordered_map
|
||||
include/c++/v1/unordered_set
|
||||
include/c++/v1/utility
|
||||
include/c++/v1/valarray
|
||||
include/c++/v1/vector
|
||||
include/clang-c/CXCompilationDatabase.h
|
||||
include/clang-c/CXString.h
|
||||
include/clang-c/Index.h
|
||||
|
|
|
@ -1,8 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.22 2014/01/19 14:06:41 ryoon Exp $
|
||||
$NetBSD: distinfo,v 1.23 2014/02/27 17:35:35 adam Exp $
|
||||
|
||||
SHA1 (clang-3.4.src.tar.gz) = a6a3c815dd045e9c13c7ae37d2cfefe65607860d
|
||||
RMD160 (clang-3.4.src.tar.gz) = 4fbd7e735edc96e224a82ebe2277c69efc488e6b
|
||||
Size (clang-3.4.src.tar.gz) = 10619607 bytes
|
||||
SHA1 (libcxx-3.4.src.tar.gz) = c45333dce3e6bdac2583682417c03b6bb149ceb0
|
||||
RMD160 (libcxx-3.4.src.tar.gz) = 146a49dc0ae9635f87b13038d36ad816b7245666
|
||||
Size (libcxx-3.4.src.tar.gz) = 1377487 bytes
|
||||
SHA1 (llvm-3.4.src.tar.gz) = 10b1fd085b45d8b19adb9a628353ce347bc136b8
|
||||
RMD160 (llvm-3.4.src.tar.gz) = 67e3f7baa679ca95d944b9cc3528d1ffbe3cdee0
|
||||
Size (llvm-3.4.src.tar.gz) = 15920544 bytes
|
||||
|
@ -10,5 +13,6 @@ SHA1 (patch-ab) = 8dd0da6d47a57ac25eea358996cf874dd3289e08
|
|||
SHA1 (patch-ac) = 0f0cc98d443ec957fc5374fb491809d27e4f9d4e
|
||||
SHA1 (patch-ad) = ad1f6720e4c73e57fce10ba968b03637a133602d
|
||||
SHA1 (patch-include_llvm_Support_Host.h) = 545f9542cd2aaa6cea58d3653902b4e1a9e7189a
|
||||
SHA1 (patch-projects_libcxx_lib_buildit) = f19a6346099b9047f8b5c3739458fd11ea9e3e33
|
||||
SHA1 (patch-utils_lit_utils_check-coverage) = aec7c140d5b9e8cc38a0022533a5848d6b1ff0b8
|
||||
SHA1 (patch-utils_lit_utils_check-sdist) = df63c41b07f7531e787b54f6994458869023b66c
|
||||
|
|
33
lang/clang/patches/patch-projects_libcxx_lib_buildit
Normal file
33
lang/clang/patches/patch-projects_libcxx_lib_buildit
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-projects_libcxx_lib_buildit,v 1.1 2014/02/27 17:35:35 adam Exp $
|
||||
|
||||
Portability fix.
|
||||
|
||||
--- projects/libcxx/lib/buildit.orig 2013-12-27 14:42:54.000000000 +0000
|
||||
+++ projects/libcxx/lib/buildit
|
||||
@@ -45,7 +45,7 @@ case $TRIPLE in
|
||||
RC_CFLAGS="-arch i386 -arch x86_64"
|
||||
fi
|
||||
SOEXT=dylib
|
||||
- if [ "$MACOSX_DEPLOYMENT_TARGET" == "10.6" ]
|
||||
+ if [ "$MACOSX_DEPLOYMENT_TARGET" = "10.6" ]
|
||||
then
|
||||
EXTRA_FLAGS="-nostdinc++ -std=c++11 -U__STRICT_ANSI__"
|
||||
LDSHARED_FLAGS="-o libc++.1.dylib \
|
||||
@@ -101,7 +101,7 @@ case $TRIPLE in
|
||||
hostOS=`echo $hostOS | sed -e "s/\s+$//"`
|
||||
hostOS=`echo $hostOS | tr '[A-Z]' '[a-z]'`
|
||||
|
||||
- if [ $hostOS == "linux" ]
|
||||
+ if [ $hostOS = "linux" ]
|
||||
then
|
||||
LDSHARED_FLAGS="-o libc++.so.1 \
|
||||
-qmkshrobj -Wl,-soname,libc++.so.1 \
|
||||
@@ -153,7 +153,7 @@ case $TRIPLE in
|
||||
*-*-mingw*)
|
||||
;;
|
||||
*-ibm-*)
|
||||
- if [ $hostOS == "linux" ]
|
||||
+ if [ $hostOS = "linux" ]
|
||||
then
|
||||
rm -f libc++.so
|
||||
ln -s libc++.so.1 libc++.so
|
Loading…
Reference in a new issue