Update to 3.4.
One new test failure: test-bundle2-exchange.t; reported upstream. Canges: 1.1. commands annotate: add option to annotate working-directory files annotate: always prepare ancestry context of base fctx (issue4600) annotate: always adjust linkrev before walking down to parents (issue4623) annotate: prepare ancestry context of workingfilectx bookmarks: add incoming() to replace diff() for incoming bookmarks bookmarks: add outgoing() to replace diff() for outgoing bookmarks bookmarks: check @pathalias suffix before available @number for efficiency bookmarks: enhance test of showing detail about incoming/outgoing bookmarks bookmarks: prevent divergent bookmark from being updated unexpectedly bookmarks: reuse @number bookmark, if it refers changeset referred remotely bookmarks: rewrite comparing bookmarks in commands.summary() by compare() bookmarks: show detailed status about incoming/outgoing bookmarks clone: add progress support to hardlink clones (issue3059) commands.import: accept a prefix option commands.push: abort when revisions evaluate to empty set (BC) commands: add ui.statuscopies config knob debuginstall: expand the editor path before searching for it (issue4380) files: split reusable implementation into cmdutil for subrepo support files: use ctx object to access dirstate graft: allow creating sibling grafts graft: record intermediate grafts in extras log: display closing-branch nodes as "_" (BC) log: fix --follow null parent not to include revision 0 log: make -fr show complete history from the given revs log: prefer 'wctx' over 'pctx' for working context patch.internalpatch: accept a prefix parameter patch.internalpatch: add a default value for prefix patch: rename pathstrip to pathtransform pull: print "pulling from foo" before accessing the other repo push: acquire local 'wlock' if "pushback" is expected (BC) (issue4596) resolve: silence warning of unknown pats for -l/--list (BC) revert: evaluate filesets against working directory (issue4497) revert: fix --interactive on local modification (issue4576) revert: stop marking files clean after interactive revert (issue4592) revert: accept just -I/-X without paths or -a/-i (issue4592) revert: apply normallookup on reverted file if size isn't changed (issue4583) revert: restore the ability to revert across case only renames (issue4481) status: add relative directory help text (issue3835) 1.2. core bundle2: capture transaction rollback message output (issue4614) bundle2: disable ouput capture unless we use http (issue4613 issue4615) changelog: fix readpending if no pending data exist (issue4609) dirstate: fix order of initializing nf vs f filelog: allow censored files to contain padding data merge: run update hook after the last wlock release pushkey: flush pending data before running a pre-pushkey hook (issue4607) repoview: improve compute staticblockers perf revlog: _addrevision creates full-replace deltas based on censored revisions revlog: add "iscensored()" to revlog public API revlog: addgroup checks if incoming deltas add censored revs, sets flag bit revlog: in addgroup, reject ill-formed deltas based on censored nodes revlog: make converting from inline to non-line work after a strip revlog: special case expanding full-replacement deltas received by exchange subrepo: don't write .hgsubstate lines with empty subrepo state (issue4622) subrepo: update the help text to account for diff -I/-X gitsubrepo support tags: establish a separate and shared cache of .hgtags filenodes tags: change format of tags cache files tags: have a different cache file per filter level ui: disable revsetaliases in plain mode (BC) util: add progress callback support to copyfiles windows: make shellquote() quote any path containing '\' (issue4629) 1.3. extensions color: be more conservative about setting ANSI mode on Windows (BC) color: fix crash in cmd.exe color: omit terminfo/win32 warning if non-interactive (issue4543) color: support a different color mode when the pager is active convert: adjust progress bar for octopus merges (issue4169) histedit: add --edit-plan option to histedit histedit: allow histedit --continue when not on a descendant (BC) histedit: fix preventing strips during histedit histedit: fix style of new error message histedit: improve roll action integration with fold histedit: fix rollup prompting for a commit message (issue4606) largefiles: don't crash when cloning to a remote repo largefiles: don't mangle filesets when fixing up the log matcher largefiles: always consider updatelfiles 'checked' parameter set largefiles: avoid infinite recursive call of openlfdirstate in overriderevert largefiles: don't create chain of contains calls largefiles: don't prefix standin patterns with '.hglf' when logging largefiles: don't warn when reverting a forgotten largefile largefiles: extract and reuse 'standin' variable in overriderevert() largefiles: for update -C, only update largefiles when necessary largefiles: handle logging from outside the repo largefiles: introduce lfutil.findstorepath() largefiles: override cmdutil.revert() instead of comands.revert() largefiles: report the source of copied/moved largefiles in status -C largefiles: set the extension as enabled locally after a clone requiring it largefiles: teach log to handle patterns largefiles: update _subdirlfs() comment largefiles: use common function to build content of .hg_archival.txt largefiles: use lfutil.findstorepath() when verifying a local repo largefiles: use the core file copy logic to validate the destination path largefiles: use the share source as the primary local store (issue4471) mq: avoid silent failure when single patch doesn't apply (issue4604) rebase: don't forward "source" argument to rebase (issue4633) rebase: restore bookmark state on abort record: edit patch of newly added files (issue4304) record: fix adding new file with record from within a subdir (issue4626) record: fix record with change on moved file crashes (issue4619) shelve: acquire lock in the right order shelve: add interactive mode shelve: add interactive mode command line option 1.4. hgweb hgweb: resurrect <span> tag on diffline to fix rendering in monoblue style hgweb: use introrev() for finding parents (issue4506) json: implement {bookmarks} template json: implement {branches} template json: implement {changeset} template json: implement {comparison} template json: implement {fileannotate} template json: implement {filediff} template json: implement {helptopics} template json: implement {help} template json: implement {manifest} template json: implement {shortlog} and {changelog} templates json: implement {tags} template 1.5. unsorted archive: change the default prefix to '' from None archive: look for first visible revision to build repo identity (issue4591) bundle2-localpeer: properly propagate the server output on error (issue4594) bundle2-wireproto: properly propagate the server output on error (issue4594) changeset_printer: display p1rev:p1node with "+" suffix for workingctx check-commit: be more picky about detection of wrong bug tag check-commit: check capitalization in summary lines churn: deprecate -t option in favour of -T crecord: fix another underbar crecord: fix underbar style for orig_stdout devel-warn: add a prefix to all messages ("devel-warn: ") dirs._addpath: don't mutate Python strings after exposing them (issue4589) dispatch: consolidate formatting of ParseErrors dispatch: offer near-edit-distance suggestions for {file,rev}set functions dispatch: offer suggestions of similar-named commands extensions: support callbacks after another extension loads get-with-headers: support parsing and pretty printing JSON graphlog: do not bypass commands.log so that -fr works graphlog: move comment and flag denoting revs might be unsorted graphlog: remove too early return from getgraphlogrevs() for empty repo lazymanifest: fix memory leak in lmiter_iterentriesnext() after 3d485727e45e lazymanifest: fix pure hg iterkeys() linkrev: fix issue with annotate of working copy manifestv2: add support for reading new manifest format manifestv2: add support for writing new manifest format obsolete: avoid infinite loop from obs-cycle in divergence (issue4126) record: add interactive option to the commit command record: allow editing new files (issue4304) record_curses: fix ui bug for newly added file revbranchcache: add test for when the cache is not writable revbranchcache: move out of branchmap onto localrepo revbranchcache: populate cache incrementally revbranchcache: store repo on the object revbranchcache: write cache even during read operations revrange: don't parse revset aliases as hash prefixes (issue4553) rollback: clear resolve state (issue4593) ssl: resolve symlink before checking for Apple python executable (issue4588) ssl: set explicit symbol "!" to web.cacerts to disable SSL verification (BC) strip: properly clear resolve state with --keep (issue4593) subrepo: add 'cat' support for git subrepos subrepo: add basic support to hgsubrepo for the files command subrepo: add include/exclude support for diffing git subrepos subrepo: add status support for ignored and clean files in git subrepos subrepo: change arguments of abstractsubrepo.init (API) subrepos: support adding files in git subrepos test-convert-git: show insane progress bar with octopus merge (issue4169) test-histedit-edit.t: demonstrate qnew fails during a histedit (issue4366) test-https: enable dummycert test only if Apple python is used (issue4500) test-shelve: be more lenient about whitespace (issue4124) tests: add test showing tags cache drops filtered heads (issue4550) tests: handle deleted .hg directory (git 2.2.0 and higher) (issue4585) trydiff: join filename with prefix only once unbundle: acquire 'wlock' when processing bundle2 (BC) (issue4596) webcommands: define a dict of available commands webcommands: define web commands using a decorator color: be more conservative about setting ANSI mode on Windows (BC) commands.push: abort when revisions evaluate to empty set (BC) histedit: allow histedit --continue when not on a descendant (BC) log: display closing-branch nodes as "_" (BC) push: acquire local 'wlock' if "pushback" is expected (BC) (issue4596) resolve: silence warning of unknown pats for -l/--list (BC) ssl: set explicit symbol "!" to web.cacerts to disable SSL verification (BC) unbundle: acquire 'wlock' when processing bundle2 (BC) (issue4596) subrepo: change arguments of abstractsubrepo.init (API)
This commit is contained in:
parent
aa253746d8
commit
c54ff0a6f7
5 changed files with 17 additions and 53 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.5 2015/03/31 03:40:24 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2015/05/03 09:49:24 wiz Exp $
|
||||
|
||||
DISTNAME= mercurial-${VERSION}
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
|
@ -14,6 +14,7 @@ LICENSE= gnu-gpl-v2 OR gnu-gpl-v3 # OR newer
|
|||
# http://bz.selenic.com/show_bug.cgi?id=4483
|
||||
# http://bz.selenic.com/show_bug.cgi?id=4485
|
||||
#BUILD_DEPENDS+= unzip-[0-9]*:../../archivers/unzip
|
||||
DEPENDS+= ${PYPKGPREFIX}-curses-[0-9]*:../../devel/py-curses
|
||||
|
||||
USE_TOOLS+= gmake msgfmt
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile.version,v 1.17 2015/04/14 11:40:31 wiz Exp $
|
||||
# $NetBSD: Makefile.version,v 1.18 2015/05/03 09:49:24 wiz Exp $
|
||||
|
||||
VERSION= 3.3.3
|
||||
VERSION= 3.4
|
||||
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 33 34 # not yet ported as of 2.9
|
||||
# see also http://mercurial.selenic.com/wiki/SupportedPythonVersions
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2015/02/03 11:09:55 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2015/05/03 09:49:24 wiz Exp $
|
||||
bin/hg
|
||||
${PYSITELIB}/hgext/__init__.py
|
||||
${PYSITELIB}/hgext/__init__.pyc
|
||||
|
@ -12,6 +12,9 @@ ${PYSITELIB}/hgext/blackbox.pyo
|
|||
${PYSITELIB}/hgext/bugzilla.py
|
||||
${PYSITELIB}/hgext/bugzilla.pyc
|
||||
${PYSITELIB}/hgext/bugzilla.pyo
|
||||
${PYSITELIB}/hgext/censor.py
|
||||
${PYSITELIB}/hgext/censor.pyc
|
||||
${PYSITELIB}/hgext/censor.pyo
|
||||
${PYSITELIB}/hgext/children.py
|
||||
${PYSITELIB}/hgext/children.pyc
|
||||
${PYSITELIB}/hgext/children.pyo
|
||||
|
@ -243,6 +246,9 @@ ${PYSITELIB}/mercurial/context.pyo
|
|||
${PYSITELIB}/mercurial/copies.py
|
||||
${PYSITELIB}/mercurial/copies.pyc
|
||||
${PYSITELIB}/mercurial/copies.pyo
|
||||
${PYSITELIB}/mercurial/crecord.py
|
||||
${PYSITELIB}/mercurial/crecord.pyc
|
||||
${PYSITELIB}/mercurial/crecord.pyo
|
||||
${PYSITELIB}/mercurial/dagparser.py
|
||||
${PYSITELIB}/mercurial/dagparser.pyc
|
||||
${PYSITELIB}/mercurial/dagparser.pyo
|
||||
|
@ -567,6 +573,8 @@ ${PYSITELIB}/mercurial/templates/gitweb/search.tmpl
|
|||
${PYSITELIB}/mercurial/templates/gitweb/shortlog.tmpl
|
||||
${PYSITELIB}/mercurial/templates/gitweb/summary.tmpl
|
||||
${PYSITELIB}/mercurial/templates/gitweb/tags.tmpl
|
||||
${PYSITELIB}/mercurial/templates/json/changelist.tmpl
|
||||
${PYSITELIB}/mercurial/templates/json/map
|
||||
${PYSITELIB}/mercurial/templates/map-cmdline.bisect
|
||||
${PYSITELIB}/mercurial/templates/map-cmdline.changelog
|
||||
${PYSITELIB}/mercurial/templates/map-cmdline.compact
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.18 2015/04/04 11:20:35 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.19 2015/05/03 09:49:24 wiz Exp $
|
||||
|
||||
SHA1 (mercurial-3.3.3.tar.gz) = 999d5db4961e2c745f17df44d7ae64dce2d8425b
|
||||
RMD160 (mercurial-3.3.3.tar.gz) = 7b8a7e5e8c04ac3004e99d0285bdae8f7200aec7
|
||||
Size (mercurial-3.3.3.tar.gz) = 4167447 bytes
|
||||
SHA1 (patch-tests_test-merge-tools.t) = 1a62d4344eee51b27f7a9f34fe7ebff939371542
|
||||
SHA1 (mercurial-3.4.tar.gz) = b0a90cda956d89de882fef76f96d4f263e56713f
|
||||
RMD160 (mercurial-3.4.tar.gz) = 8e41cf7c3de63b25c6f10b56037e182f79e463f3
|
||||
Size (mercurial-3.4.tar.gz) = 4289081 bytes
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
$NetBSD: patch-tests_test-merge-tools.t,v 1.1 2015/04/04 11:20:35 wiz Exp $
|
||||
|
||||
# HG changeset patch
|
||||
# User Martin von Zweigbergk <martinvonz@google.com>
|
||||
# Date 1423613835 28800
|
||||
# Tue Feb 10 16:17:15 2015 -0800
|
||||
# Node ID 9d0b6ef92eb212bf4945822139dac996c4e1322c
|
||||
# Parent a450e0a2ba0ae28f84125cc6d9ada7790e2a2816
|
||||
test-merge-tools: fix flaky test by avoiding debugsetparents
|
||||
|
||||
debugsetparents is a debug command and does not provide the same
|
||||
guarantees as non-debug commands do. In particular, when the user sets
|
||||
a different parent, any clean files will remain clean in the dirstate
|
||||
even though the new parent might have a different version of the file
|
||||
(so it should appear modified compared to the new parent). Let's
|
||||
instead achieve the same effect by updating to the new parent and
|
||||
reverting the contents back to what they were.
|
||||
|
||||
This fix can be tested by passing '--config
|
||||
debug.dirstate.delaywrite=2' to the 'hg update' command in the
|
||||
beforemerge().
|
||||
|
||||
--- tests/test-merge-tools.t.orig 2015-04-01 18:27:41.000000000 +0000
|
||||
+++ tests/test-merge-tools.t
|
||||
@@ -603,7 +603,8 @@ update is a merge ...
|
||||
true.priority=1
|
||||
true.executable=cat
|
||||
# hg update -C 1
|
||||
- $ hg debugsetparent 0
|
||||
+ $ hg update -q 0
|
||||
+ $ hg revert -q -r 1 .
|
||||
$ hg update -r 2
|
||||
merging f
|
||||
revision 1
|
||||
@@ -628,7 +629,8 @@ update should also have --tool
|
||||
true.priority=1
|
||||
true.executable=cat
|
||||
# hg update -C 1
|
||||
- $ hg debugsetparent 0
|
||||
+ $ hg update -q 0
|
||||
+ $ hg revert -q -r 1 .
|
||||
$ hg update -r 2 --tool false
|
||||
merging f
|
||||
merging f failed!
|
Loading…
Reference in a new issue