Update to 4.3.12
Changes: Improved error handling in POSIX emulation, ${NAME:OFFSET:LENGTH} syntax supports negative LENGTHs, new parameter expansion flag (g:opts:) which escapes sequences like the echo and print builtins, the region_highlight array is now updated dynamically as the command line is edited and the zsh/parameter module has a new array $usergroups which contains the names of system groups.
This commit is contained in:
parent
6970017a4f
commit
c55ec6d06b
7 changed files with 44 additions and 24 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.22 2011/07/22 12:28:26 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.23 2011/07/30 11:53:52 ryoon Exp $
|
||||
|
||||
.include "../../shells/zsh/Makefile.common"
|
||||
|
||||
ZSH_VERSION= 4.3.11
|
||||
ZSH_VERSION= 4.3.12
|
||||
ZSH_MAINTAINER= ryoon@NetBSD.org
|
||||
|
||||
USE_TOOLS+= env
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.22 2011/07/22 12:28:26 ryoon Exp $
|
||||
@comment $NetBSD: PLIST,v 1.23 2011/07/30 11:53:52 ryoon Exp $
|
||||
bin/zsh
|
||||
bin/${PKGNAME}
|
||||
info/zsh.info
|
||||
|
@ -63,6 +63,7 @@ share/zsh/${PKGVERSION}/functions/VCS_INFO_detect_bzr
|
|||
share/zsh/${PKGVERSION}/functions/VCS_INFO_detect_cdv
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_detect_cvs
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_detect_darcs
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_detect_fossil
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_detect_git
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_detect_hg
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_detect_mtn
|
||||
|
@ -77,6 +78,7 @@ share/zsh/${PKGVERSION}/functions/VCS_INFO_get_data_cdv
|
|||
share/zsh/${PKGVERSION}/functions/VCS_INFO_get_data_cvs
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_get_data_darcs
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_get_data_git
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_get_data_fossil
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_get_data_hg
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_get_data_mtn
|
||||
share/zsh/${PKGVERSION}/functions/VCS_INFO_get_data_p4
|
||||
|
@ -120,6 +122,7 @@ share/zsh/${PKGVERSION}/functions/_arp
|
|||
share/zsh/${PKGVERSION}/functions/_arping
|
||||
share/zsh/${PKGVERSION}/functions/_arrays
|
||||
share/zsh/${PKGVERSION}/functions/_assign
|
||||
share/zsh/${PKGVERSION}/functions/_at
|
||||
share/zsh/${PKGVERSION}/functions/_attr
|
||||
share/zsh/${PKGVERSION}/functions/_auto-apt
|
||||
share/zsh/${PKGVERSION}/functions/_autocd
|
||||
|
@ -302,6 +305,7 @@ share/zsh/${PKGVERSION}/functions/_gnome-gv
|
|||
share/zsh/${PKGVERSION}/functions/_gnu_generic
|
||||
share/zsh/${PKGVERSION}/functions/_gnupod
|
||||
share/zsh/${PKGVERSION}/functions/_gnutls
|
||||
share/zsh/${PKGVERSION}/functions/_go
|
||||
share/zsh/${PKGVERSION}/functions/_gpg
|
||||
share/zsh/${PKGVERSION}/functions/_gphoto2
|
||||
share/zsh/${PKGVERSION}/functions/_gprof
|
||||
|
@ -334,6 +338,7 @@ share/zsh/${PKGVERSION}/functions/_imagemagick
|
|||
share/zsh/${PKGVERSION}/functions/_in_vared
|
||||
share/zsh/${PKGVERSION}/functions/_inetadm
|
||||
share/zsh/${PKGVERSION}/functions/_init_d
|
||||
share/zsh/${PKGVERSION}/functions/_initctl
|
||||
share/zsh/${PKGVERSION}/functions/_invoke-rc.d
|
||||
share/zsh/${PKGVERSION}/functions/_ionice
|
||||
share/zsh/${PKGVERSION}/functions/_ip
|
||||
|
@ -396,6 +401,7 @@ share/zsh/${PKGVERSION}/functions/_make-kpkg
|
|||
share/zsh/${PKGVERSION}/functions/_man
|
||||
share/zsh/${PKGVERSION}/functions/_match
|
||||
share/zsh/${PKGVERSION}/functions/_math
|
||||
share/zsh/${PKGVERSION}/functions/_matlab
|
||||
share/zsh/${PKGVERSION}/functions/_md5sum
|
||||
share/zsh/${PKGVERSION}/functions/_mdadm
|
||||
share/zsh/${PKGVERSION}/functions/_members
|
||||
|
@ -442,9 +448,12 @@ share/zsh/${PKGVERSION}/functions/_nice
|
|||
share/zsh/${PKGVERSION}/functions/_nmap
|
||||
share/zsh/${PKGVERSION}/functions/_normal
|
||||
share/zsh/${PKGVERSION}/functions/_nothing
|
||||
share/zsh/${PKGVERSION}/functions/_notmuch
|
||||
share/zsh/${PKGVERSION}/functions/_npm
|
||||
share/zsh/${PKGVERSION}/functions/_nslookup
|
||||
share/zsh/${PKGVERSION}/functions/_object_classes
|
||||
share/zsh/${PKGVERSION}/functions/_oldlist
|
||||
share/zsh/${PKGVERSION}/functions/_okular
|
||||
share/zsh/${PKGVERSION}/functions/_open
|
||||
share/zsh/${PKGVERSION}/functions/_options
|
||||
share/zsh/${PKGVERSION}/functions/_options_set
|
||||
|
@ -461,6 +470,7 @@ share/zsh/${PKGVERSION}/functions/_pax
|
|||
share/zsh/${PKGVERSION}/functions/_pbm
|
||||
share/zsh/${PKGVERSION}/functions/_pbuilder
|
||||
share/zsh/${PKGVERSION}/functions/_pdf
|
||||
share/zsh/${PKGVERSION}/functions/_pdftk
|
||||
share/zsh/${PKGVERSION}/functions/_perforce
|
||||
share/zsh/${PKGVERSION}/functions/_perl
|
||||
share/zsh/${PKGVERSION}/functions/_perl_basepods
|
||||
|
@ -469,6 +479,7 @@ share/zsh/${PKGVERSION}/functions/_perldoc
|
|||
share/zsh/${PKGVERSION}/functions/_pfctl
|
||||
share/zsh/${PKGVERSION}/functions/_pfexec
|
||||
share/zsh/${PKGVERSION}/functions/_php
|
||||
share/zsh/${PKGVERSION}/functions/_pgrep
|
||||
share/zsh/${PKGVERSION}/functions/_physical_volumes
|
||||
share/zsh/${PKGVERSION}/functions/_pick_variant
|
||||
share/zsh/${PKGVERSION}/functions/_pids
|
||||
|
@ -560,6 +571,7 @@ share/zsh/${PKGVERSION}/functions/_sisu
|
|||
share/zsh/${PKGVERSION}/functions/_slrn
|
||||
share/zsh/${PKGVERSION}/functions/_smit
|
||||
share/zsh/${PKGVERSION}/functions/_socket
|
||||
share/zsh/${PKGVERSION}/functions/_sockstat
|
||||
share/zsh/${PKGVERSION}/functions/_softwareupdate
|
||||
share/zsh/${PKGVERSION}/functions/_sort
|
||||
share/zsh/${PKGVERSION}/functions/_source
|
||||
|
@ -631,6 +643,7 @@ share/zsh/${PKGVERSION}/functions/_units
|
|||
share/zsh/${PKGVERSION}/functions/_unsetopt
|
||||
share/zsh/${PKGVERSION}/functions/_update-alternatives
|
||||
share/zsh/${PKGVERSION}/functions/_update-rc.d
|
||||
share/zsh/${PKGVERSION}/functions/_unison
|
||||
share/zsh/${PKGVERSION}/functions/_urls
|
||||
share/zsh/${PKGVERSION}/functions/_urpmi
|
||||
share/zsh/${PKGVERSION}/functions/_urxvt
|
||||
|
@ -666,6 +679,7 @@ share/zsh/${PKGVERSION}/functions/_whereis
|
|||
share/zsh/${PKGVERSION}/functions/_which
|
||||
share/zsh/${PKGVERSION}/functions/_whois
|
||||
share/zsh/${PKGVERSION}/functions/_wiggle
|
||||
share/zsh/${PKGVERSION}/functions/_wpa_cli
|
||||
share/zsh/${PKGVERSION}/functions/_x_arguments
|
||||
share/zsh/${PKGVERSION}/functions/_x_borderwidth
|
||||
share/zsh/${PKGVERSION}/functions/_x_color
|
||||
|
@ -693,6 +707,7 @@ share/zsh/${PKGVERSION}/functions/_xloadimage
|
|||
share/zsh/${PKGVERSION}/functions/_xmlsoft
|
||||
share/zsh/${PKGVERSION}/functions/_xmms2
|
||||
share/zsh/${PKGVERSION}/functions/_xmodmap
|
||||
share/zsh/${PKGVERSION}/functions/_xournal
|
||||
share/zsh/${PKGVERSION}/functions/_xpdf
|
||||
share/zsh/${PKGVERSION}/functions/_xrandr
|
||||
share/zsh/${PKGVERSION}/functions/_xscreensaver
|
||||
|
@ -707,6 +722,7 @@ share/zsh/${PKGVERSION}/functions/_yast
|
|||
share/zsh/${PKGVERSION}/functions/_yodl
|
||||
share/zsh/${PKGVERSION}/functions/_yp
|
||||
share/zsh/${PKGVERSION}/functions/_yum
|
||||
share/zsh/${PKGVERSION}/functions/_zargs
|
||||
share/zsh/${PKGVERSION}/functions/_zattr
|
||||
share/zsh/${PKGVERSION}/functions/_zcalc_line
|
||||
share/zsh/${PKGVERSION}/functions/_zcat
|
||||
|
@ -819,6 +835,7 @@ share/zsh/${PKGVERSION}/functions/run-help-sudo
|
|||
share/zsh/${PKGVERSION}/functions/run-help-svk
|
||||
share/zsh/${PKGVERSION}/functions/run-help-svn
|
||||
share/zsh/${PKGVERSION}/functions/select-word-style
|
||||
share/zsh/${PKGVERSION}/functions/send-invisible
|
||||
share/zsh/${PKGVERSION}/functions/smart-insert-last-word
|
||||
share/zsh/${PKGVERSION}/functions/split-shell-arguments
|
||||
share/zsh/${PKGVERSION}/functions/sticky-note
|
||||
|
@ -848,6 +865,8 @@ share/zsh/${PKGVERSION}/functions/up-case-word-match
|
|||
share/zsh/${PKGVERSION}/functions/up-line-or-beginning-search
|
||||
share/zsh/${PKGVERSION}/functions/url-quote-magic
|
||||
share/zsh/${PKGVERSION}/functions/vcs_info
|
||||
share/zsh/${PKGVERSION}/functions/vcs_info_hookadd
|
||||
share/zsh/${PKGVERSION}/functions/vcs_info_hookdel
|
||||
share/zsh/${PKGVERSION}/functions/vcs_info_lastmsg
|
||||
share/zsh/${PKGVERSION}/functions/vcs_info_printsys
|
||||
share/zsh/${PKGVERSION}/functions/vcs_info_setsys
|
||||
|
@ -892,6 +911,7 @@ share/zsh/${PKGVERSION}/functions/zkbd
|
|||
share/zsh/${PKGVERSION}/functions/zmathfuncdef
|
||||
share/zsh/${PKGVERSION}/functions/zmv
|
||||
share/zsh/${PKGVERSION}/functions/zrecompile
|
||||
share/zsh/${PKGVERSION}/functions/zsh_directory_name_cdr
|
||||
share/zsh/${PKGVERSION}/functions/zsh-mime-handler
|
||||
share/zsh/${PKGVERSION}/functions/zsh-mime-setup
|
||||
${PLIST.dynamic}share/zsh/${PKGVERSION}/functions/zsh-newuser-install
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.19 2011/04/05 13:54:24 ryoon Exp $
|
||||
$NetBSD: distinfo,v 1.20 2011/07/30 11:53:52 ryoon Exp $
|
||||
|
||||
SHA1 (zsh-4.3.11.tar.bz2) = 25cf0daadc4543d147f6241573d6730b60f16016
|
||||
RMD160 (zsh-4.3.11.tar.bz2) = e5e0d79231cdb95e6b6edac0e1b81db6c0018c37
|
||||
Size (zsh-4.3.11.tar.bz2) = 2868429 bytes
|
||||
SHA1 (patch-ab) = e093eb17eac617eeda096dbcaaba974639570b42
|
||||
SHA1 (patch-ac) = 1284846253461b13f84512d76666e943cdc068f3
|
||||
SHA1 (patch-af) = c78fa8e786d3ae2e3b15a9587f2a7b6e64891778
|
||||
SHA1 (patch-ag) = 2fe6b7f0a76ca7e5d341fda408f3ab5443d09cbc
|
||||
SHA1 (zsh-4.3.12.tar.bz2) = 8fd7a6d841770c8b12cf3ae8229dd857ecdbad93
|
||||
RMD160 (zsh-4.3.12.tar.bz2) = 83f2a0f3e590722262e5725df97d924b1fd4ee84
|
||||
Size (zsh-4.3.12.tar.bz2) = 2917959 bytes
|
||||
SHA1 (patch-ab) = 577a98385f258cbc47ff49d0b4bc6cc9134e864a
|
||||
SHA1 (patch-ac) = 8cc69ee851f76b82387e0cc4e447877b41f7cee5
|
||||
SHA1 (patch-af) = cedd6fb7369b0fc9debbaab29aaf40c25c587123
|
||||
SHA1 (patch-ag) = e18e26bae0996d42fa9f98730a8fb844ce4b7a44
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.4 2011/04/05 13:54:24 ryoon Exp $
|
||||
$NetBSD: patch-ab,v 1.5 2011/07/30 11:53:52 ryoon Exp $
|
||||
|
||||
--- Src/zsh.h.orig 2010-12-14 10:09:52.000000000 +0000
|
||||
--- Src/zsh.h.orig 2011-05-16 15:49:11.000000000 +0000
|
||||
+++ Src/zsh.h
|
||||
@@ -2105,6 +2105,7 @@ struct ttyinfo {
|
||||
@@ -2122,6 +2122,7 @@ struct ttyinfo {
|
||||
#endif
|
||||
};
|
||||
|
||||
|
@ -10,7 +10,7 @@ $NetBSD: patch-ab,v 1.4 2011/04/05 13:54:24 ryoon Exp $
|
|||
/* defines for whether tabs expand to spaces */
|
||||
#if defined(HAVE_TERMIOS_H) || defined(HAVE_TERMIO_H)
|
||||
#define SGTTYFLAG shttyinfo.tio.c_oflag
|
||||
@@ -2122,6 +2123,7 @@ struct ttyinfo {
|
||||
@@ -2139,6 +2140,7 @@ struct ttyinfo {
|
||||
# endif
|
||||
# endif
|
||||
# endif
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.5 2011/04/05 13:54:24 ryoon Exp $
|
||||
$NetBSD: patch-ac,v 1.6 2011/07/30 11:53:52 ryoon Exp $
|
||||
|
||||
--- configure.orig 2010-09-23 09:42:09.000000000 +0000
|
||||
--- configure.orig 2011-05-16 15:49:15.000000000 +0000
|
||||
+++ configure
|
||||
@@ -20091,6 +20091,10 @@ $as_echo "$zsh_cv_sys_elf" >&6; }
|
||||
@@ -11443,6 +11443,10 @@ $as_echo "$zsh_cv_sys_elf" >&6; }
|
||||
DLLD="${DLLD=$CC}"
|
||||
DLLDARG=""
|
||||
;;
|
||||
|
@ -13,7 +13,7 @@ $NetBSD: patch-ac,v 1.5 2011/04/05 13:54:24 ryoon Exp $
|
|||
* )
|
||||
DLLD="${DLLD=ld}"
|
||||
DLLDARG=""
|
||||
@@ -20101,6 +20105,7 @@ $as_echo "$zsh_cv_sys_elf" >&6; }
|
||||
@@ -11453,6 +11457,7 @@ $as_echo "$zsh_cv_sys_elf" >&6; }
|
||||
case "$host_os" in
|
||||
hpux*) DLLDFLAGS="${DLLDFLAGS=-shared}" ;;
|
||||
darwin*) DLCFLAGS="${DLCFLAGS=-fno-common}" ;;
|
||||
|
@ -21,7 +21,7 @@ $NetBSD: patch-ac,v 1.5 2011/04/05 13:54:24 ryoon Exp $
|
|||
*) DLCFLAGS="${DLCFLAGS=-fPIC}" ;;
|
||||
esac
|
||||
else
|
||||
@@ -20115,7 +20120,7 @@ $as_echo "$zsh_cv_sys_elf" >&6; }
|
||||
@@ -11467,7 +11472,7 @@ $as_echo "$zsh_cv_sys_elf" >&6; }
|
||||
fi
|
||||
case "$host_os" in
|
||||
osf*) DLLDFLAGS="${DLLDFLAGS=-shared -expect_unresolved '*'}" ;;
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-af,v 1.3 2008/12/22 02:18:51 uebayasi Exp $
|
||||
$NetBSD: patch-af,v 1.4 2011/07/30 11:53:52 ryoon Exp $
|
||||
|
||||
--- Config/defs.mk.in.orig 2008-03-13 18:44:39.000000000 +0900
|
||||
--- Config/defs.mk.in.orig 2011-04-19 15:05:00.000000000 +0000
|
||||
+++ Config/defs.mk.in
|
||||
@@ -81,6 +81,7 @@ TEXI2PDF = @TEXI2PDF@
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ag,v 1.3 2008/12/22 02:18:51 uebayasi Exp $
|
||||
$NetBSD: patch-ag,v 1.4 2011/07/30 11:53:52 ryoon Exp $
|
||||
|
||||
--- Makefile.in.orig 2008-02-01 20:22:22.000000000 +0900
|
||||
--- Makefile.in.orig 2009-03-14 18:27:05.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -87,6 +87,7 @@ install.fns:
|
||||
scriptdir="$(scriptdir)" \
|
||||
|
|
Loading…
Reference in a new issue