Update to 1.18. No proper NEWS file found.
This commit is contained in:
parent
fd7b7edb19
commit
c560ce7a0d
3 changed files with 6 additions and 60 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.18 2012/10/03 21:56:03 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.19 2012/10/21 22:55:52 wiz Exp $
|
||||
|
||||
DISTNAME= Finance-Quote-1.17
|
||||
DISTNAME= Finance-Quote-1.18
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= finance perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Finance/}
|
||||
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.9 2011/02/26 05:39:45 obache Exp $
|
||||
$NetBSD: distinfo,v 1.10 2012/10/21 22:55:52 wiz Exp $
|
||||
|
||||
SHA1 (Finance-Quote-1.17.tar.gz) = a04482f539b06e14ec7984ca7c009daf93303968
|
||||
RMD160 (Finance-Quote-1.17.tar.gz) = 724d331879b6b039746f16c7ede7e6959d28c429
|
||||
Size (Finance-Quote-1.17.tar.gz) = 130686 bytes
|
||||
SHA1 (patch-lib_Finance_Quote_VWD.pm) = 95f3294c6acf64b6b9c8a58cd997ed3854cf3ae1
|
||||
SHA1 (Finance-Quote-1.18.tar.gz) = d23c2e2ab6e7b90a652cc759c1f3a2fbab1f619d
|
||||
RMD160 (Finance-Quote-1.18.tar.gz) = c733a48281cee30e80dda03103ef036f68a5a430
|
||||
Size (Finance-Quote-1.18.tar.gz) = 147575 bytes
|
||||
|
|
|
@ -1,52 +0,0 @@
|
|||
$NetBSD: patch-lib_Finance_Quote_VWD.pm,v 1.1 2011/02/26 05:39:45 obache Exp $
|
||||
|
||||
* http://rt.cpan.org/Public/Bug/Display.html?id=66041
|
||||
|
||||
--- lib/Finance/Quote/VWD.pm.orig 2009-10-05 17:39:57.000000000 +0000
|
||||
+++ lib/Finance/Quote/VWD.pm
|
||||
@@ -123,7 +123,10 @@ sub vwd
|
||||
next if not $content;
|
||||
|
||||
# <h1> contains price, time, name, and symbol
|
||||
- my $head = $content->find("h1");
|
||||
+ my $head = $content->look_down(
|
||||
+ "_tag", "div",
|
||||
+ "class", "wpHeadline"
|
||||
+ );
|
||||
next if not $head;
|
||||
|
||||
my $wpkurs = $head->look_down(
|
||||
@@ -148,21 +151,24 @@ sub vwd
|
||||
$_->delete;
|
||||
}
|
||||
|
||||
- if ($head->as_trimmed_text =~ /^(.*) \((.+)\)$/) {
|
||||
- $info{$fund, "name"} = $1;
|
||||
- $info{$fund, "symbol"} = $2;
|
||||
+ my $wpsymbol = $content->look_down(
|
||||
+ "_tag", "ul",
|
||||
+ "class", "wpInfo"
|
||||
+ );
|
||||
+ if ($wpsymbol) {
|
||||
+ my @li = $wpsymbol->find("li");
|
||||
+ if ($li[4]->as_text =~ /WKN:(\w+)/) {
|
||||
+ $info{$fund, "symbol"} = $1;
|
||||
+ }
|
||||
}
|
||||
|
||||
# <ul> contains currency as 3rd <li>
|
||||
my $wpinfo = $content->look_down(
|
||||
- "_tag", "ul",
|
||||
- "class", "wpInfo"
|
||||
+ "_tag", "span",
|
||||
+ "class", "whrg"
|
||||
);
|
||||
if ($wpinfo) {
|
||||
- my @li = $wpinfo->find("li");
|
||||
- if ($li[2]->as_text =~ /Währung:(\w+)/) {
|
||||
- $info{$fund, "currency"} = substr($1, 0, 3);
|
||||
- }
|
||||
+ $info{$fund, "currency"} = substr($wpinfo->as_text, 0, 3);
|
||||
}
|
||||
|
||||
# fund ok
|
Loading…
Reference in a new issue