Make this package compile on NetBSD 1.6.

This commit is contained in:
kristerw 2004-01-23 18:57:26 +00:00
parent 78f2b62fb6
commit c582404b61
3 changed files with 52 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2004/01/08 15:24:42 adam Exp $
$NetBSD: distinfo,v 1.7 2004/01/23 18:57:26 kristerw Exp $
SHA1 (atari800-1.3.2.tar.gz) = 3325fc0656a3d54b2718df1f7eb7cfda0985d5a2
Size (atari800-1.3.2.tar.gz) = 998541 bytes
@ -7,3 +7,5 @@ Size (xf25.zip) = 188942 bytes
SHA1 (patch-aa) = cf2122ef21bb8a8e27f9aa723ed11f16630bfbef
SHA1 (patch-ab) = 33edb843d4d8c4b29e725a7d0e0594a1f7c9626f
SHA1 (patch-ac) = 1815c2f531a8bdba6e12d5cf062206e8eb2740d9
SHA1 (patch-ad) = 45530538aaca1ccfe79906c3aee09ae2a3499d50
SHA1 (patch-ae) = 46db6f94b486a4d9544de40b7b28e5a0a9e2071f

View file

@ -0,0 +1,36 @@
$NetBSD: patch-ad,v 1.1 2004/01/23 18:57:26 kristerw Exp $
--- configure.orig Fri Jan 23 19:42:59 2004
+++ configure Fri Jan 23 19:43:29 2004
@@ -1396,7 +1396,7 @@
a8_target="UNKNOWN"
;;
esac
-if [ "$a8_target" == "UNKNOWN" ]; then
+if [ "$a8_target" = "UNKNOWN" ]; then
echo
echo "Usage: configure --target=<target> <other options>"
echo
@@ -1593,11 +1593,11 @@
;;
esac
-if [ "X_$CFLAGS" == "X_" ]; then
+if [ "X_$CFLAGS" = "X_" ]; then
CFLAGS="-O2 -Wall"
fi
-if [ "X_$LDFLAGS" == "X_" ]; then
+if [ "X_$LDFLAGS" = "X_" ]; then
LDFLAGS="-s"
fi
@@ -4331,7 +4331,7 @@
OBJS=
-if [ "$a8_host" == "win" ]; then
+if [ "$a8_host" = "win" ]; then
as_ac_Lib=`echo "ac_cv_lib_gdi32''_main" | $as_tr_sh`
echo "$as_me:$LINENO: checking for main in -lgdi32" >&5

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1 2004/01/23 18:57:26 kristerw Exp $
--- cartridge.c.orig Fri Jan 23 19:44:54 2004
+++ cartridge.c Fri Jan 23 19:45:06 2004
@@ -772,7 +772,7 @@
void CARTStateRead( void )
{
- int savedCartType = CART_NONE;;
+ int savedCartType = CART_NONE;
UWORD namelen;
FILE *fp;
char filename[FILENAME_MAX];