Fixed improper tgetstr call that was causing bitchx to crash when
used with NetBSD curses.
This commit is contained in:
parent
1bebacda6c
commit
c5a960ec80
3 changed files with 41 additions and 6 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.8 2001/07/27 10:49:16 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2001/09/30 13:52:57 blymn Exp $
|
||||
|
||||
DISTNAME= ircii-pana-1.0c18
|
||||
PKGNAME= bitchx-1.0.3.18
|
||||
|
@ -14,10 +14,6 @@ USE_BUILDLINK_ONLY= yes
|
|||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-ssl
|
||||
|
||||
# We need ncurses since BitchX dumps core on startup when using curses.
|
||||
USE_NCURSES= yes
|
||||
BUILDLINK_DEPENDS.ncurses= ncurses>=5.2
|
||||
|
||||
# Files are installed using a .bz2 extension, and BitchX assumes it can
|
||||
# find bunzip2 in the PATH.
|
||||
#
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/18 11:07:14 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/09/30 13:52:58 blymn Exp $
|
||||
|
||||
SHA1 (ircii-pana-1.0c18.tar.gz) = b0a25ad0d2a36ad36f5640cdf9fe34022a00d8a5
|
||||
Size (ircii-pana-1.0c18.tar.gz) = 2514378 bytes
|
||||
SHA1 (patch-aa) = a772d3e2a9d21f3fcabb85107f61d96bce4558f3
|
||||
SHA1 (patch-ab) = c0fc1dd62c9af33abc6d8a37cecdbfe0c439951c
|
||||
SHA1 (patch-ac) = 066e43ca994b3720b9575fb51460942e9392880a
|
||||
|
|
38
chat/bitchx/patches/patch-ac
Normal file
38
chat/bitchx/patches/patch-ac
Normal file
|
@ -0,0 +1,38 @@
|
|||
$NetBSD: patch-ac,v 1.3 2001/09/30 13:52:58 blymn Exp $
|
||||
|
||||
--- source/term.c.orig Mon Jan 8 16:54:22 2001
|
||||
+++ source/term.c
|
||||
@@ -819,14 +819,14 @@
|
||||
#ifndef WTERM_C
|
||||
int i;
|
||||
int desired;
|
||||
-
|
||||
+ char *t2ptr;
|
||||
|
||||
#if !defined(__EMX__) && !defined(WINNT) && !defined(GUI)
|
||||
memset(current_term, 0, sizeof(struct term_struct));
|
||||
|
||||
if (dumb_mode)
|
||||
ircpanic("term_init called in dumb_mode");
|
||||
- *termcap2 = 0;
|
||||
+ t2ptr = termcap2;
|
||||
if (!term && !(term = getenv("TERM")))
|
||||
{
|
||||
fprintf(stderr, "\n");
|
||||
@@ -873,11 +873,15 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
- cval = Tgetstr(tcaps[i], termcap2);
|
||||
+ cval = Tgetstr(tcaps[i], t2ptr);
|
||||
+#ifdef HAVE_TERMINFO
|
||||
if (cval == (char *) -1)
|
||||
*(char **)tcaps[i].ptr = NULL;
|
||||
else
|
||||
*(char **)tcaps[i].ptr = cval;
|
||||
+#else
|
||||
+ *(char **)tcaps[i].ptr = cval;
|
||||
+#endif
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in a new issue