Update pear-MDB2_Driver_mysql to 1.5.0b4 and add LICENSE.

Changelog:

- Make varchar_max_length property public, Bug #19582.
- Revert 327099 by afz, caused "Notice: Undefined index: charset on line 1003"
- PEAR::isError() -> MDB2::isError(), Bug #19491.
- PEAR::loadExtension() -> extension_loaded(), Bug #19583.
- max value for VARCHAR is 65535 but if used multi-bytes (UTF8) so it is 21844,
  because UTF8 string takes 3bytes
- Fix Bug #19262. Updates conditional stagements to use logical operators to
  include MDB2_FETCHMODE_OBJECT where appropriate. Was broken in r321197.
- Have truncateTable() return MDB2_OK on success, as documented (bug 19201)
- Have alterTable() return MDB2_OK on success, as documented (bug 19200)
- Have dropIndex() return MDB2_OK on success, as documented (bug 19198)
- Have vacuum() return MDB2_OK on success, as documented (bug 19196)
- Have createIndex() return MDB2_OK on success, as documented (bug 19195)
- Have dropConstraint() return MDB2_OK on success, as documented (bug 19194)
- Have dropSequence() return MDB2_OK on success, as documented (bug 19191).
- Make setOption('result_wrap_class') actually useful by changing the default
  value of $result_wrap_class parameters from false to true.
- Obtain error information in _doQuery() because standaloneQuery() throws off
  $this->connection.
- FETCHMODE constants are NOT bitwise.
- Make $sql_comments public (was before, used in tests, no real harm).
- Property visibility
- boolean data type
- fixed bug #17984: Error is not reported when mysqli_stmt_bind_param() fails
  [dennylin93]
- fixed bug #18057: Result of getDeclaration() can have invalid syntax
  [hschletz]
- request #18068: mapNativeDatatype() returns decimal places also for 'float'
  mdb2type
- fixed bug #18203: Type introspection breaks with associative arrays if names
  are identical (patch by Peter Bex)
- fixed bug #17892: removed debug message [pdt256]
- fixed bug #18057: Result of getDeclaration() can have invalid syntax
  [hschletz]
- request #18068: mapNativeDatatype() returns decimal places also for 'float'
  mdb2type

open todo items:
- use a trigger to emulate setting default now()
This commit is contained in:
taca 2013-03-16 03:33:45 +00:00
parent d1e249b51b
commit c5ccb0bba6
3 changed files with 13 additions and 12 deletions

View file

@ -1,11 +1,12 @@
# $NetBSD: Makefile,v 1.7 2012/10/02 21:25:37 asau Exp $
# $NetBSD: Makefile,v 1.8 2013/03/16 03:33:45 taca Exp $
DISTNAME= MDB2_Driver_mysql-1.5.0b3
DISTNAME= MDB2_Driver_mysql-1.5.0b4
CATEGORIES= databases
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://pear.php.net/package/MDB2_Driver_mysql
COMMENT= Mysql MDB2 driver
LICENSE= modified-bsd
DEPENDS+= ${PHP_PKG_PREFIX}-mysql-[0-9]*:../../databases/php-mysql
DEPENDS+= ${PHP_PKG_PREFIX}-pear-MDB2>=2.5:../../databases/pear-MDB2

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.6 2010/12/22 15:29:34 taca Exp $
$NetBSD: distinfo,v 1.7 2013/03/16 03:33:45 taca Exp $
SHA1 (pear/MDB2_Driver_mysql-1.5.0b3.tgz) = 26cdb9ec37a6f0324803bc40b6224ff31ad34939
RMD160 (pear/MDB2_Driver_mysql-1.5.0b3.tgz) = 0be1f58a1ae7b0483791a91123a7d46a174b6504
Size (pear/MDB2_Driver_mysql-1.5.0b3.tgz) = 45734 bytes
SHA1 (patch-aa) = ce2847873a620145b4f961fa35427b102f8f5c80
SHA1 (pear/MDB2_Driver_mysql-1.5.0b4.tgz) = d13059220f4f414965516ccad27c94691d7abd48
RMD160 (pear/MDB2_Driver_mysql-1.5.0b4.tgz) = 100bd5664b3e992df99f3d667036e0258fcf0bde
Size (pear/MDB2_Driver_mysql-1.5.0b4.tgz) = 47418 bytes
SHA1 (patch-aa) = 0841c6698f9c5e2de7b9a570e7806c70d9dbf867

View file

@ -1,10 +1,10 @@
$NetBSD: patch-aa,v 1.5 2010/12/22 15:29:34 taca Exp $
$NetBSD: patch-aa,v 1.6 2013/03/16 03:33:45 taca Exp $
--- ../package.xml.orig 2010-08-29 12:22:53.000000000 +0000
+++ ../package.xml
@@ -80,9 +80,6 @@ open todo items:
--- ../package.xml.orig 2012-10-24 03:12:26.000000000 +0900
+++ ../package.xml 2012-11-15 14:04:40.000000000 +0900
@@ -95,9 +95,6 @@
<channel>pear.php.net</channel>
<min>1.5.0b3</min>
<min>2.5.0b4</min>
</package>
- <extension>
- <name>mysql</name>