Update clanlib to 0.2.2. Changes are mostly bugfixes.
This commit is contained in:
parent
f7b9029f4e
commit
c5ddef14ad
8 changed files with 2693 additions and 355 deletions
|
@ -1,13 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.3 1999/09/29 22:58:44 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.4 1999/11/30 13:24:45 rh Exp $
|
||||
|
||||
DISTNAME= ClanLib-0.1.15
|
||||
CATEGORIES= games x11
|
||||
DISTNAME= ClanLib-0.2.2
|
||||
CATEGORIES= graphics games devel x11
|
||||
MASTER_SITES= http://dark.x.dtu.dk/clansoft/clanlib/download/
|
||||
|
||||
MAINTAINER= root@garbled.net
|
||||
HOMEPAGE= http://www.clanlib.org/
|
||||
|
||||
DEPENDS+= Hermes-1.2.5:../../graphics/hermes
|
||||
DEPENDS+= Hermes-1.2.6*:../../graphics/hermes
|
||||
DEPENDS+= Mesa-*:../../graphics/Mesa
|
||||
DEPENDS+= png-1.0.3:../../graphics/png
|
||||
|
||||
|
@ -18,15 +18,23 @@ USE_PERL5= yes
|
|||
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CFLAGS+= -I${LOCALBASE}/include/Hermes
|
||||
CONFIGURE_ARGS+= --disable-asm386 \
|
||||
--enable-libpng \
|
||||
--enable-clansound \
|
||||
--enable-dyn \
|
||||
--enable-network --enable-mesa
|
||||
.if ${MACHINE_ARCH} == "i386"
|
||||
CONFIGURE_ARGS+= --enable-asm386
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-asm386
|
||||
.endif
|
||||
CONFIGURE_ARGS+= --enable-libpng
|
||||
CONFIGURE_ARGS+= --enable-clansound
|
||||
CONFIGURE_ARGS+= --enable-dyn
|
||||
CONFIGURE_ARGS+= --enable-network
|
||||
CONFIGURE_ARGS+= --enable-mesa
|
||||
|
||||
CONFIGURE_ENV+= LOCALBASE="${LOCALBASE}"# CC='cc ${CFLAGS} ${LDFLAGS}'
|
||||
MAKE_ENV+= LDFLAGS="${LDFLAGS}"
|
||||
|
||||
post-patch:
|
||||
${CHMOD} +x ${WRKSRC}/configure
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/07/21 22:56:35 garbled Exp $
|
||||
$NetBSD: md5,v 1.2 1999/11/30 13:24:46 rh Exp $
|
||||
|
||||
MD5 (ClanLib-0.1.15.tar.gz) = 967d0721918fe2372edb4e42fb2ec58c
|
||||
MD5 (ClanLib-0.2.2.tar.gz) = 5d8006eb64e82e1dd482376ee8212ad8
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 1999/07/21 22:56:35 garbled Exp $
|
||||
$NetBSD: patch-sum,v 1.2 1999/11/30 13:24:46 rh Exp $
|
||||
|
||||
MD5 (patch-aa) = d00db11088d1df9c88baf1229b8a778e
|
||||
MD5 (patch-aa) = bdd68da18224d22e69bf14f4524f17cc
|
||||
MD5 (patch-ab) = d3147151b40a0d3cff75065819cdb2e5
|
||||
MD5 (patch-ac) = 35c9336b18c8a420e51a1ff0081f64d5
|
||||
MD5 (patch-ad) = 9bdd72ec2cf530d60f4b920d07894afe
|
||||
MD5 (patch-ad) = 035dd0798ad8cf382dc5202a0c4c3985
|
||||
MD5 (patch-ae) = d5d450a7ff806e375df3678947a86bdb
|
||||
MD5 (patch-af) = 88ab835403ca1d513d569634fe37119b
|
||||
MD5 (patch-af) = 14a7d0dff76d48e556d79d6cd25a75b3
|
||||
MD5 (patch-ag) = 38186794a82a102c7cdaba0d7e09f2b2
|
||||
MD5 (patch-ah) = 4172a64a8f34f2680e6dd8cd641d7bc6
|
||||
MD5 (patch-ah) = b5b0b6c581ce3725f7f8376ca3982e1c
|
||||
MD5 (patch-ai) = fb7080c36cf90dea10b4856fc61b1622
|
||||
MD5 (patch-aj) = da715da3beff1da0199dfb2b709f065d
|
||||
MD5 (patch-ak) = 5ef731e7b8f81c1ccd7448036293fc1a
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,15 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 1999/07/21 22:56:35 garbled Exp $
|
||||
--- Makefile.conf.in.orig Sun May 30 15:43:50 1999
|
||||
+++ Makefile.conf.in Thu Jul 8 11:27:24 1999
|
||||
@@ -9,9 +9,9 @@
|
||||
INC_PREFIX = @includedir@
|
||||
$NetBSD: patch-ad,v 1.2 1999/11/30 13:24:47 rh Exp $
|
||||
|
||||
--- Makefile.conf.in.orig Mon Nov 29 16:59:33 1999
|
||||
+++ Makefile.conf.in Mon Nov 29 17:02:28 1999
|
||||
@@ -13,7 +13,7 @@
|
||||
BIN_PREFIX = @bindir@
|
||||
TARGET_PREFIX = @libdir@/ClanLib
|
||||
|
||||
-INCLUDE_DIRS = -I . -I Layer1 -I Layer2 -I Layer2/StreamSoundProviders/mikmod/include @x_includes@
|
||||
+INCLUDE_DIRS = -I . -I Layer1 -I Layer2 -I Layer2/StreamSoundProviders/mikmod/include @x_includes@ -I$(LOCALBASE)/include
|
||||
+INCLUDE_DIRS = -I . -I Layer1 -I Layer2 -I Layer2/StreamSoundProviders/mikmod/include @x_includes@ -I${LOCALBASE}/include
|
||||
|
||||
-COMP_OPTIONS = -Wall -g $(INCLUDE_DIRS) -fPIC -O2 @DEFS@
|
||||
+COMP_OPTIONS = -g $(CFLAGS) $(INCLUDE_DIRS) -fPIC -O2 @DEFS@
|
||||
COMP_OPTIONS = -Wall $(INCLUDE_DIRS) -fPIC @DEFS@ @comp_mode@
|
||||
|
||||
LINK_LIBS1 = @libs1@
|
||||
LINK_LIBS2 = @libs2@
|
||||
|
|
|
@ -1,23 +1,16 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 1999/07/21 22:56:35 garbled Exp $
|
||||
--- Layer1/System/Unix/init_linux.cpp.orig Thu Jun 3
|
||||
19:58:39 1999
|
||||
+++ Layer1/System/Unix/init_linux.cpp Tue Jul 20 08:34:23 1999
|
||||
@@ -193,7 +193,7 @@
|
||||
|
||||
if (dynload_add_network == NULL)
|
||||
{
|
||||
- cout << "Unable to load any sound implementation. Sorry." << endl;
|
||||
+ cout << "Unable to load any network implementation. Sorry." << endl;
|
||||
exit(1);
|
||||
}
|
||||
|
||||
@@ -275,7 +275,9 @@
|
||||
// init signal handling
|
||||
act.sa_handler = signal_handler;
|
||||
act.sa_flags = 0;
|
||||
+#ifndef __NetBSD__
|
||||
act.sa_restorer = NULL;
|
||||
$NetBSD: patch-af,v 1.2 1999/11/30 13:24:47 rh Exp $
|
||||
|
||||
--- Layer1/System/Unix/mutex_pthread.cpp.orig Sun Aug 15 00:53:30 1999
|
||||
+++ Layer1/System/Unix/mutex_pthread.cpp Mon Nov 29 18:30:10 1999
|
||||
@@ -31,7 +31,11 @@
|
||||
{
|
||||
pthread_mutexattr_t attr;
|
||||
pthread_mutexattr_init(&attr);
|
||||
+#ifdef PTHREAD_MUTEX_RECURSIVE_NP
|
||||
pthread_mutexattr_setkind_np(&attr, PTHREAD_MUTEX_RECURSIVE_NP);
|
||||
+#else
|
||||
+ pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE);
|
||||
+#endif
|
||||
sigemptyset(&act.sa_mask);
|
||||
sigaction(SIGTERM,&act,&old); // terminated, by kill
|
||||
sigaction(SIGINT,&act,&old); // interrupt, ctrl-c
|
||||
pthread_mutex_init(&mutex, &attr);
|
||||
pthread_mutexattr_destroy(&attr);
|
||||
}
|
||||
|
|
|
@ -1,239 +1,31 @@
|
|||
$NetBSD: patch-ah,v 1.1.1.1 1999/07/21 22:56:35 garbled Exp $
|
||||
--- Makefile.in.orig Fri Jun 4 08:44:28 1999
|
||||
+++ Makefile.in Tue Jul 20 20:16:34 1999
|
||||
@@ -96,7 +96,6 @@
|
||||
OutputFiles/cardplayback_clan.o \
|
||||
OutputFiles/clansound.o \
|
||||
OutputFiles/mixer.o \
|
||||
- OutputFiles/mixer_asm.o \
|
||||
OutputFiles/oss.o \
|
||||
OutputFiles/sample.o \
|
||||
OutputFiles/session.o \
|
||||
@@ -209,11 +208,11 @@
|
||||
$NetBSD: patch-ah,v 1.2 1999/11/30 13:24:47 rh Exp $
|
||||
|
||||
--- Common/clanstring.h.orig Sun Jul 11 13:14:05 1999
|
||||
+++ Common/clanstring.h Tue Nov 30 10:28:01 1999
|
||||
@@ -65,6 +65,8 @@
|
||||
|
||||
display_targets: @display_targets@
|
||||
#ifndef WIN32
|
||||
#include <ctype.h>
|
||||
+#include <stdio.h>
|
||||
+#include <sys/param.h>
|
||||
#endif
|
||||
|
||||
-sound_targets: libclan-sound.so
|
||||
+sound_targets: libclan-sound.so.0.0
|
||||
#ifdef __BEOS__
|
||||
@@ -148,6 +150,9 @@
|
||||
|
||||
-network_targets: libclan-network.so
|
||||
+network_targets: libclan-network.so.0.0
|
||||
float float_number = _float_number;
|
||||
|
||||
-core_libs: libclan.so libclanlayer1.so libclanlayer2.so libclancommon.so
|
||||
+core_libs: libclan.so.0.0 libclanlayer1.so.0.0 libclanlayer2.so.0.0 libclancommon.so.0.0
|
||||
+#if (defined(BSD) && BSD >= 199306)
|
||||
+ snprintf(buf, sizeof buf, "%.*f", precision, (double)_float_number);
|
||||
+#else
|
||||
const char *_float_buffer = fcvt(
|
||||
float_number,
|
||||
precision,
|
||||
@@ -172,6 +177,7 @@
|
||||
|
||||
install: all
|
||||
@echo ""
|
||||
@@ -225,33 +224,33 @@
|
||||
@for i in `find Layer1 -name 'API'`; do install -d $(INC_PREFIX)/ClanLib/$$i; done
|
||||
@for i in `find Layer2 -type d|grep -v CVS`; do install -d $(INC_PREFIX)/ClanLib/$$i; done
|
||||
@install -d $(INC_PREFIX)/ClanLib/Common
|
||||
- @for i in `find Layer1 -name '*.h'|grep API`; do install -m 0644 $$i $(INC_PREFIX)/ClanLib/$$i; done
|
||||
- @for i in `find Layer2 -name '*.h'`; do install -m 0644 $$i $(INC_PREFIX)/ClanLib/$$i; done
|
||||
- @for i in `find Common -name '*.h'`; do install -m 0644 $$i $(INC_PREFIX)/ClanLib/$$i; done
|
||||
- @install -m 0644 clanlib.h $(INC_PREFIX)/ClanLib/clanlib.h
|
||||
- @install -m 0644 clanlayer2.h $(INC_PREFIX)/ClanLib/clanlayer2.h
|
||||
+ @for i in `find Layer1 -name '*.h'|grep API`; do install -c -m 0644 $$i $(INC_PREFIX)/ClanLib/$$i; done
|
||||
+ @for i in `find Layer2 -name '*.h'`; do install -c -m 0644 $$i $(INC_PREFIX)/ClanLib/$$i; done
|
||||
+ @for i in `find Common -name '*.h'`; do install -c -m 0644 $$i $(INC_PREFIX)/ClanLib/$$i; done
|
||||
+ @install -c -m 0644 clanlib.h $(INC_PREFIX)/ClanLib/clanlib.h
|
||||
+ @install -c -m 0644 clanlayer2.h $(INC_PREFIX)/ClanLib/clanlayer2.h
|
||||
@strip Utils/DatafileCompiler/datafile_compiler
|
||||
@echo "Datafile compiler is being installed in $(BIN_PREFIX)."
|
||||
@install Utils/DatafileCompiler/datafile_compiler $(BIN_PREFIX)
|
||||
@echo "Libraries are being installed in $(LIB_PREFIX)."
|
||||
- @install libclan.so $(LIB_PREFIX)
|
||||
- @install libclanlayer1.so $(LIB_PREFIX)
|
||||
- @install libclanlayer2.so $(LIB_PREFIX)
|
||||
- @install libclancommon.so $(LIB_PREFIX)
|
||||
- @install libclan-network.so $(LIB_PREFIX)
|
||||
- @install libclan-sound.so $(LIB_PREFIX)
|
||||
- @if [ -f libclan-display-x11.so ]; then install libclan-display-x11.so $(LIB_PREFIX); fi
|
||||
- @if [ -f libclan-display-mesa.so ]; then install libclan-display-mesa.so $(LIB_PREFIX); fi
|
||||
- @if [ -f libclan-display-fbdev.so ]; then install libclan-display-fbdev.so $(LIB_PREFIX); fi
|
||||
- @if [ -f libclan-display-ptc.so ]; then install libclan-display-ptc.so $(LIB_PREFIX); fi
|
||||
- @if [ -f libclan-display-svgalib.so ]; then install libclan-display-svgalib.so $(LIB_PREFIX); fi
|
||||
- @if [ -f libclan-display-ggi.so ]; then install libclan-display-ggi.so $(LIB_PREFIX); fi
|
||||
+ @install libclan.so.0.0 $(LIB_PREFIX)
|
||||
+ @install libclanlayer1.so.0.0 $(LIB_PREFIX)
|
||||
+ @install libclanlayer2.so.0.0 $(LIB_PREFIX)
|
||||
+ @install libclancommon.so.0.0 $(LIB_PREFIX)
|
||||
+ @install libclan-network.so.0.0 $(LIB_PREFIX)
|
||||
+ @install libclan-sound.so.0.0 $(LIB_PREFIX)
|
||||
+ @if [ -f libclan-display-x11.so.0.0 ]; then install libclan-display-x11.so.0.0 $(LIB_PREFIX); fi
|
||||
+ @if [ -f libclan-display-mesa.so.0.0 ]; then install libclan-display-mesa.so.0.0 $(LIB_PREFIX); fi
|
||||
+ @if [ -f libclan-display-fbdev.so.0.0 ]; then install libclan-display-fbdev.so.0.0 $(LIB_PREFIX); fi
|
||||
+ @if [ -f libclan-display-ptc.so.0.0 ]; then install libclan-display-ptc.so.0.0 $(LIB_PREFIX); fi
|
||||
+ @if [ -f libclan-display-svgalib.so.0.0 ]; then install libclan-display-svgalib.so.0.0 $(LIB_PREFIX); fi
|
||||
+ @if [ -f libclan-display-ggi.so.0.0 ]; then install libclan-display-ggi.so.0.0 $(LIB_PREFIX); fi
|
||||
|
||||
docs: configure
|
||||
- cd Docs; make
|
||||
+ cd Docs; gmake
|
||||
|
||||
docs_install: docs
|
||||
- cd Docs; make install
|
||||
+ cd Docs; gmake install
|
||||
|
||||
configure: configure.in
|
||||
@autoconf
|
||||
@@ -263,16 +262,16 @@
|
||||
@echo ""
|
||||
@cat ascii-logo
|
||||
|
||||
-utils: libclan.so
|
||||
- @cd Utils; make
|
||||
+utils: libclan.so.0.0
|
||||
+ @cd Utils; gmake
|
||||
|
||||
examples:
|
||||
- @cd Docs/examples; make
|
||||
+ @cd Docs/examples; gmake
|
||||
|
||||
clean:
|
||||
@echo "Cleaning project..."
|
||||
@find . -name '*.o' -exec rm "{}" \;
|
||||
- @find . -name '*.so' -exec rm "{}" \;
|
||||
+ @find . -name '*.so.0.0' -exec rm "{}" \;
|
||||
@find . -name '*.a' -exec rm "{}" \;
|
||||
@if [ -d "OutputFiles" ]; then rm -rf OutputFiles; fi
|
||||
@rm -f ./Utils/DatafileCompiler/datafile_compiler
|
||||
@@ -286,8 +285,8 @@
|
||||
@rm -f Docs/perceps
|
||||
@rm -f Docs/reference/.perceps
|
||||
@find . -name '.#*' -exec rm "{}" \;
|
||||
- @cd Docs && make distclean
|
||||
- @cd Docs/examples && make distclean
|
||||
+ @cd Docs && gmake distclean
|
||||
+ @cd Docs/examples && gmake distclean
|
||||
@autoconf
|
||||
|
||||
dep:
|
||||
@@ -305,55 +304,79 @@
|
||||
|
||||
# Dynamic linking:
|
||||
|
||||
-LIB_OPTIONS = -fPIC -fpic -g -shared
|
||||
+LIB_OPTIONS = -fPIC -g -shared $(LDFLAGS)
|
||||
|
||||
-libclancommon.so: $(OBJF_COMMON)
|
||||
- @echo "Building dynamic library (libclancommon.so)"
|
||||
- @g++ $(LIB_OPTIONS) -o libclancommon.so $(OBJF_COMMON)
|
||||
-
|
||||
-libclanlayer1.so: libclancommon.so $(OBJF_GENERIC_ALL) $(OBJF_UNIX)
|
||||
- @echo "Building dynamic library (libclanlayer1.so)"
|
||||
- @g++ $(LIB_OPTIONS) -ldl -o libclanlayer1.so -L. -lclancommon $(LINK_LIBS1) $(OBJF_GENERIC_ALL) $(OBJF_UNIX)
|
||||
-
|
||||
-libclanlayer2.so: $(OBJF_LAYER2)
|
||||
- @echo "Building dynamic library (libclanlayer2.so)"
|
||||
- @g++ $(LIB_OPTIONS) -o libclanlayer2.so $(LINK_LIBS2) $(OBJF_LAYER2)
|
||||
-
|
||||
-libclan.so: $(OBJF_COMMON) $(OBJF_GENERIC_ALL) $(OBJF_UNIX)
|
||||
- @echo "Building dynamic library (libclan.so)"
|
||||
- @g++ $(LIB_OPTIONS) -ldl -o libclan.so $(LINK_LIBS1) $(OBJF_COMMON) $(OBJF_GENERIC_ALL) $(OBJF_UNIX)
|
||||
-
|
||||
-libclan-network.so: $(OBJF_NETWORK_UNIX)
|
||||
- @echo "Building dynamic library (libclan-network.so)"
|
||||
- @g++ $(LIB_OPTIONS) -o libclan-network.so $(OBJF_NETWORK_UNIX)
|
||||
-
|
||||
-libclan-sound.so: $(OBJF_SOUND_CLANSOUND)
|
||||
- @echo "Building dynamic library (libclan-sound.so)"
|
||||
- @g++ $(LIB_OPTIONS) -o libclan-sound.so $(OBJF_SOUND_CLANSOUND)
|
||||
-
|
||||
-libclan-display-x11.so: $(OBJF_DISP_X11)
|
||||
- @echo "Building dynamic library (libclan-display-x11.so)"
|
||||
- @g++ $(LIB_OPTIONS) @x_libraries@ -o libclan-display-x11.so $(OBJF_DISP_X11)
|
||||
-
|
||||
-libclan-display-ptc.so: $(OBJF_DISP_PTC) libclan-display-x11.so
|
||||
- @echo "Building dynamic library (libclan-display-ptc.so)"
|
||||
- @g++ $(LIB_OPTIONS) -L . -lclan-display-x11 -lptc -o libclan-display-ptc.so $(OBJF_DISP_PTC)
|
||||
-
|
||||
-libclan-display-mesa.so: $(OBJF_DISP_MESA) libclan-display-x11.so
|
||||
- @echo "Building dynamic library (libclan-display-mesa.so)"
|
||||
- @g++ $(LIB_OPTIONS) -L . -lclan-display-x11 @x_libraries@ -lMesaGL -o libclan-display-mesa.so $(OBJF_DISP_MESA)
|
||||
-
|
||||
-libclan-display-ggi.so: $(OBJF_DISP_GGI)
|
||||
- @echo "Building dynamic library (libclan-display-ggi.so)"
|
||||
- @g++ $(LIB_OPTIONS) -lggi -o libclan-display-ggi.so $(OBJF_DISP_GGI)
|
||||
-
|
||||
-libclan-display-fbdev.so: $(OBJF_DISP_FBDEV)
|
||||
- @echo "Building dynamic library (libclan-display-fbdev.so)"
|
||||
- @g++ $(LIB_OPTIONS) -o libclan-display-fbdev.so $(OBJF_DISP_FBDEV)
|
||||
-
|
||||
-libclan-display-svgalib.so: $(OBJF_DISP_SVGALIB)
|
||||
- @echo "Building dynamic library (libclan-display-svgalib.so)"
|
||||
- @g++ $(LIB_OPTIONS) -lvga -o libclan-display-svgalib.so $(OBJF_DISP_SVGALIB)
|
||||
+libclancommon.so.0.0: $(OBJF_COMMON)
|
||||
+ @echo "Building dynamic library (libclancommon.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -o libclancommon.so.0.0 $(OBJF_COMMON)
|
||||
+ -@ln -s libclancommon.so.0.0 libclancommon.so.0
|
||||
+ -@ln -s libclancommon.so.0.0 libclancommon.so
|
||||
+
|
||||
+libclanlayer1.so.0.0: libclancommon.so.0.0 $(OBJF_GENERIC_ALL) $(OBJF_UNIX)
|
||||
+ @echo "Building dynamic library (libclanlayer1.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -o libclanlayer1.so.0.0 -L. -lclancommon $(LINK_LIBS1) $(OBJF_GENERIC_ALL) $(OBJF_UNIX)
|
||||
+ -@ln -s libclanlayer1.so.0.0 libclanlayer1.so.0
|
||||
+ -@ln -s libclanlayer1.so.0.0 libclanlayer1.so
|
||||
+
|
||||
+libclanlayer2.so.0.0: $(OBJF_LAYER2)
|
||||
+ @echo "Building dynamic library (libclanlayer2.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -o libclanlayer2.so.0.0 $(LINK_LIBS2) $(OBJF_LAYER2)
|
||||
+ -@ln -s libclanlayer2.so.0.0 libclanlayer2.so.0
|
||||
+ -@ln -s libclanlayer2.so.0.0 libclanlayer2.so
|
||||
+
|
||||
+libclan.so.0.0: $(OBJF_COMMON) $(OBJF_GENERIC_ALL) $(OBJF_UNIX)
|
||||
+ @echo "Building dynamic library (libclan.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -o libclan.so.0.0 $(LINK_LIBS1) $(OBJF_COMMON) $(OBJF_GENERIC_ALL) $(OBJF_UNIX)
|
||||
+ -@ln -s libclan.so.0.0 libclan.so.0
|
||||
+ -@ln -s libclan.so.0.0 libclan.so
|
||||
+
|
||||
+libclan-network.so.0.0: $(OBJF_NETWORK_UNIX)
|
||||
+ @echo "Building dynamic library (libclan-network.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -o libclan-network.so.0.0 $(OBJF_NETWORK_UNIX)
|
||||
+ -@ln -s libclan-network.so.0.0 libclan-network.so.0
|
||||
+ -@ln -s libclan-network.so.0.0 libclan-network.so
|
||||
+
|
||||
+libclan-sound.so.0.0: $(OBJF_SOUND_CLANSOUND)
|
||||
+ @echo "Building dynamic library (libclan-sound.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -lossaudio -o libclan-sound.so.0.0 $(OBJF_SOUND_CLANSOUND)
|
||||
+ -@ln -s libclan-sound.so.0.0 libclan-sound.so.0
|
||||
+ -@ln -s libclan-sound.so.0.0 libclan-sound.so
|
||||
+
|
||||
+libclan-display-x11.so.0.0: $(OBJF_DISP_X11)
|
||||
+ @echo "Building dynamic library (libclan-display-x11.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) @x_libraries@ -o libclan-display-x11.so.0.0 $(OBJF_DISP_X11)
|
||||
+ -@ln -s libclan-display-x11.so.0.0 libclan-display-x11.so.0
|
||||
+ -@ln -s libclan-display-x11.so.0.0 libclan-display-x11.so
|
||||
+
|
||||
+libclan-display-ptc.so.0.0: $(OBJF_DISP_PTC) libclan-display-x11.so.0.0
|
||||
+ @echo "Building dynamic library (libclan-display-ptc.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -L . -lclan-display-x11 -lptc -o libclan-display-ptc.so.0.0 $(OBJF_DISP_PTC)
|
||||
+ -@ln -s libclan-display-ptc.so.0.0 libclan-display-ptc.so.0
|
||||
+ -@ln -s libclan-display-ptc.so.0.0 libclan-display-ptc.so
|
||||
+
|
||||
+libclan-display-mesa.so.0.0: $(OBJF_DISP_MESA) libclan-display-x11.so.0.0
|
||||
+ @echo "Building dynamic library (libclan-display-mesa.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -L . -lclan-display-x11 @x_libraries@ -lMesaGL -o libclan-display-mesa.so.0.0 $(OBJF_DISP_MESA)
|
||||
+ -@ln -s libclan-display-mesa.so.0.0 libclan-display-mesa.so.0
|
||||
+ -@ln -s libclan-display-mesa.so.0.0 libclan-display-mesa.so
|
||||
+
|
||||
+libclan-display-ggi.so.0.0: $(OBJF_DISP_GGI)
|
||||
+ @echo "Building dynamic library (libclan-display-ggi.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -lggi -o libclan-display-ggi.so.0.0 $(OBJF_DISP_GGI)
|
||||
+ -@ln -s libclan-display-ggi.so.0.0 libclan-display-ggi.so.0
|
||||
+ -@ln -s libclan-display-ggi.so.0.0 libclan-display-ggi.so
|
||||
+
|
||||
+libclan-display-fbdev.so.0.0: $(OBJF_DISP_FBDEV)
|
||||
+ @echo "Building dynamic library (libclan-display-fbdev.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -o libclan-display-fbdev.so.0.0 $(OBJF_DISP_FBDEV)
|
||||
+ -@ln -s libclan-display-fbdev.so.0.0 libclan-display-fbdev.so.0
|
||||
+ -@ln -s libclan-display-fbdev.so.0.0 libclan-display-fbdev.so
|
||||
+
|
||||
+libclan-display-svgalib.so.0.0: $(OBJF_DISP_SVGALIB)
|
||||
+ @echo "Building dynamic library (libclan-display-svgalib.so.0.0)"
|
||||
+ @g++ $(LIB_OPTIONS) -lvga -o libclan-display-svgalib.so.0.0 $(OBJF_DISP_SVGALIB)
|
||||
+ -@ln -s libclan-display-svgalib.so.0.0 libclan-display-svgalib.so.0
|
||||
+ -@ln -s libclan-display-svgalib.so.0.0 libclan-display-svgalib.so
|
||||
|
||||
include Makefile.dep
|
||||
strcat(buf, ".");
|
||||
strcat(buf, &float_buffer[decimal]);
|
||||
+#endif
|
||||
|
||||
copy_strings:
|
||||
int len=0;
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/07/21 22:56:35 garbled Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 1999/11/30 13:24:48 rh Exp $
|
||||
bin/datafile_compiler
|
||||
include/ClanLib/Layer1/Display/API/cliprect.h
|
||||
include/ClanLib/Layer1/Display/API/display.h
|
||||
|
@ -8,8 +8,9 @@ include/ClanLib/Layer1/Display/API/pixelformat.h
|
|||
include/ClanLib/Layer1/Display/API/surface.h
|
||||
include/ClanLib/Layer1/Display/API/surfacepriority.h
|
||||
include/ClanLib/Layer1/Display/API/surfaceprovider.h
|
||||
include/ClanLib/Layer1/Display/API/target.h
|
||||
include/ClanLib/Layer1/Display/API/vidmode.h
|
||||
include/ClanLib/Layer1/IOData/API/endian.h
|
||||
include/ClanLib/Layer1/IOData/API/cl_endian.h
|
||||
include/ClanLib/Layer1/IOData/API/inputsource.h
|
||||
include/ClanLib/Layer1/IOData/API/inputsource_provider.h
|
||||
include/ClanLib/Layer1/IOData/API/outputsource.h
|
||||
|
@ -23,7 +24,6 @@ include/ClanLib/Layer1/Input/API/inputdevice.h
|
|||
include/ClanLib/Layer1/Input/API/inputhat.h
|
||||
include/ClanLib/Layer1/Input/API/keyboard.h
|
||||
include/ClanLib/Layer1/Input/API/mouse.h
|
||||
include/ClanLib/Layer1/Network/API/netchannel.h
|
||||
include/ClanLib/Layer1/Network/API/netcomputer.h
|
||||
include/ClanLib/Layer1/Network/API/netgame.h
|
||||
include/ClanLib/Layer1/Network/API/netgroup.h
|
||||
|
@ -38,38 +38,52 @@ include/ClanLib/Layer1/Sound/API/stream_soundprovider.h
|
|||
include/ClanLib/Layer1/System/API/cl_assert.h
|
||||
include/ClanLib/Layer1/System/API/clanapp.h
|
||||
include/ClanLib/Layer1/System/API/error.h
|
||||
include/ClanLib/Layer1/System/API/mutex.h
|
||||
include/ClanLib/Layer1/System/API/settings.h
|
||||
include/ClanLib/Layer1/System/API/system.h
|
||||
include/ClanLib/Layer1/System/API/thread.h
|
||||
include/ClanLib/Layer1/System/API/timer_manager.h
|
||||
include/ClanLib/Layer2/InputConverters/inputaxis_basic.h
|
||||
include/ClanLib/Layer2/InputConverters/inputaxis_group.h
|
||||
include/ClanLib/Layer2/InputConverters/inputbuffer_simple.h
|
||||
include/ClanLib/Layer2/InputConverters/inputbutton_basic.h
|
||||
include/ClanLib/Layer2/InputConverters/inputbutton_group.h
|
||||
include/ClanLib/Layer2/InputConverters/inputbutton_to_axis_analog.h
|
||||
include/ClanLib/Layer2/InputConverters/inputbutton_to_axis_digital.h
|
||||
include/ClanLib/Layer2/Misc/cltime.h
|
||||
include/ClanLib/Layer2/Misc/font.h
|
||||
include/ClanLib/Layer2/Misc/font_description.h
|
||||
include/ClanLib/Layer2/Misc/inputsource_memory.h
|
||||
include/ClanLib/Layer2/Misc/layermanager.h
|
||||
include/ClanLib/Layer2/Misc/menu.h
|
||||
include/ClanLib/Layer2/Misc/outputsource_memory.h
|
||||
include/ClanLib/Layer2/NetChannels/netchannel_filetransfer.h
|
||||
include/ClanLib/Layer2/NetChannels/netchannel_portnumbers.h
|
||||
include/ClanLib/Layer2/NetChannels/netchannel_resource.h
|
||||
include/ClanLib/Layer2/NetChannels/netchannels.h
|
||||
include/ClanLib/Layer2/NetPorts/netport_filetransfer.h
|
||||
include/ClanLib/Layer2/NetPorts/netport_portnumbers.h
|
||||
include/ClanLib/Layer2/NetPorts/netport_sms.h
|
||||
include/ClanLib/Layer2/NetChannels/netdata_controller.h
|
||||
include/ClanLib/Layer2/NetChannels/netobject.h
|
||||
include/ClanLib/Layer2/NetChannels/netobject_controller_basic.h
|
||||
include/ClanLib/Layer2/NetChannels/netobject_creator.h
|
||||
include/ClanLib/Layer2/Resources/resource.h
|
||||
include/ClanLib/Layer2/Resources/resource_manager.h
|
||||
include/ClanLib/Layer2/Resources/resourceoption.h
|
||||
include/ClanLib/Layer2/Resources/resourceoptions.h
|
||||
include/ClanLib/Layer2/Resources/resourcetype.h
|
||||
include/ClanLib/Layer2/Resources/resourcetype_boolean.h
|
||||
include/ClanLib/Layer2/Resources/resourcetype_font.h
|
||||
include/ClanLib/Layer2/Resources/resourcetype_integer.h
|
||||
include/ClanLib/Layer2/Resources/resourcetype_palette.h
|
||||
include/ClanLib/Layer2/Resources/resourcetype_raw.h
|
||||
include/ClanLib/Layer2/Resources/resourcetype_sample.h
|
||||
include/ClanLib/Layer2/Resources/resourcetype_string.h
|
||||
include/ClanLib/Layer2/Resources/resourcetype_surface.h
|
||||
include/ClanLib/Layer2/StaticSoundProviders/raw_sample.h
|
||||
include/ClanLib/Layer2/StaticSoundProviders/wave_sample.h
|
||||
include/ClanLib/Layer2/StreamSoundProviders/mikmod/include/mikmod.h
|
||||
include/ClanLib/Layer2/StreamSoundProviders/mikmod/include/mikmod_build.h
|
||||
include/ClanLib/Layer2/StreamSoundProviders/mikmod/include/mikmod_internals.h
|
||||
include/ClanLib/Layer2/StreamSoundProviders/mikmod/mik_pragmas.h
|
||||
include/ClanLib/Layer2/StreamSoundProviders/mikmod/streamed_mikmod_sample.h
|
||||
include/ClanLib/Layer2/StreamSoundProviders/streamed_raw_sample.h
|
||||
include/ClanLib/Layer2/StreamSoundProviders/streamed_wave_sample.h
|
||||
|
@ -78,18 +92,21 @@ include/ClanLib/Layer2/SurfaceProviders/provider_convpoly.h
|
|||
include/ClanLib/Layer2/SurfaceProviders/provider_convpoly_basics.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/provider_empty.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/provider_fli.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/provider_mpeg.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/provider_pcx.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/provider_png.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/provider_targa.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/sprite.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/sprite2.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/sprite_subarray_provider.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/sprite_subsection_provider.h
|
||||
include/ClanLib/Layer2/SurfaceProviders/surface_manager.h
|
||||
include/ClanLib/Common/clanstring.h
|
||||
include/ClanLib/Common/array.h
|
||||
include/ClanLib/Common/hashtable.h
|
||||
include/ClanLib/Common/bezier.h
|
||||
include/ClanLib/Common/clanstring.h
|
||||
include/ClanLib/Common/error.h
|
||||
include/ClanLib/Common/formatted_data.h
|
||||
include/ClanLib/Common/hashtable.h
|
||||
include/ClanLib/Common/link.h
|
||||
include/ClanLib/Common/matrix.h
|
||||
include/ClanLib/Common/memory.h
|
||||
|
@ -98,14 +115,15 @@ include/ClanLib/Common/stack.h
|
|||
include/ClanLib/Common/vector.h
|
||||
include/ClanLib/clanlib.h
|
||||
include/ClanLib/clanlayer2.h
|
||||
lib/libclan.so.0.0
|
||||
lib/libclanlayer1.so.0.0
|
||||
lib/libclanlayer2.so.0.0
|
||||
lib/libclancommon.so.0.0
|
||||
lib/libclan-network.so.0.0
|
||||
lib/libclan-sound.so.0.0
|
||||
lib/libclan-display-x11.so.0.0
|
||||
lib/libclan-display-mesa.so.0.0
|
||||
lib/ClanLib/libclan-input-tty.so.0.2.2
|
||||
lib/ClanLib/libclan-display-x11.so.0.2.2
|
||||
lib/ClanLib/libclan-display-glx.so.0.2.2
|
||||
lib/ClanLib/libclan-sound.so.0.2.2
|
||||
lib/ClanLib/libclan-network.so.0.2.2
|
||||
lib/libclan.so.0.2.2
|
||||
lib/libclanlayer1.so.0.2.2
|
||||
lib/libclanlayer2.so.0.2.2
|
||||
lib/libclancommon.so.0.2.2
|
||||
@dirrm include/ClanLib/Layer1/Display/API
|
||||
@dirrm include/ClanLib/Layer1/Display
|
||||
@dirrm include/ClanLib/Layer1/IOData/API
|
||||
|
@ -122,7 +140,6 @@ lib/libclan-display-mesa.so.0.0
|
|||
@dirrm include/ClanLib/Layer2/InputConverters
|
||||
@dirrm include/ClanLib/Layer2/Misc
|
||||
@dirrm include/ClanLib/Layer2/NetChannels
|
||||
@dirrm include/ClanLib/Layer2/NetPorts
|
||||
@dirrm include/ClanLib/Layer2/Resources
|
||||
@dirrm include/ClanLib/Layer2/StreamSoundProviders/mikmod/drivers
|
||||
@dirrm include/ClanLib/Layer2/StreamSoundProviders/mikmod/include
|
||||
|
@ -136,3 +153,4 @@ lib/libclan-display-mesa.so.0.0
|
|||
@dirrm include/ClanLib/Layer2
|
||||
@dirrm include/ClanLib/Common
|
||||
@dirrm include/ClanLib
|
||||
@dirrm lib/ClanLib
|
||||
|
|
Loading…
Reference in a new issue