Fix rpath arguments in brotli pkgconfig files
The pkgconfig files for brotli had a direct -R missing -Wl, this breaks the linking step when used. Remove them and use PKGCONFIG_OVERRIDE instead.
This commit is contained in:
parent
01c0f5c6c6
commit
c5e30eec1c
5 changed files with 50 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.8 2020/08/31 08:45:44 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2021/03/21 19:24:24 nros Exp $
|
||||
|
||||
DISTNAME= brotli-1.0.9
|
||||
CATEGORIES= archivers
|
||||
|
@ -13,4 +13,8 @@ LICENSE= mit
|
|||
USE_CMAKE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
PKGCONFIG_OVERRIDE+= scripts/libbrotlicommon.pc.in
|
||||
PKGCONFIG_OVERRIDE+= scripts/libbrotlidec.pc.in
|
||||
PKGCONFIG_OVERRIDE+= scripts/libbrotlienc.pc.in
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.8 2020/08/31 08:45:44 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.9 2021/03/21 19:24:24 nros Exp $
|
||||
|
||||
SHA1 (brotli-1.0.9.tar.gz) = ddfefdf2593b3f03eec221a7f4ceaa710e5a2e6b
|
||||
RMD160 (brotli-1.0.9.tar.gz) = aef7f7c6f4f1cea3c8dd84563598de17a6118c0e
|
||||
SHA512 (brotli-1.0.9.tar.gz) = b8e2df955e8796ac1f022eb4ebad29532cb7e3aa6a4b6aee91dbd2c7d637eee84d9a144d3e878895bb5e62800875c2c01c8f737a1261020c54feacf9f676b5f5
|
||||
Size (brotli-1.0.9.tar.gz) = 486984 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = ab1b60d2ae23e7976339c127dab7f5296c8a791b
|
||||
SHA1 (patch-scripts_libbrotlicommon.pc.in) = 4544629c9e6ec539dc58624991a4a916c6232aef
|
||||
SHA1 (patch-scripts_libbrotlidec.pc.in) = 54969400b302c736c97f48add611eaa471b7dbe1
|
||||
SHA1 (patch-scripts_libbrotlienc.pc.in) = d697b2fb3859c99f3815ff00072d3949e482522c
|
||||
|
|
13
archivers/brotli/patches/patch-scripts_libbrotlicommon.pc.in
Normal file
13
archivers/brotli/patches/patch-scripts_libbrotlicommon.pc.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-scripts_libbrotlicommon.pc.in,v 1.1 2021/03/21 19:24:24 nros Exp $
|
||||
|
||||
Remove wrong rpath argument on Linux and use PKGCONFIG_OVERIDE instead
|
||||
|
||||
--- scripts/libbrotlicommon.pc.in.orig 2021-03-21 12:51:37.961672495 +0000
|
||||
+++ scripts/libbrotlicommon.pc.in
|
||||
@@ -7,5 +7,5 @@ Name: libbrotlicommon
|
||||
URL: https://github.com/google/brotli
|
||||
Description: Brotli common dictionary library
|
||||
Version: @PACKAGE_VERSION@
|
||||
-Libs: -L${libdir} -R${libdir} -lbrotlicommon
|
||||
+Libs: -L${libdir} -lbrotlicommon
|
||||
Cflags: -I${includedir}
|
14
archivers/brotli/patches/patch-scripts_libbrotlidec.pc.in
Normal file
14
archivers/brotli/patches/patch-scripts_libbrotlidec.pc.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-scripts_libbrotlidec.pc.in,v 1.1 2021/03/21 19:24:24 nros Exp $
|
||||
|
||||
Remove wrong rpath argument on Linux and use PKGCONFIG_OVERIDE instead
|
||||
|
||||
--- scripts/libbrotlidec.pc.in.orig 2021-03-21 12:52:03.713184864 +0000
|
||||
+++ scripts/libbrotlidec.pc.in
|
||||
@@ -7,6 +7,6 @@ Name: libbrotlidec
|
||||
URL: https://github.com/google/brotli
|
||||
Description: Brotli decoder library
|
||||
Version: @PACKAGE_VERSION@
|
||||
-Libs: -L${libdir} -R${libdir} -lbrotlidec
|
||||
+Libs: -L${libdir} -lbrotlidec
|
||||
Requires.private: libbrotlicommon >= 1.0.2
|
||||
Cflags: -I${includedir}
|
14
archivers/brotli/patches/patch-scripts_libbrotlienc.pc.in
Normal file
14
archivers/brotli/patches/patch-scripts_libbrotlienc.pc.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-scripts_libbrotlienc.pc.in,v 1.1 2021/03/21 19:24:24 nros Exp $
|
||||
|
||||
Remove wrong rpath argument on Linux and use PKGCONFIG_OVERIDE instead
|
||||
|
||||
--- scripts/libbrotlienc.pc.in.orig 2021-03-21 12:52:22.084860314 +0000
|
||||
+++ scripts/libbrotlienc.pc.in
|
||||
@@ -7,6 +7,6 @@ Name: libbrotlienc
|
||||
URL: https://github.com/google/brotli
|
||||
Description: Brotli encoder library
|
||||
Version: @PACKAGE_VERSION@
|
||||
-Libs: -L${libdir} -R${libdir} -lbrotlienc
|
||||
+Libs: -L${libdir} -lbrotlienc
|
||||
Requires.private: libbrotlicommon >= 1.0.2
|
||||
Cflags: -I${includedir}
|
Loading…
Reference in a new issue