fuse-encfs: workaround netbsd being wrong about which version of FUSE

changed the arguments of fuse_unmount. Fix build.

I get the impression this update was done by someone on NetBSD, so I speculate
the build succeeded to some people. In that cae, bump PKGREVISION, so the
right arguments will be passed!
This commit is contained in:
maya 2019-04-09 16:32:28 +00:00
parent 517c5be2ec
commit c603d01648
3 changed files with 22 additions and 5 deletions

View file

@ -1,8 +1,11 @@
# $NetBSD: Makefile,v 1.15 2018/03/21 22:38:57 gdt Exp $
# $NetBSD: Makefile,v 1.16 2019/04/09 16:32:28 maya Exp $
#
GITHUB_PROJECT= encfs
GITHUB_TAG= v${PKGVERSION_NOREV}
DISTNAME= encfs-1.9.4
PKGNAME= fuse-${DISTNAME}
PKGREVISION= 1
CATEGORIES= filesystems
MASTER_SITES= ${MASTER_SITE_GITHUB:=vgough/}
@ -11,9 +14,6 @@ HOMEPAGE= http://www.arg0.net/encfs
COMMENT= FUSE Encrypted Filesystem
LICENSE= gnu-gpl-v3
GITHUB_PROJECT= encfs
GITHUB_TAG= v${PKGVERSION_NOREV}
USE_TOOLS+= autoconf cmake pkg-config
USE_CMAKE= yes

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.8 2018/03/21 22:38:57 gdt Exp $
$NetBSD: distinfo,v 1.9 2019/04/09 16:32:28 maya Exp $
SHA1 (encfs-1.9.4.tar.gz) = bf1e2b7688ee715c487d3d181e810d53c5983a0a
RMD160 (encfs-1.9.4.tar.gz) = 847f943f6ae7622d54aa9ef25a64344153c23da0
SHA512 (encfs-1.9.4.tar.gz) = 082e35e6eae4730b5e7827eed729422f9d995ebe9e441c5f9725f39cc2f46f014ac1479c7b0a7ce04e9e7228c1a93ecf5b4228e667fc48e6a7d3b68d2324cd0b
Size (encfs-1.9.4.tar.gz) = 2794574 bytes
SHA1 (patch-encfs_DirNode.cpp) = 960480ee442f534357e3325c5001b6056b2338a6
SHA1 (patch-encfs_FileUtils.cpp) = 6c39557409ac91e6fdd2505a6511b9c47ddc7619
SHA1 (patch-encfs_main.cpp) = f7f1d9aa6d953aee98b534428e111f38b012d70f

View file

@ -0,0 +1,16 @@
$NetBSD: patch-encfs_FileUtils.cpp,v 1.1 2019/04/09 16:32:28 maya Exp $
Unclear FUSE API mismatch. fuse_unmount as of FUSE 3.0 seems to take
a single argument, but NetBSD perfuse thinks it's since FUSE 2.2.
--- encfs/FileUtils.cpp.orig 2018-01-28 21:07:41.000000000 +0000
+++ encfs/FileUtils.cpp
@@ -1690,7 +1690,7 @@ bool unmountFS(EncFS_Context *ctx) {
return false;
}
// Time to unmount!
-#if FUSE_USE_VERSION < 30
+#if (FUSE_USE_VERSION < 30) && !defined(__NetBSD__)
fuse_unmount(ctx->opts->mountPoint.c_str(), nullptr);
#else
fuse_unmount(fuse_get_context()->fuse);