Initial import of isapnptools-1.26 - manually query and configure isapnp

devices.

Provided in PR 17681 by Ben Collver (collver1@attbi.com)

The isapnptools consist of two programs - one allows the dumping of
resource data and generation of a skeleton configuration file, the
other configures ISA PnP hardware using a configuration file.
This commit is contained in:
agc 2002-07-23 12:07:45 +00:00
parent b71252b134
commit c60741ec10
9 changed files with 529 additions and 0 deletions

View file

@ -0,0 +1,3 @@
The isapnp tools consist of two programs - one allows the dumping of
resource data and generation of a skeleton configuration file, the
other configures ISA PnP hardware using a configuration file.

View file

@ -0,0 +1,19 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/07/23 12:07:45 agc Exp $
#
DISTNAME= isapnptools-1.26
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SUNSITE:=system/hardware/} \
ftp://tsx-11.mit.edu/pub/linux/sources/sbin/ \
ftp://ftp.demon.co.uk/pub/unix/linux/utils/
EXTRACT_SUFX= .tgz
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.roestock.demon.co.uk
COMMENT= manually query and configure isapnp devices
USE_GMAKE= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --disable-realtime --disable-pci
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,19 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/07/23 12:07:45 agc Exp $
include/isapnp/callbacks.h
include/isapnp/errcodes.h
include/isapnp/errenum.h
include/isapnp/iopl.h
include/isapnp/mysnprtf.h
include/isapnp/pnp-access.h
include/isapnp/pnp.h
include/isapnp/realtime.h
include/isapnp/release.h
include/isapnp/res-access.h
include/isapnp/resource.h
lib/libisapnp.a
sbin/isapnp
sbin/pnpdump
man/man5/isapnp.conf.5
man/man8/isapnp.8
man/man8/pnpdump.8
@dirrm include/isapnp

View file

@ -0,0 +1,9 @@
$NetBSD: distinfo,v 1.1.1.1 2002/07/23 12:07:45 agc Exp $
SHA1 (isapnptools-1.26.tgz) = 0b12b06ed60abe8d836fa8d4c1e20bd4b033d76c
Size (isapnptools-1.26.tgz) = 231098 bytes
SHA1 (patch-aa) = 150793665a3bb775a02a84a63ad69b244556ac28
SHA1 (patch-ab) = e584c500e6262e37d67184a55e8f05cd5d55db14
SHA1 (patch-ac) = 0696f3b6d091f5ae356973ed0277ca5700d6d22e
SHA1 (patch-ad) = 6f431cfd99581742ded732dc5ec43d1722bc9a2c
SHA1 (patch-ae) = baf6cf651f42f9359bc64ca377f249469b2463d5

View file

@ -0,0 +1,35 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/07/23 12:07:45 agc Exp $
--- src/iopl.c Tue May 8 15:14:21 2001
+++ src/iopl.c Mon Jul 22 07:46:37 2002
@@ -61,10 +61,17 @@
*/
ret = iopl(3);
#else
+#if defined(__NetBSD__) && defined(HAVE_LIBI386)
+ /*
+ * Have to get unrestricted access to io ports, as WRITE_DATA port > 0x3ff
+ */
+ ret = i386_iopl(3);
+#else
#ifdef HAVE_IOPERM
/* ALPHA only has ioperm, apparently, so cover all with one permission */
ret = ioperm(MIN_READ_ADDR, WRITEDATA_ADDR - MIN_READ_ADDR + 1, 1);
#endif /* HAVE_IOPERM */
+#endif /* !(__NetBSD__ && HAVE_LIBI386) */
#endif /* !HAVE_IOPL */
if (ret < 0) {
@@ -85,9 +92,13 @@
#ifdef HAVE_IOPL
ret = iopl(0);
#else
+#if defined(__NetBSD__) && defined(HAVE_LIBI386)
+ ret = i386_iopl(0);
+#else
#ifdef HAVE_IOPERM
ret = ioperm(MIN_READ_ADDR, WRITEDATA_ADDR - MIN_READ_ADDR + 1, 0);
#endif /* HAVE_IOPERM */
+#endif /* !(__NetBSD__ && HAVE_LIBI386) */
#endif /* !HAVE_IOPL */
if (ret < 0) {

View file

@ -0,0 +1,24 @@
$NetBSD: patch-ab,v 1.1.1.1 2002/07/23 12:07:45 agc Exp $
--- include/isapnp/iopl.h Tue May 8 15:14:21 2001
+++ include/isapnp/iopl.h Mon Jul 22 07:40:38 2002
@@ -45,6 +45,12 @@
#endif
/****************************************************************************/
+#if defined(__NetBSD__) && defined(HAVE_LIBI386)
+#include <sys/types.h>
+#include <machine/bus.h>
+#include <machine/sysarch.h>
+#include <machine/pio.h>
+#else
#ifdef __DJGPP__
#if !defined __TURBOC__ && !defined __BORLANDC__
#include <inlines/pc.h>
@@ -65,6 +71,7 @@
#include <sys/hw.h>
#endif /* _OS2_ */
#endif
+#endif /* !(__NetBSD__ && HAVE_LIBI386) */
/****************************************************************************/

View file

@ -0,0 +1,27 @@
$NetBSD: patch-ac,v 1.1.1.1 2002/07/23 12:07:45 agc Exp $
--- include/isapnp/pnp.h Thu Apr 12 11:51:19 2001
+++ include/isapnp/pnp.h Mon Jul 22 07:51:51 2002
@@ -33,13 +33,23 @@
#else /* !_OS2_ && !__DJGPP__ */
#ifdef DEBUG
static int x;
+#if defined(__NetBSD__) && defined(HAVE_LIBI386)
+#define ADDRESS(x) (outb(ADDRESS_ADDR, x), printf("\nAddress: %04x", x))
+#define WRITE_DATA(x) (outb(WRITEDATA_ADDR, x), printf(" WR(%02x)", x & 0xff))
+#else
#define ADDRESS(x) (outb(x, ADDRESS_ADDR), printf("\nAddress: %04x", x))
#define WRITE_DATA(x) (outb(x, WRITEDATA_ADDR), printf(" WR(%02x)", x & 0xff))
+#endif
#define READ_DATA (x = inb(read_port), printf(" RD(%02x)", x & 0xff), x)
#define READ_IOPORT(p) (x = inb(p), printf(" [%04x](%02x)", p, x & 0xff), x)
#else /* !DEBUG */
+#if defined(__NetBSD__) && defined(HAVE_LIBI386)
+#define ADDRESS(x) outb(ADDRESS_ADDR, x)
+#define WRITE_DATA(x) outb(WRITEDATA_ADDR, x)
+#else
#define ADDRESS(x) outb(x, ADDRESS_ADDR)
#define WRITE_DATA(x) outb(x, WRITEDATA_ADDR)
+#endif
#define READ_DATA inb(read_port)
#define READ_IOPORT(p) inb(p)
#endif /* !DEBUG */

View file

@ -0,0 +1,380 @@
$NetBSD: patch-ad,v 1.1.1.1 2002/07/23 12:07:45 agc Exp $
--- configure Tue May 8 15:52:59 2001
+++ configure Mon Jul 22 07:48:37 2002
@@ -1555,14 +1555,61 @@
fi
+echo $ac_n "checking for i386_iopl in -li386""... $ac_c" 1>&6
+echo "configure:1560: checking for i386_iopl in -li386" >&5
+ac_lib_var=`echo i386'_'i386_iopl | sed 'y%./+-%__p_%'`
+if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+else
+ ac_save_LIBS="$LIBS"
+LIBS="-li386 $LIBS"
+cat > conftest.$ac_ext <<EOF
+#line 1568 "configure"
+#include "confdefs.h"
+/* Override any gcc2 internal prototype to avoid an error. */
+/* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+char i386_iopl();
+
+int main() {
+i386_iopl()
+; return 0; }
+EOF
+if { (eval echo configure:1579: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=yes"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ eval "ac_cv_lib_$ac_lib_var=no"
+fi
+rm -f conftest*
+LIBS="$ac_save_LIBS"
+
+fi
+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+ ac_tr_lib=HAVE_LIB`echo i386 | sed -e 's/[^a-zA-Z0-9_]/_/g' \
+ -e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
+ cat >> confdefs.h <<EOF
+#define $ac_tr_lib 1
+EOF
+
+ LIBS="-li386 $LIBS"
+
+else
+ echo "$ac_t""no" 1>&6
+fi
+
echo $ac_n "checking for ANSI C header files""... $ac_c" 1>&6
-echo "configure:1561: checking for ANSI C header files" >&5
+echo "configure:1608: checking for ANSI C header files" >&5
if eval "test \"`echo '$''{'ac_cv_header_stdc'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1566 "configure"
+#line 1613 "configure"
#include "confdefs.h"
#include <stdlib.h>
#include <stdarg.h>
@@ -1570,7 +1617,7 @@
#include <float.h>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1574: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1621: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
@@ -1587,7 +1634,7 @@
if test $ac_cv_header_stdc = yes; then
# SunOS 4.x string.h does not declare mem*, contrary to ANSI.
cat > conftest.$ac_ext <<EOF
-#line 1591 "configure"
+#line 1638 "configure"
#include "confdefs.h"
#include <string.h>
EOF
@@ -1605,7 +1652,7 @@
if test $ac_cv_header_stdc = yes; then
# ISC 2.0.2 stdlib.h does not declare free, contrary to ANSI.
cat > conftest.$ac_ext <<EOF
-#line 1609 "configure"
+#line 1656 "configure"
#include "confdefs.h"
#include <stdlib.h>
EOF
@@ -1626,7 +1673,7 @@
:
else
cat > conftest.$ac_ext <<EOF
-#line 1630 "configure"
+#line 1677 "configure"
#include "confdefs.h"
#include <ctype.h>
#define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
@@ -1637,7 +1684,7 @@
exit (0); }
EOF
-if { (eval echo configure:1641: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
+if { (eval echo configure:1688: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
then
:
else
@@ -1664,17 +1711,17 @@
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-echo "configure:1668: checking for $ac_hdr" >&5
+echo "configure:1715: checking for $ac_hdr" >&5
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1673 "configure"
+#line 1720 "configure"
#include "confdefs.h"
#include <$ac_hdr>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1678: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1725: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
@@ -1702,12 +1749,12 @@
echo $ac_n "checking for working const""... $ac_c" 1>&6
-echo "configure:1706: checking for working const" >&5
+echo "configure:1753: checking for working const" >&5
if eval "test \"`echo '$''{'ac_cv_c_const'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1711 "configure"
+#line 1758 "configure"
#include "confdefs.h"
int main() {
@@ -1756,7 +1803,7 @@
; return 0; }
EOF
-if { (eval echo configure:1760: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1807: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_c_const=yes
else
@@ -1777,21 +1824,21 @@
fi
echo $ac_n "checking for inline""... $ac_c" 1>&6
-echo "configure:1781: checking for inline" >&5
+echo "configure:1828: checking for inline" >&5
if eval "test \"`echo '$''{'ac_cv_c_inline'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_cv_c_inline=no
for ac_kw in inline __inline__ __inline; do
cat > conftest.$ac_ext <<EOF
-#line 1788 "configure"
+#line 1835 "configure"
#include "confdefs.h"
int main() {
} $ac_kw foo() {
; return 0; }
EOF
-if { (eval echo configure:1795: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1842: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_c_inline=$ac_kw; break
else
@@ -1817,12 +1864,12 @@
esac
echo $ac_n "checking for pid_t""... $ac_c" 1>&6
-echo "configure:1821: checking for pid_t" >&5
+echo "configure:1868: checking for pid_t" >&5
if eval "test \"`echo '$''{'ac_cv_type_pid_t'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1826 "configure"
+#line 1873 "configure"
#include "confdefs.h"
#include <sys/types.h>
#if STDC_HEADERS
@@ -1850,12 +1897,12 @@
fi
echo $ac_n "checking for size_t""... $ac_c" 1>&6
-echo "configure:1854: checking for size_t" >&5
+echo "configure:1901: checking for size_t" >&5
if eval "test \"`echo '$''{'ac_cv_type_size_t'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1859 "configure"
+#line 1906 "configure"
#include "confdefs.h"
#include <sys/types.h>
#if STDC_HEADERS
@@ -1884,12 +1931,12 @@
echo $ac_n "checking return type of signal handlers""... $ac_c" 1>&6
-echo "configure:1888: checking return type of signal handlers" >&5
+echo "configure:1935: checking return type of signal handlers" >&5
if eval "test \"`echo '$''{'ac_cv_type_signal'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1893 "configure"
+#line 1940 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <signal.h>
@@ -1906,7 +1953,7 @@
int i;
; return 0; }
EOF
-if { (eval echo configure:1910: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1957: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_type_signal=void
else
@@ -1925,12 +1972,12 @@
echo $ac_n "checking for vprintf""... $ac_c" 1>&6
-echo "configure:1929: checking for vprintf" >&5
+echo "configure:1976: checking for vprintf" >&5
if eval "test \"`echo '$''{'ac_cv_func_vprintf'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1934 "configure"
+#line 1981 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char vprintf(); below. */
@@ -1953,7 +2000,7 @@
; return 0; }
EOF
-if { (eval echo configure:1957: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2004: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_vprintf=yes"
else
@@ -1977,12 +2024,12 @@
if test "$ac_cv_func_vprintf" != yes; then
echo $ac_n "checking for _doprnt""... $ac_c" 1>&6
-echo "configure:1981: checking for _doprnt" >&5
+echo "configure:2028: checking for _doprnt" >&5
if eval "test \"`echo '$''{'ac_cv_func__doprnt'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1986 "configure"
+#line 2033 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char _doprnt(); below. */
@@ -2005,7 +2052,7 @@
; return 0; }
EOF
-if { (eval echo configure:2009: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2056: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func__doprnt=yes"
else
@@ -2033,12 +2080,12 @@
for ac_func in strncmp
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:2037: checking for $ac_func" >&5
+echo "configure:2084: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2042 "configure"
+#line 2089 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -2061,7 +2108,7 @@
; return 0; }
EOF
-if { (eval echo configure:2065: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2112: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else
@@ -2088,12 +2135,12 @@
for ac_func in strdup strerror strtol strtoul nanosleep sched_setscheduler snprintf strncasecmp getdelim memcmp
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:2092: checking for $ac_func" >&5
+echo "configure:2139: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2097 "configure"
+#line 2144 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -2116,7 +2163,7 @@
; return 0; }
EOF
-if { (eval echo configure:2120: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2167: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else
@@ -2143,12 +2190,12 @@
for ac_func in iopl ioperm usleep delay _sleep2
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:2147: checking for $ac_func" >&5
+echo "configure:2194: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2152 "configure"
+#line 2199 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -2171,7 +2218,7 @@
; return 0; }
EOF
-if { (eval echo configure:2175: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2222: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else
@@ -2199,12 +2246,12 @@
for ac_func in getopt_long
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:2203: checking for $ac_func" >&5
+echo "configure:2250: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2208 "configure"
+#line 2255 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -2227,7 +2274,7 @@
; return 0; }
EOF
-if { (eval echo configure:2231: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2278: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1.1.1 2002/07/23 12:07:45 agc Exp $
--- include/config.h.in Fri Apr 27 13:51:05 2001
+++ include/config.h.in Mon Jul 22 07:48:39 2002
@@ -142,6 +142,9 @@
/* Define if you have the <unistd.h> header file. */
#undef HAVE_UNISTD_H
+/* Define if you have the i386 library (-li386). */
+#undef HAVE_LIBI386
+
/* Name of package */
#undef PACKAGE