make sure to include stdlib where alloca() is used, to fix build under freebsd,
to pick the builtin alloca
This commit is contained in:
parent
93bf89b092
commit
c60903adf7
4 changed files with 30 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.63 2006/10/22 06:42:43 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.64 2007/02/18 11:17:03 tonio Exp $
|
||||
|
||||
DISTNAME= rpm-2.5.4
|
||||
PKGREVISION= 5
|
||||
PKGREVISION= 6
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x/
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.8 2005/02/24 11:02:58 agc Exp $
|
||||
$NetBSD: distinfo,v 1.9 2007/02/18 11:17:03 tonio Exp $
|
||||
|
||||
SHA1 (rpm-2.5.4.tar.gz) = a7fcd67883aec8d5f17483d5efebe7e5f5453462
|
||||
RMD160 (rpm-2.5.4.tar.gz) = 6c9a46d370fe97c7fcf7f814db049ea2bba300da
|
||||
|
@ -14,3 +14,6 @@ SHA1 (patch-ca) = 7f4b008eee3b9f1bd3abc49686f70a327376af55
|
|||
SHA1 (patch-cb) = 30f98037c6a5ba753bc19b20564e177ad1e8c1a9
|
||||
SHA1 (patch-cc) = d5955ec8b51950aadf930a62743601c2d4a0a127
|
||||
SHA1 (patch-cd) = 30e28a8f9453d4a4553ed08eeb43ba049fb35567
|
||||
SHA1 (patch-ce) = 9cbf130f8f10b5c8368028cfab295d9c61db2e7c
|
||||
SHA1 (patch-cf) = 636b77cd05f9eb5083d11aa362a5b75d424014ad
|
||||
SHA1 (patch-cg) = bc094d702cb13b5c89d696770bbcaffaca3b853c
|
||||
|
|
12
misc/rpm/patches/patch-cf
Normal file
12
misc/rpm/patches/patch-cf
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-cf,v 1.1 2007/02/18 11:17:03 tonio Exp $
|
||||
|
||||
--- lib/rebuilddb.c.orig Sun Sep 27 22:17:08 1998
|
||||
+++ lib/rebuilddb.c
|
||||
@@ -3,6 +3,7 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/stat.h> /* for mkdir(2) !?! */
|
||||
#include <unistd.h>
|
12
misc/rpm/patches/patch-cg
Normal file
12
misc/rpm/patches/patch-cg
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-cg,v 1.1 2007/02/18 11:17:03 tonio Exp $
|
||||
|
||||
--- build.c.orig Thu Sep 24 22:23:16 1998
|
||||
+++ build.c
|
||||
@@ -8,6 +8,7 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/stat.h>
|
||||
#include <unistd.h>
|
Loading…
Reference in a new issue