Update to 1.0.1:

ogg123

    * Support for playing FLAC and Speex files. Both the native FLAC and
      Ogg FLAC varieties are supported. Special thanks to OldMan, adiabatic,
      and smack from #vorbis for sponsoring the development of this feature.
    * Send correct User Agent and Accept strings in the HTTP 1.1 headers
    * Fixed bug preventing the status line from showing the total time
      information in certain circumstances
    * Fixed a pthread crash bug on certain platforms (like NetBSD)
    * Added support for the --end option to specify at what time
      playback should stop. Both --skip and --end also now accept times in
      hh:mm:ss format. Thanks to Hans Schou.
    * If the --skip option is greater than the length of the file,
      ogg123 now terminates with an error.

oggdec

    * Fixed small memory leak.
    * Fixed error that caused oggdec to crash when output file was not
      specified.

oggenc

    * Patch from Jordan Mendelson to support reading little-endian AIFF
      files (which happen to be made by MacOS X when ripping CDs?).
    * --scale option to allow scaling the volume of the input. Helps
      with clipping inputs.
    * Fixed usage messages.
    * 24 bit input support
    * FLAC and Ogg FLAC read support. Comments from the FLAC file are
      preserved unless explicitly dropped with the --discard-comments option.
      Also funded by OldMan, adiabatic, and smack.
    * Less frequent status updates.

ogginfo

    * Minor typo and portability fixes.
    * Emits fewer spurious errors when minor errors are detected.
    * Return a useful status code.
    * Fixed overflow bug on really long files.

vcut

    * Patch from Jared Anderson allows the cutpoint to be specified in
      (integer) seconds by prefixing it with a +.

vorbiscomment

    * More forgiving of Ogg files that begin with garbage (like ID3v2
      tags).
This commit is contained in:
wiz 2003-12-08 14:43:48 +00:00
parent 2a3d44f723
commit c632d292ab
6 changed files with 35 additions and 37 deletions

View file

@ -1,10 +1,8 @@
# $NetBSD: Makefile,v 1.26 2003/09/05 19:16:36 explorer Exp $
# $NetBSD: Makefile,v 1.27 2003/12/08 14:43:48 wiz Exp $
DISTNAME= vorbis-tools-1.0
PKGNAME= vorbis-tools-1.0.0.8
PKGREVISION= 6
DISTNAME= vorbis-tools-1.0.1
CATEGORIES= audio
MASTER_SITES= http://www.vorbis.com/files/1.0/unix/
MASTER_SITES= http://www.vorbis.com/files/1.0.1/unix/
MAINTAINER= lukem@NetBSD.org
HOMEPAGE= http://www.vorbis.com/
@ -28,9 +26,11 @@ PLIST_SUBST+= DISTNAME="${DISTNAME}"
PTHREAD_OPTS+= require
.include "../../audio/flac/buildlink2.mk"
.include "../../audio/libao/buildlink2.mk"
.include "../../audio/libogg/buildlink2.mk"
.include "../../audio/libvorbis/buildlink2.mk"
.include "../../audio/speex/buildlink2.mk"
.include "../../converters/libiconv/buildlink2.mk"
.include "../../www/curl/buildlink2.mk"
.include "../../mk/pthread.buildlink2.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2002/09/22 17:17:38 mycroft Exp $
@comment $NetBSD: PLIST,v 1.5 2003/12/08 14:43:48 wiz Exp $
bin/ogg123
bin/oggdec
bin/oggenc
@ -12,7 +12,15 @@ man/man1/ogginfo.1
man/man1/vcut.1
man/man1/vorbiscomment.1
share/doc/${DISTNAME}/ogg123rc-example
${PKGLOCALEDIR}/locale/be/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/cs/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/da/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/hr/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/hu/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/ro/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/vorbis-tools.mo
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/vorbis-tools.mo
@dirrm share/doc/${DISTNAME}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.12 2003/10/28 12:32:42 reed Exp $
$NetBSD: distinfo,v 1.13 2003/12/08 14:43:48 wiz Exp $
SHA1 (vorbis-tools-1.0.tar.gz) = 5c2508786cf6a2a270c697d3debe66ee83df376d
Size (vorbis-tools-1.0.tar.gz) = 425404 bytes
SHA1 (patch-aa) = b209cd1eb5931886a6d806f0edd17e7a7c5469d9
SHA1 (patch-ab) = 7005d73f3fffb1762fdc52177a8411a1db1b74fe
SHA1 (patch-ac) = 0a0e19efd7135fedd6f67a1d772e27b06fbfd694
SHA1 (vorbis-tools-1.0.1.tar.gz) = 5555a55acd643fcca7020b7de4900aeb706725e5
Size (vorbis-tools-1.0.1.tar.gz) = 717697 bytes
SHA1 (patch-aa) = 2adc912765d58b19c1285c12ac0935b860b7da34
SHA1 (patch-ab) = 6c154334ea5a7a7e76982f0588de30548c802fca
SHA1 (patch-ac) = 7eb178a2d7a5dbecd83a5df0138c9ab41943251a

View file

@ -1,17 +1,8 @@
$NetBSD: patch-aa,v 1.8 2003/10/28 12:32:42 reed Exp $
$NetBSD: patch-aa,v 1.9 2003/12/08 14:43:48 wiz Exp $
--- ogg123/buffer.c.orig 2002-07-13 22:38:00.000000000 -0700
+++ ogg123/buffer.c 2003-10-28 02:32:10.000000000 -0800
@@ -37,7 +37,7 @@
/* Special debugging code. THIS IS NOT PORTABLE! */
#ifdef DEBUG_BUFFER
FILE *debugfile;
-#define DEBUG(x, y...) { fprintf (debugfile, "%d: " x "\n", getpid(), ## y); }
+#define DEBUG(...) { fprintf (debugfile, "%d: ", getpid());fprintf(debugfile, __VA_ARGS__);fprintf(debugfile,"\n"); }
#else
#define DEBUG(x, y...)
#endif
@@ -434,7 +434,9 @@ void buffer_destroy (buf_t *buf)
--- ogg123/buffer.c.orig Mon Sep 1 22:15:19 2003
+++ ogg123/buffer.c
@@ -412,7 +412,9 @@ void buffer_reset (buf_t *buf)
/* Cleanup pthread variables */
pthread_mutex_destroy(&buf->mutex);
@ -20,4 +11,4 @@ $NetBSD: patch-aa,v 1.8 2003/10/28 12:32:42 reed Exp $
+ COND_SIGNAL(buf->playback_cond);
pthread_cond_destroy(&buf->playback_cond);
free(buf);
/* Reinit pthread variables */

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.5 2003/07/12 22:35:30 wiz Exp $
$NetBSD: patch-ab,v 1.6 2003/12/08 14:43:48 wiz Exp $
--- ogg123/ogg123.c.orig 2002-07-06 21:12:18.000000000 +0200
--- ogg123/ogg123.c.orig Tue Sep 2 21:37:05 2003
+++ ogg123/ogg123.c
@@ -580,7 +580,13 @@ void play (char *source_string)
@@ -606,7 +606,13 @@ void play (char *source_string)
format->cleanup(decoder);
transport->close(source);

View file

@ -1,9 +1,8 @@
$NetBSD: patch-ac,v 1.5 2003/09/05 19:16:23 explorer Exp $
$NetBSD: patch-ac,v 1.6 2003/12/08 14:43:48 wiz Exp $
diff -ur oggenc/oggenc.c.orig oggenc/oggenc.c
--- oggenc/oggenc.c.orig 2002-07-11 19:55:11.000000000 -0700
+++ oggenc/oggenc.c 2003-09-05 12:09:59.000000000 -0700
@@ -613,6 +613,8 @@
--- oggenc/oggenc.c.orig Tue Sep 16 00:04:00 2003
+++ oggenc/oggenc.c
@@ -640,6 +640,8 @@ static void parse_options(int argc, char
break;
case 'a':
@ -12,7 +11,7 @@ diff -ur oggenc/oggenc.c.orig oggenc/oggenc.c
opt->artist = realloc(opt->artist, (++opt->artist_count)*sizeof(char *));
opt->artist[opt->artist_count - 1] = strdup(optarg);
break;
@@ -625,10 +627,14 @@
@@ -652,10 +654,14 @@ static void parse_options(int argc, char
opt->comments[opt->comment_count - 1] = strdup(optarg);
break;
case 'd':
@ -27,7 +26,7 @@ diff -ur oggenc/oggenc.c.orig oggenc/oggenc.c
opt->genre = realloc(opt->genre, (++opt->genre_count)*sizeof(char *));
opt->genre[opt->genre_count - 1] = strdup(optarg);
break;
@@ -637,6 +643,8 @@
@@ -664,6 +670,8 @@ static void parse_options(int argc, char
exit(0);
break;
case 'l':
@ -36,7 +35,7 @@ diff -ur oggenc/oggenc.c.orig oggenc/oggenc.c
opt->album = realloc(opt->album, (++opt->album_count)*sizeof(char *));
opt->album[opt->album_count - 1] = strdup(optarg);
break;
@@ -647,6 +655,8 @@
@@ -674,6 +682,8 @@ static void parse_options(int argc, char
opt->serial = 0; /* Failed, so just set to zero */
break;
case 't':