Update mail-notification to 5.4
pkgsrc changes: patch to use gmime24 Changes since 5.3: * The regression which caused some read IMAP messages to be reported as unread has been fixed. * And more, see the NEWS file. Changes since 5.2: * A crash affecting IMAP, Maildir and POP3 mailboxes has been fixed. * A crash affecting Evolution mailboxes on 64-bit systems has been fixed. * And more, see the NEWS file. Changes since 5.1: * Default configuration values were not registered. Changes since 5.0: * A number of minor issues have been fixed. Most notably, the message count is now drawn properly. * And more, see the NEWS file.
This commit is contained in:
parent
4f427bd580
commit
c6557673cb
10 changed files with 117 additions and 141 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.48 2009/08/26 19:57:57 sno Exp $
|
||||
# $NetBSD: Makefile,v 1.49 2009/11/10 20:33:38 markd Exp $
|
||||
#
|
||||
|
||||
DISTNAME= mail-notification-5.0
|
||||
PKGREVISION= 3
|
||||
DISTNAME= mail-notification-5.4
|
||||
CATEGORIES= mail gnome
|
||||
MASTER_SITES= http://savannah.nongnu.org/download/mailnotify/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -13,14 +12,19 @@ COMMENT= Status icon that provides new mail notifications
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
HAS_CONFIGURE= YES
|
||||
CONFIGURE_SCRIPT= ./jb configure
|
||||
USE_TOOLS+= gmake intltool msgfmt pkg-config
|
||||
USE_PKGLOCALEDIR= YES
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR:Q}
|
||||
CONFIGURE_ARGS= prefix="${PREFIX}" destdir="${DESTDIR}" sysconfdir=${PKG_SYSCONFDIR:Q}
|
||||
CONFIGURE_ARGS+= cc="${CC}" cflags="${CFLAGS}" cppflags="${CPPFLAGS}" ldflags="${LDFLAGS}"
|
||||
CONFIGURE_ENV+= jb_cppflags="${CPPFLAGS}" jb_ldflags="${LDFLAGS}"
|
||||
|
||||
GCONF_SCHEMAS= mail-notification.schemas
|
||||
|
||||
CONFIGURE_ARGS+= evolution=no
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.mail-notification
|
||||
PKG_SUPPORTED_OPTIONS= inet6 sasl ssl
|
||||
PKG_SUGGESTED_OPTIONS= ssl
|
||||
|
@ -29,37 +33,40 @@ PKG_SUGGESTED_OPTIONS= ssl
|
|||
|
||||
# Whether to add IPv6 support.
|
||||
.if empty(PKG_OPTIONS:Minet6)
|
||||
CONFIGURE_ARGS+= --disable-ipv6
|
||||
CONFIGURE_ARGS+= ipv6=no
|
||||
.endif
|
||||
|
||||
# Whether to add SASL2 support.
|
||||
.if !empty(PKG_OPTIONS:Msasl)
|
||||
. include "../../security/cyrus-sasl/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-sasl
|
||||
CONFIGURE_ARGS+= sasl=no
|
||||
.endif
|
||||
|
||||
# Whether to add SSL support.
|
||||
.if !empty(PKG_OPTIONS:Mssl)
|
||||
. include "../../security/openssl/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-ssl
|
||||
CONFIGURE_ARGS+= ssl=no
|
||||
.endif
|
||||
|
||||
.include "../../devel/eel/buildlink3.mk"
|
||||
do-build:
|
||||
cd ${WRKSRC} && ./jb build
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC} && ./jb install
|
||||
|
||||
.include "../../devel/GConf/schemas.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/libbonobo/buildlink3.mk"
|
||||
.include "../../devel/libglade/buildlink3.mk"
|
||||
.include "../../devel/libgnome/buildlink3.mk"
|
||||
.include "../../devel/libgnomeui/buildlink3.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../mail/gmime/buildlink3.mk"
|
||||
.include "../../net/ORBit2/buildlink3.mk"
|
||||
.include "../../mail/gmime24/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../sysutils/gnome-vfs/buildlink3.mk"
|
||||
.include "../../sysutils/libnotify/buildlink3.mk"
|
||||
.include "../../mk/omf-scrollkeeper.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.9 2009/06/14 18:04:36 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.10 2009/11/10 20:33:38 markd Exp $
|
||||
bin/mail-notification
|
||||
lib/bonobo/servers/GNOME_MailNotification.server
|
||||
share/applications/mail-notification-properties.desktop
|
||||
share/applications/mail-notification.desktop
|
||||
share/gconf/schemas/mail-notification.schemas
|
||||
|
@ -29,7 +28,6 @@ share/locale/ru/LC_MESSAGES/mail-notification.mo
|
|||
share/locale/sr/LC_MESSAGES/mail-notification.mo
|
||||
share/locale/sr@Latn/LC_MESSAGES/mail-notification.mo
|
||||
share/locale/sv/LC_MESSAGES/mail-notification.mo
|
||||
share/omf/mail-notification/mail-notification-C.omf
|
||||
share/mail-notification/gmail.png
|
||||
share/mail-notification/hotmail.png
|
||||
share/mail-notification/logo.png
|
||||
|
@ -37,3 +35,4 @@ share/mail-notification/mailbox-properties-dialog.glade
|
|||
share/mail-notification/new-mail.wav
|
||||
share/mail-notification/properties-dialog.glade
|
||||
share/mail-notification/yahoo.png
|
||||
share/omf/mail-notification/mail-notification-C.omf
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.12 2008/05/21 16:13:46 gdt Exp $
|
||||
$NetBSD: distinfo,v 1.13 2009/11/10 20:33:38 markd Exp $
|
||||
|
||||
SHA1 (mail-notification-5.0.tar.bz2) = d43c070957c60d0ffd975475ae1c27c29dd83764
|
||||
RMD160 (mail-notification-5.0.tar.bz2) = a24c6a02844ef01c8a8be026a78e4c061c2275f5
|
||||
Size (mail-notification-5.0.tar.bz2) = 774039 bytes
|
||||
SHA1 (patch-aa) = 648bea57e01de4dc36d6c4715aa47de9fb53d3cd
|
||||
SHA1 (patch-ab) = 9b5d4620c77e75f0d5916f298323c730781ef374
|
||||
SHA1 (patch-af) = 0d3f3931e574ff97b48bc3cc725b4bc00cb9ded4
|
||||
SHA1 (mail-notification-5.4.tar.bz2) = c148449c5d2fd0a75571e4e42932da1f1ae013f6
|
||||
RMD160 (mail-notification-5.4.tar.bz2) = 64946509ef99fdeba8ff547ffac3830c36131484
|
||||
Size (mail-notification-5.4.tar.bz2) = 570008 bytes
|
||||
SHA1 (patch-ag) = c337f8df3898c4fb1055525b6756b0586c396883
|
||||
SHA1 (patch-ah) = 572787f23bfca47ff10f6ef1dd796a1dce0d20ff
|
||||
SHA1 (patch-ai) = 0178794de2141bed09f51bd5c80405b785d688b0
|
||||
SHA1 (patch-aj) = 694c3f99157189c357eaef32913c3d9c7d61162a
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.6 2008/02/21 00:16:53 gdt Exp $
|
||||
|
||||
Add patch from upstream that is needed if SSL is not compiled with
|
||||
thread support. If it is, this is merely extra.
|
||||
|
||||
--- src/mn-client-session.c.orig Wed Jan 17 15:07:49 2007
|
||||
+++ src/mn-client-session.c Fri Apr 20 19:05:51 2007
|
||||
@@ -369,6 +369,8 @@
|
||||
{
|
||||
SSL_CTX *ctx;
|
||||
GError *err = NULL;
|
||||
+ static GStaticMutex ssl_lock = G_STATIC_MUTEX_INIT;
|
||||
+ int status;
|
||||
|
||||
g_return_val_if_fail(session != NULL, FALSE);
|
||||
g_return_val_if_fail(session->ssl == NULL, FALSE);
|
||||
@@ -394,7 +396,11 @@
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
- if (SSL_connect(session->ssl) != 1)
|
||||
+ g_static_mutex_lock(&ssl_lock);
|
||||
+ status = SSL_connect(session->ssl);
|
||||
+ g_static_mutex_unlock(&ssl_lock);
|
||||
+
|
||||
+ if (status != 1)
|
||||
{
|
||||
mn_client_session_set_error(session, MN_CLIENT_SESSION_ERROR_OTHER, _("unable to perform the SSL/TLS handshake: %s"), mn_ssl_get_error());
|
||||
return FALSE;
|
|
@ -1,73 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2008/05/21 16:13:46 gdt Exp $
|
||||
|
||||
This patch is from upstream, at
|
||||
http://launchpadlibrarian.net/11684452/mail-notification-5.0-eelfix.diff
|
||||
referenced from
|
||||
https://bugs.launchpad.net/mail-notification/+bug/180400
|
||||
|
||||
--- src/mn-maildir-mailbox-backend.c.orig 2008-01-04 17:03:57.000000000 +0100
|
||||
+++ src/mn-maildir-mailbox-backend.c 2008-01-31 20:47:10.000000000 +0100
|
||||
@@ -161,7 +161,7 @@
|
||||
{
|
||||
char *filename;
|
||||
|
||||
- filename = eel_uri_get_basename(info_uri);
|
||||
+ filename = mn_vfs_uri_get_basename(info_uri);
|
||||
if (filename)
|
||||
{
|
||||
if (filename[0] != '.')
|
||||
--- src/mn-mh-mailbox-backend.c.orig 2008-01-04 17:03:57.000000000 +0100
|
||||
+++ src/mn-mh-mailbox-backend.c 2008-01-31 20:46:49.000000000 +0100
|
||||
@@ -191,7 +191,7 @@
|
||||
{
|
||||
char *filename;
|
||||
|
||||
- filename = eel_uri_get_basename(info_uri);
|
||||
+ filename = mn_vfs_uri_get_basename(info_uri);
|
||||
if (filename)
|
||||
{
|
||||
if (! strcmp(filename, SEQUENCES_FILE) || mn_str_isnumeric(filename))
|
||||
--- src/mn-sylpheed-mailbox-backend.c.orig 2008-01-04 17:03:58.000000000 +0100
|
||||
+++ src/mn-sylpheed-mailbox-backend.c 2008-01-31 20:46:57.000000000 +0100
|
||||
@@ -180,7 +180,7 @@
|
||||
{
|
||||
char *filename;
|
||||
|
||||
- filename = eel_uri_get_basename(info_uri);
|
||||
+ filename = mn_vfs_uri_get_basename(info_uri);
|
||||
if (filename)
|
||||
{
|
||||
/*
|
||||
--- src/mn-vfs.c.orig 2008-01-04 16:40:15.000000000 +0100
|
||||
+++ src/mn-vfs.c 2008-01-31 20:45:31.000000000 +0100
|
||||
@@ -335,3 +335,21 @@
|
||||
g_set_error(err, 0, 0, "%s", gnome_vfs_result_to_string(result));
|
||||
return FALSE;
|
||||
}
|
||||
+
|
||||
+char *
|
||||
+mn_vfs_uri_get_basename (const char *text_uri)
|
||||
+{
|
||||
+ GnomeVFSURI *uri;
|
||||
+ char *name;
|
||||
+
|
||||
+ g_return_val_if_fail(text_uri != NULL, NULL);
|
||||
+
|
||||
+ uri = gnome_vfs_uri_new(text_uri);
|
||||
+ if (! uri)
|
||||
+ return NULL;
|
||||
+
|
||||
+ name = gnome_vfs_uri_extract_short_name(uri);
|
||||
+ gnome_vfs_uri_unref(uri);
|
||||
+
|
||||
+ return name;
|
||||
+}
|
||||
--- src/mn-vfs.h.orig 2008-01-04 16:40:16.000000000 +0100
|
||||
+++ src/mn-vfs.h 2008-01-31 20:45:42.000000000 +0100
|
||||
@@ -54,4 +54,6 @@
|
||||
|
||||
gboolean mn_vfs_result_to_g_error (GnomeVFSResult result, GError **err);
|
||||
|
||||
+char *mn_vfs_uri_get_basename (const char *text_uri);
|
||||
+
|
||||
#endif /* _MN_VFS_H */
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.2 2008/02/21 00:16:53 gdt Exp $
|
||||
|
||||
Place xdg files in pkgsrc standard location.
|
||||
Not to be submitted upstream.
|
||||
|
||||
--- data/Makefile.in.orig 2008-01-04 11:03:27.000000000 -0500
|
||||
+++ data/Makefile.in
|
||||
@@ -250,7 +250,7 @@ top_srcdir = @top_srcdir@
|
||||
gnome_cappletdir = $(datadir)/applications
|
||||
gnome_capplet_in_files = mail-notification-properties.desktop.in
|
||||
gnome_capplet_DATA = mail-notification-properties.desktop
|
||||
-autostartdir = $(sysconfdir)/xdg/autostart
|
||||
+autostartdir = $(prefix)/share/applications
|
||||
autostart_in_files = mail-notification.desktop.in
|
||||
autostart_DATA = mail-notification.desktop
|
||||
serverdir = $(libdir)/bonobo/servers
|
15
mail/mail-notification/patches/patch-ag
Normal file
15
mail/mail-notification/patches/patch-ag
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ag,v 1.1 2009/11/10 20:33:38 markd Exp $
|
||||
|
||||
gmime2.4 fix
|
||||
|
||||
--- build/src/mn-base-mbox-mailbox-backend.c.orig 2008-05-23 03:47:49.000000000 +1200
|
||||
+++ build/src/mn-base-mbox-mailbox-backend.c
|
||||
@@ -301,7 +301,7 @@ mn_base_mbox_mailbox_backend_get_mailbox
|
||||
mime_message = g_mime_parser_construct_message(parser);
|
||||
if (mime_message)
|
||||
{
|
||||
- if (g_mime_message_get_header(mime_message, "X-Mozilla-Status"))
|
||||
+ if (g_mime_object_get_header(mime_message, "X-Mozilla-Status"))
|
||||
{
|
||||
#if WITH_MOZILLA
|
||||
type = MN_TYPE_MOZILLA_MAILBOX_BACKEND;
|
15
mail/mail-notification/patches/patch-ah
Normal file
15
mail/mail-notification/patches/patch-ah
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ah,v 1.1 2009/11/10 20:33:38 markd Exp $
|
||||
|
||||
gmime2.4 fix
|
||||
|
||||
--- build/src/mn-mozilla-mailbox-backend.c.orig 2008-05-23 03:47:49.000000000 +1200
|
||||
+++ build/src/mn-mozilla-mailbox-backend.c
|
||||
@@ -194,7 +194,7 @@ mn_mozilla_mailbox_backend_get_status_fl
|
||||
|
||||
const char *header;
|
||||
|
||||
- header = g_mime_message_get_header(mime_message, header_name);
|
||||
+ header = g_mime_object_get_header(mime_message, header_name);
|
||||
if (header && mn_str_ishex(header))
|
||||
return strtol(header, NULL, 16);
|
||||
else
|
27
mail/mail-notification/patches/patch-ai
Normal file
27
mail/mail-notification/patches/patch-ai
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-ai,v 1.1 2009/11/10 20:33:38 markd Exp $
|
||||
|
||||
gmime2.4 fix
|
||||
|
||||
Place xdg files in pkgsrc standard location.
|
||||
Not to be submitted upstream.
|
||||
|
||||
--- jbsrc/jb.c.orig 2008-05-23 03:47:04.000000000 +1200
|
||||
+++ jbsrc/jb.c
|
||||
@@ -166,7 +166,7 @@ jb_package_configure (void)
|
||||
jb_require_packages("GNOME", "gnome", "glib-2.0 >= 2.14 gthread-2.0 gconf-2.0 >= 2.4.0 gtk+-2.0 >= 2.12 libgnomeui-2.0 >= 2.14.0 gnome-vfs-2.0 libglade-2.0 libxml-2.0 libnotify >= 0.4.1");
|
||||
jb_require_packages("D-Bus", "dbus", "dbus-glib-1");
|
||||
|
||||
- jb_check_packages_for_options("GMime", "gmime", "gmime-2.0 >= 2.2.7",
|
||||
+ jb_check_packages_for_options("GMime", "gmime", "gmime-2.4",
|
||||
"hotmail",
|
||||
"imap",
|
||||
"maildir",
|
||||
@@ -376,7 +376,7 @@ jb_package_add_resources (void)
|
||||
group = jb_group_new("data");
|
||||
|
||||
jb_group_add_desktop_file(group, "mail-notification-properties.desktop.in", "$datadir/applications");
|
||||
- jb_group_add_desktop_file(group, "mail-notification.desktop.in", "$sysconfdir/xdg/autostart");
|
||||
+ jb_group_add_desktop_file(group, "mail-notification.desktop.in", "$datadir/applications");
|
||||
|
||||
jb_group_add_resource(group, JB_GROUP_RESOURCE(jb_template_new("mail-notification.schemas.in.in")));
|
||||
jb_group_add_gconf_schemas(group, "mail-notification.schemas.in");
|
30
mail/mail-notification/patches/patch-aj
Normal file
30
mail/mail-notification/patches/patch-aj
Normal file
|
@ -0,0 +1,30 @@
|
|||
$NetBSD: patch-aj,v 1.1 2009/11/10 20:33:38 markd Exp $
|
||||
|
||||
gmime2.4 fix
|
||||
|
||||
--- src/mn-message-mime.c.orig 2008-05-23 03:45:35.000000000 +1200
|
||||
+++ src/mn-message-mime.c
|
||||
@@ -33,12 +33,12 @@ is_spam (GMimeMessage *mime_message)
|
||||
g_return_val_if_fail(GMIME_IS_MESSAGE(mime_message), FALSE);
|
||||
|
||||
/* SpamAssassin */
|
||||
- spam = g_mime_message_get_header(mime_message, "X-Spam-Status");
|
||||
+ spam = g_mime_object_get_header(mime_message, "X-Spam-Status");
|
||||
if (spam && mn_ascii_str_case_has_prefix(spam, "yes"))
|
||||
return TRUE;
|
||||
|
||||
/* bogofilter */
|
||||
- spam = g_mime_message_get_header(mime_message, "X-Bogosity");
|
||||
+ spam = g_mime_object_get_header(mime_message, "X-Bogosity");
|
||||
if (spam && mn_ascii_str_case_has_prefix(spam, "yes"))
|
||||
return TRUE;
|
||||
|
||||
@@ -89,7 +89,7 @@ mn_message_new_from_mime_message_full (G
|
||||
{
|
||||
const char *status;
|
||||
|
||||
- status = g_mime_message_get_header(mime_message, "Status");
|
||||
+ status = g_mime_object_get_header(mime_message, "Status");
|
||||
if (status && strchr(status, 'R'))
|
||||
return NULL; /* the message was read */
|
||||
else if (status && strchr(status, 'O'))
|
Loading…
Reference in a new issue