New package devel/bmkdep, NetBSD version of mkdep(1)

This commit is contained in:
cheusov 2013-12-08 15:22:23 +00:00
parent ac0c0d7853
commit c67591264d
7 changed files with 94 additions and 1 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1820 2013/12/07 00:59:02 wiz Exp $
# $NetBSD: Makefile,v 1.1821 2013/12/08 15:22:23 cheusov Exp $
#
COMMENT= Development utilities
@ -72,6 +72,7 @@ SUBDIR+= bison
SUBDIR+= blame
SUBDIR+= blib
SUBDIR+= bmake
SUBDIR+= bmkdep
SUBDIR+= boa-constructor
SUBDIR+= boehm-gc
SUBDIR+= boost-build

6
devel/bmkdep/DESCR Normal file
View file

@ -0,0 +1,6 @@
This is NetBSD version of mkdep.
Because it is a C program and does all postprocessing and file handling
without calling any external programs, it is up to 10-percent faster than
the original BSD mkdep shell script. Also it contains options not available
in the original BSD mkdep.

19
devel/bmkdep/Makefile Normal file
View file

@ -0,0 +1,19 @@
# $NetBSD: Makefile,v 1.1 2013/12/08 15:22:23 cheusov Exp $
DISTNAME= bmkdep-20131009
CATEGORIES= devel
MASTER_SITES= http://bmkdep.googlecode.com/files/
MAINTAINER= cheusov@NetBSD.org
HOMEPAGE= https://code.google.com/p/bmkdep/
COMMENT= NetBSD version of mkdep(1)
LICENSE= 2-clause-bsd
MAKE_ENV= BINOWN=${BINOWN} BINGRP=${BINGRP} \
MANOWN=${MANOWN} MANGRP=${MANGRP} \
MKHTML=no MKCATPAGES=no
MAKE_FLAGS= MANDIR=${PREFIX}/${PKGMANDIR}
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
.include "../../mk/bsd.pkg.mk"

3
devel/bmkdep/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2013/12/08 15:22:23 cheusov Exp $
bin/bmkdep
man/man1/bmkdep.1

7
devel/bmkdep/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2013/12/08 15:22:23 cheusov Exp $
SHA1 (bmkdep-20131009.tar.gz) = ee39788129f1f755718aeb63ede9214c17fe8e33
RMD160 (bmkdep-20131009.tar.gz) = 4fb5ce80f88ee6b342830805a5ce15bd82e38160
Size (bmkdep-20131009.tar.gz) = 7389 bytes
SHA1 (patch-findcc.c) = 72f7b14313ccd37ff34ccc42dcad3fd539f13297
SHA1 (patch-mkdep.c) = c2a57cd6b8e3224bab542666452fb844fcb2e811

View file

@ -0,0 +1,15 @@
--- findcc.c.orig 2013-10-09 17:38:38.000000000 +0300
+++ findcc.c 2013-12-08 17:33:49.000000000 +0300
@@ -34,12 +34,6 @@
#endif
#include <sys/cdefs.h>
-#if !defined(lint)
-__COPYRIGHT("@(#) Copyright (c) 1999 The NetBSD Foundation, Inc.\
- All rights reserved.");
-__RCSID("$NetBSD: patch-findcc.c,v 1.1 2013/12/08 15:22:23 cheusov Exp $");
-#endif /* not lint */
-
#include <sys/param.h>
#include <stdio.h>
#include <stdlib.h>

View file

@ -0,0 +1,42 @@
$NetBSD: patch-mkdep.c,v 1.1 2013/12/08 15:22:23 cheusov Exp $
For better portability
--- mkdep.c.orig 2013-10-09 17:38:38.000000000 +0300
+++ mkdep.c 2013-12-08 17:31:52.000000000 +0300
@@ -34,12 +34,6 @@
#endif
#include <sys/cdefs.h>
-#if !defined(lint)
-__COPYRIGHT("@(#) Copyright (c) 1999 The NetBSD Foundation, Inc.\
- All rights reserved.");
-__RCSID("$NetBSD: patch-mkdep.c,v 1.1 2013/12/08 15:22:23 cheusov Exp $");
-#endif /* not lint */
-
#include <sys/mman.h>
#include <sys/param.h>
#include <sys/wait.h>
@@ -89,13 +83,13 @@
return (const char *)p - (const char *)0 + (char *)0;
}
-__dead2 static void
+static void
usage(void)
{
(void)fprintf(stderr,
"usage: %s [-aDdiopqv] [-f file] [-P prefix] [-s suffixes] "
"-- [flags] file ...\n",
- getprogname());
+ "bmkdep");
exit(EXIT_FAILURE);
}
@@ -234,7 +228,6 @@
sl = NULL; /* XXXGCC -Wuninitialized [sun2] */
setlocale(LC_ALL, "");
- setprogname(argv[0]);
aflag = O_WRONLY | O_APPEND | O_CREAT | O_TRUNC;
dflag = 0;