Update mlterm to 3.7.1.
Changes noted in doc/en/ReleaseNote: ver 3.7.1 * Add "vt_color_mode" to OSC 5380 and 5381. * Support SKK (--im skk) as an input method plugin. * Support input method plugins (canna, wnn and skk) on MacOSX/Cocoa. * Show the number of each conversion candidate on an input method window of wnn. * Bug fixes: Fix compiling error of registobmp. (Enbugged at 3.7.0) (Thanks to Amadeusz) Fix https://sourceforge.net/p/mlterm/mailman/message/34992704/ Fix https://github.com/saitoha/homebrew-sixel/pull/2 (Thanks to @kefir_) Fix a bug which dropped almost all glyph complementary fonts.
This commit is contained in:
parent
3b4b74f992
commit
c693930277
5 changed files with 38 additions and 15 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.126 2016/03/14 16:03:36 tsutsui Exp $
|
||||
# $NetBSD: Makefile,v 1.127 2016/06/21 12:57:39 tsutsui Exp $
|
||||
|
||||
DISTNAME= mlterm-3.7.0
|
||||
DISTNAME= mlterm-3.7.1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=mlterm/}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.37 2016/03/26 04:27:21 tsutsui Exp $
|
||||
@comment $NetBSD: PLIST,v 1.38 2016/06/21 12:57:39 tsutsui Exp $
|
||||
bin/mlcc
|
||||
bin/mlclient
|
||||
bin/mlclientx
|
||||
|
@ -24,6 +24,8 @@ ${PLIST.fb}lib/mlterm/libim-kbd-fb.la
|
|||
${PLIST.m17nlib}lib/mlterm/libim-m17nlib.la
|
||||
${PLIST.fb}${PLIST.m17nlib}lib/mlterm/libim-m17nlib-fb.la
|
||||
${PLIST.scim}lib/mlterm/libim-scim.la
|
||||
${PLIST.skk}lib/mlterm/libim-skk.la
|
||||
${PLIST.fb}${PLIST.skk}lib/mlterm/libim-skk-fb.la
|
||||
${PLIST.uim}lib/mlterm/libim-uim.la
|
||||
${PLIST.fb}${PLIST.uim}lib/mlterm/libim-uim-fb.la
|
||||
${PLIST.wnn}lib/mlterm/libim-wnn.la
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.64 2016/03/14 16:03:36 tsutsui Exp $
|
||||
$NetBSD: distinfo,v 1.65 2016/06/21 12:57:39 tsutsui Exp $
|
||||
|
||||
SHA1 (mlterm-3.7.0.tar.gz) = 10900f0303c39cdc6e5d52da6eab569b4410c777
|
||||
RMD160 (mlterm-3.7.0.tar.gz) = ba63031fb844eb79c8f5289aba9a62a7a4d0a3e2
|
||||
SHA512 (mlterm-3.7.0.tar.gz) = 93dd7e5e15154f1d8e902069f70fe5b50cb30b948ae444bba76fc3f021a9a5d169837efb8e5bb94855eeaf04cecde9323b30330f74ed7929f4e576aab2c6e98b
|
||||
Size (mlterm-3.7.0.tar.gz) = 3685301 bytes
|
||||
SHA1 (patch-configure) = 686754205102c2ffeb2456b4fad77f72b1a992a6
|
||||
SHA1 (mlterm-3.7.1.tar.gz) = f74611603a2da0835080740da1eecc8f9f97f879
|
||||
RMD160 (mlterm-3.7.1.tar.gz) = 7cbb593f9102756cdf168b5f32f34455aec40175
|
||||
SHA512 (mlterm-3.7.1.tar.gz) = 9f724b35063a2c60a566a6f2270e89145c947ba22fbf8f3a31eb728ffd99c62505cf0e154f4813da7b16548b177ae53f5da2bcfba1514d0cd53949d8d02cdd15
|
||||
Size (mlterm-3.7.1.tar.gz) = 3706958 bytes
|
||||
SHA1 (patch-configure) = 43d7577d5d99a8d21de75851ba9e76d0a03eaeff
|
||||
SHA1 (patch-etc_font-fb) = 03f0b2ecee20ef3201c8e4ce17f03ac90f657b00
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: options.mk,v 1.11 2016/02/14 14:04:16 tsutsui Exp $
|
||||
# $NetBSD: options.mk,v 1.12 2016/06/21 12:57:39 tsutsui Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.mlterm
|
||||
PKG_SUPPORTED_OPTIONS= cairo canna fribidi gdk_pixbuf2 ibus libind m17nlib mlterm-fb otl scim uim wnn4 xft2
|
||||
PKG_SUPPORTED_OPTIONS= cairo canna fribidi gdk_pixbuf2 ibus libind m17nlib mlterm-fb otl scim skk uim wnn4 xft2
|
||||
PKG_SUGGESTED_OPTIONS= cairo fribidi gdk_pixbuf2 m17nlib otl xft2
|
||||
.if ${OPSYS} == "NetBSD" || ${OPSYS} == "FreeBSD" || ${OPSYS} == "Linux"
|
||||
PKG_SUGGESTED_OPTIONS+= mlterm-fb
|
||||
|
@ -9,7 +9,7 @@ PKG_SUGGESTED_OPTIONS+= mlterm-fb
|
|||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
PLIST_VARS+= bidi cairo canna fb ibus ind m17nlib otl scim uim wnn xft2
|
||||
PLIST_VARS+= bidi cairo canna fb ibus ind m17nlib otl scim skk uim wnn xft2
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mmlterm-fb)
|
||||
CONFIGURE_ARGS+= --with-gui=xlib,fb
|
||||
|
@ -87,6 +87,13 @@ USE_LANGUAGES= c c++
|
|||
CONFIGURE_ARGS+= --disable-scim
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mskk)
|
||||
CONFIGURE_ARGS+= --enable-skk
|
||||
PLIST.skk= yes
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-skk
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Muim)
|
||||
.include "../../inputmethod/uim/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --enable-uim
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: patch-configure,v 1.13 2015/06/13 21:25:45 tsutsui Exp $
|
||||
$NetBSD: patch-configure,v 1.14 2016/06/21 12:57:39 tsutsui Exp $
|
||||
|
||||
- setuid root is handled by SPECIAL_PERMS in pkgsrc
|
||||
- fix a bug that skk is always enabled
|
||||
|
||||
--- configure.orig 2015-06-07 01:36:26.000000000 +0000
|
||||
--- configure.orig 2016-05-08 06:47:04.000000000 +0000
|
||||
+++ configure
|
||||
@@ -21667,7 +21667,7 @@ else
|
||||
@@ -21909,7 +21909,7 @@ else
|
||||
fi
|
||||
|
||||
if test "$gui" = "fb" ; then
|
||||
|
@ -13,3 +14,16 @@ $NetBSD: patch-configure,v 1.13 2015/06/13 21:25:45 tsutsui Exp $
|
|||
fi
|
||||
|
||||
|
||||
@@ -23610,7 +23610,11 @@ if test "${enable_skk+set}" = set; then
|
||||
enableval=$enable_skk; skk=$enable_skk
|
||||
fi
|
||||
|
||||
-if test "$enable_shared" != "no" ; then
|
||||
+if test "$enable_shared" = "no" ; then
|
||||
+ skk="no"
|
||||
+fi
|
||||
+
|
||||
+if test "x$skk" != "xno" ; then
|
||||
MAKE_DIRS="inputmethod/skk ${MAKE_DIRS}"
|
||||
OUTPUT_FILES="inputmethod/skk/Makefile ${OUTPUT_FILES}"
|
||||
if test "x$with_libltdl" != xno ; then
|
||||
|
|
Loading…
Reference in a new issue