(textproc/R-writexl) import R-writexl-1.4.2

Zero-dependency data frame to xlsx exporter based on 'libxlsxwriter'.
Fast and no Java or Excel required.
This commit is contained in:
mef 2024-02-06 12:24:07 +00:00
parent babc9b14ad
commit c6ce760234
4 changed files with 50 additions and 0 deletions

2
textproc/R-writexl/DESCR Normal file
View File

@ -0,0 +1,2 @@
Zero-dependency data frame to xlsx exporter based on 'libxlsxwriter'.
Fast and no Java or Excel required.

View File

@ -0,0 +1,20 @@
# $NetBSD: Makefile,v 1.1 2024/02/06 12:24:07 mef Exp $
R_PKGNAME= writexl
R_PKGVER= 1.4.2
CATEGORIES= textproc
MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= Export Data Frames to Excel 'xlsx' Format
LICENSE= 2-clause-bsd # + file LICENSE
# Package suggested but not available: 'nycflights13'
TEST_DEPENDS+= R-bit64-[0-9]*:../../devel/R-bit64
TEST_DEPENDS+= R-readxl-[0-9]*:../../textproc/R-readxl
TEST_DEPENDS+= R-spelling-[0-9]*:../../textproc/R-spelling
TEST_DEPENDS+= R-testthat-[0-9]*:../../devel/R-testthat
USE_LANGUAGES= c
.include "../../math/R/Makefile.extension"
.include "../../mk/bsd.pkg.mk"

View File

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2024/02/06 12:24:08 mef Exp $
BLAKE2s (R/writexl_1.4.2.tar.gz) = fa9fade030aff5b12171570adfb9a7050c92324e22308602a04a2c3c5757a68d
SHA512 (R/writexl_1.4.2.tar.gz) = 36f2fca87f27e5e965b7458e0caebdd7bacf32b56c0a48f957fe479fcb68dc51702d184ef8229c24168c747bc8418aa2757633be80779f024d9bb3c7f1911b2a
Size (R/writexl_1.4.2.tar.gz) = 258454 bytes
SHA1 (patch-src_minizip_ioapi.h) = 5ceed88a90ddb4d1fb0bf5c6b424ed31a050d74a

View File

@ -0,0 +1,22 @@
$NetBSD: patch-src_minizip_ioapi.h,v 1.1 2024/02/06 12:24:08 mef Exp $
** testing if installed package can be loaded from temporary location
Error: package or namespace load failed for 'writexl' in dyn.load(file, DLLpath = DLLpath, ...):
unable to load shared object '/tmp/W/textproc/R-writexl/work/.destdir/usr/pkg/lib/R/library/00LOCK-writexl/00new/writexl/libs/writexl.so':
/tmp/W/textproc/R-writexl/work/.destdir/usr/pkg/lib/R/library/00LOCK-writexl/00new/writexl/libs/writexl.so: Undefined PLT symbol "fseeko64" (symnum = 25)
Error: loading failed
Execution halted
ERROR: loading failed
* removing '/tmp/W/textproc/R-writexl/work/.destdir/usr/pkg/lib/R/library/writexl'
--- src/minizip/ioapi.h.orig 2023-01-07 02:19:12.000000000 +0900
+++ src/minizip/ioapi.h 2024-02-06 21:15:18.108719602 +0900
@@ -56,7 +56,7 @@
#define ftello64 ftell
#define fseeko64 fseek
#else
-#if defined(__FreeBSD__) || defined(__OpenBSD__)
+#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
#define fopen64 fopen
#define ftello64 ftello
#define fseeko64 fseeko