Update devel/pstreams to version 1.0.3

pkgsrc changes:
drop perl dependecy, it is only used when buildling docs
install license, needed when distributing the .h file
use gmake

changes:
new license, boost-license
fix installation on case-insensitive file systems
This commit is contained in:
nros 2022-02-15 10:28:38 +00:00
parent d19a056c99
commit c7243dff03
4 changed files with 22 additions and 26 deletions

View file

@ -1,22 +1,26 @@
# $NetBSD: Makefile,v 1.15 2021/05/24 19:52:01 wiz Exp $
# $NetBSD: Makefile,v 1.16 2022/02/15 10:28:38 nros Exp $
#
DISTNAME= pstreams-0.8.1
PKGREVISION= 5
DISTNAME= pstreams-1.0.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pstreams/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://pstreams.sourceforge.net/
COMMENT= POSIX Process Control in C++
LICENSE= gnu-lgpl-v3
LICENSE= boost-license
USE_LANGUAGES= c++
USE_TOOLS+= perl:build
INSTALL_MAKE_FLAGS= prefix=${PREFIX}
USE_TOOLS+= gmake
TEST_TARGET= test
INSTALL_MAKE_FLAGS= prefix=${PREFIX}
INSTALLATION_DIRS= share/doc/${PKGBASE}
post-install:
${INSTALL_DATA} ${WRKSRC}/LICENSE_1_0.txt \
${DESTDIR}${PREFIX}/share/doc/${PKGBASE}
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2011/10/29 10:39:31 ryoon Exp $
@comment $NetBSD: PLIST,v 1.2 2022/02/15 10:28:38 nros Exp $
include/pstreams/pstream.h
share/doc/pstreams/LICENSE_1_0.txt

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.6 2021/10/26 10:18:05 nia Exp $
$NetBSD: distinfo,v 1.7 2022/02/15 10:28:38 nros Exp $
BLAKE2s (pstreams-0.8.1.tar.gz) = 990290a23fe801d845963fd96b642daf00f2a62dde1f080de9e9a547899cded2
SHA512 (pstreams-0.8.1.tar.gz) = edb6fa30e0a77c4a83bbb7a15c427376d39d73db17112cc5888c404fa1e99407c42c09c9ca072027ac52c753071fb7d7333237bd49aa44488512ce64de22d8f3
Size (pstreams-0.8.1.tar.gz) = 58588 bytes
SHA1 (patch-Makefile) = 64d1f6d0ff991e5de03e23a038cd3227ae1edbfa
BLAKE2s (pstreams-1.0.3.tar.gz) = e4f1b09ca0bebc064ac7f0c177b4c821cff8c29721d1f680204ecfcf2c0adc8e
SHA512 (pstreams-1.0.3.tar.gz) = 5d23a98dacfe307ffaad40b72b70c62d1854fdf08e3f5cffb338060e0afe7c8d6fbddb89c1de38821914e35a88a1cbbda042fec156e17176774c823e9a526a74
Size (pstreams-1.0.3.tar.gz) = 69119 bytes
SHA1 (patch-Makefile) = 95a98894b81bf72890c4060a849e626fe9472306

View file

@ -1,11 +1,11 @@
$NetBSD: patch-Makefile,v 1.2 2015/09/24 23:08:42 ryoon Exp $
$NetBSD: patch-Makefile,v 1.3 2022/02/15 10:28:38 nros Exp $
* disable documents generation
* BSD install does not support -v option
--- Makefile.orig 2014-02-07 13:18:56.000000000 +0000
--- Makefile.orig 2020-06-10 20:17:32.000000000 +0000
+++ Makefile
@@ -27,7 +27,7 @@ CXXFLAGS=$(CFLAGS) -std=c++98 -Woverload
@@ -18,7 +18,7 @@ CXXFLAGS=$(CFLAGS) -std=c++98 -Woverload
prefix = /usr/local
includedir = $(prefix)/include
INSTALL = install
@ -13,13 +13,4 @@ $NetBSD: patch-Makefile,v 1.2 2015/09/24 23:08:42 ryoon Exp $
+INSTALL_DATA = $(INSTALL) -p -m 0644
SOURCES = pstream.h
GENERATED_FILES = ChangeLog MANIFEST
@@ -38,7 +38,7 @@ DIST_FILES = $(SOURCES) $(GENERATED_FILE
VERS := $(shell awk -F' ' '/^\#define *PSTREAMS_VERSION/{ print $$NF }' pstream.h)
-all: docs $(GENERATED_FILES)
+all: $(GENERATED_FILES)
check: test_pstreams test_minimum | pstreams.wout
@for test in $^ ; do echo $$test ; ./$$test >/dev/null 2>&1 || echo "$$test EXITED WITH STATUS $$?" ; done
TESTS = test_pstreams test_minimum