py-acme py-certbot: updated to 1.25.0

Certbot 1.25.0

Changed

Dropped 32 bit support for the Windows beta installer
Windows beta installer is now distributed as "certbot-beta-installer-win_amd64.exe".
Users of the Windows beta should uninstall the old version before running this.
Added a check whether OCSP stapling is supported by the installer when requesting a
certificate with the run subcommand in combination with the --must-staple option.
If the installer does not support OCSP and the --must-staple option is used, Certbot
will raise an error and quit.
Certbot and its acme module now depend on josepy>=1.13.0 due to better type annotation
support.

Fixed

Updated dependencies to use new version of cryptography that uses OpenSSL 1.1.1n, in
response to https://www.openssl.org/news/secadv/20220315.txt.


Certbot 1.24.0

Added

When the --debug-challenges option is used in combination with -v, Certbot
now displays the challenge URLs (for http-01 challenges) or FQDNs (for
dns-01 challenges) and their expected return values.

Changed

Support for Python 3.6 was removed.
All Certbot components now require setuptools>=41.6.0.
The acme library now requires requests>=2.20.0.
Certbot and its acme library now require pytz>=2019.3.
certbot-nginx now requires pyparsing>=2.2.1.
certbot-dns-route53 now requires boto3>=1.15.15.

Fixed

Nginx plugin now checks included files for the singleton server_names_hash_bucket_size directive.
This commit is contained in:
adam 2022-03-17 12:23:31 +00:00
parent 77ed3648d1
commit c73fe009fe
34 changed files with 100 additions and 114 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.27 2022/02/10 21:23:32 adam Exp $
# $NetBSD: Makefile,v 1.28 2022/03/17 12:23:31 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -9,12 +9,11 @@ COMMENT= ACME protocol implementation in Python
DEPENDS+= ${PYPKGPREFIX}-OpenSSL>=17.3.0:../../security/py-OpenSSL
DEPENDS+= ${PYPKGPREFIX}-cryptography>=2.5.0:../../security/py-cryptography
DEPENDS+= ${PYPKGPREFIX}-josepy>=1.10.0:../../security/py-josepy
DEPENDS+= ${PYPKGPREFIX}-pytz-[0-9]*:../../time/py-pytz
DEPENDS+= ${PYPKGPREFIX}-requests>=2.14.2:../../devel/py-requests
DEPENDS+= ${PYPKGPREFIX}-josepy>=1.13.0:../../security/py-josepy
DEPENDS+= ${PYPKGPREFIX}-pytz>=2019.3:../../time/py-pytz
DEPENDS+= ${PYPKGPREFIX}-requests>=2.20.0:../../devel/py-requests
DEPENDS+= ${PYPKGPREFIX}-requests-toolbelt>=0.3.0:../../devel/py-requests-toolbelt
DEPENDS+= ${PYPKGPREFIX}-rfc3339-[0-9]*:../../time/py-rfc3339
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
TEST_DEPENDS+= ${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test
TEST_DEPENDS+= ${PYPKGPREFIX}-test-xdist-[0-9]*:../../devel/py-test-xdist
TEST_DEPENDS+= ${PYPKGPREFIX}-typing-extensions-[0-9]*:../../devel/py-typing-extensions

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.37 2022/02/10 21:23:32 adam Exp $
$NetBSD: distinfo,v 1.38 2022/03/17 12:23:31 adam Exp $
BLAKE2s (acme-1.23.0.tar.gz) = 4462dc8aaea12b2562563c724f723d9a239473b60b188db228f3610dfc3e12b4
SHA512 (acme-1.23.0.tar.gz) = a4f2a52ee2a12de4bad6de4726a4a4ebd1eb4aa89d6c723b2ffd51d5551feca6fbc10b040a0ece0a8c083b874103319f83ec908e6f55cdd854ca59f64735c532
Size (acme-1.23.0.tar.gz) = 99388 bytes
BLAKE2s (acme-1.25.0.tar.gz) = c3f04ebe30b7a9daee27d97bc7abd4a928a6352a665fa770e3ea7338239bb594
SHA512 (acme-1.25.0.tar.gz) = a7508fb9a71578509925fa5d0ce9994910e9dfbd92c07f25409bc6463bb23693a925a8cb946330c3c187da85dc083c0775193baa1c5ff1327ed8e1541507d877
Size (acme-1.25.0.tar.gz) = 99215 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.16 2022/02/10 21:23:32 adam Exp $
# $NetBSD: Makefile,v 1.17 2022/03/17 12:23:31 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= Apache plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-augeas-[0-9]*:../../sysutils/py-augeas
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.37 2022/02/10 21:23:32 adam Exp $
$NetBSD: distinfo,v 1.38 2022/03/17 12:23:31 adam Exp $
BLAKE2s (certbot-apache-1.23.0.tar.gz) = 94f4b4a6819ebb07349910891b21e568ccd72884c47cb1096a3a6ab26787a4f3
SHA512 (certbot-apache-1.23.0.tar.gz) = 1684db62ac92dfb2d13baf7208f875ffd2047d485b61c86636a980bbb7eea725c0bb2cc834f6564cc8f6972fcda82cfc412962907eb9b52470be6d0ee0ab0df8
Size (certbot-apache-1.23.0.tar.gz) = 224914 bytes
BLAKE2s (certbot-apache-1.25.0.tar.gz) = 5d046803efdea968e18a687fe29e63d7a91219ed466e96d75ed9affd12d27fc8
SHA512 (certbot-apache-1.25.0.tar.gz) = 9017bc1148930d52213e004fd4e3f96d55b2d08c6d64a40df60aa999eb352bc6a4269072c8612b43b3a8758a692ca8c3ea953eabbce58ce322f483cea12d5e7a
Size (certbot-apache-1.25.0.tar.gz) = 224605 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2022/02/10 21:23:32 adam Exp $
# $NetBSD: Makefile,v 1.8 2022/03/17 12:23:32 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= DigitalOcean DNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-digitalocean>=1.11:../../net/py-digitalocean
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.25 2022/02/10 21:23:32 adam Exp $
$NetBSD: distinfo,v 1.26 2022/03/17 12:23:32 adam Exp $
BLAKE2s (certbot-dns-digitalocean-1.23.0.tar.gz) = fb07384b41fcf89a042c6a8020b0d75358a80b3b9793ecaa0cd3c563cedbdc75
SHA512 (certbot-dns-digitalocean-1.23.0.tar.gz) = 94bf54cfccea492bf11ca03476b29502993021222f68382e0978ebbc9b2a0d7a9c41872efd68147b3e2c340753abaa02488413775507254c98139f0e44c4f8ad
Size (certbot-dns-digitalocean-1.23.0.tar.gz) = 14248 bytes
BLAKE2s (certbot-dns-digitalocean-1.25.0.tar.gz) = 7efa010249e84ae0d8c7605eaf3adb0ebb2f4ca778500209e52314b19eee642c
SHA512 (certbot-dns-digitalocean-1.25.0.tar.gz) = bac3638259575a94f18b5683141219a15ec0eea67adb4d644a0a51505a470b8a681e3c038d75e3ecfbd3c295d4baf185b66ca62c178f2edcef5a2ce5b18a2870
Size (certbot-dns-digitalocean-1.25.0.tar.gz) = 14164 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.10 2022/02/10 21:23:32 adam Exp $
# $NetBSD: Makefile,v 1.11 2022/03/17 12:23:32 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= DNSimple DNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-lexicon>=3.2.1:../../net/py-lexicon
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.32 2022/02/10 21:23:32 adam Exp $
$NetBSD: distinfo,v 1.33 2022/03/17 12:23:32 adam Exp $
BLAKE2s (certbot-dns-dnsimple-1.23.0.tar.gz) = f032939024c794b34a2c0bf16fecc2e12fdd114f31fbd2efff26ba3f319fb2d9
SHA512 (certbot-dns-dnsimple-1.23.0.tar.gz) = 0ef8b0dd99f7388b138e72b61c594ccece8c344d6e5a118efd955a8896db96471b488a9b4afa4aaf512ff5a8ce09bcb201cee7584c6ed055960048328cfb9198
Size (certbot-dns-dnsimple-1.23.0.tar.gz) = 12550 bytes
BLAKE2s (certbot-dns-dnsimple-1.25.0.tar.gz) = 6c3f979e85215a2fdf630a8c5af0f15391ee937d8b8e745f141f6349664bc321
SHA512 (certbot-dns-dnsimple-1.25.0.tar.gz) = 85d3d958cb3545f64ec94959f33d879c833df290f613b0894efaa4dd0f06a1c0325531a25ebda733858ce2380a1781ab3f8647317f81812c3886cc2b3b407163
Size (certbot-dns-dnsimple-1.25.0.tar.gz) = 12485 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.9 2022/02/10 21:23:32 adam Exp $
# $NetBSD: Makefile,v 1.10 2022/03/17 12:23:32 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= DNS Made Easy DNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-lexicon>=3.2.1:../../net/py-lexicon
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.32 2022/02/10 21:23:32 adam Exp $
$NetBSD: distinfo,v 1.33 2022/03/17 12:23:32 adam Exp $
BLAKE2s (certbot-dns-dnsmadeeasy-1.23.0.tar.gz) = c5c3cb937aa1daff432c9680d0ee26aec886215726fdc819339f276e2ad1c9c8
SHA512 (certbot-dns-dnsmadeeasy-1.23.0.tar.gz) = 3662655ab14b7b84b2b4d21f5ace7eb23d9c0beecf7a53ed5028b42d4e1dcdc2c6d30b609d873bd215861af5e930fe2363f183bdc066706db9748bb6fc0ee0a3
Size (certbot-dns-dnsmadeeasy-1.23.0.tar.gz) = 12738 bytes
BLAKE2s (certbot-dns-dnsmadeeasy-1.25.0.tar.gz) = 90ae0f8074e39728577ce9e2b77c750118d5a3c4807142e293b6bae0cc546bd3
SHA512 (certbot-dns-dnsmadeeasy-1.25.0.tar.gz) = 4bf3e3a8a08371f3393b029b48b30aa891610898056d1a9cd6dd55707721d2397c9624aa3cd310736a2930898b8ca7faeab714e824d28c2123104d40c4274d38
Size (certbot-dns-dnsmadeeasy-1.25.0.tar.gz) = 12682 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.10 2022/02/10 21:23:32 adam Exp $
# $NetBSD: Makefile,v 1.11 2022/03/17 12:23:32 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= Gehirn Infrastracture Service DNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-lexicon>=3.2.1:../../net/py-lexicon
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.32 2022/02/10 21:23:32 adam Exp $
$NetBSD: distinfo,v 1.33 2022/03/17 12:23:32 adam Exp $
BLAKE2s (certbot-dns-gehirn-1.23.0.tar.gz) = 33934ace83fbb7fe5ac874b65c52c13e06e623107628b7732bd859b9b6baaeb7
SHA512 (certbot-dns-gehirn-1.23.0.tar.gz) = a5ca435365458877ca8c67f447bd8027f6e3988a9415debdc8db11950ce32caae9c7b54c884b6678c6be6a905de2fce60e7050864ddf78b8d798b57650db0f84
Size (certbot-dns-gehirn-1.23.0.tar.gz) = 12664 bytes
BLAKE2s (certbot-dns-gehirn-1.25.0.tar.gz) = bcacba292f1e5f4e5c7ba32a06b554e8a070a16ba787296aa61c8929173a02a8
SHA512 (certbot-dns-gehirn-1.25.0.tar.gz) = 5e4e2c1f5f1d2d137ae7e099001ff16bcf739d35b80634c86a39dc93a4c0119b5253b4e96f1f7b78d3cc20db6983c22ba33368f8ddca0a0b1549abe8870428f6
Size (certbot-dns-gehirn-1.25.0.tar.gz) = 12574 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.11 2022/02/10 21:23:33 adam Exp $
# $NetBSD: Makefile,v 1.12 2022/03/17 12:23:32 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -11,7 +11,6 @@ DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-google-api-python-client>=1.5.5:../../www/py-google-api-python-client
DEPENDS+= ${PYPKGPREFIX}-httplib2-[0-9]*:../../www/py-httplib2
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
DEPENDS+= ${PYPKGPREFIX}-oauth2client>=4.0:../../security/py-oauth2client
.include "../../lang/python/egg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.32 2022/02/10 21:23:33 adam Exp $
$NetBSD: distinfo,v 1.33 2022/03/17 12:23:32 adam Exp $
BLAKE2s (certbot-dns-google-1.23.0.tar.gz) = e7efa778ea88f6166a13f26a1250a17dd0cd56216c5543e8572548da69870bd2
SHA512 (certbot-dns-google-1.23.0.tar.gz) = c52dd84d61dae2375af5c5420abc650975447ac966bf7f52b9021cef52b0bc6712336e59a3a132cf41338b3ae36cef06d34565e5b4baf2728622289288e946ed
Size (certbot-dns-google-1.23.0.tar.gz) = 23851 bytes
BLAKE2s (certbot-dns-google-1.25.0.tar.gz) = e816709578d682cac7e4d94e10c1e2a03371183e32c8ea4e4b8e054c601c7781
SHA512 (certbot-dns-google-1.25.0.tar.gz) = e173d6d69ca7ca47d2f14c0d8f16436b20c732ed872bc89e3140f6f94a569e18fd659d44234ab08e8426fa90dc5e59e97ca7cf782804416dc641f65683ee1143
Size (certbot-dns-google-1.25.0.tar.gz) = 23742 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.11 2022/02/10 21:23:33 adam Exp $
# $NetBSD: Makefile,v 1.12 2022/03/17 12:23:32 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= Linode DNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-lexicon>=3.2.1:../../net/py-lexicon
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.32 2022/02/10 21:23:33 adam Exp $
$NetBSD: distinfo,v 1.33 2022/03/17 12:23:32 adam Exp $
BLAKE2s (certbot-dns-linode-1.23.0.tar.gz) = 72eab13f56eef69d8d1f68e84edb5a1054dc15be5376140542e15d4b2795c92b
SHA512 (certbot-dns-linode-1.23.0.tar.gz) = 4157d38c7d6e6b1d1addeac2e563ea965be1a46cf37173dca769fc9072a71d4d2ba85b986fdfee2d4fe3ef0796c4a254d378155528ef76b63952f5299dadcdc3
Size (certbot-dns-linode-1.23.0.tar.gz) = 13120 bytes
BLAKE2s (certbot-dns-linode-1.25.0.tar.gz) = d0eeb1e91c688eadb5b90a71ead833642bb64a049b88b2044fadd2421ec781bd
SHA512 (certbot-dns-linode-1.25.0.tar.gz) = 9535a31f478feb481dbc72b25fcfe449341698807a0f54a6a0dfab6e4101e5af0aa6fd8a4a59359c81a697e4022ba37df7a55ef6f10b659b5c7eb6fc9612322d
Size (certbot-dns-linode-1.25.0.tar.gz) = 13043 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.15 2022/02/10 21:23:33 adam Exp $
# $NetBSD: Makefile,v 1.16 2022/03/17 12:23:32 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= LuaDNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-lexicon>=3.2.1:../../net/py-lexicon
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.37 2022/02/10 21:23:33 adam Exp $
$NetBSD: distinfo,v 1.38 2022/03/17 12:23:32 adam Exp $
BLAKE2s (certbot-dns-luadns-1.23.0.tar.gz) = 0119a040360a5731ae307f87c1e6d4e21326f96d8b9b32e05c8fabaa3f638d48
SHA512 (certbot-dns-luadns-1.23.0.tar.gz) = 5851c480f0db019f1a2caf0bde20b6ef106461ce5003b650df98263f4ae2c19070db1b565c80c9f6fca703daa0fb8373ffb69242496734b95ee0fe6e0dcd6c28
Size (certbot-dns-luadns-1.23.0.tar.gz) = 12583 bytes
BLAKE2s (certbot-dns-luadns-1.25.0.tar.gz) = 1bd61b42132b771d27269383dbceaaca6d1144bcfcb38dc61a9375596184bc32
SHA512 (certbot-dns-luadns-1.25.0.tar.gz) = 18b2a058fbcd9e78e33843363194433deeae4248a5a7530264064b1158ac1f0f033ae890ddb994589cbf02b5046060b8e7795538d42c1afbdeb556baa4355563
Size (certbot-dns-luadns-1.25.0.tar.gz) = 12495 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.15 2022/02/10 21:23:33 adam Exp $
# $NetBSD: Makefile,v 1.16 2022/03/17 12:23:32 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= NS1 DNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-lexicon>=3.2.1:../../net/py-lexicon
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.37 2022/02/10 21:23:33 adam Exp $
$NetBSD: distinfo,v 1.38 2022/03/17 12:23:32 adam Exp $
BLAKE2s (certbot-dns-nsone-1.23.0.tar.gz) = e1feb105b8305196e872245560188940201dac088d577449077e4cde5d225dbd
SHA512 (certbot-dns-nsone-1.23.0.tar.gz) = bc41b4a7c629204a60e064b2e2fb99ac022288cac30c5774ef6a0d189f0eba8b59d01416c807e9c7c89f372398edb58af1aadf20a0bab2cf2ce644c4de2dd20f
Size (certbot-dns-nsone-1.23.0.tar.gz) = 12598 bytes
BLAKE2s (certbot-dns-nsone-1.25.0.tar.gz) = 3de540a82b340c97a2893148be52e25b7d21170592c6aa1a8c405b40bda000cc
SHA512 (certbot-dns-nsone-1.25.0.tar.gz) = fd40aa9a34d5aa0b4abdb0967df9751443d46980d2eafdfc4641f7ecd952fdd751b09b364fce606dd43efafc5f94e0862e3b41590eed38cafeeed360963b969a
Size (certbot-dns-nsone-1.25.0.tar.gz) = 12541 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.16 2022/02/10 21:23:33 adam Exp $
# $NetBSD: Makefile,v 1.17 2022/03/17 12:23:32 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= OVH DNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-lexicon>=3.2.1:../../net/py-lexicon
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.37 2022/02/10 21:23:33 adam Exp $
$NetBSD: distinfo,v 1.38 2022/03/17 12:23:32 adam Exp $
BLAKE2s (certbot-dns-ovh-1.23.0.tar.gz) = 008281cc939e8987bc5b0f7e1c6132ba115f34a639d742fb6ad7e81ccf32a3ab
SHA512 (certbot-dns-ovh-1.23.0.tar.gz) = c2ecf155b7d76688fee8a1c529e5b66b9f49ebdc44dd61f8c93db49387c2fc1805a9bee83956b801709c22cbbe39980cfaed3f86e847b0393d1065e2e9dc5e1f
Size (certbot-dns-ovh-1.23.0.tar.gz) = 12960 bytes
BLAKE2s (certbot-dns-ovh-1.25.0.tar.gz) = c7e46a50b0339ff6c8d7b0ecf2ba0ff7d39ccf81b92778111df5cb0eef52e801
SHA512 (certbot-dns-ovh-1.25.0.tar.gz) = e1c2e29c7505b4a9f691ca264011db39ba3f3771bbb082ac465a0fd78040fb953dcd291c52a148245f54a24abff72b77209691ff2bb01f134bbb0aaf4a121ef4
Size (certbot-dns-ovh-1.25.0.tar.gz) = 12891 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.17 2022/02/10 21:23:33 adam Exp $
# $NetBSD: Makefile,v 1.18 2022/03/17 12:23:33 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= RFC 2136 DNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-dns>=1.15.0:../../net/py-dns
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.37 2022/02/10 21:23:33 adam Exp $
$NetBSD: distinfo,v 1.38 2022/03/17 12:23:33 adam Exp $
BLAKE2s (certbot-dns-rfc2136-1.23.0.tar.gz) = 6fdcaa995dff212a9e80b9acd7ac92c686e9f5e5ea52ca4d39bd7bea0119b777
SHA512 (certbot-dns-rfc2136-1.23.0.tar.gz) = 482261b08fdd333ff7dab317f59f76a7d50768ae9243334102b7b2e7b5734e20a8bd9c9dba9a7833bf3083a9a607c6f27273944e6e6fda202043a2e45cae6e04
Size (certbot-dns-rfc2136-1.23.0.tar.gz) = 15452 bytes
BLAKE2s (certbot-dns-rfc2136-1.25.0.tar.gz) = 8e1184a487b8e4ae92ef2f76fe2f31dce4006c89d8b17799982b1409fa6e6738
SHA512 (certbot-dns-rfc2136-1.25.0.tar.gz) = 231c5bf88f56b6296e362a0306310b1aaa035eee653519a2f7ffe6ec2ebc238e7d546dd6a2150e634eb2e902c620ca0a49b84016ddb16e61e3c7d0d75dc7b43a
Size (certbot-dns-rfc2136-1.25.0.tar.gz) = 15382 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.15 2022/02/10 21:23:33 adam Exp $
# $NetBSD: Makefile,v 1.16 2022/03/17 12:23:33 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -8,9 +8,8 @@ MASTER_SITES= ${MASTER_SITE_PYPI:=c/certbot-dns-route53/}
COMMENT= Amazon Web Services Route 53 API plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-boto3-[0-9]*:../../net/py-boto3
DEPENDS+= ${PYPKGPREFIX}-boto3>=1.15.15:../../net/py-boto3
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.37 2022/02/10 21:23:33 adam Exp $
$NetBSD: distinfo,v 1.38 2022/03/17 12:23:33 adam Exp $
BLAKE2s (certbot-dns-route53-1.23.0.tar.gz) = 3ffd4706957a1b29389ea3e4c29f33deb32944019495b4a6edce0892edd4f326
SHA512 (certbot-dns-route53-1.23.0.tar.gz) = 164f1b2be6595c19253ee06cbb243f1b45fdfe69f2010a072f25f57aeff5fd3bdf0ddd623fa138a8b7f7ff7c5b734809b28273a3048c7382f8f9b71458838cfd
Size (certbot-dns-route53-1.23.0.tar.gz) = 15060 bytes
BLAKE2s (certbot-dns-route53-1.25.0.tar.gz) = acafa5b4f1efdd083c285cbe15a4621a7a03241ae8cc8b1b820430f212ad12cd
SHA512 (certbot-dns-route53-1.25.0.tar.gz) = 8c420b74e4406adfb022df4d72f01427143b951f9875487104d8bbab6f4bccc8f5d0cd2d1a18b742c73aa112485bf8c59b9b794dd6d826a0f6cee77c419dbf6e
Size (certbot-dns-route53-1.25.0.tar.gz) = 14998 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.16 2022/02/10 21:23:33 adam Exp $
# $NetBSD: Makefile,v 1.17 2022/03/17 12:23:33 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,7 +10,6 @@ COMMENT= Sakura Cloud DNS Authenticator plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-lexicon>=3.2.1:../../net/py-lexicon
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.37 2022/02/10 21:23:33 adam Exp $
$NetBSD: distinfo,v 1.38 2022/03/17 12:23:33 adam Exp $
BLAKE2s (certbot-dns-sakuracloud-1.23.0.tar.gz) = a54f7c8a811ed323c31fa3f9fde08ce560c81ea3505832ca84d212c10e7f2408
SHA512 (certbot-dns-sakuracloud-1.23.0.tar.gz) = 004ba113bb125552589825b33bc0317571f5ae8f7b79de307e56e59410016e21ef6cb0dba21a6dafcf4b81756a61527599f9f265948fff661bc09fe427cd42e1
Size (certbot-dns-sakuracloud-1.23.0.tar.gz) = 12641 bytes
BLAKE2s (certbot-dns-sakuracloud-1.25.0.tar.gz) = ffbd0f722cb0cda8a06ba5fbfa6ef050678a0562080f657a59633f1b49fd1f93
SHA512 (certbot-dns-sakuracloud-1.25.0.tar.gz) = 9e26c935dbc1ead4ee4cb5296cd4b6c96669c7ee3cd183997809e1178aaa80e8492fa1ac85bea118f4b750e4f2eb7ac3aba0fb84edd73071a388b6920c741bd9
Size (certbot-dns-sakuracloud-1.25.0.tar.gz) = 12573 bytes

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.19 2022/02/10 21:23:34 adam Exp $
# $NetBSD: Makefile,v 1.20 2022/03/17 12:23:33 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -10,8 +10,7 @@ COMMENT= Nginx plugin for Certbot
DEPENDS+= ${PYPKGPREFIX}-OpenSSL>=17.3.0:../../security/py-OpenSSL
DEPENDS+= ${PYPKGPREFIX}-acme>=${CERTBOT_VERSION}:../../security/py-acme
DEPENDS+= ${PYPKGPREFIX}-certbot>=${CERTBOT_VERSION}:../../security/py-certbot
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
DEPENDS+= ${PYPKGPREFIX}-pyparsing>=2.2.0:../../devel/py-pyparsing
DEPENDS+= ${PYPKGPREFIX}-pyparsing>=2.2.1:../../devel/py-pyparsing
PKG_SYSCONFVAR= nginx

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.38 2022/02/10 21:23:34 adam Exp $
$NetBSD: distinfo,v 1.39 2022/03/17 12:23:33 adam Exp $
BLAKE2s (certbot-nginx-1.23.0.tar.gz) = 63cfa4a9a21a7b0360716d3702e7ae5496cbd0797aea6f85b8585ee81effcd3a
SHA512 (certbot-nginx-1.23.0.tar.gz) = e747f53f2fe07a66a60f97e55576228510d8cecfa514d29874cc04ae9c100716a4718dcb8dbbedea5782193124fa48fc196acf351e4495de846fdf29da4b5190
Size (certbot-nginx-1.23.0.tar.gz) = 78044 bytes
SHA1 (patch-certbot__nginx___internal_constants.py) = a63042550f5eee5992579897bf4e9ea2cb7def20
BLAKE2s (certbot-nginx-1.25.0.tar.gz) = 5c6eddebec536284786fb7d6332c37552e27898ba10ebae138a0b6980da5f610
SHA512 (certbot-nginx-1.25.0.tar.gz) = c095864060e1cd7799dc4a81c8cef7b978553f8ed6be4ef48affead294f6f28dc2cb15ec7bcba1f1b90b5fc50fe8a24463d7eb68e16c12e4579ddcea812594e4
Size (certbot-nginx-1.25.0.tar.gz) = 78622 bytes
SHA1 (patch-certbot__nginx___internal_constants.py) = a997b742be045374043a508a187db21fa45dde0c

View file

@ -1,8 +1,8 @@
$NetBSD: patch-certbot__nginx___internal_constants.py,v 1.4 2021/04/15 05:16:37 adam Exp $
$NetBSD: patch-certbot__nginx___internal_constants.py,v 1.5 2022/03/17 12:23:33 adam Exp $
Look for nginx.conf in PKG_SYSCONFDIR
--- certbot_nginx/_internal/constants.py.orig 2021-04-06 17:17:00.000000000 +0000
--- certbot_nginx/_internal/constants.py.orig 2022-03-16 18:16:28.000000000 +0000
+++ certbot_nginx/_internal/constants.py
@@ -3,19 +3,8 @@ import platform
from typing import Any
@ -19,9 +19,9 @@ Look for nginx.conf in PKG_SYSCONFDIR
-else:
- server_root_tmp = LINUX_SERVER_ROOT
-
CLI_DEFAULTS: Dict[str, Any] = dict(
- server_root=server_root_tmp,
+ server_root="@PKG_SYSCONFDIR@/nginx",
ctl="nginx",
sleep_seconds=1
)
CLI_DEFAULTS: Dict[str, Any] = {
- "server_root": server_root_tmp,
+ "server_root": "@PKG_SYSCONFDIR@/nginx",
"ctl": "nginx",
"sleep_seconds": 1
}

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.33 2022/02/10 21:23:32 adam Exp $
# $NetBSD: Makefile,v 1.34 2022/03/17 12:23:31 adam Exp $
.include "../../security/py-certbot/Makefile.common"
@ -12,11 +12,10 @@ DEPENDS+= ${PYPKGPREFIX}-configargparse>=0.9.3:../../devel/py-configargparse
DEPENDS+= ${PYPKGPREFIX}-configobj>=5.0.6:../../devel/py-configobj
DEPENDS+= ${PYPKGPREFIX}-cryptography>=2.5.0:../../security/py-cryptography
DEPENDS+= ${PYPKGPREFIX}-distro>=1.0.1:../../devel/py-distro
DEPENDS+= ${PYPKGPREFIX}-josepy>=1.9.0:../../security/py-josepy
DEPENDS+= ${PYPKGPREFIX}-josepy>=1.13.0:../../security/py-josepy
DEPENDS+= ${PYPKGPREFIX}-parsedatetime>=2.4:../../time/py-parsedatetime
DEPENDS+= ${PYPKGPREFIX}-pytz-[0-9]*:../../time/py-pytz
DEPENDS+= ${PYPKGPREFIX}-pytz>=2019.3:../../time/py-pytz
DEPENDS+= ${PYPKGPREFIX}-rfc3339-[0-9]*:../../time/py-rfc3339
DEPENDS+= ${PYPKGPREFIX}-setuptools>=39.0.1:../../devel/py-setuptools
DEPENDS+= ${PYPKGPREFIX}-ZopeComponent-[0-9]*:../../devel/py-ZopeComponent
DEPENDS+= ${PYPKGPREFIX}-ZopeInterface-[0-9]*:../../devel/py-ZopeInterface
# Needed for the test target

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.62 2022/02/10 21:23:32 adam Exp $
# $NetBSD: Makefile.common,v 1.63 2022/03/17 12:23:31 adam Exp $
# used by security/py-acme/Makefile
# used by security/py-certbot/Makefile
# used by security/py-certbot-apache/Makefile
@ -16,7 +16,7 @@
# used by security/py-certbot-dns-sakuracloud/Makefile
# used by security/py-certbot-nginx/Makefile
CERTBOT_VERSION= 1.23.0
CERTBOT_VERSION= 1.25.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES?= security python
@ -25,6 +25,8 @@ MAINTAINER= adam@NetBSD.org
HOMEPAGE= https://github.com/certbot/certbot
LICENSE= apache-2.0
DEPENDS+= ${PYPKGPREFIX}-setuptools>=41.6.0:../../devel/py-setuptools
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.65 2022/02/10 21:23:32 adam Exp $
$NetBSD: distinfo,v 1.66 2022/03/17 12:23:31 adam Exp $
BLAKE2s (certbot-1.23.0.tar.gz) = c6ea9bef067942709a6054e7a6d2c1de6c51ed758baf57fe29c7a1c45d766ed0
SHA512 (certbot-1.23.0.tar.gz) = 18bb89bce0cdcec4cb181c160e4eb331bfebfc0d3fe142678be81cba30e1719364ea151e04f2ff161238a3d8f46cf7b2f4aa1ef74575cc2938249a0289328db1
Size (certbot-1.23.0.tar.gz) = 418030 bytes
BLAKE2s (certbot-1.25.0.tar.gz) = 4d7ea36acf3648529784fbcd20df1ccd01e4579a46171419d573d2c302e88173
SHA512 (certbot-1.25.0.tar.gz) = 985daf1ae70296d9a6eba436a349be1f31570e8314bdcc514dea9ffbcdcf35c4917250757d14c9192475afde14b840d4df8f7763f607465195686d28580fb6b4
Size (certbot-1.25.0.tar.gz) = 421545 bytes