Add OpenBSD support.

From Dario Niedermann <dnied@tiscali.it> on pkgsrc-users.
This commit is contained in:
wiz 2013-05-29 11:26:12 +00:00
parent 3926f588b0
commit c7520d7ae4
9 changed files with 79 additions and 25 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.4 2012/10/02 23:48:04 asau Exp $
# $NetBSD: Makefile,v 1.5 2013/05/29 11:26:12 wiz Exp $
#
DISTNAME= pd-0.43-0.src
@ -63,6 +63,8 @@ SUBST_FILES.doc+= tcl/pd_menus.tcl
EXTERNAL_EXTENSION= d_fat
.elif ${OPSYS} == "Linux"
EXTERNAL_EXTENSION= pd_linux
.elif ${OPSYS} == "OpenBSD"
CFLAGS+= -DAPI_DEFAULT=API_OSS -DAPI_DEFSTRING=\"OSS\"
.else
EXTERNAL_EXTENSION= # empty
.endif

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.4 2012/02/15 22:36:38 hans Exp $
$NetBSD: distinfo,v 1.5 2013/05/29 11:26:12 wiz Exp $
SHA1 (pd-0.43-0.src.tar.gz) = 9bc4377fe25d034120bd393d63fe4180c7a500bc
RMD160 (pd-0.43-0.src.tar.gz) = 6c737e69430180187281747830e655401b803b55
@ -6,20 +6,20 @@ Size (pd-0.43-0.src.tar.gz) = 2194131 bytes
SHA1 (patch-Makefile.am) = 7a8da5f1902dcfb8f49ef9c915ae96a1996bd83d
SHA1 (patch-configure.ac) = 31baa676afeea342e3634d6fc2e06b4f61ede9dd
SHA1 (patch-extra_bonk~_bonk~.c) = 4b72a2f34c50abcceed7a41f7e2e855abe23f8fa
SHA1 (patch-extra_pd~_pd~.c) = fd2f6984648ae752667c5e286fd16465fed2ed32
SHA1 (patch-extra_pd~_pd~.c) = 0d654e9a2c86d76869542d62700075e017309c5e
SHA1 (patch-extra_sigmund~_sigmund~.c) = 53017104c6b966f57480ca95db888fae841935c8
SHA1 (patch-src_Makefile.am) = a87c3380b0180a906c0496e743fbece772226da3
SHA1 (patch-src_configure) = 19d9f53db01c426b23679fd3ad6fca3ef426b52b
SHA1 (patch-src_configure.in) = 3fc4c5f1d241e233105783ecf40375ca4ad15a36
SHA1 (patch-src_d__array.c) = ab2b0016a46ccc60a31a2631b265af5d98c10121
SHA1 (patch-src_d__osc.c) = f49281a1b43728f27d9b51439b27d75cb66a9529
SHA1 (patch-src_d__array.c) = bd9bbc1fa0d5a5754ecce7304025336fb3c3adc4
SHA1 (patch-src_d__osc.c) = 5993b07b579ab60e5e1ef8d44c85f8fc87234ac8
SHA1 (patch-src_d__soundfile.c) = d292b8b39918e76e397b511503ba6dcb7382d433
SHA1 (patch-src_m__binbuf.c) = 29ef42a7505cae668bbb88627b25ae1162f6ec18
SHA1 (patch-src_s__audio__oss.c) = 322602c9243d3e5fc3a6fdafa93c8670b50a8b27
SHA1 (patch-src_s__file.c) = fba59996a07d960b879f36ee9508ae420df51838
SHA1 (patch-src_s__audio__oss.c) = 79ebd0ee72e255359bc6d7accd1725d9daf04ef9
SHA1 (patch-src_s__file.c) = b35e5708a63e6416e0dcace32564275fdf2ae954
SHA1 (patch-src_s__inter.c) = 3fa8a59963753244a641304dcb9e2da8415e5c21
SHA1 (patch-src_s__loader.c) = 446977bcf1ea5b75ff0ec7de0bf6d32fca0bc6d5
SHA1 (patch-src_s__loader.c) = 6ebc4ed6c697e2daad3cd8021c36d847cf498ac4
SHA1 (patch-src_s__stuff.h) = 1ebfb78dd7cfe8d8c7c0e4ecde3d8de814480a96
SHA1 (patch-src_s__utf8.c) = 84b5ccb7a47f2c3c8a56b5f3d78947210cff043e
SHA1 (patch-src_x__list.c) = af68452cf181cf83dcc6e119ac9a5f969c6add5a
SHA1 (patch-src_x__misc.c) = f2eccedc7ad297f3358c921b03e9879f5b63f77f
SHA1 (patch-src_x__misc.c) = e0d927b94127854f162c20c51d2c3ce5fbe2ab64

View file

@ -1,8 +1,9 @@
$NetBSD: patch-extra_pd~_pd~.c,v 1.3 2012/02/15 22:36:38 hans Exp $
$NetBSD: patch-extra_pd~_pd~.c,v 1.4 2013/05/29 11:26:12 wiz Exp $
Add missing include (for SIGPIPE).
Define extensions for NetBSD.
https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478072
Define extensions for OpenBSD.
--- extra/pd~/pd~.c.orig 2010-07-28 20:55:17.000000000 +0000
+++ extra/pd~/pd~.c
@ -14,7 +15,7 @@ https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478
#include <string.h>
#include <unistd.h>
#include <stdlib.h>
@@ -56,6 +57,24 @@ static char pd_tilde_dllextent[] = ".l_i
@@ -56,6 +57,33 @@ static char pd_tilde_dllextent[] = ".l_i
pd_tilde_dllextent2[] = ".pd_linux";
#endif
#endif
@ -27,6 +28,15 @@ https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478
+ pd_tilde_dllextent2[] = ".pd_netbsd";
+#endif
+#endif
+#if defined(__OpenBSD__)
+#ifdef __x86_64__
+static char pd_tilde_dllextent[] = ".b_ia64",
+ pd_tilde_dllextent2[] = ".pd_openbsd";
+#else
+static char pd_tilde_dllextent[] = ".b_i386",
+ pd_tilde_dllextent2[] = ".pd_openbsd";
+#endif
+#endif
+#if defined(__sun)
+#ifdef __x86_64__
+static char pd_tilde_dllextent[] = ".s_ia64",

View file

@ -1,11 +1,20 @@
$NetBSD: patch-src_d__array.c,v 1.3 2012/02/15 22:36:39 hans Exp $
$NetBSD: patch-src_d__array.c,v 1.4 2013/05/29 11:26:12 wiz Exp $
Detect endianness on NetBSD.
https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478072
Detect endianness on OpenBSD.
Detect endianness on Solaris.
--- src/d_array.c.orig 2010-07-28 20:55:17.000000000 +0000
+++ src/d_array.c
@@ -502,7 +502,7 @@ static void tabread4_tilde_setup(void)
@@ -498,11 +498,11 @@ static void tabread4_tilde_setup(void)
/* this is all copied from d_osc.c... what include file could this go in? */
#define UNITBIT32 1572864. /* 3*2^19; bit 32 has place value 1 */
-#ifdef IRIX
+#if defined(IRIX) || defined(__OpenBSD__)
#include <sys/endian.h>
#endif

View file

@ -1,11 +1,20 @@
$NetBSD: patch-src_d__osc.c,v 1.3 2012/02/15 22:36:39 hans Exp $
$NetBSD: patch-src_d__osc.c,v 1.4 2013/05/29 11:26:12 wiz Exp $
Detect endianness on NetBSD.
https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478072
Detect endianness on OpenBSD.
Detect endianness on Solaris.
--- src/d_osc.c.orig 2010-07-28 20:55:17.000000000 +0000
+++ src/d_osc.c
@@ -15,7 +15,7 @@
@@ -11,11 +11,11 @@
#define UNITBIT32 1572864. /* 3*2^19; bit 32 has place value 1 */
-#ifdef IRIX
+#if defined(IRIX) || defined(__OpenBSD__)
#include <sys/endian.h>
#endif

View file

@ -1,18 +1,24 @@
$NetBSD: patch-src_s__audio__oss.c,v 1.3 2012/02/15 22:36:39 hans Exp $
$NetBSD: patch-src_s__audio__oss.c,v 1.4 2013/05/29 11:26:12 wiz Exp $
Use proper soundcard.h include on NetBSD and add missing argument
to ioctl().
https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478072
Include proper header for OpenBSD.
Solaris fixes.
--- src/s_audio_oss.c.orig 2011-03-07 01:33:39.000000000 +0000
+++ src/s_audio_oss.c
@@ -5,12 +5,17 @@
@@ -5,12 +5,19 @@
/* this file inputs and outputs audio using the OSS API available on linux. */
-#if defined(__FreeBSD_kernel__)
+#if defined(__FreeBSD_kernel__) || defined(__NetBSD__) || defined(__sun)
# include <sys/soundcard.h>
+#elif defined(__OpenBSD__)
+# include <soundcard.h>
#else
# include <linux/soundcard.h>
#endif
@ -25,7 +31,7 @@ https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478
#include "m_pd.h"
#include "s_stuff.h"
#include <errno.h>
@@ -120,7 +125,7 @@ typedef struct _multidev {
@@ -120,7 +127,7 @@ typedef struct _multidev {
int oss_reset(int fd) {
int err;

View file

@ -1,8 +1,12 @@
$NetBSD: patch-src_s__file.c,v 1.3 2012/02/15 22:36:39 hans Exp $
$NetBSD: patch-src_s__file.c,v 1.4 2013/05/29 11:26:12 wiz Exp $
File handling under NetBSD is the same as under Linux.
https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478072
Support OpenBSD.
Support Solaris.
--- src/s_file.c.orig 2011-03-19 22:22:27.000000000 +0000
+++ src/s_file.c
@@ -36,7 +36,7 @@ int sys_defeatrt;
@ -10,7 +14,7 @@ https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478
void sys_doflags( void);
-#if defined(__linux__) || defined(__CYGWIN__) || defined(__FreeBSD_kernel__) || defined(__GNU__) || defined(ANDROID)
+#if defined(__linux__) || defined(__CYGWIN__) || defined(__FreeBSD_kernel__) || defined(__GNU__) || defined(ANDROID) || defined(__NetBSD__) || defined(__sun)
+#if defined(__linux__) || defined(__CYGWIN__) || defined(__FreeBSD_kernel__) || defined(__GNU__) || defined(ANDROID) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__sun)
static char *sys_prefbuf;
static int sys_prefbufsize;

View file

@ -1,11 +1,15 @@
$NetBSD: patch-src_s__loader.c,v 1.3 2012/02/15 22:36:39 hans Exp $
$NetBSD: patch-src_s__loader.c,v 1.4 2013/05/29 11:26:12 wiz Exp $
Define extensions for NetBSD.
https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478072
Define extensions for OpenBSD.
Define extensions for Solaris.
--- src/s_loader.c.orig 2010-07-29 03:50:34.000000000 +0000
+++ src/s_loader.c
@@ -38,6 +38,18 @@ a fat binary or an indication of the ins
@@ -38,6 +38,24 @@ a fat binary or an indication of the ins
#ifdef __FreeBSD__
static char sys_dllextent[] = ".b_i386", sys_dllextent2[] = ".pd_freebsd";
@ -15,6 +19,12 @@ https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478
+# else
+static char sys_dllextent[] = ".n_i386", sys_dllextent2[] = ".pd_netbsd";
+# endif
+#elif defined(__OpenBSD__)
+# ifdef __x86_64__
+static char sys_dllextent[] = ".b_ia64", sys_dllextent2[] = ".pd_openbsd";
+# else
+static char sys_dllextent[] = ".b_i386", sys_dllextent2[] = ".pd_openbsd";
+# endif
+#elif defined(__sun)
+# ifdef __x86_64__
+static char sys_dllextent[] = ".s_ia64", sys_dllextent2[] = ".pd_sunos";

View file

@ -1,8 +1,12 @@
$NetBSD: patch-src_x__misc.c,v 1.3 2012/02/15 22:36:39 hans Exp $
$NetBSD: patch-src_x__misc.c,v 1.4 2013/05/29 11:26:12 wiz Exp $
Define missing symbol the same as on FreeBSD/Mac OS X.
Define missing symbol the same as on FreeBSD/Mac OS X for NetBSD.
https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478072
Define missing symbol the same as on FreeBSD/Mac OS X for OpenBSD.
Define missing symbol the same as on FreeBSD/Mac OS X for Solaris.
--- src/x_misc.c.orig 2010-07-28 20:55:17.000000000 +0000
+++ src/x_misc.c
@@ -20,7 +20,7 @@
@ -10,7 +14,7 @@ https://sourceforge.net/tracker/?func=detail&aid=3411732&group_id=55736&atid=478
#endif /* _WIN32 */
-#if defined (__APPLE__) || defined (__FreeBSD__)
+#if defined (__APPLE__) || defined (__FreeBSD__) || defined(__NetBSD__) || defined(__sun)
+#if defined (__APPLE__) || defined (__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__sun)
#define CLOCKHZ CLK_TCK
#endif
#if defined (__linux__) || defined (__CYGWIN__) || defined (ANDROID)