Version 1.9.0

User-visible changes:
- General:
  * make all commands provide brief description in help output (r1522518)
  * flush stdout before exiting to avoid information being lost (r1543868)

- Major new features:
  * fsfs: new format 7 with more efficient on-disk layout (r1547045 et al)
  * resolve: improve interactive conflict resolution menus
  * blame: support showing prospective as well as previous changes
  * info: support printing of individual values with --show-item (r1662620)
  * svn auth: new subcommand to manage cached credentials and certs
  * svnserve: cache config and authz to lower resource usage and be able to
    serve large numbers of connections with a limited number of threads
  * membuffer: quadruple the maximum cacheable directory size (r1545948 et al)
  * new filesystem fsx (faster, smaller); experimental - see release notes

- Minor new features and improvements:
See http://svn.apache.org/repos/asf/subversion/tags/1.9.0/CHANGES
This commit is contained in:
adam 2015-08-13 20:47:41 +00:00
parent 2e86d0f24d
commit c757e6a2a8
13 changed files with 1211 additions and 584 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.31 2015/04/06 08:17:25 adam Exp $ # $NetBSD: Makefile,v 1.32 2015/08/13 20:47:41 adam Exp $
PKGNAME= java-subversion-${SVNVER} PKGNAME= java-subversion-${SVNVER}
PKGREVISION= 1
COMMENT= Java bindings for Subversion COMMENT= Java bindings for Subversion
MAKE_JOBS_SAFE= no MAKE_JOBS_SAFE= no

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.84 2015/06/12 10:49:58 wiz Exp $ # $NetBSD: Makefile,v 1.85 2015/08/13 20:47:42 adam Exp $
PKGNAME= p5-subversion-${SVNVER} PKGNAME= p5-subversion-${SVNVER}
PKGREVISION= 2
COMMENT= Perl bindings for Subversion COMMENT= Perl bindings for Subversion
.include "../../devel/subversion/Makefile.common" .include "../../devel/subversion/Makefile.common"

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.64 2015/04/06 08:17:26 adam Exp $ # $NetBSD: Makefile,v 1.65 2015/08/13 20:47:42 adam Exp $
PKGNAME= ${PYPKGPREFIX}-subversion-${SVNVER} PKGNAME= ${PYPKGPREFIX}-subversion-${SVNVER}
PKGREVISION= 1
COMMENT= Python bindings and tools for Subversion COMMENT= Python bindings and tools for Subversion
.include "../../devel/subversion/Makefile.common" .include "../../devel/subversion/Makefile.common"

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.53 2015/04/06 08:17:27 adam Exp $ # $NetBSD: Makefile,v 1.54 2015/08/13 20:47:42 adam Exp $
PKGNAME= ${RUBY_PKGPREFIX}-subversion-${SVNVER} PKGNAME= ${RUBY_PKGPREFIX}-subversion-${SVNVER}
PKGREVISION= 1
COMMENT= Ruby bindings for Subversion COMMENT= Ruby bindings for Subversion
.include "../../devel/subversion/Makefile.common" .include "../../devel/subversion/Makefile.common"

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.97 2015/04/06 08:17:14 adam Exp $ # $NetBSD: Makefile,v 1.98 2015/08/13 20:47:42 adam Exp $
PKGNAME= subversion-base-${SVNVER} PKGNAME= subversion-base-${SVNVER}
PKGREVISION= 1
COMMENT= Version control system, base programs and libraries COMMENT= Version control system, base programs and libraries
# on at least solaris, configure fails to figure out # on at least solaris, configure fails to figure out

View file

@ -1,7 +1,9 @@
@comment $NetBSD: PLIST,v 1.23 2014/03/11 14:05:01 jperkin Exp $ @comment $NetBSD: PLIST,v 1.24 2015/08/13 20:47:42 adam Exp $
bin/svn bin/svn
bin/svnadmin bin/svnadmin
bin/svnbench
bin/svndumpfilter bin/svndumpfilter
bin/svnfsfs
bin/svnlook bin/svnlook
bin/svnmucc bin/svnmucc
bin/svnrdump bin/svnrdump
@ -51,6 +53,7 @@ include/subversion-1/svn_user.h
include/subversion-1/svn_utf.h include/subversion-1/svn_utf.h
include/subversion-1/svn_version.h include/subversion-1/svn_version.h
include/subversion-1/svn_wc.h include/subversion-1/svn_wc.h
include/subversion-1/svn_x509.h
include/subversion-1/svn_xml.h include/subversion-1/svn_xml.h
lib/libsvn_client-1.la lib/libsvn_client-1.la
lib/libsvn_delta-1.la lib/libsvn_delta-1.la
@ -59,6 +62,7 @@ lib/libsvn_fs-1.la
lib/libsvn_fs_fs-1.la lib/libsvn_fs_fs-1.la
${PLIST.db4}lib/libsvn_fs_base-1.la ${PLIST.db4}lib/libsvn_fs_base-1.la
lib/libsvn_fs_util-1.la lib/libsvn_fs_util-1.la
lib/libsvn_fs_x-1.la
lib/libsvn_ra-1.la lib/libsvn_ra-1.la
lib/libsvn_ra_local-1.la lib/libsvn_ra_local-1.la
${PLIST.serf}lib/libsvn_ra_serf-1.la ${PLIST.serf}lib/libsvn_ra_serf-1.la
@ -66,6 +70,21 @@ lib/libsvn_ra_svn-1.la
lib/libsvn_repos-1.la lib/libsvn_repos-1.la
lib/libsvn_subr-1.la lib/libsvn_subr-1.la
lib/libsvn_wc-1.la lib/libsvn_wc-1.la
lib/pkgconfig/libsvn_client.pc
lib/pkgconfig/libsvn_delta.pc
lib/pkgconfig/libsvn_diff.pc
lib/pkgconfig/libsvn_fs.pc
lib/pkgconfig/libsvn_fs_base.pc
lib/pkgconfig/libsvn_fs_fs.pc
lib/pkgconfig/libsvn_fs_util.pc
lib/pkgconfig/libsvn_fs_x.pc
lib/pkgconfig/libsvn_ra.pc
lib/pkgconfig/libsvn_ra_local.pc
lib/pkgconfig/libsvn_ra_serf.pc
lib/pkgconfig/libsvn_ra_svn.pc
lib/pkgconfig/libsvn_repos.pc
lib/pkgconfig/libsvn_subr.pc
lib/pkgconfig/libsvn_wc.pc
man/man1/svn.1 man/man1/svn.1
man/man1/svnadmin.1 man/man1/svnadmin.1
man/man1/svndumpfilter.1 man/man1/svndumpfilter.1

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.40 2013/11/29 13:49:27 adam Exp $ # $NetBSD: Makefile.common,v 1.41 2015/08/13 20:47:42 adam Exp $
# used by devel/java-subversion/Makefile # used by devel/java-subversion/Makefile
# used by devel/p5-subversion/Makefile # used by devel/p5-subversion/Makefile
# used by devel/py-subversion/Makefile # used by devel/py-subversion/Makefile
@ -31,9 +31,9 @@ DISTINFO_FILE= ${.CURDIR}/../../devel/subversion/distinfo
FILESDIR= ${.CURDIR}/../../devel/subversion/files FILESDIR= ${.CURDIR}/../../devel/subversion/files
PATCHDIR= ${.CURDIR}/../../devel/subversion/patches PATCHDIR= ${.CURDIR}/../../devel/subversion/patches
USE_LIBTOOL= YES USE_LIBTOOL= yes
USE_PKGLOCALEDIR= YES USE_PKGLOCALEDIR= yes
GNU_CONFIGURE= YES GNU_CONFIGURE= yes
.include "../../mk/bsd.prefs.mk" .include "../../mk/bsd.prefs.mk"
.include "../../devel/subversion-base/options.mk" .include "../../devel/subversion-base/options.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.version,v 1.72 2015/03/31 20:32:11 adam Exp $ # $NetBSD: Makefile.version,v 1.73 2015/08/13 20:47:42 adam Exp $
# When updating subversion, all packages are updated at the same time # When updating subversion, all packages are updated at the same time
# to have a consistent set of packages. A particularly tricky aspect # to have a consistent set of packages. A particularly tricky aspect
@ -7,5 +7,5 @@
# changing the version. # changing the version.
.if !defined(SVNVER) .if !defined(SVNVER)
SVNVER= 1.8.13 SVNVER= 1.9.0
.endif .endif

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.95 2015/03/31 20:32:11 adam Exp $ $NetBSD: distinfo,v 1.96 2015/08/13 20:47:42 adam Exp $
SHA1 (subversion-1.8.13.tar.bz2) = aa0bd14ac6a8f0fb178cc9ff325387de01cd7452 SHA1 (subversion-1.9.0.tar.bz2) = 2ba78f59b3669e461ef6f56326426918100e2073
RMD160 (subversion-1.8.13.tar.bz2) = 7d73be6695030b1eff81aad0b9a934886eaa73f2 RMD160 (subversion-1.9.0.tar.bz2) = a09e98804de413c9b39e5f41b3b5f92196f8992b
Size (subversion-1.8.13.tar.bz2) = 6863330 bytes Size (subversion-1.9.0.tar.bz2) = 7743404 bytes
SHA1 (patch-ad) = ae54d77447c2ef746bca21f755aa7c255c9521b9 SHA1 (patch-ad) = 27c13ae7564e2c4974cf0084acd4bd7582b894b0
SHA1 (patch-ae) = 0e9816be14d0fa33e88e12c8087f7d53dead4ed8 SHA1 (patch-ae) = a9cd7d26fb5f9da8ff81413ef32948ccd6c4290e
SHA1 (patch-tools_dev_benchmarks_large__dirs_create__bigdir.sh) = ff19087ff4d348fdcf904eb52406f6b717fe444a SHA1 (patch-tools_dev_benchmarks_large__dirs_create__bigdir.sh) = ff19087ff4d348fdcf904eb52406f6b717fe444a

File diff suppressed because one or more lines are too long

View file

@ -1,13 +1,22 @@
$NetBSD: patch-ad,v 1.15 2011/03/04 03:12:36 taca Exp $ $NetBSD: patch-ad,v 1.16 2015/08/13 20:47:42 adam Exp $
--- Makefile.in.orig 2010-11-25 17:55:59.000000000 +0000 --- Makefile.in.orig 2015-07-26 23:03:10.000000000 +0000
+++ Makefile.in +++ Makefile.in
@@ -682,7 +682,7 @@ $(SWIG_PL_DIR)/native/Makefile.PL: $(SWI @@ -89,7 +89,7 @@ swig_rbdir = $(SWIG_RB_SITE_ARCH_DIR)/sv
toolsdir = @bindir@/svn-tools
# where to install pkg-config files
-pkgconfig_dir = $(datadir)/pkgconfig
+pkgconfig_dir = $(libdir)/pkgconfig
javahl_javadir = @libdir@/svn-javahl
javahl_javahdir = @libdir@/svn-javahl/include
@@ -837,7 +837,7 @@ $(SWIG_PL_DIR)/native/Makefile.PL: $(SWI
./config.status subversion/bindings/swig/perl/native/Makefile.PL ./config.status subversion/bindings/swig/perl/native/Makefile.PL
$(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL $(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
- cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL - cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL PREFIX=$(prefix)
+ cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL INSTALLDIRS=vendor + cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL PREFIX=$(prefix) INSTALLDIRS=vendor
# There is a "readlink -f" command on some systems for the same purpose, # There is a "readlink -f" command on some systems for the same purpose,
# but it's not as portable (e.g. Mac OS X doesn't have it). These should # but it's not as portable (e.g. Mac OS X doesn't have it). These should

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ae,v 1.21 2013/09/18 12:15:57 obache Exp $ $NetBSD: patch-ae,v 1.22 2015/08/13 20:47:42 adam Exp $
* tell location of libraries from subversion base package. * tell location of libraries from subversion base package.
--- subversion/bindings/swig/perl/native/Makefile.PL.in.orig 2012-12-14 06:05:48.000000000 +0000 --- subversion/bindings/swig/perl/native/Makefile.PL.in.orig 2014-01-17 04:54:43.000000000 +0000
+++ subversion/bindings/swig/perl/native/Makefile.PL.in +++ subversion/bindings/swig/perl/native/Makefile.PL.in
@@ -35,9 +35,11 @@ my $svnlib_srcdir = "${top_srcdir}/subve @@ -35,9 +35,11 @@ my $svnlib_srcdir = "${top_srcdir}/subve
my $svnlib_builddir = "${top_builddir}/subversion"; my $svnlib_builddir = "${top_builddir}/subversion";
@ -15,4 +15,4 @@ $NetBSD: patch-ae,v 1.21 2013/09/18 12:15:57 obache Exp $
+ $subversion_base_lib, + $subversion_base_lib,
map { abs_path($svnlib_builddir) . "/libsvn_$_/.libs" } map { abs_path($svnlib_builddir) . "/libsvn_$_/.libs" }
@modules, qw/diff subr ra_local ra_svn ra_serf @modules, qw/diff subr ra_local ra_svn ra_serf
fs_base fs_util fs_fs/); fs_base fs_util fs_fs fs_x/);

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.70 2015/04/06 08:17:39 adam Exp $ # $NetBSD: Makefile,v 1.71 2015/08/13 20:47:42 adam Exp $
PKGNAME= ${APACHE_PKG_PREFIX}-subversion-${SVNVER} PKGNAME= ${APACHE_PKG_PREFIX}-subversion-${SVNVER}
PKGREVISION= 1
COMMENT= WebDAV server (Apache module) for Subversion COMMENT= WebDAV server (Apache module) for Subversion
.include "../../devel/subversion/Makefile.common" .include "../../devel/subversion/Makefile.common"