Update to 2.7c. Straight from the NEWS file:

Bug Fixes:
 Install two DLLs for the Win32 version.  Don't crash for HTTP servers that send
 headers prefixed with whitespace.  Make the "edit selected entry" option work.
 Don't write uncompressed data to the cache with a header saying it is
 compressed.  Be more lenient in detecting spiders that cannot make requests.
 The wwwoffle-tools programs now handle dir names as if they had http:// in
 front.  Disallow wwwoffle requests for protocols that WWWOFFLE does not
 handle.  Use the command line config filename in error messages.  Fix to allow
 compilation on SGI IRIX.  Handle XHTML style tags when modifying HTML.  Updated
 setuid/setgid code.  Some memory leaks removed and potential crashes removed
 due to using lint).

New Features:
 Split up Set-Cookie headers since browsers can't handle them.
 Don't request deflated data since WWWOFFLE and servers don't agree on format.
 Added a form on the monitor options page to stop monitoring a URL.
 The confirm-requests option now asks for confirmation for page reloads.

Documentation:
 Update FAQ to reference privoxy as well as JunkBuster.
 Describe how to modify htdig templates to work with WWWOFFLE.
This commit is contained in:
fredb 2002-07-16 14:28:07 +00:00
parent b250653f67
commit c75fe1231c
3 changed files with 5 additions and 20 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.36 2002/04/25 10:43:26 fredb Exp $
# $NetBSD: Makefile,v 1.37 2002/07/16 14:28:07 fredb Exp $
DISTNAME= wwwoffle-2.7b
PKGNAME= wwwoffle-2.7.2
DISTNAME= wwwoffle-2.7c
CATEGORIES= www
MASTER_SITES= ftp://ftp.demon.co.uk/pub/unix/httpd/ \
http://www.gedanken.freeserve.co.uk/download-wwwoffle/ \

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.11 2002/05/14 15:37:19 fredb Exp $
$NetBSD: distinfo,v 1.12 2002/07/16 14:28:07 fredb Exp $
SHA1 (wwwoffle-2.7b.tgz) = fb9d8c4a374e9fe1c339537af756896f6dd1172d
Size (wwwoffle-2.7b.tgz) = 857511 bytes
SHA1 (wwwoffle-2.7c.tgz) = 6260ba0f039ad5430f2e9c31d702e3da35b92a44
Size (wwwoffle-2.7c.tgz) = 867164 bytes
SHA1 (patch-aa) = 897de385a47826e16a8a09b1bc1c207a2d350f94
SHA1 (patch-ab) = 976d43802c8d8db406b1e5bceead2903c6ef33bf

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.7 2002/05/14 15:37:20 fredb Exp $
--- src/headbody.c.orig Sat Apr 13 09:45:24 2002
+++ src/headbody.c
@@ -205,7 +205,7 @@
{
/* Append text to the last header line */
- if(!head->key[head->n-1])
+ if(head->n==0 || !head->key[head->n-1])
return; /* weird: there must be a last header... */
head->size+=strlen(val);