Update sysutils/htop to 2.0.2
Changes: Mac OS X: stop trying when task_for_pid fails for a process, stops spamming logs with errors. Add Ctrl+A and Ctrl+E to go to beginning and end of line FreeBSD: fixes for CPU calculation (thanks to Tim Creech, Andy Pilate) Usability: auto-follow process after a search. Use Linux backend on GNU Hurd Improvement for reproducible builds. BUGFIX: Fix behavior of Alt-key combinations (thanks to Kang-Che Sung) Various code tweaks and cleanups (thanks to Kang-Che Sung)
This commit is contained in:
parent
0696fb99ee
commit
c767ece990
3 changed files with 19 additions and 34 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.12 2016/05/06 16:00:47 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2016/07/22 05:30:58 maya Exp $
|
||||
|
||||
DISTNAME= htop-2.0.1
|
||||
DISTNAME= htop-2.0.2
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://hisham.hm/htop/releases/${PKGVERSION_NOREV}/
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.8 2016/05/06 16:00:47 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.9 2016/07/22 05:30:58 maya Exp $
|
||||
|
||||
SHA1 (htop-2.0.1.tar.gz) = ef9adab68b0218a16936c306f635e7fce227b7e6
|
||||
RMD160 (htop-2.0.1.tar.gz) = e9dbf292c7edd7eb67f694c0df281c2c4d27a003
|
||||
SHA512 (htop-2.0.1.tar.gz) = 57991a55b69028c01549b067ec749099466df5b08a0ed9a65dd779e6d2c8ee0a5d9c330bb6c727b04a349146ad441b7115718e433d1f8232f74b28903fb351ff
|
||||
Size (htop-2.0.1.tar.gz) = 477196 bytes
|
||||
SHA1 (patch-configure.ac) = 0e3cfeb585b8c0b30a28b611d90ed7e5efa57d20
|
||||
SHA1 (htop-2.0.2.tar.gz) = 201f793f13dce2448e36047079875b9bd5bba75a
|
||||
RMD160 (htop-2.0.2.tar.gz) = af17b9f7e1744e2db4d6a28c95cdfb9536343786
|
||||
SHA512 (htop-2.0.2.tar.gz) = 1c9bf71a36c56b301667aa6d03756fc757fbcb63e848d9581d10db3df6193cdeb00e55ceb6e2392794ac03ea034b04459a8fe550b3ac2318cd86263a74c78cda
|
||||
Size (htop-2.0.2.tar.gz) = 476364 bytes
|
||||
SHA1 (patch-configure.ac) = 87557f0b0027462f244cd0c9e14739d10bbfc010
|
||||
|
|
|
@ -1,34 +1,19 @@
|
|||
$NetBSD: patch-configure.ac,v 1.4 2016/05/06 16:00:47 fhajny Exp $
|
||||
$NetBSD: patch-configure.ac,v 1.5 2016/07/22 05:30:58 maya Exp $
|
||||
|
||||
Add minimal NetBSD support.
|
||||
|
||||
--- configure.ac.orig 2016-03-07 21:12:25.000000000 +0000
|
||||
--- configure.ac.orig 2016-07-21 19:54:31.000000000 +0000
|
||||
+++ configure.ac
|
||||
@@ -39,6 +39,12 @@ case "$target" in
|
||||
*darwin*)
|
||||
my_htop_platform=darwin
|
||||
@@ -31,7 +31,7 @@ LT_INIT([disable-shared static])
|
||||
# Checks for platform.
|
||||
# ----------------------------------------------------------------------
|
||||
case "$target_os" in
|
||||
-linux*|gnu*)
|
||||
+linux*|gnu*|*solaris*|*netbsd*)
|
||||
my_htop_platform=linux
|
||||
;;
|
||||
+*netbsd*)
|
||||
+ my_htop_platform=linux
|
||||
+ ;;
|
||||
+*solaris*)
|
||||
+ my_htop_platform=linux
|
||||
+ ;;
|
||||
*)
|
||||
my_htop_platform=unsupported
|
||||
;;
|
||||
@@ -211,6 +217,10 @@ if test "$my_htop_platform" = "openbsd";
|
||||
AC_CHECK_LIB([kvm], [kvm_open], [], [missing_libraries="$missing_libraries libkvm"])
|
||||
fi
|
||||
|
||||
+if test "$my_htop_platform" = "netbsd"; then
|
||||
+ AC_CHECK_LIB([kvm], [kvm_open], [], [missing_libraries="$missing_libraries libkvm"])
|
||||
+fi
|
||||
+
|
||||
AC_ARG_ENABLE(linux_affinity, [AC_HELP_STRING([--enable-linux-affinity], [enable Linux sched_setaffinity and sched_getaffinity for affinity support, disables hwloc])], ,enable_linux_affinity="yes")
|
||||
if test "x$enable_linux_affinity" = xyes -a "x$cross_compiling" = xno; then
|
||||
AC_MSG_CHECKING([for usable sched_setaffinity])
|
||||
@@ -256,6 +266,8 @@ AM_CONDITIONAL([HTOP_LINUX], [test "$my_
|
||||
freebsd*|kfreebsd*)
|
||||
@@ -266,6 +266,8 @@ AM_CONDITIONAL([HTOP_LINUX], [test "$my_
|
||||
AM_CONDITIONAL([HTOP_FREEBSD], [test "$my_htop_platform" = freebsd])
|
||||
AM_CONDITIONAL([HTOP_OPENBSD], [test "$my_htop_platform" = openbsd])
|
||||
AM_CONDITIONAL([HTOP_DARWIN], [test "$my_htop_platform" = darwin])
|
||||
|
|
Loading…
Reference in a new issue