Fix build with libtasn1-3.1.

Add comments to patches I modified.
This commit is contained in:
wiz 2013-07-06 22:20:33 +00:00
parent 6b80ae2d22
commit c7ac133115
3 changed files with 55 additions and 9 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.42 2011/12/28 21:23:17 joerg Exp $
$NetBSD: distinfo,v 1.43 2013/07/06 22:20:33 wiz Exp $
SHA1 (gnome-keyring-2.32.1.tar.bz2) = 3d0ecc3e29f426ecfcaa488ea17d3e330fe34eb6
RMD160 (gnome-keyring-2.32.1.tar.bz2) = cb72f171f5918ff26f40feb7bba90dc7e2e120ec
Size (gnome-keyring-2.32.1.tar.bz2) = 1619245 bytes
SHA1 (patch-ad) = d49bc78227646b3de3c357cd0f1e90cd38862ee4
SHA1 (patch-ae) = a4e6fabd0534a56b974ec799539ce93df6580ff1
SHA1 (patch-af) = f89bc8980fd966f330c67907b4534ba01f2591f9
SHA1 (patch-ag) = ab3e02f84cbfc80eba1483e0cc69c13d8beb6d01
SHA1 (patch-af) = 38738bc4441a6db38c27198ee22c8d3a77559844
SHA1 (patch-ag) = 56c977df4f0f43da04b5e39212551b00642ef674
SHA1 (patch-configure) = de2997d31a79ac573e4c5e339b9817f6cb84e2f0

View file

@ -1,8 +1,41 @@
$NetBSD: patch-af,v 1.3 2011/04/13 16:39:14 drochner Exp $
$NetBSD: patch-af,v 1.4 2013/07/06 22:20:33 wiz Exp $
First and second chunk: libtasn-3.1 compat.
Third chunk:
date: 2009-03-17 14:52:08 +0100; author: tnn; state: Exp;
Fix build failure due to 64-bit time_t.
--- egg/egg-asn1x.h.orig 2010-10-19 02:11:38.000000000 +0000
+++ egg/egg-asn1x.h
@@ -167,10 +167,10 @@ gboolean egg_asn1x_set_oid_as
@@ -25,6 +25,7 @@
#define EGG_ASN1X_H_
#include <glib.h>
+#include <libtasn1.h>
#ifndef HAVE_EGG_ALLOCATOR
typedef void* (*EggAllocator) (void* p, gsize);
@@ -33,15 +34,13 @@ typedef void* (*EggAllocator) (void* p,
typedef gboolean (*EggAsn1xEncoder) (gpointer data, guchar *buf, gsize n_buf);
-struct static_struct_asn;
-
-GNode* egg_asn1x_create (const struct static_struct_asn *defs,
+GNode* egg_asn1x_create (const ASN1_ARRAY_TYPE *defs,
const gchar *type);
-GNode* egg_asn1x_create_quark (const struct static_struct_asn *defs,
+GNode* egg_asn1x_create_quark (const ASN1_ARRAY_TYPE *defs,
GQuark type);
-GNode* egg_asn1x_create_and_decode (const struct static_struct_asn *defs,
+GNode* egg_asn1x_create_and_decode (const ASN1_ARRAY_TYPE *defs,
const gchar *type,
gconstpointer data,
gsize n_data);
@@ -167,10 +166,10 @@ gboolean egg_asn1x_set_oid_as
void egg_asn1x_destroy (gpointer asn);

View file

@ -1,8 +1,21 @@
$NetBSD: patch-ag,v 1.4 2011/05/12 12:54:17 adam Exp $
$NetBSD: patch-ag,v 1.5 2013/07/06 22:20:33 wiz Exp $
First chunk: libtasn1-3.1 compat.
Chunk 2: Fix building on systems where ulong is not defined.
Chunk 3+4: Fix build failure due to 64-bit time_t.
--- egg/egg-asn1x.c.orig 2010-10-19 02:11:38.000000000 +0000
+++ egg/egg-asn1x.c
@@ -1988,8 +1988,8 @@ anode_write_integer_ulong (gulong value,
@@ -49,8 +49,6 @@
#include "egg-asn1x.h"
-#include <libtasn1.h>
-
#include <stdlib.h>
#include <string.h>
@@ -1988,8 +1986,8 @@ anode_write_integer_ulong (gulong value,
guchar buf[sizeof (gulong)];
gint bytes, i, off;
@ -13,7 +26,7 @@ $NetBSD: patch-ag,v 1.4 2011/05/12 12:54:17 adam Exp $
buf[i] = (value >> (off * 8)) & 0xFF;
}
@@ -3746,11 +3746,11 @@ egg_asn1x_destroy (gpointer data)
@@ -3746,11 +3744,11 @@ egg_asn1x_destroy (gpointer data)
* TIME PARSING
*/
@ -27,7 +40,7 @@ $NetBSD: patch-ag,v 1.4 2011/05/12 12:54:17 adam Exp $
struct tm when;
gint offset = 0;
@@ -3777,11 +3777,11 @@ egg_asn1x_parse_time_general (const gcha
@@ -3777,11 +3775,11 @@ egg_asn1x_parse_time_general (const gcha
return value;
}