net/vino: Fix for DragonFly

Add socket.h (if available) to a header using sockaddr structure, fixes
build for DragonFly.
This commit is contained in:
marino 2011-11-26 17:14:54 +00:00
parent 8f6cf131e2
commit c7e8ee3ac0
2 changed files with 17 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.10 2011/05/04 17:46:22 drochner Exp $
$NetBSD: distinfo,v 1.11 2011/11/26 17:14:54 marino Exp $
SHA1 (vino-2.28.3.tar.bz2) = 5ffd9d9b3d9ecfd028468e1e889006929e5590af
RMD160 (vino-2.28.3.tar.bz2) = 885bdcab1f2993bbd9a74e78ede93f58a93d4eee
@ -6,3 +6,4 @@ Size (vino-2.28.3.tar.bz2) = 848908 bytes
SHA1 (patch-aa) = a79f5d6cae5377c9029e5f1dfaf9b76f6da7e0a2
SHA1 (patch-ab) = 81efc17f2d1275ea6131ffd44bdb8f50d0cf464e
SHA1 (patch-ac) = 69bf929df606e106bf9401fc3a5b2a0fc241b8e7
SHA1 (patch-ad) = 0e1b226e8c5ac5f9e3d3c7270b9a19a2314ef737

15
net/vino/patches/patch-ad Normal file
View file

@ -0,0 +1,15 @@
$NetBSD: patch-ad,v 1.1 2011/11/26 17:14:54 marino Exp $
--- server/libvncserver/rfb/rfb.h.orig 2011-05-02 16:07:11.000000000 +0000
+++ server/libvncserver/rfb/rfb.h
@@ -45,6 +45,10 @@ extern "C"
#include <sys/types.h>
#endif
+#ifdef HAVE_SYS_SOCKET_H
+#include <sys/socket.h>
+#endif
+
#ifndef HAVE_NETINET_IN_H
#include <netinet/in.h>
#endif