Update to 3.4.2:

* Fix static linking for mingw.
* Move the defaults so we can overwrite them depending on the
  platform.
* Finally fix static and dynamic plugins on mingw.
* Fixed being able to pass a ip%interface form of address string to
  a PIPSocket::Address and it still works correctly, using the ip
  part if there.
* Add the joined Makefile to the stable branch. Do not use it yet.
* Also delete static lib on make clean.
* Fixed correct upper/lower case comparisons as per RFC952 for
  domain names, which is not locale dependent, remove use of
  toupper().
* Killed the ununsed .major and .major.minor symlinks.
  The SONAME has always referred to the .major.minor.build lib.
* Switch the Makefiles in v2_4 like it was already done in trunk.
* Removed obsolete comment...
* Fixed gcc warning. Backport from TRUNK.
* Fixed Windows Speech API search directory to be more flexible.
* Make vfw configurable.
* STUN was not working with Open NAT.
* Applied patch for VXML not starting if not yet loaded and then
  not being started if later does get loaded. Thanks Antonio
  Rivera.
* Fixed incorrect port displayed in trace log for STUN, very
  confusing.
* Make sure CreateSocketPair also works with open nat.
* Fixed problem with "interface only" ip addresses not being parsed
  correctly on Windows Mobile systems.
* Windows Mobile build fixes
* More fixes to VXML, thank you Antonio Rivera
* Ensure Windows video output devices are available when using MSVC
  and not just MingW
  Backport from trunk
* Allow video file output device to work with new files
  Backport from trunk
* Fixed problem with PSafeCollection destructor deleting objects
  even if they still have a PSafePtr referencing them.
* Fix compilation without vfw.
This commit is contained in:
jmcneill 2008-10-25 18:12:34 +00:00
parent ea16291f2b
commit c8021ea592
5 changed files with 39 additions and 39 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.3 2008/09/22 23:36:54 jmcneill Exp $
# $NetBSD: Makefile,v 1.4 2008/10/25 18:12:34 jmcneill Exp $
DISTNAME= ptlib-2.4.1
DISTNAME= ptlib-2.4.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/ptlib/2.4/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2008/09/22 23:36:54 jmcneill Exp $
@comment $NetBSD: PLIST,v 1.4 2008/10/25 18:12:34 jmcneill Exp $
bin/ptlib-config
include/ptbuildopts.h
include/ptclib/asnber.h
@ -161,13 +161,11 @@ include/ptlib/video.h
include/ptlib/videoio.h
include/ptlib/videoio1394dc.h
lib/libpt.so
lib/libpt.so.2
lib/libpt.so.2.4
lib/libpt.so.2.4.1
lib/libpt.so.${PKGVERSION}
lib/libpt_s.a
lib/pkgconfig/ptlib.pc
lib/ptlib-2.4.1/devices/sound/oss_pwplugin.so
lib/ptlib-2.4.1/devices/videoinput/v4l2_pwplugin.so
lib/ptlib-${PKGVERSION}/devices/sound/oss_pwplugin.so
lib/ptlib-${PKGVERSION}/devices/videoinput/v4l2_pwplugin.so
share/ptlib/make/common.mak
share/ptlib/make/lib.mak
share/ptlib/make/plugins.mak
@ -178,10 +176,10 @@ share/ptlib/make/unix.mak
share/ptlib/version.h
@dirrm share/ptlib/make
@dirrm share/ptlib
@dirrm lib/ptlib-2.4.1/devices/videoinput
@dirrm lib/ptlib-2.4.1/devices/sound
@dirrm lib/ptlib-2.4.1/devices
@dirrm lib/ptlib-2.4.1
@dirrm lib/ptlib-2.4.2/devices/videoinput
@dirrm lib/ptlib-2.4.2/devices/sound
@dirrm lib/ptlib-2.4.2/devices
@dirrm lib/ptlib-2.4.2
@dirrm include/ptlib/unix/ptlib
@dirrm include/ptlib/unix
@dirrm include/ptlib

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.3 2008/09/22 23:36:54 jmcneill Exp $
# $NetBSD: buildlink3.mk,v 1.4 2008/10/25 18:12:34 jmcneill Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
PTLIB_BUILDLINK3_MK:= ${PTLIB_BUILDLINK3_MK}+
@ -12,8 +12,8 @@ BUILDLINK_PACKAGES+= ptlib
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}ptlib
.if !empty(PTLIB_BUILDLINK3_MK:M+)
BUILDLINK_API_DEPENDS.ptlib+= ptlib>=2.4.1
BUILDLINK_ABI_DEPENDS.ptlib?= ptlib>=2.4.1
BUILDLINK_API_DEPENDS.ptlib+= ptlib>=2.4.2
BUILDLINK_ABI_DEPENDS.ptlib?= ptlib>=2.4.2
BUILDLINK_PKGSRCDIR.ptlib?= ../../devel/ptlib
.endif # PTLIB_BUILDLINK3_MK

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.4 2008/09/22 23:36:54 jmcneill Exp $
$NetBSD: distinfo,v 1.5 2008/10/25 18:12:34 jmcneill Exp $
SHA1 (ptlib-2.4.1.tar.bz2) = f4c0e922730e70db53692f2c79ad9e08a0508070
RMD160 (ptlib-2.4.1.tar.bz2) = c507414762a677c059b4b005866c3885a7118247
Size (ptlib-2.4.1.tar.bz2) = 5085930 bytes
SHA1 (ptlib-2.4.2.tar.bz2) = d4fb343006fc108ca7cc0431a14cf4c4ea7233d3
RMD160 (ptlib-2.4.2.tar.bz2) = 110c53c4dc6f1144a5b11bb63b0f114fdeee2fc9
Size (ptlib-2.4.2.tar.bz2) = 3004289 bytes
SHA1 (patch-ac) = b0cb79c86fb0cf3182d08a33ad48a3f9becc9c20
SHA1 (patch-ad) = 04504e7549709f4936dc2c791b0fbcc425781c08
SHA1 (patch-ae) = 92d140bd9536837186a03a3d3230bbb207df0ae4
SHA1 (patch-af) = 837cf090245e924397118132bd9529bfc394e0b3
SHA1 (patch-ah) = e2612c09f253af3fe9a66d0624a7524e95f7e2d9
SHA1 (patch-ah) = 5d98d2037c1b389e098d993217f3cefb5050a908
SHA1 (patch-ai) = 47a7d53e52f5a28b0f25baaf1782a4152e6c6927

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ah,v 1.1.1.1 2008/09/12 13:18:26 jmcneill Exp $
$NetBSD: patch-ah,v 1.2 2008/10/25 18:12:34 jmcneill Exp $
--- src/ptlib/unix/socket.cxx.orig 2008-09-12 08:46:26.000000000 -0400
+++ src/ptlib/unix/socket.cxx 2008-09-12 08:57:49.000000000 -0400
--- src/ptlib/unix/socket.cxx.orig 2008-10-01 03:03:56.000000000 -0400
+++ src/ptlib/unix/socket.cxx 2008-10-25 13:26:34.000000000 -0400
@@ -67,6 +67,10 @@
#include <netinet/if_ether.h>
#endif
@ -13,7 +13,7 @@ $NetBSD: patch-ah,v 1.1.1.1 2008/09/12 13:18:26 jmcneill Exp $
#define ROUNDUP(a) \
((a) > 0 ? (1 + (((a) - 1) | (sizeof(long) - 1))) : sizeof(long))
@@ -462,6 +466,12 @@
@@ -471,6 +475,12 @@
PBYTEArray buffer;
struct ifconf ifConf;
@ -26,7 +26,7 @@ $NetBSD: patch-ah,v 1.1.1.1 2008/09/12 13:18:26 jmcneill Exp $
#ifdef SIOCGIFNUM
int ifNum;
PAssert(::ioctl(sock.GetHandle(), SIOCGIFNUM, &ifNum) >= 0, "could not do ioctl for ifNum");
@@ -477,8 +487,14 @@
@@ -486,8 +496,14 @@
ifreq * ifName = ifConf.ifc_req;
while (ifName < ifEndList) {
@ -41,7 +41,7 @@ $NetBSD: patch-ah,v 1.1.1.1 2008/09/12 13:18:26 jmcneill Exp $
if (ioctl(sock.GetHandle(), SIOCGIFFLAGS, &ifReq) >= 0) {
int flags = ifReq.ifr_flags;
@@ -490,14 +506,16 @@
@@ -499,14 +515,16 @@
}
}
@ -60,21 +60,21 @@ $NetBSD: patch-ah,v 1.1.1.1 2008/09/12 13:18:26 jmcneill Exp $
return PFalse;
}
@@ -1554,7 +1572,13 @@
@@ -1559,7 +1577,13 @@
PBYTEArray buffer;
struct ifconf ifConf;
+#if defined(P_NETBSD)
+ struct ifaddrs *ifap, *ifa;
+
+ PAssert(getifaddrs(&ifap) == 0, "getifaddrs failed");
+ PAssert(getifaddrs(&ifap) == 0, "getifaddrs failed");
+
+ for (ifa = ifap; ifa; ifa = ifa->ifa_next) {
+#else
// HERE
#if defined(SIOCGIFNUM)
int ifNum;
@@ -1570,9 +1594,14 @@
@@ -1575,9 +1599,14 @@
void * ifEndList = (char *)ifConf.ifc_req + ifConf.ifc_len;
ifreq * ifName = ifConf.ifc_req;
while (ifName < ifEndList) {
@ -90,31 +90,33 @@ $NetBSD: patch-ah,v 1.1.1.1 2008/09/12 13:18:26 jmcneill Exp $
if (ioctl(sock.GetHandle(), SIOCGIFFLAGS, &ifReq) >= 0) {
int flags = ifReq.ifr_flags;
@@ -1588,13 +1617,23 @@
@@ -1593,13 +1622,25 @@
}
#endif
+#if defined(P_NETBSD)
+#if !defined(P_NETBSD)
memcpy(&ifReq, ifName, sizeof(ifreq));
+#else
+ memset(&ifReq, 0, sizeof(ifReq));
+ strncpy(ifReq.ifr_name, ifa->ifa_name, sizeof(ifReq.ifr_name) - 1);
+#else
memcpy(&ifReq, ifName, sizeof(ifreq));
+#endif
+
if (ioctl(sock.GetHandle(), SIOCGIFADDR, &ifReq) >= 0) {
sockaddr_in * sin = (sockaddr_in *)&ifReq.ifr_addr;
PIPSocket::Address addr = sin->sin_addr;
+#if defined(P_NETBSD)
+#if !defined(P_NETBSD)
memcpy(&ifReq, ifName, sizeof(ifreq));
+#else
+ memset(&ifReq, 0, sizeof(ifReq));
+ strncpy(ifReq.ifr_name, ifa->ifa_name, sizeof(ifReq.ifr_name) - 1);
+#else
memcpy(&ifReq, ifName, sizeof(ifreq));
+#endif
+
if (ioctl(sock.GetHandle(), SIOCGIFNETMASK, &ifReq) >= 0) {
PIPSocket::Address mask =
#ifndef __BEOS__
@@ -1632,15 +1671,17 @@
#ifndef P_BEOS
@@ -1637,15 +1678,17 @@
}
}