Update ibus-pinyin to 1.4.0.

* ibus-1.4 support
* add option to support build without boost with c++0x feature
* and some fixes.
This commit is contained in:
obache 2012-04-22 14:02:50 +00:00
parent bbdefbdb10
commit c8047a2af4
4 changed files with 33 additions and 11 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.12 2012/03/10 10:56:13 obache Exp $
# $NetBSD: Makefile,v 1.13 2012/04/22 14:02:50 obache Exp $
#
DISTNAME= ibus-pinyin-1.3.11
PKGREVISION= 5
DISTNAME= ibus-pinyin-1.4.0
CATEGORIES= inputmethod chinese
MASTER_SITES= http://ibus.googlecode.com/files/
DISTFILES= ${DEFAULT_DISTFILES} ${DBTAR}
@ -38,7 +37,6 @@ SUBST_SED.epython= -e 's;exec python;exec ${PYTHONBIN};g'
CONFIGURE_ARGS+= --localedir=${PREFIX}/${PKGLOCALEDIR}/locale
CONFIGURE_ARGS+= --disable-db-android
CONFIGURE_ARGS+= --enable-db-open-phrase
CONFIGURE_ARGS+= --with-boost=${BUILDLINK_PREFIX.boost-headers}
.include "options.mk"
@ -50,13 +48,20 @@ CONFIGURE_ARGS+= --with-boost=${BUILDLINK_PREFIX.boost-headers}
.endif
.if (!empty(PKGSRC_COMPILER:Mgcc) && !empty(CC_VERSION:Mgcc-4.[4-9]*)) || !empty(PKGSRC_COMPILER:Mclang)
CXXFLAGS+= -std=c++0x
CONFIGURE_ARGS+= --disable-boost
.else
CONFIGURE_ARGS+= --enable-boost
CONFIGURE_ARGS+= --with-boost=${BUILDLINK_PREFIX.boost-headers}
.include "../../devel/boost-headers/buildlink3.mk"
SUBST_CLASSES+= shared_ptr
SUBST_STAGE.shared_ptr= post-configure
SUBST_FILES.shared_ptr= src/*.h
SUBST_SED.shared_ptr= -e 's,std::shared_ptr,boost::shared_ptr,g'
.endif
.include "../../inputmethod/ibus/bad-env-usage.mk"
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../devel/boost-headers/buildlink3.mk"
.include "../../inputmethod/ibus/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,8 +1,9 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/08/07 02:02:40 obache Exp $
@comment $NetBSD: PLIST,v 1.2 2012/04/22 14:02:50 obache Exp $
libexec/ibus-engine-pinyin
libexec/ibus-setup-pinyin
${PLIST.lua}share/ibus-pinyin/base.lua
share/ibus-pinyin/db/create_index.sql
share/ibus-pinyin/db/english.db
share/ibus-pinyin/db/open-phrase.db
share/ibus-pinyin/icons/chinese.svg
share/ibus-pinyin/icons/english.svg

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.2 2010/09/06 07:56:24 obache Exp $
$NetBSD: distinfo,v 1.3 2012/04/22 14:02:50 obache Exp $
SHA1 (ibus-pinyin-1.3.11.tar.gz) = 2999f28c208ec119c40c5b5eafcfbb8a78bba706
RMD160 (ibus-pinyin-1.3.11.tar.gz) = 89f0945b55ffc8ec31972e4098fa5416e6224e33
Size (ibus-pinyin-1.3.11.tar.gz) = 1659622 bytes
SHA1 (ibus-pinyin-1.4.0.tar.gz) = 499ceb4d3bec5614f88322b8e7695c04586b63e9
RMD160 (ibus-pinyin-1.4.0.tar.gz) = b1c540225e2204ebade5cfa527305898807c4dbf
Size (ibus-pinyin-1.4.0.tar.gz) = 1813003 bytes
SHA1 (pinyin-database-1.2.99.tar.bz2) = e38a148a772e9909facda66b2d579e17b94cccbe
RMD160 (pinyin-database-1.2.99.tar.bz2) = 1679567f31c20a235577f02175df38e16a05e7de
Size (pinyin-database-1.2.99.tar.bz2) = 9977983 bytes
SHA1 (patch-src_PYUtil.h) = 93e289e83abaec2fef6cd5a7cf924cd3bb6a20ad

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_PYUtil.h,v 1.1 2012/04/22 14:02:50 obache Exp $
* error `already defined' on NetBSD-5.1.2.
--- src/PYUtil.h.orig 2011-09-17 02:43:37.000000000 +0000
+++ src/PYUtil.h
@@ -43,7 +43,7 @@
namespace std {
// import boost::shared_ptr to std namespace
- using boost::shared_ptr;
+ // using boost::shared_ptr;
// import boost::scoped_ptr to std namespace, and rename to unique_ptr
// XXX: the unique_ptr can transfer the pointer ownership,
// but scoped_ptr cannot.