Update to OpenMPI 1.5.3:

1.5.3
-----

- Add missing "affinity" MPI extension (i.e., the OMPI_Affinity_str()
  API) that was accidentally left out of the 1.5.2 release.


1.5.2
-----

- Replaced all custom topology / affinity code with initial support
  for hwloc v1.1.1 (PLPA has been removed -- long live hwloc!).  Note
  that hwloc is bundled with Open MPI, but an external hwloc can be
  used, if desired.  See README for more details.
- Many CMake updates for Windows builds.
- Updated opal_cr_thread_sleep_wait MCA param default value to make it
  less aggressive.
- Updated debugger support to allow Totalview attaching from jobs
  launched directly via srun (not mpirun).  Thanks to Nikolay Piskun
  for the patch.
- Added more FTB/CIFTS support.
- Fixed compile error with the PGI compiler.
- Portability fixes to allow the openib BTL to run on the Solaris
  verbs stack.
- Fixed multi-token command-line issues when using the mpirun
  --debug switch.  For example:
      mpirun --debug -np 2 a.out "foo bar"
  Thanks to Gabriele Fatigati for reporting the issue.
- Added ARM support.
- Added the MPI_ROOT environment variable in the Open MPI Linux SRPM
  for customers who use the BPS and LSF batch managers.
- Updated ROMIO from MPICH v1.3.1 (plus one additional patch).
- Fixed some deprecated MPI API function notification messages.
- Added new "bfo" PML that provides failover on OpenFabrics networks.
- Fixed some buffer memcheck issues in MPI_*_init.
- Added Solaris-specific chip detection and performance improvements.
- Fix some compile errors on Solaris.
- Updated the "rmcast" framework with bug fixes, new functionality.
- Updated the Voltaire FCA component with bug fixes, new
  functionality.  Support for FCA version 2.1.
- Fix gcc 4.4.x and 4.5.x over-aggressive warning notifications on
  possibly freeing stack variables.  Thanks to the Gentoo packagers
  for reporting the issue.
- Make the openib component be verbose when it disqualifies itself due
  to MPI_THREAD_MULTIPLE.
- Minor man page fixes.
- Various checkpoint / restart fixes.
- Fix race condition in the one-sided unlock code.  Thanks to
  Guillaume Thouvenin for finding the issue.
- Improve help message aggregation.
- Add OMPI_Affinity_str() optional user-level API function (i.e., the
  "affinity" MPI extension).  See README for more details.
- Added btl_tcp_if_seq MCA parameter to select a different ethernet
  interface for each MPI process on a node.  This parameter is only
  useful when used with virtual ethernet interfaces on a single
  network card (e.g., when using virtual interfaces give dedicated
  hardware resources on the NIC to each process).
- Changed behavior of mpirun to terminate if it receives 10 (or more)
  SIGPIPEs.
- Fixed oversubscription detection.
- Added new mtl_mx_board and mtl_mx_endpoint MCA parameters.
- Added ummunotify support for OpenFabrics-based transports.  See the
  README for more details.
This commit is contained in:
asau 2011-03-23 05:32:29 +00:00
parent d97b0e19d9
commit c80c1fd2e4
4 changed files with 19 additions and 18 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.8 2010/12/16 21:00:53 asau Exp $
# $NetBSD: Makefile,v 1.9 2011/03/23 05:32:29 asau Exp $
DISTNAME= openmpi-1.5.1
DISTNAME= openmpi-1.5.3
CATEGORIES= parallel
MASTER_SITES= http://www.open-mpi.org/software/ompi/v1.5/downloads/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.5 2010/12/16 21:00:53 asau Exp $
@comment $NetBSD: PLIST,v 1.6 2011/03/23 05:32:29 asau Exp $
bin/mpiCC
bin/mpic++
bin/mpicc
@ -91,7 +91,6 @@ lib/openmpi/mca_coll_tuned.la
lib/openmpi/mca_crs_none.la
lib/openmpi/mca_dpm_orte.la
lib/openmpi/mca_errmgr_default.la
lib/openmpi/mca_ess_cm.la
lib/openmpi/mca_ess_env.la
lib/openmpi/mca_ess_hnp.la
lib/openmpi/mca_ess_singleton.la
@ -115,9 +114,10 @@ lib/openmpi/mca_odls_default.la
lib/openmpi/mca_oob_tcp.la
lib/openmpi/mca_osc_pt2pt.la
lib/openmpi/mca_osc_rdma.la
lib/openmpi/mca_paffinity_posix.la
lib/openmpi/mca_paffinity_hwloc.la
lib/openmpi/mca_plm_rsh.la
lib/openmpi/mca_plm_rshd.la
lib/openmpi/mca_pml_bfo.la
lib/openmpi/mca_pml_cm.la
lib/openmpi/mca_pml_csum.la
lib/openmpi/mca_pml_ob1.la
@ -505,6 +505,7 @@ share/openmpi/help-mpi-btl-tcp.txt
share/openmpi/help-mpi-coll-sm.txt
share/openmpi/help-mpi-common-sm.txt
share/openmpi/help-mpi-errors.txt
share/openmpi/help-mpi-pml-bfo.txt
share/openmpi/help-mpi-pml-csum.txt
share/openmpi/help-mpi-pml-ob1.txt
share/openmpi/help-mpi-runtime.txt

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.6 2010/12/16 21:00:53 asau Exp $
$NetBSD: distinfo,v 1.7 2011/03/23 05:32:29 asau Exp $
SHA1 (openmpi-1.5.1.tar.bz2) = fe21acc211fe60e30dc6bef1c83a70c34e093998
RMD160 (openmpi-1.5.1.tar.bz2) = 25b5b6e68c28eb406bee148d65908f876e7bd35b
Size (openmpi-1.5.1.tar.bz2) = 7410701 bytes
SHA1 (openmpi-1.5.3.tar.bz2) = 669565c708deab82ad4069d82675b2020eb0e0c6
RMD160 (openmpi-1.5.3.tar.bz2) = c1d0950c9a5c53c8543838adadf6a7477abe3989
Size (openmpi-1.5.3.tar.bz2) = 7589097 bytes
SHA1 (patch-aa) = 90f74e14eb686cd68bf29ea28cfb9818984f6408
SHA1 (patch-ai) = 0b03f80d15b176e10d804132b20cff835aa11566
SHA1 (patch-ai) = 650906ec3701cc7bac6b7f916c87506ccb885341
SHA1 (patch-aj) = dc85e6c9eb6db0eb40bb896a11c223afeda63c2f
SHA1 (patch-ak) = f6ea4220d51dd0c84ac2067d695c265f00904a0f

View file

@ -1,18 +1,18 @@
$NetBSD: patch-ai,v 1.2 2010/12/16 21:00:54 asau Exp $
$NetBSD: patch-ai,v 1.3 2011/03/23 05:32:29 asau Exp $
Install configuration files into example directory.
--- orte/etc/Makefile.in.orig 2009-11-04 18:01:21.000000000 +0300
+++ orte/etc/Makefile.in 2010-01-12 20:48:26.000000000 +0300
@@ -1018,6 +1018,7 @@
--- orte/etc/Makefile.in.orig 2011-03-09 17:51:05.000000000 +0300
+++ orte/etc/Makefile.in 2011-03-11 00:11:49.000000000 +0300
@@ -1051,6 +1051,7 @@
sharedstatedir = @sharedstatedir@
srcdir = @srcdir@
sysconfdir = @sysconfdir@
+exampledir = $(pkgdatadir)/examples
target_alias = @target_alias@
timer_aix_LIBS = @timer_aix_LIBS@
top_build_prefix = @top_build_prefix@
@@ -1223,19 +1224,19 @@
sysinfo_solaris_CFLAGS = @sysinfo_solaris_CFLAGS@
sysinfo_solaris_CPPFLAGS = @sysinfo_solaris_CPPFLAGS@
sysinfo_solaris_LDFLAGS = @sysinfo_solaris_LDFLAGS@
@@ -1264,19 +1265,19 @@
# details why the mkdir is in install-data-local.
install-data-local: