Update libthrift pacakge to 0.7.0.
Changes are too many to write here, please refer http://svn.apache.org/viewvc/thrift/tags/thrift-0.7.0/CHANGES in detail.
This commit is contained in:
parent
20b3b67506
commit
c815e65e2f
7 changed files with 44 additions and 53 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.8 2011/06/10 21:57:07 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2011/09/12 15:51:02 taca Exp $
|
||||
|
||||
DISTNAME= thrift-${THRIFT_VERSION}
|
||||
PKGNAME= libthrift-${THRIFT_VERSION}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_APACHE:=thrift/${THRIFT_VERSION}/}
|
||||
EXTRACT_SUFX= .tar.gz
|
||||
|
@ -21,7 +20,10 @@ USE_TOOLS+= gmake pkg-config
|
|||
GNU_CONFIGURE= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/thrift-${THRIFT_VERSION}
|
||||
THRIFT_VERSION= 0.6.1
|
||||
THRIFT_VERSION= 0.7.0
|
||||
|
||||
pre-build:
|
||||
${CHMOD} 0755 ${WRKSRC}/lib/erl/rebar
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2011/08/19 12:37:09 obache Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2011/09/12 15:51:02 taca Exp $
|
||||
bin/thrift
|
||||
include/thrift/TApplicationException.h
|
||||
include/thrift/TLogging.h
|
||||
include/thrift/TProcessor.h
|
||||
include/thrift/TReflectionLocal.h
|
||||
include/thrift/Thrift.h
|
||||
include/thrift/async/SimpleCallback.h
|
||||
include/thrift/async/TAsyncBufferProcessor.h
|
||||
include/thrift/async/TAsyncChannel.h
|
||||
include/thrift/async/TAsyncProcessor.h
|
||||
|
@ -47,6 +46,8 @@ include/thrift/transport/TFileTransport.h
|
|||
include/thrift/transport/THttpClient.h
|
||||
include/thrift/transport/THttpServer.h
|
||||
include/thrift/transport/THttpTransport.h
|
||||
include/thrift/transport/TSSLServerSocket.h
|
||||
include/thrift/transport/TSSLSocket.h
|
||||
include/thrift/transport/TServerSocket.h
|
||||
include/thrift/transport/TServerTransport.h
|
||||
include/thrift/transport/TShortReadTransport.h
|
||||
|
@ -71,6 +72,7 @@ ${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/ebin/thrift_http_transport.be
|
|||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/ebin/thrift_memory_buffer.beam
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/ebin/thrift_processor.beam
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/ebin/thrift_protocol.beam
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/ebin/thrift_reconnecting_client.beam
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/ebin/thrift_server.beam
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/ebin/thrift_service.beam
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/ebin/thrift_socket_server.beam
|
||||
|
@ -93,6 +95,7 @@ ${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/src/thrift_http_transport.erl
|
|||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/src/thrift_memory_buffer.erl
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/src/thrift_processor.erl
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/src/thrift_protocol.erl
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/src/thrift_reconnecting_client.erl
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/src/thrift_server.erl
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/src/thrift_service.erl
|
||||
${PLIST.erlang}lib/erlang/lib/thrift-${PKGVERSION}/src/thrift_socket_server.erl
|
||||
|
@ -148,6 +151,9 @@ ${PLIST.python}${PYSITELIB}/thrift/server/THttpServer.pyo
|
|||
${PLIST.python}${PYSITELIB}/thrift/server/TNonblockingServer.py
|
||||
${PLIST.python}${PYSITELIB}/thrift/server/TNonblockingServer.pyc
|
||||
${PLIST.python}${PYSITELIB}/thrift/server/TNonblockingServer.pyo
|
||||
${PLIST.python}${PYSITELIB}/thrift/server/TProcessPoolServer.py
|
||||
${PLIST.python}${PYSITELIB}/thrift/server/TProcessPoolServer.pyc
|
||||
${PLIST.python}${PYSITELIB}/thrift/server/TProcessPoolServer.pyo
|
||||
${PLIST.python}${PYSITELIB}/thrift/server/TServer.py
|
||||
${PLIST.python}${PYSITELIB}/thrift/server/TServer.pyc
|
||||
${PLIST.python}${PYSITELIB}/thrift/server/TServer.pyo
|
||||
|
@ -157,6 +163,9 @@ ${PLIST.python}${PYSITELIB}/thrift/server/__init__.pyo
|
|||
${PLIST.python}${PYSITELIB}/thrift/transport/THttpClient.py
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/THttpClient.pyc
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/THttpClient.pyo
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TSSLSocket.py
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TSSLSocket.pyc
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TSSLSocket.pyo
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TSocket.py
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TSocket.pyc
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TSocket.pyo
|
||||
|
@ -166,6 +175,9 @@ ${PLIST.python}${PYSITELIB}/thrift/transport/TTransport.pyo
|
|||
${PLIST.python}${PYSITELIB}/thrift/transport/TTwisted.py
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TTwisted.pyc
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TTwisted.pyo
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TZlibTransport.py
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TZlibTransport.pyc
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/TZlibTransport.pyo
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/__init__.py
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/__init__.pyc
|
||||
${PLIST.python}${PYSITELIB}/thrift/transport/__init__.pyo
|
||||
|
@ -213,10 +225,12 @@ ${PLIST.java}share/doc/thrift/java/help-doc.html
|
|||
${PLIST.java}share/doc/thrift/java/index-all.html
|
||||
${PLIST.java}share/doc/thrift/java/index.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/EncodingUtils.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/ProcessFunction.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/ShortStack.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/TApplicationException.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/TBase.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/TBaseHelper.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/TBaseProcessor.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/TByteArrayOutputStream.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/TDeserializer.html
|
||||
${PLIST.java}share/doc/thrift/java/org/apache/thrift/TEnum.html
|
||||
|
@ -341,6 +355,9 @@ ${PLIST.java}share/doc/thrift/java/overview-frame.html
|
|||
${PLIST.java}share/doc/thrift/java/overview-summary.html
|
||||
${PLIST.java}share/doc/thrift/java/overview-tree.html
|
||||
${PLIST.java}share/doc/thrift/java/package-list
|
||||
${PLIST.java}share/doc/thrift/java/resources/inherit.gif
|
||||
${PLIST.java}share/doc/thrift/java/resources/background.gif
|
||||
${PLIST.java}share/doc/thrift/java/resources/tab.gif
|
||||
${PLIST.java}share/doc/thrift/java/resources/titlebar.gif
|
||||
${PLIST.java}share/doc/thrift/java/resources/titlebar_end.gif
|
||||
${PLIST.java}share/doc/thrift/java/serialized-form.html
|
||||
${PLIST.java}share/doc/thrift/java/stylesheet.css
|
||||
|
|
|
@ -1,9 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.4 2011/06/03 13:39:44 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.5 2011/09/12 15:51:02 taca Exp $
|
||||
|
||||
SHA1 (thrift-0.6.1.tar.gz) = 0a764a5ffbf92291538c0c78457786c02f78f0fa
|
||||
RMD160 (thrift-0.6.1.tar.gz) = fc038573f6968f98e39e2d0fbe5399630f819f91
|
||||
Size (thrift-0.6.1.tar.gz) = 2034583 bytes
|
||||
SHA1 (patch-aa) = 3075afcacfc51f74e00c01109782ea85e4c57b32
|
||||
SHA1 (patch-ab) = b41c1c5b3a1e44dea10328b7e2ccddaecd8d03ce
|
||||
SHA1 (patch-lib__rb__Makefile.in) = b3dfc24c1e7b7a77f3ea8fc0e8ffa8a603de7cd8
|
||||
SHA1 (thrift-0.7.0.tar.gz) = b8f6877bc75878984355da4efe171ad99ff05b6a
|
||||
RMD160 (thrift-0.7.0.tar.gz) = d9db8ff077347134101cd017e086511c4317b052
|
||||
Size (thrift-0.7.0.tar.gz) = 2248326 bytes
|
||||
SHA1 (patch-lib__rb__setup.rb) = 4e08bb4c0828306ee2391f5d5760e74a5df30a73
|
||||
SHA1 (patch-lib_erl_Makefile.in) = 74bfbc9f191f685cb175801a495ae4af0eaa6e69
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2010/10/16 11:38:05 tonnerre Exp $
|
||||
|
||||
--- configure.orig 2010-10-08 00:09:33.000000000 +0000
|
||||
+++ configure
|
||||
@@ -15391,7 +15391,7 @@ $as_echo "#define HAVE_BOOST /**/" >>con
|
||||
fi
|
||||
|
||||
|
||||
- if test "x$succeeded" == "xyes" ; then
|
||||
+ if test "x$succeeded" = "xyes" ; then
|
||||
have_cpp="yes"
|
||||
fi
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2011/05/20 01:07:12 tonnerre Exp $
|
||||
|
||||
--- test/hs/run-test.sh.orig 2011-01-31 01:13:11.000000000 +0000
|
||||
+++ test/hs/run-test.sh
|
||||
@@ -19,7 +19,7 @@
|
||||
# under the License.
|
||||
#
|
||||
|
||||
-if [ "x" == "x$1" ]; then
|
||||
+if [ "x" = "x$1" ]; then
|
||||
printf "run-test.sh needs an argument, the name of the test to run. Try 'ThriftTest' or 'ProtoDebugTest'\n"
|
||||
exit 2
|
||||
fi
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-lib__rb__Makefile.in,v 1.1 2011/06/03 13:39:44 fhajny Exp $
|
||||
|
||||
Add DESTDIR support to Ruby installation.
|
||||
--- lib/rb/Makefile.in.orig 2011-06-03 07:19:09.444665000 +0000
|
||||
+++ lib/rb/Makefile.in
|
||||
@@ -426,7 +426,7 @@ all-local:
|
||||
$(RUBY) setup.rb setup
|
||||
|
||||
install-exec-hook:
|
||||
- $(RUBY) setup.rb install
|
||||
+ $(RUBY) setup.rb install --prefix=$(DESTDIR)
|
||||
|
||||
# Make sure this doesn't fail if Ruby is not configured.
|
||||
clean-local:
|
14
devel/libthrift/patches/patch-lib_erl_Makefile.in
Normal file
14
devel/libthrift/patches/patch-lib_erl_Makefile.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-lib_erl_Makefile.in,v 1.1 2011/09/12 15:51:02 taca Exp $
|
||||
|
||||
Build test directory before use it.
|
||||
|
||||
--- lib/erl/Makefile.in.orig 2011-08-11 13:19:02.000000000 +0000
|
||||
+++ lib/erl/Makefile.in
|
||||
@@ -481,6 +481,7 @@ uninstall-am: uninstall-info-am
|
||||
|
||||
|
||||
.generated: $(THRIFT_FILES)
|
||||
+ $(MKDIR_P) test
|
||||
for f in $(THRIFT_FILES) ; do \
|
||||
$(THRIFT) --gen erl -out test $$f ; \
|
||||
done ; \
|
Loading…
Reference in a new issue