Tighten JVM_MAX_HEAP used during the build to 800MB, so that the build

will work comfortable within a 2GB limit.
This commit is contained in:
joerg 2015-06-27 22:37:42 +00:00
parent 23b6bb83f7
commit c8673a82de
3 changed files with 54 additions and 13 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.20 2015/06/13 23:57:25 tnn Exp $
$NetBSD: distinfo,v 1.21 2015/06/27 22:37:42 joerg Exp $
SHA1 (openjdk7/bootstrap-jdk-1.7.76-freebsd-10-amd64-20150301.tar.xz) = 7408f52d3bbe35c2b14bbd3215cbf60f1335d334
RMD160 (openjdk7/bootstrap-jdk-1.7.76-freebsd-10-amd64-20150301.tar.xz) = 24f1577b5fc86d137f070aedb4610c8c89e45815
@ -46,7 +46,8 @@ SHA1 (patch-ba) = a54a25d4f8982ff4d2cb4e7e456fe2a44656b800
SHA1 (patch-bh) = 6194a7c319a496f8ff7df173912cf87118f26a63
SHA1 (patch-bi) = 190056b3d4c42986ae0a600668b02711598361b8
SHA1 (patch-bn) = a50dbe17236a90d60d4bbb852ae447e51a279892
SHA1 (patch-common_autoconf_generated-configure.sh) = f754ad280fc9bb235ddf515d84ddb4db0e0bf096
SHA1 (patch-common_autoconf_boot-jdk.m4) = b7f8722a25c1c7ab489a9fd65cf60fb4af9530eb
SHA1 (patch-common_autoconf_generated-configure.sh) = 44eb643c3741500bb1ad1c5c5a7806ac7aa4e9e2
SHA1 (patch-common_autoconf_spec.gmk.in) = e98bc4c8a09f49c6a26447e6f78abf4709ee694b
SHA1 (patch-hotspot_agent_src_share_classes_sun_jvm_hotspot_utilities_PlatformInfo.java) = 893f3b7ad0839a75be49ddd0f5eefcff2dbd2928
SHA1 (patch-hotspot_make_bsd_makefiles_defs.make) = 6b3e2f769c754b3ee5de8c07444964414136fa81

View file

@ -0,0 +1,22 @@
$NetBSD: patch-common_autoconf_boot-jdk.m4,v 1.1 2015/06/27 22:37:42 joerg Exp $
--- common/autoconf/boot-jdk.m4.orig 2015-06-27 20:05:32.000000000 +0000
+++ common/autoconf/boot-jdk.m4
@@ -324,16 +324,15 @@ AC_DEFUN_ONCE([BOOTJDK_SETUP_BOOT_JDK_AR
# Maximum amount of heap memory.
# Maximum stack size.
if test "x$BUILD_NUM_BITS" = x32; then
- JVM_MAX_HEAP=1100M
STACK_SIZE=768
else
# Running Javac on a JVM on a 64-bit machine, takes more space since 64-bit
# pointers are used. Apparently, we need to increase the heap and stack
# space for the jvm. More specifically, when running javac to build huge
# jdk batch
- JVM_MAX_HEAP=1600M
STACK_SIZE=1536
fi
+ JVM_MAX_HEAP=800M
ADD_JVM_ARG_IF_OK([-Xmx$JVM_MAX_HEAP],boot_jdk_jvmargs_big,[$JAVA])
ADD_JVM_ARG_IF_OK([-XX:ThreadStackSize=$STACK_SIZE],boot_jdk_jvmargs_big,[$JAVA])
ADD_JVM_ARG_IF_OK([-XX:PermSize=32m],boot_jdk_jvmargs_big,[$JAVA])

View file

@ -1,6 +1,6 @@
$NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51 tnn Exp $
$NetBSD: patch-common_autoconf_generated-configure.sh,v 1.5 2015/06/27 22:37:42 joerg Exp $
--- common/autoconf/generated-configure.sh.orig 2015-06-09 13:44:54.000000000 +0000
--- common/autoconf/generated-configure.sh.orig 2015-06-10 10:29:06.000000000 +0000
+++ common/autoconf/generated-configure.sh
@@ -6883,7 +6883,7 @@ test -n "$target_alias" &&
VAR_CPU_BITS=32
@ -42,7 +42,25 @@ $NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51
# This is not a symbolic link! We are done!
break
fi
@@ -19774,7 +19774,7 @@ $as_echo_n "checking resolved symbolic l
@@ -16217,16 +16217,15 @@ $as_echo_n "checking flags for boot jdk
# Maximum amount of heap memory.
# Maximum stack size.
if test "x$BUILD_NUM_BITS" = x32; then
- JVM_MAX_HEAP=1100M
STACK_SIZE=768
else
# Running Javac on a JVM on a 64-bit machine, takes more space since 64-bit
# pointers are used. Apparently, we need to increase the heap and stack
# space for the jvm. More specifically, when running javac to build huge
# jdk batch
- JVM_MAX_HEAP=1600M
STACK_SIZE=1536
fi
+ JVM_MAX_HEAP=800M
$ECHO "Check if jvm arg is ok: -Xmx$JVM_MAX_HEAP" >&5
$ECHO "Command: $JAVA -Xmx$JVM_MAX_HEAP -version" >&5
@@ -19774,7 +19773,7 @@ $as_echo_n "checking resolved symbolic l
# Resolve file symlinks
while test $COUNTER -lt 20; do
ISLINK=`$LS -l $sym_link_dir/$sym_link_file | $GREP '\->' | $SED -e 's/.*-> \(.*\)/\1/'`
@ -51,7 +69,7 @@ $NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51
# This is not a symbolic link! We are done!
break
fi
@@ -20212,7 +20212,7 @@ $as_echo_n "checking for resolved symbol
@@ -20212,7 +20211,7 @@ $as_echo_n "checking for resolved symbol
# Resolve file symlinks
while test $COUNTER -lt 20; do
ISLINK=`$LS -l $sym_link_dir/$sym_link_file | $GREP '\->' | $SED -e 's/.*-> \(.*\)/\1/'`
@ -60,7 +78,7 @@ $NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51
# This is not a symbolic link! We are done!
break
fi
@@ -21375,7 +21375,7 @@ $as_echo_n "checking resolved symbolic l
@@ -21375,7 +21374,7 @@ $as_echo_n "checking resolved symbolic l
# Resolve file symlinks
while test $COUNTER -lt 20; do
ISLINK=`$LS -l $sym_link_dir/$sym_link_file | $GREP '\->' | $SED -e 's/.*-> \(.*\)/\1/'`
@ -69,7 +87,7 @@ $NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51
# This is not a symbolic link! We are done!
break
fi
@@ -21813,7 +21813,7 @@ $as_echo_n "checking for resolved symbol
@@ -21813,7 +21812,7 @@ $as_echo_n "checking for resolved symbol
# Resolve file symlinks
while test $COUNTER -lt 20; do
ISLINK=`$LS -l $sym_link_dir/$sym_link_file | $GREP '\->' | $SED -e 's/.*-> \(.*\)/\1/'`
@ -78,7 +96,7 @@ $NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51
# This is not a symbolic link! We are done!
break
fi
@@ -29862,7 +29862,7 @@ fi
@@ -29862,7 +29861,7 @@ fi
#
case $COMPILER_NAME in
gcc )
@ -87,7 +105,7 @@ $NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51
-pipe \
-D_GNU_SOURCE -D_REENTRANT -D_LARGEFILE64_SOURCE"
case $OPENJDK_TARGET_CPU_ARCH in
@@ -30475,7 +30475,8 @@ $as_echo "alsa pulse x11" >&6; }
@@ -30475,7 +30474,8 @@ $as_echo "alsa pulse x11" >&6; }
if test "x$OPENJDK_TARGET_OS" = xbsd; then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking what is not needed on BSD?" >&5
$as_echo_n "checking what is not needed on BSD?... " >&6; }
@ -97,7 +115,7 @@ $NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51
ALSA_NOT_NEEDED=yes
PULSE_NOT_NEEDED=yes
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: alsa pulse" >&5
@@ -31701,7 +31702,11 @@ $as_echo "$as_me: WARNING: freetype not
@@ -31701,7 +31701,11 @@ $as_echo "$as_me: WARNING: freetype not
# Allow --with-freetype-lib and --with-freetype-include to override
if test "x$with_freetype_include" != x; then
@ -110,7 +128,7 @@ $NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51
fi
if test "x$with_freetype_lib" != x; then
POTENTIAL_FREETYPE_LIB_PATH="$with_freetype_lib"
@@ -34519,7 +34524,7 @@ $as_echo "$as_me: The path of FREETYPE_I
@@ -34519,7 +34523,7 @@ $as_echo "$as_me: The path of FREETYPE_I
FREETYPE_INCLUDE_PATH="`cd "$path"; $THEPWDCMD -L`"
fi
@ -119,7 +137,7 @@ $NetBSD: patch-common_autoconf_generated-configure.sh,v 1.4 2015/06/10 11:38:51
FREETYPE_CFLAGS="-I$FREETYPE_INCLUDE_PATH/freetype2 -I$FREETYPE_INCLUDE_PATH"
else
FREETYPE_CFLAGS="-I$FREETYPE_INCLUDE_PATH"
@@ -34652,7 +34657,7 @@ $as_echo "$as_me: The path of FREETYPE_L
@@ -34652,7 +34656,7 @@ $as_echo "$as_me: The path of FREETYPE_L
if test "x$OPENJDK_TARGET_OS" = xwindows; then
FREETYPE_LIBS="$FREETYPE_LIB_PATH/freetype.lib"
else