Adapt to new p5-Digest-MD5, will feed back changes to author.
This commit is contained in:
parent
5785fefa61
commit
c88dcfd625
4 changed files with 39 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.2 2001/09/15 22:33:46 mjl Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2001/09/19 03:44:39 mjl Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Apache-Session-1.53
|
||||
|
@ -10,7 +10,7 @@ MAINTAINER= packages@netbsd.org
|
|||
COMMENT= perl5 module to provide persistent storage
|
||||
|
||||
DEPENDS+= p5-Storable>=1.0.11:../../devel/p5-Storable/
|
||||
DEPENDS+= p5-Digest-MD5>=2.12:../../security/p5-Digest-MD5/
|
||||
DEPENDS+= p5-Digest-MD5>=2.16:../../security/p5-Digest-MD5/
|
||||
|
||||
USE_PERL5= # defined
|
||||
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Apache/Session/.packlist
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/05/21 21:49:03 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/09/19 03:44:39 mjl Exp $
|
||||
|
||||
SHA1 (Apache-Session-1.53.tar.gz) = bd1fb03954b91712daaf77334be87ddc80d98da7
|
||||
Size (Apache-Session-1.53.tar.gz) = 25572 bytes
|
||||
SHA1 (patch-aa) = c3d70b4a708611f9eeff3116cb4e55810c60c053
|
||||
SHA1 (patch-ab) = 4cc24c09b21b6305d502d9fcace129ed469d6e0d
|
||||
|
|
12
www/p5-Apache-Session/patches/patch-aa
Normal file
12
www/p5-Apache-Session/patches/patch-aa
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.1 2001/09/19 03:44:39 mjl Exp $
|
||||
|
||||
--- Makefile.PL.orig Wed Sep 19 05:38:17 2001
|
||||
+++ Makefile.PL Wed Sep 19 05:38:27 2001
|
||||
@@ -5,6 +5,6 @@
|
||||
|
||||
NAME => "Apache::Session",
|
||||
VERSION_FROM => "Session.pm",
|
||||
- PREREQ_PM => { MD5 => 0, Storable => 0 },
|
||||
+ PREREQ_PM => { Digest::MD5 => 0, Storable => 0 },
|
||||
'dist' => { COMPRESS=>"gzip", SUFFIX=>"gz" }
|
||||
);
|
22
www/p5-Apache-Session/patches/patch-ab
Normal file
22
www/p5-Apache-Session/patches/patch-ab
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ab,v 1.1 2001/09/19 03:44:39 mjl Exp $
|
||||
|
||||
--- Session/Generate/MD5.pm.orig Wed Sep 19 05:38:57 2001
|
||||
+++ Session/Generate/MD5.pm Wed Sep 19 05:39:38 2001
|
||||
@@ -11,7 +11,7 @@
|
||||
|
||||
use strict;
|
||||
use vars qw($VERSION);
|
||||
-use MD5;
|
||||
+use Digest::MD5;
|
||||
|
||||
$VERSION = '2.0';
|
||||
|
||||
@@ -24,7 +24,7 @@
|
||||
}
|
||||
|
||||
$session->{data}->{_session_id} =
|
||||
- substr(MD5->hexhash(MD5->hexhash(time(). {}. rand(). $$)), 0, $length);
|
||||
+ substr(Digest::MD5::md5_hex(Digest::MD5::md5_hex(time(). {}. rand(). $$)), 0, $length);
|
||||
|
||||
|
||||
}
|
Loading…
Reference in a new issue