Major cleanup:

- Use our libtool to build the "art_lgpl" library.
- Install documentation in "share/doc/gnome-libs".
- Use "/var/games" instead of "/var/gnome/games" for game score files.

This fixes PR pkg/6581 by Christian E. Hopps.
This commit is contained in:
tron 1998-12-29 17:53:10 +00:00
parent e35f6f1fda
commit c8947ca0c6
6 changed files with 95 additions and 16 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.9 1998/12/29 14:23:04 tron Exp $
# $NetBSD: Makefile,v 1.10 1998/12/29 17:53:10 tron Exp $
#
DISTNAME= gnome-libs-0.99.0
@ -8,6 +8,7 @@ MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
ftp://ftp.geo.net/pub/gnome/sources/
MAINTAINER= tron@netbsd.org
HOMEPAGE= http://www.gnome.org/
DEPENDS+= gtk+-1.1.9:../../x11/gtk
DEPENDS+= tiff-3.4:../../graphics/tiff

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ae,v 1.1 1998/12/29 17:53:11 tron Exp $
--- devel-docs/Makefile.in.orig Wed Dec 16 10:57:31 1998
+++ devel-docs/Makefile.in Tue Dec 29 17:45:24 1998
@@ -139,7 +139,7 @@
SUBDIRS = ui-guide templates
-htmldir = $(prefix)/html
+htmldir = $(prefix)/share/doc/gnome-libs/html
html_DATA = gnome-dev-info.html
TEXT_FILES = \
@@ -169,7 +169,7 @@
libgnome.sgml \
$(TEXT_FILES)
-docdir = $(prefix)/doc
+docdir = $(prefix)/share/doc/gnome-libs
doc_DATA = $(TEXT_FILES)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../config.h

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1 1998/12/29 17:53:11 tron Exp $
--- tools/gnome-doc/Makefile.in.orig Wed Dec 16 10:56:38 1998
+++ tools/gnome-doc/Makefile.in Tue Dec 29 17:56:38 1998
@@ -139,7 +139,7 @@
EXTRA_DIST = gnome-doc.el gnome-doc mkstub
-docdir = $(datadir)/doc
+docdir = $(datadir)/doc/gnome-libs
doc_DATA = $(EXTRA_DIST)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs

View file

@ -0,0 +1,24 @@
$NetBSD: patch-ag,v 1.1 1998/12/29 17:53:11 tron Exp $
--- gnome-data/Makefile.in.orig Wed Dec 16 10:57:33 1998
+++ gnome-data/Makefile.in Tue Dec 29 17:51:06 1998
@@ -147,7 +147,7 @@
gnome.mime \
paper.config
-scoredir=$(localstatedir)/games
+scoredir=/var/games
sysconf_DATA=paper.config mime-magic
soundlistdir = $(sysconfdir)/sound/events
@@ -304,8 +304,8 @@
install-data-local:
- $(mkinstalldirs) $(scoredir)
- -chgrp games $(scoredir) && chmod g=rwXs $(scoredir)
+# $(mkinstalldirs) $(scoredir)
+# -chgrp games $(scoredir) && chmod g=rwXs $(scoredir)
$(top_builddir)/libgnome/gnome-gen-mimedb $(sysconfdir)/mime-magic
# Tell versions [3.59,3.63) of GNU make to not export all variables.

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ah,v 1.1 1998/12/29 17:53:11 tron Exp $
--- libart_lgpl/configure.orig Wed Dec 16 10:52:25 1998
+++ libart_lgpl/configure Tue Dec 29 18:00:46 1998
@@ -1272,6 +1272,7 @@
fi
# Always use our own libtool.
+if false; then
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
# Check for any special flags to pass to ltconfig.
@@ -1316,6 +1317,7 @@
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
+fi
# Redirect the config.log output again, so that the ltconfig log is not
# clobbered by the next message.

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 1998/12/29 14:23:04 tron Exp $
@comment $NetBSD: PLIST,v 1.5 1998/12/29 17:53:11 tron Exp $
bin/convertrgb
bin/dns-helper
bin/gconfigger
@ -11,19 +11,11 @@ bin/gnome-moz-remote
bin/gnome-name-service
bin/gnome_segv
bin/goad-browser
doc/README.gtkcauldron
doc/README.gtkcauldron_for_python
doc/adding-sounds.txt
doc/api-comment-style.txt
doc/gtk_dialog_cauldron.3
doc/suggestions.txt
doc/mime-type-handling.txt
etc/mime-magic
etc/mime-magic.dat
etc/paper.config
etc/sound/events/gnome.soundlist
etc/sound/events/gtk-events.soundlist
@exec mkdir %D/html
include/gnome.h
include/popt-gnome.h
include/libart_lgpl/art_affine.h
@ -164,7 +156,6 @@ lib/gnome-libs/include/popt-gnome.h
lib/gnomeConf.sh
lib/libart_lgpl.a
lib/libart_lgpl.so.0.0
lib/libart_lgpl.la
lib/libartConf.sh
lib/libgnome.so.30.0
lib/libgnome.a
@ -180,9 +171,17 @@ lib/libzvt.a
lib/libzvt.so.0.0
sbin/gnome-pty-helper
share/aclocal/libart.m4
share/doc/gnome-doc.el
share/doc/gnome-doc
share/doc/mkstub
share/doc/gnome-libs/README.gtkcauldron
share/doc/gnome-libs/README.gtkcauldron_for_python
share/doc/gnome-libs/adding-sounds.txt
share/doc/gnome-libs/api-comment-style.txt
share/doc/gnome-libs/gnome-doc.el
share/doc/gnome-libs/gnome-doc
share/doc/gnome-libs/gtk_dialog_cauldron.3
share/doc/gnome-libs/mime-type-handling.txt
share/doc/gnome-libs/mkstub
share/doc/gnome-libs/suggestions.txt
@exec mkdir -p %D/share/doc/gnome-libs/html
share/idl/name-service.idl
share/idl/gnome-factory.idl
share/idl/Table.idl
@ -191,10 +190,8 @@ share/pixmaps/calculator-font.png
share/pixmaps/yes.xpm
share/pixmaps/no.xpm
share/gtkrc
@dirrm doc
@dirrm etc/sound/events
@dirrm etc/sound
@dirrm html
@dirrm include/libgnorba
@dirrm include/libgnome
@dirrm include/libgnomeui
@ -203,6 +200,8 @@ share/gtkrc
@dirrm include/zvt
@dirrm lib/gnome-libs/include
@dirrm lib/gnome-libs
@dirrm share/doc/gnome-libs/html
@dirrm share/doc/gnome-libs
@dirrm share/idl
@dirrm share/mime-info
@dirrm share/pixmaps