Update databases/py-barman to 1.6.0.
Version 1.6.0 - 29 Feb 2016 - Support for streaming replication connection through the streaming_conninfo server option - Support for the streaming_archiver option that allows Barman to receive WAL files through PostgreSQL's native streaming protocol. When set to 'on', it relies on pg_receivexlog to receive WAL data, reducing Recovery Point Objective. Currently, WAL streaming is an additional feature (standard log archiving is still required) - Implement the receive-wal command that, when streaming_archiver is on, wraps pg_receivexlog for WAL streaming. Add --stop option to stop receiving WAL files via streaming protocol. Add --reset option to reset the streaming status and restart from the current xlog in Postgres. - Automatic management (startup and stop) of receive-wal command via cron command - Support for the path_prefix configuration option - Introduction of the archiver option (currently fixed to on) which enables continuous WAL archiving for a specific server, through log shipping via PostgreSQL's archive_command - Support for streaming_wals_directory and errors_directory options - Management of WAL duplicates in archive-wal command and integration with check command - Verify if pg_receivexlog is running in check command when streaming_archiver is enabled - Verify if failed backups are present in check command - Accept compressed WAL files in incoming directory - Add support for the pigz compressor (thanks to Stefano Zacchiroli zack@upsilon.cc) - Implement pygzip and pybzip2 compressors (based on an initial idea of Christoph Moench-Tegeder christoph@2ndquadrant.de) - Creation of an implicit restore point at the end of a backup - Current size of the PostgreSQL data files in barman status - Permit archive_mode=always for PostgreSQL 9.5 servers (thanks to Christoph Moench-Tegeder christoph@2ndquadrant.de) - Complete refactoring of the code responsible for connecting to PostgreSQL - Improve messaging of cron command regarding sub-processes - Native support for Python >= 3.3 - Changes of behaviour: - Stop trashing WAL files during archive-wal (commit:e3a1d16) - Bug fixes: - Atomic WAL file archiving (#9 and #12) - Propagate "-c" option to any Barman subprocess (#19) - Fix management of backup ID during backup deletion (#22) - Improve archive-wal robustness and log messages (#24) - Improve error handling in case of missing parameters Version 1.5.1 - 16 Nov 2015 - Add support for the 'archive-wal' command which performs WAL maintenance operations on a given server - Add support for "per-server" concurrency of the 'cron' command - Improved management of xlog.db errors - Add support for mixed compression types in WAL files (SF.net#61) - Bug fixes: - Avoid retention policy checks during the recovery - Avoid 'wal_level' check on PostgreSQL version < 9.0 (#3) - Fix backup size calculation (#5)
This commit is contained in:
parent
4b1a8aef73
commit
c8d20ef953
4 changed files with 25 additions and 13 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.6 2015/10/20 08:42:43 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2016/03/04 16:55:45 fhajny Exp $
|
||||
|
||||
DISTNAME= barman-1.5.0
|
||||
DISTNAME= barman-1.6.0
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pgbarman/}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2015/10/20 08:42:43 fhajny Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2016/03/04 16:55:45 fhajny Exp $
|
||||
bin/barman
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
|
@ -44,9 +44,18 @@ ${PYSITELIB}/barman/lockfile.pyo
|
|||
${PYSITELIB}/barman/output.py
|
||||
${PYSITELIB}/barman/output.pyc
|
||||
${PYSITELIB}/barman/output.pyo
|
||||
${PYSITELIB}/barman/postgres.py
|
||||
${PYSITELIB}/barman/postgres.pyc
|
||||
${PYSITELIB}/barman/postgres.pyo
|
||||
${PYSITELIB}/barman/process.py
|
||||
${PYSITELIB}/barman/process.pyc
|
||||
${PYSITELIB}/barman/process.pyo
|
||||
${PYSITELIB}/barman/recovery_executor.py
|
||||
${PYSITELIB}/barman/recovery_executor.pyc
|
||||
${PYSITELIB}/barman/recovery_executor.pyo
|
||||
${PYSITELIB}/barman/remote_status.py
|
||||
${PYSITELIB}/barman/remote_status.pyc
|
||||
${PYSITELIB}/barman/remote_status.pyo
|
||||
${PYSITELIB}/barman/retention_policies.py
|
||||
${PYSITELIB}/barman/retention_policies.pyc
|
||||
${PYSITELIB}/barman/retention_policies.pyo
|
||||
|
@ -59,6 +68,9 @@ ${PYSITELIB}/barman/utils.pyo
|
|||
${PYSITELIB}/barman/version.py
|
||||
${PYSITELIB}/barman/version.pyc
|
||||
${PYSITELIB}/barman/version.pyo
|
||||
${PYSITELIB}/barman/wal_archiver.py
|
||||
${PYSITELIB}/barman/wal_archiver.pyc
|
||||
${PYSITELIB}/barman/wal_archiver.pyo
|
||||
${PYSITELIB}/barman/xlog.py
|
||||
${PYSITELIB}/barman/xlog.pyc
|
||||
${PYSITELIB}/barman/xlog.pyo
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.6 2015/11/04 17:41:16 agc Exp $
|
||||
$NetBSD: distinfo,v 1.7 2016/03/04 16:55:45 fhajny Exp $
|
||||
|
||||
SHA1 (barman-1.5.0.tar.gz) = 9833e9023b011fbd87d3c68ad867683c8acbc356
|
||||
RMD160 (barman-1.5.0.tar.gz) = d2e81a588f2135efe7785b910e91d77cade49106
|
||||
SHA512 (barman-1.5.0.tar.gz) = 7b9501277868b141f3813a545fe5463a1f7cddb0d4aaeb6c13a21aa969ced4a0a53a38ecb6e091b84c0174dae0593235cb8b586bdd244b30776273030cdfc1e8
|
||||
Size (barman-1.5.0.tar.gz) = 128132 bytes
|
||||
SHA1 (patch-barman_utils.py) = 30723ff650fcbe0c1cf5108424d997bf96898fd4
|
||||
SHA1 (barman-1.6.0.tar.gz) = 580403f8ae63e096050ff0ae5840285d791814aa
|
||||
RMD160 (barman-1.6.0.tar.gz) = 7ed0b8983107dc9bc457eb03c55c4feee4e28d66
|
||||
SHA512 (barman-1.6.0.tar.gz) = 2f214fd85b19a098e5e16f32f781c6af1ab18d369b40afbbda118b4e7663beec8cdb44482171f7195a17c48949cc0f6fdec0eafda1b33add159e4e6144ddda4a
|
||||
Size (barman-1.6.0.tar.gz) = 157048 bytes
|
||||
SHA1 (patch-barman_utils.py) = 725e8d6b4531dbfcb1e75d25059fc4af5744d49d
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-barman_utils.py,v 1.1 2015/06/09 15:06:39 fhajny Exp $
|
||||
$NetBSD: patch-barman_utils.py,v 1.2 2016/03/04 16:55:45 fhajny Exp $
|
||||
|
||||
Make portable for non-glibc platforms too.
|
||||
--- barman/utils.py.orig 2015-04-17 13:05:38.000000000 +0000
|
||||
--- barman/utils.py.orig 2016-02-22 08:01:31.000000000 +0000
|
||||
+++ barman/utils.py
|
||||
@@ -239,7 +239,7 @@ def fsync_dir(dir_path):
|
||||
@@ -253,7 +253,7 @@ def fsync_dir(dir_path):
|
||||
:param str dir_path: The directory to sync
|
||||
:raise OSError: If fail opening the directory
|
||||
"""
|
||||
|
@ -11,4 +11,4 @@ Make portable for non-glibc platforms too.
|
|||
+ dir_fd = os.open(dir_path, os.O_RDONLY)
|
||||
try:
|
||||
os.fsync(dir_fd)
|
||||
except OSError, e:
|
||||
except OSError as e:
|
||||
|
|
Loading…
Reference in a new issue