Initial import of cherokee, version 0.5.3:
Cherokee is a very fast, flexible and easy to configure Web Server. It supports the widespread technologies nowadays: FastCGI, SCGI, PHP, CGI, TLS and SSL encrypted connections, Virtual hosts, Authentication, on the fly encoding, Apache compatible log files, and much more.
This commit is contained in:
parent
5de9b9424b
commit
c8f474fc43
7 changed files with 309 additions and 0 deletions
4
www/cherokee/DESCR
Normal file
4
www/cherokee/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Cherokee is a very fast, flexible and easy to configure Web Server. It
|
||||
supports the widespread technologies nowadays: FastCGI, SCGI, PHP, CGI,
|
||||
TLS and SSL encrypted connections, Virtual hosts, Authentication, on the
|
||||
fly encoding, Apache compatible log files, and much more.
|
12
www/cherokee/MESSAGE
Normal file
12
www/cherokee/MESSAGE
Normal file
|
@ -0,0 +1,12 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2006/05/01 07:22:29 jmmv Exp $
|
||||
|
||||
You need to copy the cherokee PAM configuration file to your PAM
|
||||
configuration directory (typically /etc/pam.d). You can find a sample
|
||||
file in:
|
||||
|
||||
${EGDIR}/pam.d/cherokee
|
||||
|
||||
It may need to be manually adjusted.
|
||||
|
||||
===========================================================================
|
81
www/cherokee/Makefile
Normal file
81
www/cherokee/Makefile
Normal file
|
@ -0,0 +1,81 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2006/05/01 07:22:29 jmmv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= cherokee-0.5.3
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.0x50.org/download/0.5/0.5.3/
|
||||
|
||||
MAINTAINER= jmmv@NetBSD.org
|
||||
HOMEPAGE= http://www.0x50.org/
|
||||
COMMENT= Flexible and fast web server
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE:Q}
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR:Q}
|
||||
CONFIGURE_ARGS+= --with-wwwroot=${PREFIX}/share/cherokee
|
||||
|
||||
PKGCONFIG_OVERRIDE= cherokee.pc.in
|
||||
|
||||
INSTALL_MAKE_FLAGS+= sysconfdir=${EGDIR:Q}
|
||||
OWN_DIRS= ${PKG_SYSCONFDIR}/cherokee
|
||||
OWN_DIRS+= ${PKG_SYSCONFDIR}/cherokee/mods-enabled
|
||||
OWN_DIRS+= ${PKG_SYSCONFDIR}/cherokee/sites-enabled
|
||||
OWN_DIRS+= ${VARBASE}/log
|
||||
OWN_DIRS+= ${VARBASE}/run
|
||||
EGDIR= ${PREFIX}/share/examples/cherokee
|
||||
MESSAGE_SUBST+= EGDIR=${EGDIR:Q}
|
||||
CONF_FILES=
|
||||
.for f in advanced.conf \
|
||||
cherokee.conf \
|
||||
icons.conf \
|
||||
mime.compression.types \
|
||||
mime.types
|
||||
CONF_FILES+= ${EGDIR}/cherokee/${f} ${PKG_SYSCONFDIR}/cherokee/${f}
|
||||
.endfor
|
||||
CONF_FILES+= ${EGDIR}/cherokee/sites-available/default \
|
||||
${PKG_SYSCONFDIR}/cherokee/sites-enabled/default
|
||||
|
||||
RCD_SCRIPTS= cherokee
|
||||
|
||||
SUBST_CLASSES+= varbase
|
||||
SUBST_STAGE.varbase= pre-configure
|
||||
SUBST_MESSAGE.varbase= Fixing references to local state directory.
|
||||
SUBST_SED.varbase= -e 's|/var/|${VARBASE}/|g'
|
||||
SUBST_FILES.varbase= cherokee.conf.sample.pre
|
||||
SUBST_FILES.varbase+= http-cherokee.xml
|
||||
SUBST_FILES.varbase+= cherokee-logrotate.1
|
||||
SUBST_FILES.varbase+= sites-default.sample.pre
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.cherokee
|
||||
PKG_OPTIONS_OPTIONAL_GROUPS= ssl
|
||||
PKG_OPTIONS_GROUP.ssl= gnutls openssl
|
||||
PKG_SUGGESTED_OPTIONS+= inet6 gnutls
|
||||
PKG_SUPPORTED_OPTIONS+= inet6
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Minet6)
|
||||
CONFIGURE_ARGS+= --enable-ipv6
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-ipv6
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mgnutls)
|
||||
CONFIGURE_ARGS+= --enable-tls=gnutls
|
||||
.include "../../security/gnutls/buildlink3.mk"
|
||||
CONF_FILES+= ${EGDIR}/cherokee/mods-available/ssl \
|
||||
${PKG_SYSCONFDIR}/cherokee/mods-enabled/ssl
|
||||
.elif !empty(PKG_OPTIONS:Mopenssl)
|
||||
CONFIGURE_ARGS+= --enable-tls=openssl
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
CONF_FILES+= ${EGDIR}/cherokee/mods-available/ssl \
|
||||
${PKG_SYSCONFDIR}/cherokee/mods-enabled/ssl
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-tls
|
||||
.endif
|
||||
|
||||
pre-install:
|
||||
${INSTALL_DATA_DIR} ${EGDIR}/pam.d
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
170
www/cherokee/PLIST
Normal file
170
www/cherokee/PLIST
Normal file
|
@ -0,0 +1,170 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2006/05/01 07:22:29 jmmv Exp $
|
||||
bin/cget
|
||||
bin/cherokee-config
|
||||
bin/cherokee-panic
|
||||
bin/cherokee_logrotate
|
||||
include/cherokee/admin_client.h
|
||||
include/cherokee/buffer.h
|
||||
include/cherokee/cherokee-config.h
|
||||
include/cherokee/cherokee.h
|
||||
include/cherokee/common.h
|
||||
include/cherokee/connection.h
|
||||
include/cherokee/connection_info.h
|
||||
include/cherokee/downloader.h
|
||||
include/cherokee/encoder.h
|
||||
include/cherokee/fdpoll.h
|
||||
include/cherokee/handler.h
|
||||
include/cherokee/header.h
|
||||
include/cherokee/http.h
|
||||
include/cherokee/list.h
|
||||
include/cherokee/list_merge_sort.h
|
||||
include/cherokee/logger.h
|
||||
include/cherokee/macros.h
|
||||
include/cherokee/mime.h
|
||||
include/cherokee/mime_entry.h
|
||||
include/cherokee/module.h
|
||||
include/cherokee/module_loader.h
|
||||
include/cherokee/nonce.h
|
||||
include/cherokee/resolv_cache.h
|
||||
include/cherokee/server.h
|
||||
include/cherokee/table.h
|
||||
include/cherokee/typed_table.h
|
||||
include/cherokee/url.h
|
||||
include/cherokee/util.h
|
||||
lib/cherokee/libplugin_admin.la
|
||||
lib/cherokee/libplugin_cgi.la
|
||||
lib/cherokee/libplugin_combined.la
|
||||
lib/cherokee/libplugin_common.la
|
||||
lib/cherokee/libplugin_dirlist.la
|
||||
lib/cherokee/libplugin_error_redir.la
|
||||
lib/cherokee/libplugin_fastcgi.la
|
||||
lib/cherokee/libplugin_fcgi.la
|
||||
lib/cherokee/libplugin_file.la
|
||||
lib/cherokee/libplugin_gzip.la
|
||||
lib/cherokee/libplugin_htdigest.la
|
||||
lib/cherokee/libplugin_ncsa.la
|
||||
lib/cherokee/libplugin_nn.la
|
||||
lib/cherokee/libplugin_phpcgi.la
|
||||
lib/cherokee/libplugin_plain.la
|
||||
lib/cherokee/libplugin_read_config.la
|
||||
lib/cherokee/libplugin_redir.la
|
||||
lib/cherokee/libplugin_scgi.la
|
||||
lib/cherokee/libplugin_server_info.la
|
||||
lib/cherokee/libplugin_w3c.la
|
||||
lib/libcherokee-base.la
|
||||
lib/libcherokee-client.la
|
||||
lib/libcherokee-config.la
|
||||
lib/libcherokee-server.la
|
||||
lib/pkgconfig/cherokee.pc
|
||||
man/man1/cget.1
|
||||
man/man1/cherokee-config.1
|
||||
man/man1/cherokee.1
|
||||
man/man1/cherokee_logrotate.1
|
||||
sbin/cherokee
|
||||
share/aclocal/cherokee.m4
|
||||
share/cherokee/deps/combined.deps
|
||||
share/cherokee/deps/common.deps
|
||||
share/cherokee/deps/error_redir.deps
|
||||
share/cherokee/deps/nn.deps
|
||||
share/cherokee/deps/phpcgi.deps
|
||||
share/cherokee/icons/back.png
|
||||
share/cherokee/icons/binary.png
|
||||
share/cherokee/icons/blank.png
|
||||
share/cherokee/icons/bomb.png
|
||||
share/cherokee/icons/compressed.png
|
||||
share/cherokee/icons/folder.png
|
||||
share/cherokee/icons/image.png
|
||||
share/cherokee/icons/iso.png
|
||||
share/cherokee/icons/java.png
|
||||
share/cherokee/icons/movie.png
|
||||
share/cherokee/icons/pdf.png
|
||||
share/cherokee/icons/ps.png
|
||||
share/cherokee/icons/readme.png
|
||||
share/cherokee/icons/script.png
|
||||
share/cherokee/icons/sound.png
|
||||
share/cherokee/icons/tex.png
|
||||
share/cherokee/icons/text.png
|
||||
share/cherokee/icons/unknown.png
|
||||
share/cherokee/images/cherokee-logo.png
|
||||
share/cherokee/images/default-bg.png
|
||||
share/cherokee/images/powered_by_cherokee.png
|
||||
share/cherokee/index.html
|
||||
share/cherokee/mime_types.txt
|
||||
share/doc/cherokee/Authentication.html
|
||||
share/doc/cherokee/Authors.html
|
||||
share/doc/cherokee/Behavior_configuration.html
|
||||
share/doc/cherokee/CGI_executing.html
|
||||
share/doc/cherokee/Cget.html
|
||||
share/doc/cherokee/Cherokee-icono.png
|
||||
share/doc/cherokee/Combined_logger.html
|
||||
share/doc/cherokee/Combined_logs.html
|
||||
share/doc/cherokee/Common_behavior.html
|
||||
share/doc/cherokee/Comparison_servers.html
|
||||
share/doc/cherokee/Compiling_and_Installing.html
|
||||
share/doc/cherokee/Configuration.html
|
||||
share/doc/cherokee/Copying_and_license.html
|
||||
share/doc/cherokee/Current_events.html
|
||||
share/doc/cherokee/Directory_configuration.html
|
||||
share/doc/cherokee/Directory_listing.html
|
||||
share/doc/cherokee/Encoders.html
|
||||
share/doc/cherokee/Exquisite-khelpcenter.png
|
||||
share/doc/cherokee/Extension_configuration.html
|
||||
share/doc/cherokee/FastCGI.html
|
||||
share/doc/cherokee/File_sending.html
|
||||
share/doc/cherokee/Frequently_asked_questions.html
|
||||
share/doc/cherokee/Gzip_encoder.html
|
||||
share/doc/cherokee/How_to_generate_SSL_keys.html
|
||||
share/doc/cherokee/How_to_manage_Virtual_Host.html
|
||||
share/doc/cherokee/Htdigest_validator.html
|
||||
share/doc/cherokee/Htpasswd_validator.html
|
||||
share/doc/cherokee/Icons_configuration.html
|
||||
share/doc/cherokee/Jaws_and_Cherokee_with_FastCGI.html
|
||||
share/doc/cherokee/Logging_system.html
|
||||
share/doc/cherokee/Mime_types_configuration.html
|
||||
share/doc/cherokee/NCSA_logger.html
|
||||
share/doc/cherokee/NCSA_logs.html
|
||||
share/doc/cherokee/PAM_validator.html
|
||||
share/doc/cherokee/PHP_execution.html
|
||||
share/doc/cherokee/Plain_validator.html
|
||||
share/doc/cherokee/Redirections.html
|
||||
share/doc/cherokee/Request_configuration.html
|
||||
share/doc/cherokee/Ruby_on_Rails_with_SCGI.html
|
||||
share/doc/cherokee/SCGI.html
|
||||
share/doc/cherokee/Server-conf-small.png
|
||||
share/doc/cherokee/Server_configuration.html
|
||||
share/doc/cherokee/U-Cherokee.html
|
||||
share/doc/cherokee/Validators.html
|
||||
share/doc/cherokee/W3C_logger.html
|
||||
share/doc/cherokee/W3C_logs.html
|
||||
share/doc/cherokee/WebApplications.html
|
||||
share/doc/cherokee/cherokee.png
|
||||
share/doc/cherokee/index.html
|
||||
share/examples/cherokee/cherokee/advanced.conf
|
||||
share/examples/cherokee/cherokee/cherokee.conf
|
||||
share/examples/cherokee/cherokee/icons.conf
|
||||
share/examples/cherokee/cherokee/mime.compression.types
|
||||
share/examples/cherokee/cherokee/mime.types
|
||||
share/examples/cherokee/cherokee/mods-available/admin
|
||||
share/examples/cherokee/cherokee/mods-available/ssl
|
||||
share/examples/cherokee/cherokee/sites-available/default
|
||||
share/examples/cherokee/cherokee/sites-available/example.com
|
||||
share/examples/cherokee/cherokee/sites-enabled/default
|
||||
share/examples/cherokee/pam.d/cherokee
|
||||
share/examples/rc.d/cherokee
|
||||
@dirrm share/examples/cherokee/pam.d
|
||||
@exec ${MKDIR} %D/share/examples/cherokee/cherokee/ssl
|
||||
@dirrm share/examples/cherokee/cherokee/ssl
|
||||
@dirrm share/examples/cherokee/cherokee/sites-enabled
|
||||
@dirrm share/examples/cherokee/cherokee/sites-available
|
||||
@exec ${MKDIR} %D/share/examples/cherokee/cherokee/mods-enabled
|
||||
@dirrm share/examples/cherokee/cherokee/mods-enabled
|
||||
@dirrm share/examples/cherokee/cherokee/mods-available
|
||||
@dirrm share/examples/cherokee/cherokee
|
||||
@dirrm share/examples/cherokee
|
||||
@dirrm share/doc/cherokee
|
||||
@dirrm share/cherokee/images
|
||||
@dirrm share/cherokee/icons
|
||||
@dirrm share/cherokee/deps
|
||||
@dirrm share/cherokee
|
||||
@dirrm lib/cherokee
|
||||
@dirrm include/cherokee
|
6
www/cherokee/distinfo
Normal file
6
www/cherokee/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2006/05/01 07:22:29 jmmv Exp $
|
||||
|
||||
SHA1 (cherokee-0.5.3.tar.gz) = 97f436a8e5109eb1420b9ead70f281adac535278
|
||||
RMD160 (cherokee-0.5.3.tar.gz) = adad3e9c0f3b181dda135c931337b1946770bfce
|
||||
Size (cherokee-0.5.3.tar.gz) = 1547870 bytes
|
||||
SHA1 (patch-aa) = 541c40b0ffeedab919f345b4439305a3c7c63dc4
|
24
www/cherokee/files/cherokee.sh
Normal file
24
www/cherokee/files/cherokee.sh
Normal file
|
@ -0,0 +1,24 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: cherokee.sh,v 1.1.1.1 2006/05/01 07:22:29 jmmv Exp $
|
||||
#
|
||||
# PROVIDE: cherokee
|
||||
# REQUIRE: DAEMON
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="cherokee"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/sbin/${name}"
|
||||
command_args="&"
|
||||
required_files="@PKG_SYSCONFDIR@/cherokee/${name}.conf"
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
@ECHO@ -n " ${name}"
|
||||
${command} ${cherokee_flags} ${command_args}
|
||||
fi
|
12
www/cherokee/patches/patch-aa
Normal file
12
www/cherokee/patches/patch-aa
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2006/05/01 07:22:29 jmmv Exp $
|
||||
|
||||
--- Makefile.in.orig 2006-04-22 13:26:05.000000000 +0200
|
||||
+++ Makefile.in 2006-04-22 13:26:10.000000000 +0200
|
||||
@@ -1047,7 +1047,6 @@
|
||||
else \
|
||||
$(INSTALL_DATA) $(top_srcdir)/mods-admin.sample $(DESTDIR)$(cherokeeconfdir)/mods-available/admin; \
|
||||
fi
|
||||
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)
|
||||
|
||||
uninstall-local: uninstall-local-config
|
||||
@if test -f $(DESTDIR)$(cherokeeconfdir)/cherokee.conf ; then \
|
Loading…
Reference in a new issue